WMP9 Hotfix Removal - Breaks WMP10 Integration

Questions about Update Pack making? Ask here.
Post Reply
User avatar
DigeratiPrime
Posts: 84
Joined: Fri Feb 25, 2005 4:31 pm

WMP9 Hotfix Removal - Breaks WMP10 Integration

Post by DigeratiPrime » Fri Feb 25, 2005 4:40 pm

NOTE: this probably only concerns XP MCE users.
Remove .infs entries in RVMUpPck.inf along with files for these hotfixes:

KB887078, KB888407, KB885353, KB886610

(To determine what files to delete read hotfixes description in RVMUpPck.inf, just hit "ctrl + F")
Delete compressed cats in svcpack folder and remove entries for .cats in svcpack.inf file
I'm having some trouble doing this. I figured I was supposed to expand the SP2 Update CAB and remove the files before integration. The problem with that is repacking all the files into one CAB again, I cannot find the cmd to do that.

I also tried integrating with nLite, and then following the above instructions. Unfortunately I get several errors throughout Windows setup about missing files.

Hope we can clear this up :)

war59312
Posts: 213
Joined: Fri Nov 26, 2004 1:11 am
Location: U.S.A
Contact:

Post by war59312 » Sat Feb 26, 2005 12:56 am

Yeap I cant figure it out either.

Right after it done installing windows about about to logon for the first time it keeps repeating itself. Playing the stupid sound in the background. Just just a black backgroud, so no video.

Have tried five times now and getting ready to give up.

Hope somone here comes up with a solution because its really annorying.

cya,
Will
God Bless America

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Sat Feb 26, 2005 4:45 am

Why are you trying to repack the files into a CAB again? Just copy them to i386...

(Though you'll also want to expand the INF file and remove the relevant entries). However, I was able to install WMP10 (build 3802) over 1.2 without issue, so what's the problem?
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
DigeratiPrime
Posts: 84
Joined: Fri Feb 25, 2005 4:31 pm

Post by DigeratiPrime » Sat Feb 26, 2005 12:05 pm

I was trying to repack the CAB because I wanted it to integrate with nLite-minus the WMP9 hotfixes.

Though I will try the Manual Integration method and report back later on how that goes.

war59312
Posts: 213
Joined: Fri Nov 26, 2004 1:11 am
Location: U.S.A
Contact:

Post by war59312 » Sat Feb 26, 2005 5:06 pm

Well I for did what you just said Ryan.

Heres my infs. Did I mess up somewhere?

http://www.willsdownloads.com/RVMUpPck.in_

http://www.willsdownloads.com/svcpack.in_

I tried the other method just commenting out the line and same result so dont really matter. I just removed it completely.

Anyways how where you able to install 3802? U used the batch file and just copied the files from %systemroot%\i386 to your i386 folder? Thats what I like it says and what u just said.

And like I said in the other thread the error I am getting before doing this, when just doing the batch file like normal is:

"Windows Media Player is not installed properly and must be reinstalled."

Now it works fine before your pack is intergrated into the mix. Have done both ways, using nlite and manually and same results every time. Have tried like 8 times now.

Oh and this problem was introduced with 1.20 version of your pack. The old versions worked pefectly as expected.

And yes I tried old version of wmp that I know worked with your old back and still same results when trying with 1.20.

Thanks for your help,
Will
God Bless America

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Sat Feb 26, 2005 5:08 pm

I install it from inside windows after the fact. I don't integrate it into the CD.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

war59312
Posts: 213
Joined: Fri Nov 26, 2004 1:11 am
Location: U.S.A
Contact:

Post by war59312 » Sat Feb 26, 2005 5:12 pm

Oh yeah of course. ;)

I'm just hoping i can find the cause of the issue and hopefully have it fixed in the next version if its indeed a problem with that pack which I am sure of atm.

Take,
Will

I just dont get why not its freezing right before the first logon and play the darn music in the background with no video and why it keeps repeating. :(
God Bless America

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Sat Feb 26, 2005 5:14 pm

I think I'm going to attempt WMP10 integration in April when I'm done with classes for awhile.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
keytotime
Posts: 491
Joined: Thu Dec 16, 2004 9:44 pm

Post by keytotime » Sat Feb 26, 2005 7:12 pm

I'm using the newest pack and wmp10 works fine.

war59312
Posts: 213
Joined: Fri Nov 26, 2004 1:11 am
Location: U.S.A
Contact:

Post by war59312 » Sat Feb 26, 2005 11:47 pm

Well I dont get it.

I took winxp gold and intergrated sp2 and then pack and then wmp 10 and same problem.

So then tried winxp gold and intergrated sp2 and the wmp 10 then pack and still same problem.

So no matter what I do I have the same issue.

Not using nlite or while using nlite. Same issue.

keytotime can you explain what u did?

But ok, Ryan glad to hear it.
God Bless America

User avatar
keytotime
Posts: 491
Joined: Thu Dec 16, 2004 9:44 pm

Post by keytotime » Sun Feb 27, 2005 7:19 am

First sp2.
Then ryan's pack
Then wmp10.

If you do ryan's pack last you're overwritten new files with old files.

Here's my code. With my method the files are protected by sfc.

Code: Select all

@ECHO OFF
TITLE Slipstreaming WMP10
SET P=C:\MPTEMP
SET OUT=C:\WMP10
SET SVC=c:\WMP10cat
SET C=MAKECAB /D CompressionType=LZX /D CompressionMemory=21 /L %OUT% %P%\
SET S=MAKECAB /D CompressionType=LZX /D CompressionMemory=21 /L %SVC% %P%\
IF EXIST %P% RD %P%
IF EXIST %OUT% RD %OUT%
COLOR 0A

TITLE Extracting MP10Setup.exe to %P%...
ECHO Extracting MP10Setup.exe to %P%...
START /WAIT MP10Setup.exe /C /Q /T:%P%
ECHO Complete!

CLS
TITLE Compresing needed files to %OUT%
Echo Compresing needed files to %OUT%
@ECHO OFF
%C%wmplayer.adm
%C%asferror.dll
%C%blackbox.dll
%C%CEWMDM.dll
%C%custsat.dll
%C%DRMClien.dll
%C%DrmStor.dll
%C%drmv2clt.dll
%C%LAPRXY.DLL
%C%mpvis.DLL
%C%msnetobj.dll
%C%MsPMSNSv.dll
%C%MsPMSP.dll
%C%msscp.dll
%C%MSWMDM.dll
%C%qasf.dll
%C%WMADMOD.DLL
%C%WMADMOE.DLL
%C%WMASF.DLL
%C%WMDMLOG.dll
%C%WMDMPS.dll
%C%wmerror.dll
%C%wmidx.dll
%C%WMNetMgr.dll
%C%wmp.dll
%C%wmpasf.dll
%C%wmpband.dll
%C%wmpcd.dll
%C%wmpcore.dll
%C%wmpdxm.dll
%C%wmploc.DLL
%C%wmpshell.dll
%C%wmpui.dll
%C%WMSDMOD.DLL
%C%WMSDMOE2.DLL
%C%WMSPDMOD.DLL
%C%WMSPDMOE.DLL
%C%WMVCORE.DLL
%C%WMVDMOD.DLL
%C%WMVDMOE2.DLL
%C%logagent.exe
%C%migrate.exe
%C%setup_wm.exe
%C%wmlaunch.exe
%C%unregmp2.exe
%C%wmplayer.exe
%C%wmp.ocx
%C%Plylst1.wpl
%C%Plylst10.wpl
%C%Plylst11.wpl
%C%Plylst12.wpl
%C%Plylst13.wpl
%C%Plylst14.wpl
%C%Plylst15.wpl
%C%Plylst2.wpl
%C%Plylst3.wpl
%C%Plylst4.wpl
%C%Plylst5.wpl
%C%Plylst6.wpl
%C%Plylst7.wpl
%C%Plylst8.wpl
%C%Plylst9.wpl
%s%codecs10.cat
%s%DRM10.cat
%s%MPCD10.cat
%s%MPPRE10.cat
%s%MPSTUB10.cat
%s%WMDM10.cat
%s%WMFSDK10.cat
%s%WMP10.cat
%s%WMSET10.cat
%s%WPD10.cat
IF EXIST %P% RD /S /Q %P%
ECho Updating Source
move /Y C:\WMP10\*.* C:\XPCD\i386
Move /y C:\WMP10cat\*.* C:\XPCD\I386\svcpack
ECHO.
ECHO.
ECHO.
ECHO Complete!
ECHO.
@ECHO OFF
CLS
TITLE Making Svcpack.inf in C:\
color 0a
cd C:\XPCD\I386\svcpack
dir /a /b /-p /o:gen >c:\svcpack.inf
ECHO.Part 1 is done. Please Modify Svcpack.inf
Echo.Before the text add:
Echo.
Echo.[Version]
Echo.Signature="$Windows NT$"
Echo.MajorVersion=5
Echo.MinorVersion=1
Echo.BuildNumber=2600
Echo.[SetupData]
Echo.CatalogSubDir="\i386\svcpack"
Echo.[ProductCatalogsToInstall]
Echo.
Echo.In the text chage .ca_ to .cat
Echo.
Echo.After the text add
Echo.
Echo.[SetupHotfixesToRun]
Echo.
Echo.Remember to save
c:\Svcpack.inf
PAUSE
CLS
@ECHO OFF
TITLE Making SVCpck.inf
SET Y=C:\
SET X=C:\XPCD\i386
SET V=MAKECAB /D CompressionType=LZX /D CompressionMemory=21 /L %X% %Y%\
%V%Svcpack.inf
ECho.
ECho.
ECho Finished
PAUSE
EXIT

PsiMoon314
Posts: 63
Joined: Wed Jan 19, 2005 12:55 pm
Location: Haverfordwest, Wales, UK

Post by PsiMoon314 » Mon Feb 28, 2005 9:38 am

Hi keytotime :D

WIth your method, how much (if any) of the WMP 10 functionality is missing?

Are all of the features included?

Kind Regards

Simon

war59312
Posts: 213
Joined: Fri Nov 26, 2004 1:11 am
Location: U.S.A
Contact:

Post by war59312 » Tue Mar 01, 2005 10:17 pm

Well tried again and still:

Right after it's done installing windows and about to logon for the first time it keeps repeating itself. Playing the stupid sound in the background. Just a black backgroud, so no video.
God Bless America

User avatar
DigeratiPrime
Posts: 84
Joined: Fri Feb 25, 2005 4:31 pm

Post by DigeratiPrime » Thu Mar 03, 2005 8:04 pm

Copy over these file from the original source and replace those updated by CAB integration:
DRMV2CLT.DL_
WMNETMGR.DL_
WMP.DL_
WMVCORE.DL_

Delete These Files in the SVCPACK folder in I386.
KB885353.CA_
KB886610.CA_
KB887078.CA_
KB888407.CA_

These have the hotfixes edited out, so copy them over the ones from CAB integration.
RVMUpPck.in_
svcpack.in_

Download 'patched' RVMUpPck.in_ & svcpack.in_
http://rapidshare.de/files/759997/RVMUpPck.rar.html

war59312
Posts: 213
Joined: Fri Nov 26, 2004 1:11 am
Location: U.S.A
Contact:

Post by war59312 » Tue Mar 08, 2005 4:29 am

k will try one last time some time this week

thanks,
will
God Bless America

Post Reply