ntkrnlmp.exe corrupt or missing

Questions about Update Pack making? Ask here.
Post Reply

ntkrnlmp.exe corrupt or missing

Post by mblairbeer » Mon May 23, 2005 11:13 pm

Stumpled across your site while searching for an easy way to slipstream hotfixes into windows . Thanks for putting the cab file together! Here's my problem, I'm hoping you've seen it before, although I did not see it in the discussion forem.

I slipstreamed xp2 into my winXP sp1 to create a fresh Win XP with sp2 source. I've tried to different methods. The direct integrate method and the extract then integrate method. I then slipstreamed the cab file into the fresh source following your instructions (extract the cab files, edit the INF and SIF file). I burned a bootable cd with Nero. The cd boots into the windows install screen. When it gets to the "Press F2 to run automated recover" screen, the follwoing error message occurs:

"The entry ntkrnlmp.exe in the [SourceDisksFile] section of the INF file is corrupt or missing.

The file is on the cd in the i386 directory. As an FYI, when the cd is loaded while in windows, it opens to the intall windows screen. When Install Windows is selected, an error message pops up saying the dosnet.inf file is invalid. All other functions on the menu screen seem to work okay.

Any ideas on what is going on and how to fix? Thanks.

User avatar
Site Admin
Posts: 5190
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania

Post by RyanVM » Mon May 23, 2005 11:19 pm

Sounds like something got severely screwed up during your integration. Try integrating it with nLite and see if things work better for you.
Get up to $200 off on hosting from the same people who host this website!


Post by mblairbeer » Tue May 24, 2005 12:13 am

Using nLite, everything seems to work fine. Boots all the way through to fdisk screen. I aborted then, as I'm not quite ready to rebuild windows yet. (waiting on a new motherboard). Thanks for the suggestion. I'm going to attempt the manual slipstream again because I'm curious on what happened. Let you know if I figure anything out.


Post by mblairbeer » Tue May 24, 2005 11:36 pm

The problem seems to lie in the hotfix cabinet file or rather integrating the hotfixes into the winXp sp2 source. The latter works fine and seems to boot the windows install okay. When I integrate the cabinet hotfixes, the error concerning the ntkrnlmp.exe file occurs during the windows install boot process. I'm pretty sure I'm unpacking and integreting the cab file correctly with the manual process. Not a big deal since the nLite version is working, but still a mystery. Any thoughts?

User avatar
Posts: 1155
Joined: Tue Nov 23, 2004 9:50 pm
Location: Buffalo, NY

Post by RogueSpear » Sat May 28, 2005 12:28 pm

It took me 3 days to figure this puppy out. Somewhere along the lines, for me anyway, it seems that all of the files in i386 need to be in all caps. I actually pieced this together because of the BTS DriverPacks. I noticed that my CD always worked with the BTS DPs applied (my last step). Then I noticed BTS recently added a final step in the slipstream process where all of the files are converted to uppercase.

Well after 3 days I had nothing to lose so I snagged the command line utility filecase.exe from his packs and gave it a whirl. Sure enough that fixed the problem. What I eventually did was convert all of the files in RVM to uppercase an recabbed it.

I'm sure this has been detailed elsewhere but I never found it.

Post Reply