Q314543, and possible Unicode problem sequel

Questions about Update Pack making? Ask here.
Post Reply
Djé
Posts: 6
Joined: Sat Mar 25, 2006 8:20 pm
Location: behind

Q314543, and possible Unicode problem sequel

Post by Djé » Sat May 06, 2006 6:13 pm

Hi,
In order to be able to connect to a share at T12 using NET USE, we must correct the bug described in Q314543.
I tried to do so by making an AddOn using an [ExtraFileEdits] section in the entries.ini.
It would not work and drove me mad until I found out that the edited file, HIVESYS.INF, is in Unicode and not in ANSI on non English systems.
The 'Convert Unicode to ANSI' option is checked in RVM Integrator 1.2.2 but it does not seems to apply to the hive files, or -better said-, to the files processed in the [ExtraFileEdits] section.

Could you check for this and if is the case, could the next version of the integrator take care of this issue?




As a side note, the Q314543 fix could well be integrated in the UpdatePack.
Also, I tried to take care of it using an addreg in the addon, but it is then applied too late in the install to work (I think a reg file imported from DetachedPrograms would work tho).


[Edit]I've posted both the AddOn and an AutoIt fix for the Unicoded on msfn.
The Enemy is stupid: He beleives us being the enemy.

User avatar
Siginet
Site Admin
Posts: 2894
Joined: Fri May 27, 2005 1:07 pm
Location: Planet Earth
Contact:

Post by Siginet » Sat May 06, 2006 11:56 pm

I will look into adding the change.
Image
--Siginet--

Techware
Your Virtual Technician
Computer Management Software

Djé
Posts: 6
Joined: Sat Mar 25, 2006 8:20 pm
Location: behind

Post by Djé » Sun May 07, 2006 5:47 pm

@Siginet, Thank you very much for this and for all the good work you've already done.
The Enemy is stupid: He beleives us being the enemy.

Post Reply