[FIXED] Integrator v1.3 Problem.

Questions about Update Pack making? Ask here.
Locked
User avatar
Denney
Posts: 92
Joined: Sun Feb 19, 2006 8:25 am
Location: Brisbane, Australia
Contact:

[FIXED] Integrator v1.3 Problem.

Post by Denney » Wed Jun 28, 2006 10:47 pm

This isn't really an error... more of a cosmetic bug.

When using the [HexEdit] section, the hex edits are applied but the log file shows the following:

Code: Select all

12:30:01  - Hex Editing Files
12:30:02  -   SYSSETUP.DLL 5.1.2600.2180 No match at offset 38296. Patched at offset
12:30:03  -   SYSSETUP.DLL 5.1.2600.2180 No match at offset 101704. Patched at offset
12:30:04  -   SYSSETUP.DLL 5.1.2600.2180 No match at offset 210553. Patched at offset
12:30:05  -   DMADMIN.EXE 2600.2180.503.0 No match at offset 7216. Patched at offset
12:30:07  -   DMBOOT.SYS 2600.2180.503.0 No match at offset 69884. Patched at offset
12:30:08  -   DMBOOT.SYS 2600.2180.503.0 No match at offset 69911. Patched at offset
12:30:09  -   DMCONFIG.DLL 2600.0.503.0 No match at offset 144743. Patched at offset
12:30:10  -   DMCONFIG.DLL 2600.0.503.0 No match at offset 144770. Patched at offset
12:30:11  -   TCPIP.SYS 5.1.2600.2892 No match at offset 325574. Patched at offset
12:30:12  -   USBPORT.SYS 5.1.2600.2891 No match at offset 88471. Patched at offset
12:30:12  -   UXTHEME.DLL 6.0.2900.2845 No match at offset 104746. Patched at offset
12:30:12  -   SFC_OS.DLL 5.1.2600.2180 No match at offset 60644. Patched at offset
12:30:13  -   LGTCKCTL.DLL 1.5.540.0 No match at offset 196816. Patched at offset
I'm curious why it says there was no match but it was able to patch it properly. I've checked, double-checked and triple-checked my hex edits and they are correct. With the beta versions of the integrator, they were reported fine.

User avatar
Siginet
Site Admin
Posts: 2894
Joined: Fri May 27, 2005 1:07 pm
Location: Planet Earth
Contact:

Post by Siginet » Thu Jun 29, 2006 12:27 am

I will ook into it. Thanks for the report. ;)
Image
--Siginet--

Techware
Your Virtual Technician
Computer Management Software

jumz
Posts: 82
Joined: Fri Mar 10, 2006 1:32 am
Location: Edmonton, AB, Canada

Post by jumz » Wed Jul 05, 2006 6:56 pm

I get very similar results:

Code: Select all

16:47:58  - Hex Editing Files
16:47:58  -   sfc_os.dll 5.1.2600.2180 No match at offset 60644. Patched at offset
16:48:01  -   tcpip.sys 5.1.2600.2892 No match at offset 325026. Patch skipped.
16:48:02  -   tcpip.sys 5.1.2600.2892 No match at offset 325574. Patched at offset
JuMz

User avatar
Zacam
Moderator
Posts: 615
Joined: Tue Sep 13, 2005 7:46 pm
Location: Portland, OR

Post by Zacam » Wed Jul 05, 2006 7:11 pm

We wanted to impliment a different "faliure" message than what we had during beta to remove confusion. Somehow though, it appears to have gotten applied to "success" messages as well. As long as it actually says "Patched at offset" you can ignore the "No Match" parts.

User avatar
Siginet
Site Admin
Posts: 2894
Joined: Fri May 27, 2005 1:07 pm
Location: Planet Earth
Contact:

Post by Siginet » Wed Jul 05, 2006 8:23 pm

It is fixed in 1.4. But there isn't any harm in this the way it is. ;) Thanks for the report.
Image
--Siginet--

Techware
Your Virtual Technician
Computer Management Software

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Fri Jul 14, 2006 1:33 am

Resolving this as fixed. Denney, please PM me to reopen the thread if you're still experiencing the problem with Integrator 1.4.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

Locked