RyanVM Update Pack 2.1.2a - Updated September 27, 2006

Questions about Update Pack making? Ask here.
User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

RyanVM Update Pack 2.1.2a - Updated September 27, 2006

Post by RyanVM » Sun Sep 17, 2006 9:05 pm

What's New
Version 2.1.2
  • Added KB904829 Hotfix. Replaces KB885835 Hotfix.
  • Added KB916189 Hotfix. Replaces KB911262 Hotfix.
  • Added KB916846 Hotfix. Replaces KB917159 Hotfix.
  • Added KB919007 Hotfix.
  • Added KB919587 Hotfix. Replaces KB909363 Hotfix.
  • Added KB920183 Hotfix. Replaces KB906681 Hotfix.
  • Added KB920685 Hotfix.
  • Added KB920872 Hotfix.
  • Added KB920875 Hotfix. Replaces KB922128 Hotfix.
  • Added KB921028 Hotfix.
  • Added KB921337 Hotfix.
  • Added KB922582 Hotfix.
  • Added KB922668 Hotfix. Replaces KB912817 Hotfix.
  • Added KB922859 Hotfix. Replaces KB896424 and KB912919 Hotfixes.
  • Added KB923154 Hotfix. Replaces KB915428 Hotfix.
  • Updated Malicious Software Removal Tool to version 1.20.
For the love of God, read the nLite or Integrator directions for how to properly integrate this pack.

Notes
  • nLite 1.0.1 or RyanVM Integrator 1.4+ is required to properly integrate this release.
  • If you used nLite to integrate the pack and are having problems, PLEASE read this thread before reporting problems.
Download Here

Known Issues
  • None currently.
If you do run into anything you think is an error, be sure to consult with the FAQ on my site before asking about it here.

UPDATE: September 27, 2006
Microsoft has released the MS06-055 (KB925486) update out of cycle in order to resolve a serious security flaw. Below is an addon which can be integrated on top of 2.1.2 (or at the same time) which will update your CD to Update Pack version 2.1.2a.

http://addons.ryanvm.net/ryanvm/RVMAddo ... _Update.7z (305KB)
MD5: F9171DF277B399865DAFA92E5800FC82
Last edited by RyanVM on Sat Oct 14, 2006 3:38 pm, edited 2 times in total.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
MrNxDmX
Moderator
Posts: 3112
Joined: Mon Jan 03, 2005 7:33 am

Post by MrNxDmX » Sun Sep 17, 2006 9:08 pm

Yay, first! Thanx you very much Ryan. Downloading right now...

User avatar
Siginet
Site Admin
Posts: 2894
Joined: Fri May 27, 2005 1:07 pm
Location: Planet Earth
Contact:

Post by Siginet » Sun Sep 17, 2006 9:09 pm

Here come the Leechers! :D lol... who am I kidding... I'm gonna leech it now too. :D
Image
--Siginet--

Techware
Your Virtual Technician
Computer Management Software

User avatar
ricktendo64
Posts: 3213
Joined: Mon May 22, 2006 12:27 am
Location: Honduras

Post by ricktendo64 » Sun Sep 17, 2006 9:13 pm

Dam! that was fast

Protagonist.
Posts: 162
Joined: Tue Jun 14, 2005 12:02 am

Post by Protagonist. » Sun Sep 17, 2006 9:21 pm

Thanks for the update.

treblA
Posts: 52
Joined: Sat Feb 04, 2006 10:22 am

Post by treblA » Sun Sep 17, 2006 9:40 pm

Mucho's Gracias Ryan ur the best!!!

bledd
Posts: 47
Joined: Sat Jan 15, 2005 7:33 am

Post by bledd » Sun Sep 17, 2006 9:53 pm

awesome

ViVa

Post by ViVa » Sun Sep 17, 2006 9:59 pm

Thanks Ryan, gladly appreciated.

datalife
Posts: 73
Joined: Wed Aug 17, 2005 6:24 pm

Thanks Ryan!

Post by datalife » Sun Sep 17, 2006 10:22 pm

Thanks Ryan!

BZJoe
Posts: 35
Joined: Sun Apr 16, 2006 1:19 pm

Post by BZJoe » Sun Sep 17, 2006 10:27 pm

Thanks Ryan. Will try it and report back if I run into anything.

BTW: Weren't you supposed to be on vacations? :D

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Sun Sep 17, 2006 10:28 pm

Got home today :)
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

end3rkid
Posts: 39
Joined: Thu Apr 14, 2005 9:30 pm

Post by end3rkid » Mon Sep 18, 2006 1:31 am

Awesome Thanks :D

Rudi1
Posts: 232
Joined: Sun Mar 06, 2005 2:49 am

Post by Rudi1 » Mon Sep 18, 2006 2:50 am

Thx Ryan for your great work! :lol:

User avatar
buletov
Posts: 380
Joined: Tue Feb 15, 2005 11:30 am

Post by buletov » Mon Sep 18, 2006 3:50 am

Lovely...
Never know what life is gonna throw at you.

the_guy
Posts: 242
Joined: Wed Feb 01, 2006 6:22 am
Location: PEI, Canada

Post by the_guy » Mon Sep 18, 2006 6:00 am

Good job Ryan!

the_guy

User avatar
cyberloner
Posts: 315
Joined: Tue Sep 20, 2005 2:13 am
Location: http://www.cybermania.ws
Contact:

Post by cyberloner » Mon Sep 18, 2006 6:46 am

appreciated =.=

User avatar
warrior1109
Posts: 114
Joined: Sun Oct 09, 2005 12:05 pm
Location: London, UK

Post by warrior1109 » Mon Sep 18, 2006 8:53 am

Excellent, thanks Ryan.

SoKoOLz
Posts: 180
Joined: Tue Jul 11, 2006 3:53 am

Post by SoKoOLz » Mon Sep 18, 2006 8:54 am

Welcome back Ryan, and thanks for the updates
Image

n3dro
Posts: 4
Joined: Sun Aug 27, 2006 1:06 am
Location: N.Y.C.

Post by n3dro » Mon Sep 18, 2006 1:37 pm

Thanx for the update Ryan. Works great...no problems. 8)

User avatar
xpmaniac4ever
Posts: 45
Joined: Wed Jul 13, 2005 5:37 am

Post by xpmaniac4ever » Mon Sep 18, 2006 1:43 pm

Merci beaucoup :D
An idiot tries 2 maintain order..A genius can control chaos

soulstace
Posts: 21
Joined: Tue Feb 07, 2006 4:29 am

Post by soulstace » Tue Sep 19, 2006 12:12 am

Thanks Ryan. :)

Using this to build a UBCD (BartPE) as we speak. The updates should make it much more secure for surfing the web and such.

the_guy
Posts: 242
Joined: Wed Feb 01, 2006 6:22 am
Location: PEI, Canada

Post by the_guy » Tue Sep 19, 2006 3:56 pm

Just a cosmetic issue on the site, but MSXML 5 included in the update pack is actually MSXML 5 SP1 (msxml5.dll is version 5.10.2927.0, the .10. states SP1).

the_guy

User avatar
MrNxDmX
Moderator
Posts: 3112
Joined: Mon Jan 03, 2005 7:33 am

Post by MrNxDmX » Tue Sep 19, 2006 4:14 pm

@ the_guy: are you sure you are on right topic?

User avatar
TripleA
Posts: 36
Joined: Sat Oct 22, 2005 12:38 pm
Location: Planet Earth

Post by TripleA » Wed Sep 20, 2006 1:13 am

Thank you very much for all the quick, hard and almost-infallible work, Ryan, first!
MrNxDmx wrote:@ the_guy: are you sure you are on right topic?
I believe the_guy is referring to this bit on the update pack's download page:

"Other Updates
...
MSXML 3.0 SP7 (Includes KB919587 Hotfix)
MSXML 4.0 SP2 (Includes KB887606 Hotfix)
MSXML 5.0
..."

Not sure if that makes him/her on the right topic, though.
Last edited by TripleA on Wed Sep 20, 2006 2:51 pm, edited 1 time in total.

User avatar
MrNxDmX
Moderator
Posts: 3112
Joined: Mon Jan 03, 2005 7:33 am

Post by MrNxDmX » Wed Sep 20, 2006 1:54 am

@ TripleA: yay, thanks, got ,t now.

User avatar
Wesmosis
Posts: 350
Joined: Tue Feb 21, 2006 7:53 pm

Post by Wesmosis » Wed Sep 20, 2006 2:27 am

You da man Ryan!

the_guy
Posts: 242
Joined: Wed Feb 01, 2006 6:22 am
Location: PEI, Canada

Post by the_guy » Wed Sep 20, 2006 5:37 am

@MrNxDmx: Yes I am sure I am at the right topic. It's the part that TripleA highlighted from Ryan's update list.

the_guy

Halfwalker
Posts: 10
Joined: Thu Aug 31, 2006 10:45 pm

Update pack interferes with themes

Post by Halfwalker » Wed Sep 20, 2006 8:17 am

Please see this thread ...

http://www.ryanvm.net/forum/viewtopic.php?p=34976#34976

Basically, something in the UpdatePack2.1.2 is preventing the themes from changing the Start button and Taskbar look.

Thanks -

DC

ScOOt3r
Posts: 272
Joined: Tue May 16, 2006 12:21 am
Location: Vancouver 2010 Olympics!

Post by ScOOt3r » Wed Sep 20, 2006 8:25 am

I guess its my turn to get this too.. thanks Ryan


ScOOT3r!
Go Canada Go!

BZJoe
Posts: 35
Joined: Sun Apr 16, 2006 1:19 pm

Post by BZJoe » Wed Sep 20, 2006 1:01 pm

RyanVM wrote:Got home today :)
Man, your spoiling us! :D

Jusr reporting that it seems to be working fine with me. Although I don't use a lot of fancy things...

User avatar
MrNxDmX
Moderator
Posts: 3112
Joined: Mon Jan 03, 2005 7:33 am

Post by MrNxDmX » Wed Sep 20, 2006 1:12 pm

the_guy wrote:@MrNxDmx: Yes I am sure I am at the right topic. It's the part that TripleA highlighted from Ryan's update list.

the_guy
ok :rolleyes:

TechnoHunter
Posts: 506
Joined: Sun Feb 26, 2006 4:13 am

Re: Update pack interferes with themes

Post by TechnoHunter » Wed Sep 20, 2006 8:18 pm

Halfwalker wrote:Please see this thread ...

http://www.ryanvm.net/forum/viewtopic.php?p=34976#34976

Basically, something in the UpdatePack2.1.2 is preventing the themes from changing the Start button and Taskbar look.

Thanks -

DC
see my reply in that thread.. there is no problem with the update pack.. instead it is his build order that is at fault!

TechnoHunter

chiners_68
Posts: 55
Joined: Wed Sep 13, 2006 5:57 am

Post by chiners_68 » Fri Sep 22, 2006 6:18 am

has this pack got a fix for my problem..?
During install with 2.1.1 update pack im now getting the plug & play monitor window apear which needs manual imput. If I recall this was due to a previous microsoft update. is there a fix so this dosent apear or do i have to wait for an updated pack..?
Previous pack I usesd possibly 2.0.X didnt have this issue.

issue is with the intel 82915G/GV/910GL chipset. on a dell gx520.

cheers

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Fri Sep 22, 2006 10:31 am

Nope, and you're the only person to report such an issue, which makes me suspicious ;)
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
cyberloner
Posts: 315
Joined: Tue Sep 20, 2005 2:13 am
Location: http://www.cybermania.ws
Contact:

Post by cyberloner » Fri Sep 22, 2006 12:07 pm

chiners_68 wrote:has this pack got a fix for my problem..?
During install with 2.1.1 update pack im now getting the plug & play monitor window apear which needs manual imput. If I recall this was due to a previous microsoft update. is there a fix so this dosent apear or do i have to wait for an updated pack..?
Previous pack I usesd possibly 2.0.X didnt have this issue.

issue is with the intel 82915G/GV/910GL chipset. on a dell gx520.

cheers
ryan pack is perfect...
detected plug & play monitor sound like driver installation method or driver version u have recently install is none WHQL .. or you are running driver install before login windows...
something like that...

User avatar
ENU_user
Posts: 1253
Joined: Wed Jan 25, 2006 1:42 pm

Post by ENU_user » Sun Sep 24, 2006 9:09 am

will it be ok to ask for 2 diff requests
1 can you add an indicator for updatepack version number in RVMUpPck.inf tip
2 a link from ( updatepack.html download ) to current latest rls updatepack discussion topic

for needs &fast references ..
thanks again for the great work :)

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Sun Sep 24, 2006 9:13 am

ENU_user wrote:will it be ok to ask for 2 diff requests
1 can you add an indicator for updatepack version number in RVMUpPck.inf tip
I'm not quite sure I follow. The version number is in the [Strings] section at the bottom if that's what you want.
2 a link from ( updatepack.html download ) to current updatepack discussion topic
Good idea.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
ENU_user
Posts: 1253
Joined: Wed Jan 25, 2006 1:42 pm

Post by ENU_user » Sun Sep 24, 2006 9:25 am

yes its found under [strings] :)
thanks

begundal
Posts: 7
Joined: Wed Jul 12, 2006 3:17 pm

Post by begundal » Mon Sep 25, 2006 11:19 am

is there any way to d/l the update pack using download manager
already tried Download Accelerator Plus and FlashGet
unfortunately I'm a dial-up user

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Mon Sep 25, 2006 12:34 pm

Make sure your download manager sends referrers and it should work just fine. I've tested with Getright and it worked without issue.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

the_guy
Posts: 242
Joined: Wed Feb 01, 2006 6:22 am
Location: PEI, Canada

Post by the_guy » Tue Sep 26, 2006 6:33 pm

MS06-055 released! Patches vgx.dll flaw and replaces KB883586

the_guy

molenin
Posts: 13
Joined: Thu Aug 17, 2006 4:43 am

Post by molenin » Wed Sep 27, 2006 2:09 pm

I am using Ryan's Update packs for a long time.
And I never had problems with it... But with 2.1.1 version I can't use my LIP(stripped MS Windows MUI).
I am using Nlite 1.0.1 as usual, I am trying Integrator 1.4.1 - no way...

I tried to use "optimized" russian LIP. There was a mistakes, but all interface(80-90%) was russian in previous packs.
But 2.1.1 give me 20-30% of localization.

I used registry tweaks, and have received almost good Russian interface,
but RightClick_Menu and Display_options still in english.

With 2.1.2 I have the same problem. :(

Can you help me?

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Wed Sep 27, 2006 3:44 pm

The long story short is that you're doing something which is unsupported and no, I don't think anybody here will be of any help to you.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Wed Sep 27, 2006 3:50 pm

Bump for a majority security update.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

molenin
Posts: 13
Joined: Thu Aug 17, 2006 4:43 am

Post by molenin » Wed Sep 27, 2006 4:31 pm

RyanVM
The long story short is that you're doing something which is unsupported and no, I don't think anybody here will be of any help to you.
I always create Windows Install some way. I had created many(maybe 20 or more) installation images from 06/2005. But I have problems only with latest versions of your pack.
I think some patches prevent interface translating.

It isn't only my problem. Geraser said(Fri Aug 25):
I stand by every word of what molenin wrote. May be poltergeist , and in the new version of pack all will be ok.
New pack is out, but... :(

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Wed Sep 27, 2006 4:38 pm

Nothing went into 2.1.1 which particularly stands out, but it was probably an MS security update. At that point, take it up with them.

You can see the 2.1.1 changelog and access to all the fixes included, so you should be able to figure out exactly what fix broke it rather than spending two months waiting for someone else to do it for you out of the kindness of their heart.
Last edited by RyanVM on Wed Sep 27, 2006 4:43 pm, edited 1 time in total.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

mindwarper
Posts: 255
Joined: Mon Jul 25, 2005 9:56 pm
Location: Netherlands

Post by mindwarper » Wed Sep 27, 2006 4:43 pm

t seems when I try to download the RVM UpdatePack 2.1.2 I get an 403 error (Forbidden)...
something wrong ? or just too many users wanting to download the pack ?

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Wed Sep 27, 2006 4:44 pm

mindwarper wrote:t seems when I try to download the RVM UpdatePack 2.1.2 I get an 403 error (Forbidden)...
something wrong ? or just too many users wanting to download the pack ?
RyanVM wrote:If you do run into anything you think is an error, be sure to consult with the FAQ on my site before asking about it here.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

mindwarper
Posts: 255
Joined: Mon Jul 25, 2005 9:56 pm
Location: Netherlands

Post by mindwarper » Wed Sep 27, 2006 4:47 pm

RyanVM wrote:
mindwarper wrote:t seems when I try to download the RVM UpdatePack 2.1.2 I get an 403 error (Forbidden)...
something wrong ? or just too many users wanting to download the pack ?
RyanVM wrote:If you do run into anything you think is an error, be sure to consult with the FAQ on my site before asking about it here.
OK OK I get it, mayB my ZoneAlam is letting me not download...
and I am using Firefox 2.0 RC 1 as of today, mayB that accounts for something too

hilly
Posts: 1
Joined: Thu Jul 27, 2006 6:45 am

Post by hilly » Wed Sep 27, 2006 5:32 pm

thank you ryan for the update and thanks for the e-mail
keep up the good work

Locked