Bootable CD is NOT bootable...

Questions about Update Pack making? Ask here.
Post Reply
Zosimos
Posts: 16
Joined: Wed May 02, 2007 2:41 pm

Bootable CD is NOT bootable...

Post by Zosimos » Wed May 02, 2007 6:24 pm

I've experienced several weird events leading up to my current situation, so let me describe them all in case there is a relationship between them.

First, the Integrator seems to only run properly under Win 2k/XP. Some of us poor folk out here are still running 9x and trying to upgrade (thus my current post). The Integrator really ought to give a warning instead of trying to run and then just freezing (trying to use some features not available in Win9x I guess).

When I ran the integrator on an XP system it finally worked. But, it took more than an hour. Not all of us have the latest 64-bit dual core CPUs, either. :) Some sort of explanation of how long it might take would be a good thing to include in the instructions.

But here is where the weirdness starts, When I used the internal 'Make ISO' feature it would build the ISO out of files located in/under the destination folder instead of the source. Where the directory in the box labeled "Browse to Location which contains the I386 directory" didn't matter. It would look where the box labeled "Browse to the destination directory" for the files. I got an ISO over a gigabyte a few times as I was trying to figure out what was going on. Finally I pointed both of these to the same directory where the merged XP files were located.

When it finally made an ISO that seemed right, I burned it to CD and tried to get it to boot. It gives the message to press any key to boot from the CD, but if you do, it freezes. Looking at the CD under windows, it LOOKS fine. All of the XP install files are visible. After several tries with the internal ISO maker I tried the instructions from Elder Geek on how to burn a bootable update with Nero. It also looked successful, but produced the same result. The CD doesn't boot if you touch a key. It just freezes. Only the original Windows CD with the several years old files actually boots when you put it in a CD drive.

Seeing all these sites describing how easy and convenient it is to make these slipstreamed CDs, I have to assume that Windows does not have 'copy protection' and I have been doing something wrong. But what? I followed the instructions exactly and I've burned many CDs before. The only thing I can think of is that Nero is screwed up somehow. It is the only CD burning program available on this XP system. Is there some other free CD burner I could try?

Anyone got any idea what is going on? Or should I just start downloading Autopatcher?
Last edited by Zosimos on Thu May 03, 2007 5:06 pm, edited 1 time in total.

MrWoo
Posts: 39
Joined: Mon Aug 07, 2006 12:59 pm

Post by MrWoo » Wed May 02, 2007 8:20 pm

I would suggest that you learn grub4dos. You use the integrator or whatever you may be building, then grub4dos basically builds a menu that you can customize to do lots of neatness. You make the iso with a batch file (which is really quick). Takes a bit of learning, but the results are well worth it.

On the other hand, I have built lots of xp installs, and there are lot's of good tutorials out there for it. My favorite is the msfn unattended guide.

As for your issues, I have used all the 2k varieties as well as xp using methods similar to what eldergeek describes. I have yet to see what you are describing.

I would suggest:
Copy contents of xp source disk to hdd
Perform the slipstream of SP2
Compile the project .. burn .. test
Then use the integrator (burning again) and see if it still successful.

From my experience, if the integrator finishes, it works. My problems have always came when my update pack was corrupt or I had a messed up add-on.

later.

Zosimos
Posts: 16
Joined: Wed May 02, 2007 2:41 pm

Post by Zosimos » Thu May 03, 2007 3:53 pm

Well, I simply re-ran the entire process... waiting an hour or so for the merge to finish and then made another ISO from the new update. And used DeepBurner instead of Nero to burn the CD. THIS one seems to work. Hmm... Why is it with everything associated with Windows it works or it doesn't and the only 'fix' is to try again from scratch? But it might be that Nero was not burning the ISO properly. Anyway, so far so good.

Now for the next question... :)

Post Reply