Digital Certificate problem after integrating v2.1.10+

Questions about Update Pack making? Ask here.
Post Reply
madman77
Posts: 8
Joined: Fri Aug 31, 2007 10:54 pm

Digital Certificate problem after integrating v2.1.10+

Post by madman77 » Sat Sep 01, 2007 11:14 am

I have been using your update pack for a while now and not until recently have I had an issue using digital certificates. Here are the fine details:

I use a common access card to access my employers MS Outlook webmail service from home. I am able to do so by using the ActivCard client. After integrating your post-SP2 update pack from v2.1.10+ I can no longer select certificates when the digital certificate window appears while I try to log on. The window is grayed out and I am no longer able to see or select my certificates.

I thought it may be something that you included in your Addon Pack so I integrated a new install CD with just v2.1.11 post-SP2 pack and installed it on my notebook. All I installed after that was was the common access card driver, the ActivCard client the network card driver. The problem is still there.

I then just burned a plain XP SP2 CD, installed it and used the same common access card driver, ActivCard client and network card driver. It worked this time. So I thought I would run MS Update to see if installing any of their patches would cause the same problem. I installed all of the "high priority" updates, rebooted and tried to access webmail again. It still worked.

Sorry to run on there but there seems to be something in your post-SP2 pack from v2.1.10+ that does not allow me to access those certificates. Would you know what would cause that?

Thanks ahead of time for anyone that can help me out with this.

User avatar
mr_smartepants
Posts: 824
Joined: Thu May 18, 2006 5:56 am
Location: Cambridgeshire, UK

Re: Digital Certificate problem after integrating v2.1.10+

Post by mr_smartepants » Sat Sep 01, 2007 11:28 am

madman77 wrote: I use a common access card to access my employers MS Outlook webmail service from home. I am able to do so by using the ActivCard client.
I also use my CAC card to access webmail with the ActivCard client. I will build a new disc for testing and report back since I doubt many other users around here would be able to duplicate your problem. Currently I have no problems, but I will verify with a new build just to make sure.

madman77
Posts: 8
Joined: Fri Aug 31, 2007 10:54 pm

Re: Digital Certificate problem after integrating v2.1.10+

Post by madman77 » Sat Sep 01, 2007 11:37 am

mr_smartepants wrote:
madman77 wrote: I use a common access card to access my employers MS Outlook webmail service from home. I am able to do so by using the ActivCard client.
I also use my CAC card to access webmail with the ActivCard client. I will build a new disc for testing and report back since I doubt many other users around here would be able to duplicate your problem. Currently I have no problems, but I will verify with a new build just to make sure.
Thanks. What have you added/removed to allow access?

User avatar
mr_smartepants
Posts: 824
Joined: Thu May 18, 2006 5:56 am
Location: Cambridgeshire, UK

Post by mr_smartepants » Sat Sep 01, 2007 3:07 pm

OK, I just got done wiping and installing a fresh copy of XP and everything works great.
I used the following addons:

Code: Select all


18:23:19  - Extracting RVMUpdatePack2.1.11-ReCabbed.zip
18:23:36  -     MD5 Hash = 337EFBC4BEAB27A227D98ABA0F4364E8
18:23:36  - Extracting DX9-1.4.1-Addon-ReCabbed.zip
18:23:38  -     MD5 Hash = 918B61CC803A2DFB9D5ED9E48C21E417
18:23:38  - Extracting Fonts_Addon_LZ_Combo_v1.7z
18:23:41  -     MD5 Hash = B5EFC7A35FDB78829C83AD39E592821E
18:23:41  - Extracting Fonts_AddOn_Ricks_VistaRTM_v1.1-ReCabbed.zip
18:23:42  -     MD5 Hash = C10FDDE58B0F66785B5EFFD7A2293DA7
18:23:42  - Extracting Icons_AddonNR_DesktopIcons-ReCabbed.zip
18:23:42  -     MD5 Hash = A2AF4ECE87E64D0F900E1E247C9E2DD9
18:23:42  - Extracting NR_CursorsAIO_Addon_1.9-ReCabbed.zip
18:23:42  -     MD5 Hash = 4DD4CCBD5C1FFF6A7CA044C861AAA721
18:23:42  - Extracting RUPUpdates-2.1.11.10-Addon-ReCabbed.zip
18:23:45  -     MD5 Hash = B3F8C9753D183FF0CF6E26F0C845F95B
18:23:45  - Extracting RVMAddonsWGAN_1.7.18.5a-ReCabbed.zip
18:23:46  -     MD5 Hash = D4D3E6F19B4D41F79D9B1B113381747D
18:23:46  - Extracting Theme_Addon_BTSbg_v1.0.CAB
18:23:46  -     MD5 Hash = 54F9D8822FAFD8AC1C73A61A75DA69FE
18:23:46  - Extracting Theme_addon_LXP_startuporb_1.2-ReCabbed.zip
18:23:46  -     MD5 Hash = 47A50B8775EF7D16D477263A4F46BDBE
18:23:46  - Extracting Theme_Addon_XP_Vista_Pack.cab
18:23:47  -     MD5 Hash = DA98EC97235A6D1DAB7DBA96E0F421CD
18:23:47  - Extracting z_Addon_Ryan_DOTNETAIO.7z
18:24:03  -     MD5 Hash = 5117040F6BD5798A9E98F508BC95E51B
18:46:23  - Extracting Addon_Foxy_7-Zip_4.42_v1.0.cab
18:46:23  -     MD5 Hash = ED618E5F21FA22768A8DD0A50220B2A1
18:46:23  - Extracting Addon_Kels_CabPack_v1.4a.CAB
18:46:24  -     MD5 Hash = 8C04E910D5442B0FD88FDED26BEA05FA
18:46:24  - Extracting Addon_Kels_MSConfig_v1.1.CAB
18:46:24  -     MD5 Hash = 2B8842DC7961F6F86ECA96D803A51644
18:46:24  - Extracting Addon_Kels_VistaDriveIndicator_v2_uninstallable.CAB
18:46:24  -     MD5 Hash = A626165A56F164DEA1B98C82AB944C42
18:46:24  - Extracting Addon_Kels_XPero_ToolPack_v1.cab
18:46:24  -     MD5 Hash = 11ABD33D13C07139328EBF06049D280A
18:46:24  - Extracting Addon_ReapersPDF093.cab
18:46:25  -     MD5 Hash = DC9EAD9E323D7DF6CBBC2B1C0AFC9E1B
18:46:25  - Extracting AddOn_Ricks_VistaLunaLClock_v1.6b2.rar
18:46:25  -     MD5 Hash = 411592F3D773706D84B8938E1ADD145F
18:46:25  - Extracting Games_Addon_MrsP_Absolutist_Flash_v1.0.1.cab
18:46:25  -     MD5 Hash = 35486CCEA33109D4175CDDCEB2E847CF
18:46:25  - Extracting Games_Addon_MrsP_Neave_Flash_v1.0.1.cab
18:46:26  -     MD5 Hash = EB6D89DD939A79F50AC82B725138169F
18:46:26  - Extracting MrsP_Inno_Setup_Unpacker_Addon_v0.19.cab
18:46:26  -     MD5 Hash = CA0A3C37B0B62E5C5020285630C79091
18:46:26  - Extracting MrsP_Koepi_XviD_Addon_v1.1.3-070805.cab
18:46:26  -     MD5 Hash = 39E9DB3BA2B97419DF698192ADE76D7F
18:46:26  - Extracting MrsP_Universal_Extractor_Addon_v1.5-070804.cab
18:46:26  -     MD5 Hash = F2E03FC53441C8A37C9B2EA803093228
18:46:26  - Extracting MrsP_Visual_Ping_Addon_v0.8-070707.cab
18:46:26  -     MD5 Hash = 3CD3F3DFDB1487B61CFB15537AC89679
18:46:26  - Extracting NR_IE7en_Addon_1.0.6b_alt.7z
18:46:32  -     MD5 Hash = A578B058FE80AA80BD8E8D2E0686BF9E
18:46:32  - Extracting PatchAddon_HIVESYS_v20070628.7z
18:46:33  -     MD5 Hash = C90E903F1CE846A48F0F8723AF29B23E
18:46:33  - Extracting PatchAddon_TCP100_v20070628.7z
18:46:33  -     MD5 Hash = 1540F5753CFFB7E5AF18B933DA2D45AB
18:46:33  - Extracting PatchAddon_UXTHEME_v20070628.7z
18:46:33  -     MD5 Hash = EFC12322D04BA2129B97BD33663391D6
18:46:33  - Extracting RVMAddons_1.8.2.7z
18:46:34  -     MD5 Hash = F8194D929D6C38D16501633525F982DD
18:46:34  - Extracting Theme_Addon_MSSignedThemes_v2.2.7z
18:46:36  -     MD5 Hash = AA318D0C3005E8DE0FBE964D64C14F3C
18:46:36  - Extracting Theme_Addon_NR_VistaUAP_1.1.cab
18:46:36  -     MD5 Hash = 7983CE4BA134419805F4646863CD176E
18:46:36  - Extracting Theme_Addon_VistaWallpapers_v1.7z
18:46:52  -     MD5 Hash = DE6488DF3BCD25CF366D4286857AAE6D
18:46:52  - Extracting Theme_Ricks_VistalunaBasic2.6_AddOn.rar
18:46:52  -     MD5 Hash = E58F6DEFEB61B023AD9F44297B47247A
I also loaded the CD with the latest BTS driverpacks.

Once I reached the desktop, I went online and downloaded ActivCard v6 as well as the DoD trusted root certificates. Installed them all and presto, instant webmail access. :)
I'm not sure what is causing your problems, but it's not any of the above packs.
Try reinstalling your certificates. You can also check IE settings (Content tab, Certificates).

madman77
Posts: 8
Joined: Fri Aug 31, 2007 10:54 pm

Post by madman77 » Sat Sep 01, 2007 10:38 pm

I have manually deleted all my certificates and imported them many times, including rebooting in between and it doesn't help. The thing is I do not install anything beyond WinXP Pro with update pack v2.1.11 and the CAC card drivers, network card drivers and ActivCard v6. I don't understand why IE doesn't allow me to select/view certificates.

User avatar
mr_smartepants
Posts: 824
Joined: Thu May 18, 2006 5:56 am
Location: Cambridgeshire, UK

Post by mr_smartepants » Sun Sep 02, 2007 2:14 am

ActivCard should automatically import your personal certificates from your CAC card if they don't already exist. If not, you may have to import your card certificates manually.

madman77
Posts: 8
Joined: Fri Aug 31, 2007 10:54 pm

Post by madman77 » Sun Sep 02, 2007 10:38 am

Yes, I have made sure that the certificates were imported every time by checking under the content tab. Whether I did it manually or ActivCard did it for me. That is not the issue. The issue is that IE will not allow me to even select any certificates when the "choose digital certificate" window pops up while trying to log in.

madman77
Posts: 8
Joined: Fri Aug 31, 2007 10:54 pm

Post by madman77 » Mon Sep 03, 2007 1:09 am

Here is a pic of what I get when I try to log in. Click for full size.

Image

techtype
Posts: 268
Joined: Mon Aug 15, 2005 5:46 pm

Post by techtype » Mon Sep 03, 2007 7:35 am

Did you tweak your services? Like maybe turn off cryptographic service?

madman77
Posts: 8
Joined: Fri Aug 31, 2007 10:54 pm

Post by madman77 » Mon Sep 03, 2007 9:49 am

Not that I am aware of. This problem comes off a fresh install of XP with v2.1.11 update pack integrated.

Where should I look to see if something has been changed?

Edit: I just went to Services under Administrative Tools in the CP and it says the Cryptographic service is started.

madman77
Posts: 8
Joined: Fri Aug 31, 2007 10:54 pm

Post by madman77 » Wed Sep 05, 2007 6:06 am

Can anyone think of anything else that could be the issue here?

madman77
Posts: 8
Joined: Fri Aug 31, 2007 10:54 pm

Post by madman77 » Fri Sep 07, 2007 6:04 am

Hmmmm... I guess so. Thanks to those that helped out. I will just have to figure this one out on my own.

Post Reply