Integration order, SvcPack and other questions

Questions about Update Pack making? Ask here.
Post Reply
toco1971
Posts: 39
Joined: Wed Mar 18, 2009 10:46 pm
Location: Australia

Integration order, SvcPack and other questions

Post by toco1971 » Wed Mar 18, 2009 11:27 pm

hi all and thanks to RyanVM and jd976 and all others invovled

my first post so no need to fry me ive been through this thread with no answers


ok heres wat i want to do

slipsteam into windows xp pro sp2 v5.1.2600.2180 x86


wmp11-windowsxp-x86-enu.exe
md5: c5d9d62e35b4f8f5a6f495b41f532539

IE7-WindowsXP-x86-enu.exe
md5: ea16789f6fc1d2523f704e8f9afbe906

DotNetFx_All_In_1_Addon_v2.4.7z
md5: d521f5f64d36d5b68728d44c849815fd

WindowsXP-KB936929-SP3-x86-ENU.exe
md5: bb25707c919dd835a9d9706b5725af58

RVMUpdatePackSP3_1.0.3.7z
md5: 6b85b116ac1591f7ec2c7ffc4760e20d



programs i have are


nLite-1.4.9.1.exe
md5: cb0eff52ee9ab11d63d5d6000116e334

RVM_Integrator_1.5.4_b09.7z
md5: 5089bba2ce26abd1ccae43c9ed8302ba

wmp11slips1.4i.exe (WMP11Integrator.exe)
md5: 19d449f80cb8c0102c469de7f3c43b10


i dont know in which order i should use the above files???

eg. sp3 or netframework first? using nlite or RVM_Integrator?

dont know if i need "WMP11Integrator.exe" or not???

and believe me ive tried !!!!!!

thanks in advance

Tony

sorry 4 my long post but it may help others

User avatar
5eraph
Site Admin
Posts: 4621
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Thu Mar 19, 2009 12:00 am

I'd recommend this order:
  1. Use RyanVM Integrator 1.6 to integrate the following:
    1. RVMUpdatePackSP3_1.0.3.7z
      • You will be asked for WindowsXP-KB936929-SP3-x86-ENU.exe during integration.
    2. DotNetFx_All_In_1_Addon_v2.4.7z
  2. Use WMP11 Slipstreamer 1.4.1.0 to slipstream wmp11-windowsxp-x86-enu.exe.
  3. Use nLite 1.4.9.1 to perform the following tasks:
    1. Slipstream Hotfix: IE7-WindowsXP-x86-enu.exe
    2. Create ISO

toco1971
Posts: 39
Joined: Wed Mar 18, 2009 10:46 pm
Location: Australia

Post by toco1971 » Thu Mar 19, 2009 2:07 am

thanks for the fast reply "5eraph"

ive downloaded the new version

RVM_Integrator_1.6.7z

ill give it a go now and let u know how i go

thanks again

tony

toco1971
Posts: 39
Joined: Wed Mar 18, 2009 10:46 pm
Location: Australia

Post by toco1971 » Thu Mar 19, 2009 5:33 am

i tried the above technique using virtual pc
but netframework isnt installed and lots of critical updates missing to

High-priority updates


Windows Malicious Software Removal Tool - March 2009 (KB890830)
Download size: 9.8 MB , 4 minutes


Security Update for Windows XP (KB960225)
Typical download size: 259 KB , less than 1 minute


Security Update for Windows XP (KB938464)
Download size: 1.2 MB , less than 1 minute


Security Update for Windows XP (KB958690)
Typical download size: 613 KB , 1 minute


Update for Windows XP (KB959772)
Download size: 5.5 MB , 2 minutes


Update Rollup for ActiveX Killbits for Windows XP (KB960715)
Download size: 486 KB , less than 1 minute


Cumulative Security Update for Internet Explorer 7 for Windows XP (KB961260)
Download size: 8.6 MB , 3 minutes


Security Update for Windows XP Service Pack 3 (KB952069)
Download size: 7.4 MB , 3 minutes


Windows Genuine Advantage Notification (KB905474)
Download size: 1.3 MB , less than 1 minute

Security Update for Windows XP (KB954154)
Download size: 604 KB , less than 1 minute


Security Update for Internet Explorer 7 for Windows XP (KB938127)
Download size: 774 KB , less than 1 minute


Update for Windows Media Player 11 for Windows XP (KB939683)
Download size: 548 KB , less than 1 minute


Security Update for Windows Media Player 11 for Windows XP (KB936782)
Download size: 5.5 MB , 2 minutes


Update for Windows Media Format 11 SDK for Windows XP (KB929399)
Download size: 626 KB , less than 1 minute


Security Update for Windows XP with Windows Media Format Runtime 9.5 and 11 (KB941569)
Download size: 2.1 MB , less than 1 minute




Optional software updates


Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update (KB951847) x86
Download size: 248.4 MB , 1 hour 37 minutes



is netframework ment to intall automatically or do you have to do it manually
i noticed it "RVM_Integrator_1.6" placed "NETFXAIO.EXE" in the "\I386\svcpack\" folder on the cd
is this right ????

any help would be much appreciated

thanks tony

User avatar
5eraph
Site Admin
Posts: 4621
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Thu Mar 19, 2009 7:22 am

I'll start with the following disclaimers:
  • I use (and create update packs for) XP x64; therefore, I do not normally test x86-based addons or update packs except RyanVM's or my own. More specifically, I have not tested this .NET Framework installer, so I cannot say how well it should work nor can I provide any guarantee.
  • RyanVM last updated his pack in January. High priority updates released by Microsoft in the interim are not included. Other update packs are available that are more up-to-date, such as OnePiece's and redxii's.
  • RyanVM and redxii do not include updates for IE7 or WMP11. You will need to add these on your own in nLite, unless you use OnePiece's update pack which includes both.
Now that that is out of the way, I suppose the only remaining issue is the .NET installer.
toco1971 wrote:i tried the above technique using virtual pc
but netframework isnt installed [...]

is netframework ment to intall automatically or do you have to do it manually
i noticed it "RVM_Integrator_1.6" placed "NETFXAIO.EXE" in the "\I386\svcpack" folder on the cd
is this right ????
That is correct. A matching entry should exist in SvcPack.inf under [SetupHotfixesToRun] which should execute the .NET installer at the T-13 mark during the GUI-mode of Windows setup. If it's not working then there are other alternatives that you can try on RogueSpear's forum (registration required).

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Thu Mar 19, 2009 11:24 am

from your original post you are using an SP2 source.
you will have to slipstream the SP3 servicepack 1st and then
you can integrate the RVMupdate_103 pack and your addons.

you are trying to apply a post SP3 pack to an SP2 source

User avatar
5eraph
Site Admin
Posts: 4621
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Thu Mar 19, 2009 3:43 pm

I have covered that, user_hidden. The following steps work.
5eraph wrote:I'd recommend this order:
  1. Use RyanVM Integrator 1.6 to integrate the following:
    1. RVMUpdatePackSP3_1.0.3.7z
      • You will be asked for WindowsXP-KB936929-SP3-x86-ENU.exe during integration.
Aside from the apparent failure of the .NET package, toco1971's results are correct and expected with the steps I have laid out above.

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Thu Mar 19, 2009 9:04 pm

5eraph

you know i just plain didn't notice :oops:

toco1971
Posts: 39
Joined: Wed Mar 18, 2009 10:46 pm
Location: Australia

Post by toco1971 » Fri Mar 20, 2009 3:39 am

hi again and thanks 4 all the help

it looks like the top line of svcpack.inf (svcpack.in_) looks corrupted MAYBE???????

MSCF î , H ‰ õ*kr svcpack.inf ±«»Ôž ‰ [€€￾ 0￾~ 1 [Version]
Signature="$Windows NT$"

[SetupData]
CatalogSubDir="i386\SVCPACK"

[ProductCatalogsToInstall]

[SetupHotfixesToRun]
netfxAIO.exe

i had to change a few settings CatalogSubDir="i386\SVCPACK" originally had "i386\hotfixes"
and i had to add netfxaio.exe

thats before i try to update anything
after i did all the steps it looked even worse without all the relevent info below

[Version]
Signature="$Windows NT$"

[SetupData]
CatalogSubDir="i386\SVCPACK"

[ProductCatalogsToInstall]

[SetupHotfixesToRun]
netfxAIO.exe


i havent tried it yet cause it looks corrupted but ill give it ago anyways let you know

sry 4 my l8 and rough replies but i been a little busy

thanks tony

User avatar
5eraph
Site Admin
Posts: 4621
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Fri Mar 20, 2009 5:54 am

Did you decompress SvcPack.inf before modifying it?

Renaming SvcPack.in_ does not work. It must be decompressed with 7-Zip, WinRAR, or another file compression utility that can handle cabinet archives (.CAB).

toco1971
Posts: 39
Joined: Wed Mar 18, 2009 10:46 pm
Location: Australia

Post by toco1971 » Fri Mar 20, 2009 6:02 am

no

toco1971
Posts: 39
Joined: Wed Mar 18, 2009 10:46 pm
Location: Australia

Post by toco1971 » Fri Mar 20, 2009 6:04 am

i found this on the web should i start with it

[CatalogHeader]

[Version]
BuildNumber=2600
MinorVersion=1
MajorVersion=5
Signature="$Windows NT$"

[SetupData]
CatalogSubDir="\i386\svcpack"

[ProductCatalogsToInstall]

[SetupHotfixesToRun]

toco1971
Posts: 39
Joined: Wed Mar 18, 2009 10:46 pm
Location: Australia

Post by toco1971 » Fri Mar 20, 2009 6:05 am

how do you uncompress it i just said open with note pad

ill try 7zip

toco1971
Posts: 39
Joined: Wed Mar 18, 2009 10:46 pm
Location: Australia

Post by toco1971 » Fri Mar 20, 2009 6:06 am

ok zip worked

toco1971
Posts: 39
Joined: Wed Mar 18, 2009 10:46 pm
Location: Australia

Post by toco1971 » Fri Mar 20, 2009 6:15 am

ok i created new txt document

and added this to it


[CatalogHeader]

[Version]
BuildNumber=2600
MinorVersion=1
MajorVersion=5
Signature="$Windows NT$"

[SetupData]
CatalogSubDir="\i386\svcpack"

[ProductCatalogsToInstall]

[SetupHotfixesToRun]

then i named it "svcpack.inf"

then zipped it up with 7zip

then renamed it "svcpack.in_"

is this correct??????????

User avatar
Pasha_ZZZ
Posts: 242
Joined: Thu Jul 13, 2006 6:27 am
Location: Russia, Slobodskoy

Post by Pasha_ZZZ » Fri Mar 20, 2009 6:53 am

No-no-no!!! It must be CABbed!!! But you can place uncompressed file SVCPACK.INF if you remove SVCPACK.IN_

User avatar
5eraph
Site Admin
Posts: 4621
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Fri Mar 20, 2009 7:08 am

You should start with the original compressed SvcPack.in_ and decompress it. It contains more information than you're providing if you integrate an update pack. You can't easily recreate the missing information by hand.

If you need to, start again with a fresh source and follow my directions above--perhaps with a more recent update pack. Then, if you decompress SvcPack.in_ and take a look, you should see everything in place that needs to be there. You shouldn't need to add anything to it.

toco1971
Posts: 39
Joined: Wed Mar 18, 2009 10:46 pm
Location: Australia

Post by toco1971 » Fri Mar 20, 2009 7:34 am

Pasha_ZZZ wrote:No-no-no!!! It must be CABbed!!!
lol

ok ill try leave it unzipped this time

hey thanks 4 the help im neally there i think

lol

hey after i ran the mp11 it removed all the cat files and netfxAIO.exe

out of the inf file

maybe cause i 7zipped it ill try leave it uncompressed this time

hey should 7zip b able to uncompress the original svcpack.in_ in my sp2 source cause it cant but it unzippes it after sp3 dotnet etc....

User avatar
5eraph
Site Admin
Posts: 4621
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Fri Mar 20, 2009 7:44 am

Yes, it should. But you shouldn't touch SvcPack.in_ until everything else is done, including the WMP11 slipstreamer.

toco1971
Posts: 39
Joined: Wed Mar 18, 2009 10:46 pm
Location: Australia

Post by toco1971 » Fri Mar 20, 2009 7:50 am

it cant though im thinking it is corrupted

User avatar
5eraph
Site Admin
Posts: 4621
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Fri Mar 20, 2009 7:58 am

If it can't then delete the file before integrating an update pack. The Integrator should create a new file with the proper information.

toco1971
Posts: 39
Joined: Wed Mar 18, 2009 10:46 pm
Location: Australia

Post by toco1971 » Fri Mar 20, 2009 8:03 am

ok it was corrupted

i recopied the original cd to my hd and now it uncompresses but all it has in it is

[Version]
Signature="$Windows NT$"

[SetupData]
CatalogSubDir="i386\hotfixes"

[ProductCatalogsToInstall]

[SetupHotfixesToRun]

does that look normal to you its definetly sp2

User avatar
5eraph
Site Admin
Posts: 4621
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Fri Mar 20, 2009 8:18 am

That looks normal, but you can't use it as is. The Integrator needs to write the catalog files in the SvcPack directory under [ProductCatalogsToInstall].

toco1971
Posts: 39
Joined: Wed Mar 18, 2009 10:46 pm
Location: Australia

Post by toco1971 » Fri Mar 20, 2009 8:27 am

yeh youve already tought me that much i just wanted to make sure it looked valid first

i just integrated the dotnefix and now i have this

[Version]
Signature="$Windows NT$"

[SetupData]
CatalogSubDir="i386\SVCPACK"

[ProductCatalogsToInstall]

[SetupHotfixesToRun]
netfxaio.exe


looking good

so now ill go back to the first post u sent me
with a fresh copy again, just wanted to see if the netframework did its thing and it did

ill let you know when its done

thanks 5eraph

toco1971
Posts: 39
Joined: Wed Mar 18, 2009 10:46 pm
Location: Australia

Post by toco1971 » Fri Mar 20, 2009 9:15 am

after update and sp3

[Version]
Signature="$WINDOWS NT$"
BuildNumber=2600
MinorVersion=1
MajorVersion=5

[SetupData]
CatalogSubDir="\I386\svcpack"

[ProductCatalogsToInstall]
KB281981.CAT
KB887606.CAT
KB909520.CAT
KB917275.CAT
KB922120.CAT
KB932578.CAT
KB932716.CAT
KB938759.CAT
KB940648.CAT
KB942213.CAT
KB942288.CAT
KB943232.CAT
KB943729.CAT
KB944043.CAT
KB946648.CAT
KB947460.CAT
KB948046.CAT
KB948101.CAT
KB948720.CAT
KB949033.CAT
KB949127.CAT
KB949764.CAT
KB949900.CAT
KB950234.CAT
KB950312.CAT
KB950616.CAT
KB950762.CAT
KB950974.CAT
KB951066.CAT
KB951126.CAT
KB951163.CAT
KB951376.CAT
KB951531.CAT
KB951618.CAT
KB951624.CAT
KB951698.CAT
KB951709.CAT
KB951978.CAT
KB952069.CAT
KB952206.CAT
KB952954.CAT
KB953024.CAT
KB953028.CAT
KB953155.CAT
KB953609.CAT
KB953761.CAT
KB954193.CAT
KB954232.CAT
KB954600.CAT
KB954708.CAT
KB954879.CAT
KB954920.CAT
KB955043.CAT
KB955069.CAT
KB955109.CAT
KB955356.CAT
KB955417.CAT
KB955567.CAT
KB955576.CAT
KB955832.CAT
KB955839.CAT
KB955843.CAT
KB955988.CAT
KB956072.CAT
KB956625.CAT
KB956802.CAT
KB956841.CAT
KB957263.CAT
KB958106.CAT
KB958149.CAT
KB958215.CAT
KB958244.CAT
KB958282.CAT
KB958347.CAT
KB958644.CAT
KB958655.CAT
KB958687.CAT
KB958752.CAT
KB958817.CAT
KB959237.CAT
KB959267.CAT
KB959334.CAT
KB959439.CAT
KB959465.CAT
KB960071.CAT
KB960380.CAT
KB960417.CAT
KB960680.CAT
KB960714.CAT

[SetupHotfixesToRun]


looks good to me now ill add netframework

let u know after im done

toco1971
Posts: 39
Joined: Wed Mar 18, 2009 10:46 pm
Location: Australia

Post by toco1971 » Fri Mar 20, 2009 9:20 am

ok it added itself correctly


[SetupHotfixesToRun]
netfxAIO.exe

now 4 mp11

toco1971
Posts: 39
Joined: Wed Mar 18, 2009 10:46 pm
Location: Australia

Post by toco1971 » Fri Mar 20, 2009 9:29 am

ok heres the problem mpi left the file uncompressed and ruined it


[CatalogHeader]

[Version]
BuildNumber=2600
MinorVersion=1
MajorVersion=5
Signature="$WINDOWS NT$"
[SetupData]
CatalogSubDir="\I386\svcpack"
[SetupHotfixesToRun]
wmp11.exe /q /n /z
WMFDist11.exe /q /n /z
MSCompPackV1.exe /q /n /z
Wudf01000.exe /q /n /z
[ProductCatalogsToInstall]
wmp11.cat
WMFDist11.cat
MSCompPackV1.cat
Wudf01000.cat


ill try OnePiece's updatepack instead

post bac tomorow

toco1971
Posts: 39
Joined: Wed Mar 18, 2009 10:46 pm
Location: Australia

Post by toco1971 » Fri Mar 20, 2009 11:22 pm

man this sites got one major problem it keeps logging me out

i just type a long post click submit, but its logged me out takes me to the login screen type my username and password and doesnt bother to take me back to were i was and my long post is history
clicking back doesnt help either

ill have to type it again LOL

toco1971
Posts: 39
Joined: Wed Mar 18, 2009 10:46 pm
Location: Australia

Post by toco1971 » Sat Mar 21, 2009 12:35 am

anyway i finally got it to work thanks to 5eraph

ok heres wat i did

1. wmp11-windowsxp-x86-enu.exe (WMP11 Slipstreamer 1.4.1.0)
(cause it messes up the svcpack.inf file after RVMUpdatePackSP3_1.0.3.7z )

2. RVMUpdatePackSP3_1.0.3.7z (Use RyanVM Integrator 1.6)

3. DotNetFx_All_In_1_Addon_v2.4.7z (Use RyanVM Integrator 1.6)

4. IE7-WindowsXP-x86-enu.exe (nLite 1.4.9.1)

5 .Added missing kb updates i mentioned in an earlier post (nLite 1.4.9.1)

6. Created ISO (nLite 1.4.9.1)

but i had one problem during install unregmp2.exe cannot find wmdrmsdk.dll
(i guess window media digital rights dll)????

anyway thanks again 5eraph i knew nothing about the svcpack.inf file b4 your help now i know alittle about it

i still will have a few questions but ill do sum testing first
thanks again

toco1971
Posts: 39
Joined: Wed Mar 18, 2009 10:46 pm
Location: Australia

Post by toco1971 » Sat Mar 21, 2009 12:38 am

and yes to me thats a long post

toco1971
Posts: 39
Joined: Wed Mar 18, 2009 10:46 pm
Location: Australia

Post by toco1971 » Sat Mar 21, 2009 8:31 pm

i feel a bit stupid now ive just relized that my shortcut i had on the desktop was pointing to WMP11 Integrator and not WMP11Slipstreamer wat a dummy. sorry bout that u r probably there scratching your head

Post Reply