[Question] MUI files, how do I force XP to use them?

Questions about Update Pack making? Ask here.
Post Reply
User avatar
ricktendo64
Posts: 3213
Joined: Mon May 22, 2006 12:27 am
Location: Honduras

[Question] MUI files, how do I force XP to use them?

Post by ricktendo64 » Mon Apr 20, 2009 1:21 am

OK I have a Media Center addon that I translated to Spanish (the dirty way) but I would like to do it the legit way without ruining the digital signature

I found a Spanish MUI Pack that translated XP and the Media Center to Spanish but I could not figure out how the MUI files got used instead so I took the mui files and patched the dll files with them

Now I would like to try and leave the dll's unthouched and use the mui files the way they were meant to be used, so my question is what is the trick...is it a reg entry or something that will tell xp to use the strings in the mui?

I tried every sub-folder imaginable (es, es-es, 0c0a, 1034, 3082, etc) and its not that, so whats the trick?

ty

AndreyPopov
Posts: 54
Joined: Mon Sep 24, 2007 8:25 am

Post by AndreyPopov » Mon Apr 20, 2009 1:13 pm

are you have RegShot?

I think Windows can use mui files only if MUI pack installed.
than you select in Regional settings what system locale you want to use.

I always use English XP and install Russian MUI Pack + MCE MUI pack.

User avatar
ricktendo64
Posts: 3213
Joined: Mon May 22, 2006 12:27 am
Location: Honduras

Post by ricktendo64 » Mon Apr 20, 2009 1:24 pm

Yea I don't really need to install the full MUI pack, I just need to take the MUI's for only the Media Center, then install the English media center on Spanish xp and take the Spanish mui's and tell the media center to look for those

I would like to know if there are registry entries that I can apply to tell it to look to the mui files in a certain folder

AndreyPopov
Posts: 54
Joined: Mon Sep 24, 2007 8:25 am

Post by AndreyPopov » Mon Apr 20, 2009 1:40 pm

I only provide changes in registry when I change MUI system locale:
[HKEY_CURRENT_USER\Control Panel\Desktop]
"MUILanguagePending"="00000419"
"MUILanguagePending"="00000409"

User avatar
George King
Posts: 34
Joined: Mon Dec 01, 2008 10:25 am
Location: cs-CZ

Post by George King » Mon May 04, 2009 8:01 am

AndreyPopov wrote:I only provide changes in registry when I change MUI system locale:
[HKEY_CURRENT_USER\Control Panel\Desktop]
"MUILanguagePending"="00000419"
"MUILanguagePending"="00000409"
Do you know, if your method working?

Post Reply