Hulp gevraagd :( Framedyn.dll & Srclient.dll

Discussion of Dutch translation of the Update Pack. Wees vrij om in het Nederlands te discussiëren!
Locked
Friends4U
Posts: 138
Joined: Sat Aug 19, 2006 4:51 am

Hulp gevraagd :( Framedyn.dll & Srclient.dll

Post by Friends4U » Mon Aug 21, 2006 10:58 am

Ok,

Ik heb een Schone Windows XP Pro geslipstreamd met een SP2.
Daarna heb ik met RVM Integrator 1.4.1 de volgende updates erbij gestopt:

Code: Select all

15:46:04  - Extracting august_updatepack.7z
15:46:04  -     MD5 Hash = 185FFF1C30D04B6B887C1A9763B64169
15:46:16  - Extracting Kels_VistaXP_addon_v1.3.cab
15:46:16  -     MD5 Hash = 9ECAA157603F73E0DAB3E82E506E91D0
15:46:16  - Extracting laptop_addon.7z
15:46:16  -     MD5 Hash = FBE46FA13AD27CBF0A55F84DEC8CDE3B
15:46:16  - Extracting RVMAddons_1.7.0.7z
15:46:16  -     MD5 Hash = 1C133F6EFCC9C3BCF28E3BE2BE710FE2
15:46:17  - Extracting audio_addon.7z
15:46:17  -     MD5 Hash = 1AFDAB9E183C199A1924AE09B2593E35
15:46:18  - Extracting framework_addon.7z
15:46:18  -     MD5 Hash = 8F97CA84BCC3FE0DFAD9BFE16551486C
En daarna heb ik met RVM Integrator 1.4.1 een ISO ervan gemaakt.

Als ik nu Windows instaleer is mijn starmenu vrijwel leeg en hij geeft dus die foutmeldingen dat ik "Framedyn.dll" & "Srclient.dll" mis.
Ik had hier al een topic over gevonden:

http://msfn.org/board/index.php?act=ST&f=89&t=39005

Maar das met nLite, ok als ik framedyn en srclient.dll beide toevoeg aan het lijstje in nLite om niet te wissen dan krijg ik die foutmeldingen niet maar het startmenu is nog steeds erg leeg.

Voorheen heb ik hier nooit last van gehad met vorige updatepacks etc...

Kan iemand me helpen?

Friends4U
Posts: 138
Joined: Sat Aug 19, 2006 4:51 am

Post by Friends4U » Mon Aug 21, 2006 11:02 am

Voor de duidelijkheid ik krijg dus zowel met nLite als de Integrator geen goeie installatie (ik maak een dvd file)

User avatar
HJW
XPu Master
Posts: 622
Joined: Fri Jul 14, 2006 4:17 pm
Location: University of Technology Delft, Netherlands

Post by HJW » Mon Aug 21, 2006 3:58 pm

Ik heb het probleem ook welus gehad:

Ik deed het volgende fout:
Ik begon al met een verklote xpcd... dus ja dan ging integreren ook beetje fout...

Kijk nog eens of je XP cd dir helemaal schoon is.. :wink:

Friends4U
Posts: 138
Joined: Sat Aug 19, 2006 4:51 am

Post by Friends4U » Mon Aug 21, 2006 5:56 pm

Mja,

Ik heb nu 2 originele xp cd's gebruikt
beide handmatig geslipstreamed naar SP2 (ook met nLite geprobeerd)
Toen ISO gemaakt, werkt perfect.
daarna ALLEEN de updatepack eroverheen geen tweakes etc...
weer ISO gemaakt, en bovenstaande fout.

User avatar
Guillaume
Posts: 22
Joined: Sat Jul 08, 2006 6:42 am

Post by Guillaume » Mon Aug 21, 2006 7:52 pm

Precies hetzelfde probleem hier. Met de update pack van juli geen probleem. 'k Moet wel eerlijk zeggen dat ik bij de augustus pack de nowga add-on probeerde via nLite, en de wga handmatig van tevoren uit de juli pack heb gehaald. Verder geen verschil.

[edit]
Ik had geen gelijk: ook met de juli pack heb ik deze problemen. Zou 't probleem dan zitten in de HD Audio pack die ik integreer?

Friends4U
Posts: 138
Joined: Sat Aug 19, 2006 4:51 am

Post by Friends4U » Tue Aug 22, 2006 6:14 am

Zie mijn post... geen HD Audio pack of wat dan ook... het werkt gewoon niet, ik heb de Juli pack nog niet geprobeerd, die ga ik vandaag nog ff doen.

Friends4U
Posts: 138
Joined: Sat Aug 19, 2006 4:51 am

Post by Friends4U » Tue Aug 22, 2006 6:20 am

Shit... ik kan de Post-SP2 Update Pack July 2006 niet meer downloaden van MEULC :( Dus ik kan niet testen of het aan de updatepack ligt.

Friends4U
Posts: 138
Joined: Sat Aug 19, 2006 4:51 am

Post by Friends4U » Tue Aug 22, 2006 6:46 am

HJW wrote:Ik heb het probleem ook welus gehad:

Ik deed het volgende fout:
Ik begon al met een verklote xpcd... dus ja dan ging integreren ook beetje fout...

Kijk nog eens of je XP cd dir helemaal schoon is.. :wink:
Mja, ik maak iedere maand een nieuwe geslipstreamde cd, dit is voor het eerst dat ik dit probleem krijg.

User avatar
MEULC
Posts: 407
Joined: Tue Mar 08, 2005 8:58 am

Post by MEULC » Tue Aug 22, 2006 7:05 am

Ik zal deze avond nog eens al de packs opnieuw uploaden. Misschien is er daar ergens iets mee misgelopen en is de data corrupt ofzo...

Daarna moet je eens proberen van eerst enkel mijn updatepack te integreren, zonder iets anders erbij.

Friends4U
Posts: 138
Joined: Sat Aug 19, 2006 4:51 am

Post by Friends4U » Tue Aug 22, 2006 8:11 am

Dat is goed.

Ik heb net mijn installatie nogmaals zonder packs geprobeerd (dus alleen SP2) en dan werkt het goed.
Vanavond ga ik hem dan alleen met jou laatste pack proberen, wil je dat ik nLite of de Integrator gebruik?

Er moet aardig wat mis zijn hoor want buiten die 2 files die hij mist werkt windows update etc ook niet goed omdat er bepaalde files niet geregistreerd zijn zegtie.

Ik wacht af op je pack, kun je in deze topic een seintje geven als hij erop staat.

Groetjes,

Richard

User avatar
MEULC
Posts: 407
Joined: Tue Mar 08, 2005 8:58 am

Post by MEULC » Tue Aug 22, 2006 10:51 am

Friends4U wrote:Er moet aardig wat mis zijn hoor want buiten die 2 files die hij mist werkt windows update etc ook niet goed omdat er bepaalde files niet geregistreerd zijn zegtie.
Ja, als je de foutmelding ivm Framedyn.dll krijgt, dan loopt er heel wat mis. In het stratmenu zul je ook zien dat outlook express, windows messenger, media player... niet aanwezig is. Ik heb deze melding ook wel eens gekregen, maar toen was er wel effectief iest mis met mijn Windows Source CD. Maar als het lukt met alleen SP2, dan is er idd met je CD niets mis.

Ik laat hier een seinjte achter als ik alles opnieuw heb opgeladen.

Friends4U
Posts: 138
Joined: Sat Aug 19, 2006 4:51 am

Post by Friends4U » Tue Aug 22, 2006 12:51 pm

Is goed, en MEULC echt bedankt voor je hulp in deze!
Ik zal ook me best doen om dit probleem derhalve te tackelen en mijn bevindingen te delen.

User avatar
MEULC
Posts: 407
Joined: Tue Mar 08, 2005 8:58 am

Post by MEULC » Tue Aug 22, 2006 1:33 pm

Alle packs staan er opnieuw op (behalve audio addon).

Maar probeer het nu eerst alleen met het updatepack. Liefst met de RVMintegrator omdat ik zelf nooit werk met nlite.

PS: zeker niet vergeten om 'unicode to ansi' aan te vinken in de RVMintegrator.

User avatar
Guillaume
Posts: 22
Joined: Sat Jul 08, 2006 6:42 am

Post by Guillaume » Tue Aug 22, 2006 2:08 pm

Het lag (bij mij tenminste) waarschijnlijk niet aan de augustus pack: ook met de juli pack (hetzelfde bestand heb ik herhaaldelijk gebruikt) werkte het niet. Het euvel zat 'm in ieder geval deels in de audio add-on:

- augustus pack + audio addon: FOUT
- juli pack + audio addon: FOUT
- juli pack (zonder audio addon): GOED

Ik heb de august pack zonder audio addon niet meer geprobeerd en dat ga ik ook niet meer doen...
setuperr.txt wrote:Fout:
Setup kan informatiebestand audioaddon niet openen.

Neem contact op met de systeembeheerder. De specifieke foutcode is 0x2 op regel 4294967295.

***

Fout:
Setup kan OLE-besturing C:\WINDOWS\system32\srclient.dll niet in het register opnemen vanwege de volgende fout:
LoadLibrary heeft de volgende fout geretourneerd: 126 (de opgegeven module kan niet worden gevonden).


***

Fout:
Setup kan OLE-besturing C:\WINDOWS\system32\gpedit.dll niet in het register opnemen vanwege de volgende fout:
LoadLibrary heeft de volgende fout geretourneerd: 126 (de opgegeven module kan niet worden gevonden).


***

Fout:
Setup kan OLE-besturing C:\WINDOWS\system32\appmgr.dll niet in het register opnemen vanwege de volgende fout:
LoadLibrary heeft de volgende fout geretourneerd: 126 (de opgegeven module kan niet worden gevonden).


***

Fout:
Setup kan OLE-besturing C:\WINDOWS\system32\dgnet.dll niet in het register opnemen vanwege de volgende fout:
LoadLibrary heeft de volgende fout geretourneerd: 126 (de opgegeven module kan niet worden gevonden).


***

Fout:
Setup kan OLE-besturing C:\WINDOWS\system32\wbem\CmdEvTgProv.dll niet in het register opnemen vanwege de volgende fout:
LoadLibrary heeft de volgende fout geretourneerd: 126 (de opgegeven module kan niet worden gevonden).


***

Fout:
Setup kan OLE-besturing C:\WINDOWS\system32\userenv.dll niet in het register opnemen vanwege de volgende fout:
DllInstall heeft fout 2147746132 geretourneerd. (80040154)


***

Fout:
Setup kan OLE-besturing C:\WINDOWS\system32\eventcls.dll niet in het register opnemen vanwege de volgende fout:
DllInstall heeft fout 2147549183 geretourneerd. (8000ffff)


***

Fout:
Setup kan OLE-besturing C:\WINDOWS\system32\swprv.dll niet in het register opnemen vanwege de volgende fout:
DllInstall heeft fout 2147549183 geretourneerd. (8000ffff)


***

Fout:
Setup kan OLE-besturing C:\WINDOWS\system32\wbem\mofcomp.exe niet in het register opnemen vanwege de volgende fout:
Unknown heeft fout 0 geretourneerd. (0)


***

Friends4U
Posts: 138
Joined: Sat Aug 19, 2006 4:51 am

Post by Friends4U » Tue Aug 22, 2006 2:26 pm

Tja het kan natuurlijk dat MEULC iets heeft veranderd in zijn manier van samenstellen waardoor alles wat NA de juli pack gemaakt is deze fout bevat. IIG is hij nu op de hoogte en zal hij misschien ook met deze informatie iets kunnen :) Hoe meer hoe beter!

Friends4U
Posts: 138
Joined: Sat Aug 19, 2006 4:51 am

Post by Friends4U » Tue Aug 22, 2006 2:29 pm

Ahhh ik zie dat de geupdate pack er zijn, ik ga nu gelijk testen MEULC ik hoop over een uurtje meer te kunnen vertellen ;)

Friends4U
Posts: 138
Joined: Sat Aug 19, 2006 4:51 am

Post by Friends4U » Tue Aug 22, 2006 2:31 pm

MEULC wrote:PS: zeker niet vergeten om 'unicode to ansi' aan te vinken in de RVMintegrator.
Waar dient dit voor?

User avatar
MEULC
Posts: 407
Joined: Tue Mar 08, 2005 8:58 am

Post by MEULC » Tue Aug 22, 2006 2:50 pm

Omdat wij geen engelstalige XP hebben moeten we dat aanvinken.


Hier is een korte manual van hoe ik de integrator gebruik:
http://meulc.ryanvm.net/manual.doc

Friends4U
Posts: 138
Joined: Sat Aug 19, 2006 4:51 am

Post by Friends4U » Tue Aug 22, 2006 4:05 pm

MEULC wrote:Omdat wij geen engelstalige XP hebben moeten we dat aanvinken.


Hier is een korte manual van hoe ik de integrator gebruik:
http://meulc.ryanvm.net/manual.doc
Dat wist ik niet joh.... maar kan het probleem dan niet daarin liggen <schaamt zichzelf nu>

Friends4U
Posts: 138
Joined: Sat Aug 19, 2006 4:51 am

Post by Friends4U » Tue Aug 22, 2006 4:07 pm

Voor de rest doe ik wel wat jou manual beschrijft.

Friends4U
Posts: 138
Joined: Sat Aug 19, 2006 4:51 am

Post by Friends4U » Tue Aug 22, 2006 4:08 pm

Gaaaaaap me virtual pc is traag :( nog zo'n 20 min... dan heb ik de uitslag

Friends4U
Posts: 138
Joined: Sat Aug 19, 2006 4:51 am

Post by Friends4U » Tue Aug 22, 2006 5:03 pm

Met alleen het updatepack is het nu wel gelukt :) ik ben helemaal in mijn nopjes :P

Friends4U
Posts: 138
Joined: Sat Aug 19, 2006 4:51 am

Post by Friends4U » Tue Aug 22, 2006 5:58 pm

Updatepack inclusief:

.net
laptop update
audio update

Werkt nog niet helaas... ik ga nu testen aan welke van de 3 het ligt (heb jou nieuwe audioaddon gebruikt)

Waarom zou je deze updates niet standaard in je augustuspack zetten trouwens? of kan dat kwaad?

User avatar
Guillaume
Posts: 22
Joined: Sat Jul 08, 2006 6:42 am

Post by Guillaume » Tue Aug 22, 2006 7:58 pm

Nee, die aparte packs vind ik prima zo, imho. Die laptop is in heel veel gevallen een beetje loos om geïntegreerd te hebben, veel mobo's/soundcards zijn nog geen HD Audio, en bovenal zou ik stoppen met het gebruik van de update pack als .NET al geïntegreerd zit.

Probeer inderdaad eens alleen die audio addon te integreren. Ik verwacht wel dat dat de reden is. En als je het écht helemaal goed wilt doen zou je de nowga addon ook nog moeten betrekken in je onderzoek....

Friends4U
Posts: 138
Joined: Sat Aug 19, 2006 4:51 am

Post by Friends4U » Tue Aug 22, 2006 8:53 pm

Ok....

Een geslipstreamde Windows XP SP2 PRO NL

[Hash: 813F585D1BA58F312987EF65F7C2B603] Augustus Updatepack = OK

Plus de volgende addon(s):

[Hash: FBE46FA13AD27CBF0A55F84DEC8CDE3B] Laptop Addon = OK
[Hash: 266D79C2EE0E6A27FA57000B96B4E40B] Framework Addon = OK
[Hash: 0B3054F320367E365C5C247B7CFF2C03] Audio Addon = NOT OK

Friends4U
Posts: 138
Joined: Sat Aug 19, 2006 4:51 am

Post by Friends4U » Tue Aug 22, 2006 8:57 pm

Nu ga ik slapen... ik snap dat die framework addon niet in de pack standaard zit, maar de audio en laptop kan toch geen kwaad, als je geen hd audio ding hebt worden die drivers/files toch ook niet gebruikt?

User avatar
MEULC
Posts: 407
Joined: Tue Mar 08, 2005 8:58 am

Post by MEULC » Wed Aug 23, 2006 2:13 am

OK het is dus de audio addon. Ik heb hier op het werk eens snel gekeken en ik denk dat ik weet wat er scheelt....

in mijn entries file staat:
AudioAddon=ocgen.dll,OcEntry,AudioAddon,HIDE,7
ipv
AudioAddon=ocgen.dll,OcEntry,AudioAdd.inf,HIDE,7

*slaps himself to the head*


Ik heb dit snel aangepast, hier is een gecorrigeerde versie die je al eens kan testen:
http://rapidshare.de/files/30425438/audio_addon.7z.html

User avatar
MEULC
Posts: 407
Joined: Tue Mar 08, 2005 8:58 am

Post by MEULC » Wed Aug 23, 2006 2:19 am

Friends4U wrote:Nu ga ik slapen... ik snap dat die framework addon niet in de pack standaard zit, maar de audio en laptop kan toch geen kwaad, als je geen hd audio ding hebt worden die drivers/files toch ook niet gebruikt?
Ik wil in mijn UpdatePack alleen de hotfixes en updates steken die op Windows Update verschijnen. Dus als je dat Pack installeert zullen er 0 updates staan op WU.
Daarnaast maak ik enkele addons die nuttig zijn voor een aantal gebruikers, maar die dus niet door iedereen gaan gebruikt worden (sommige hebben nog geen hd kaart, andere gebruiken geen laptop,...)

Friends4U
Posts: 138
Joined: Sat Aug 19, 2006 4:51 am

Post by Friends4U » Wed Aug 23, 2006 11:26 am

MEULC wrote:
Friends4U wrote:Nu ga ik slapen... ik snap dat die framework addon niet in de pack standaard zit, maar de audio en laptop kan toch geen kwaad, als je geen hd audio ding hebt worden die drivers/files toch ook niet gebruikt?
Ik wil in mijn UpdatePack alleen de hotfixes en updates steken die op Windows Update verschijnen. Dus als je dat Pack installeert zullen er 0 updates staan op WU.
Daarnaast maak ik enkele addons die nuttig zijn voor een aantal gebruikers, maar die dus niet door iedereen gaan gebruikt worden (sommige hebben nog geen hd kaart, andere gebruiken geen laptop,...)
Duidelijk, maar is het nadelig als ik een cd maak voor zowel laptop als pc met dus altijd die addon erbij?

Friends4U
Posts: 138
Joined: Sat Aug 19, 2006 4:51 am

Post by Friends4U » Wed Aug 23, 2006 11:27 am

Ok....

Een geslipstreamde Windows XP SP2 PRO NL

[Hash: 813F585D1BA58F312987EF65F7C2B603] Augustus Updatepack = OK

Plus de volgende addon(s):

[Hash: FBE46FA13AD27CBF0A55F84DEC8CDE3B] Laptop Addon = OK
[Hash: 266D79C2EE0E6A27FA57000B96B4E40B] Framework Addon = OK
[Hash: A04C37294266FF41BADA5F5B6359A443] Audio Addon = OK

User avatar
UtCollector
Posts: 464
Joined: Sun Apr 09, 2006 8:31 pm
Contact:

Post by UtCollector » Wed Aug 23, 2006 11:44 am

Als ik nu Windows instaleer is mijn starmenu vrijwel leeg en hij geeft dus die foutmeldingen dat ik "Framedyn.dll" & "Srclient.dll" mis.
Hmmm ik heb dat probleem ook wel eens gehad. Met bepaalde nLite instellingen en addons. Ook wel eens met mijn Directx addon. Installeer directx eens een keer opnieuw anders. Zou maar zo kunnen helpen :)

User avatar
MEULC
Posts: 407
Joined: Tue Mar 08, 2005 8:58 am

Post by MEULC » Wed Aug 23, 2006 11:55 am

Friends4U wrote:Ok....

Een geslipstreamde Windows XP SP2 PRO NL

[Hash: 813F585D1BA58F312987EF65F7C2B603] Augustus Updatepack = OK

Plus de volgende addon(s):

[Hash: FBE46FA13AD27CBF0A55F84DEC8CDE3B] Laptop Addon = OK
[Hash: 266D79C2EE0E6A27FA57000B96B4E40B] Framework Addon = OK
[Hash: A04C37294266FF41BADA5F5B6359A443] Audio Addon = OK
Dus de addon die ik op rapidshare heb gezet, die werkt nu?
Dan zet ik deze ook in de Addon Post.

Friends4U
Posts: 138
Joined: Sat Aug 19, 2006 4:51 am

Post by Friends4U » Wed Aug 23, 2006 3:32 pm

UtCollector wrote:
Als ik nu Windows instaleer is mijn starmenu vrijwel leeg en hij geeft dus die foutmeldingen dat ik "Framedyn.dll" & "Srclient.dll" mis.
Hmmm ik heb dat probleem ook wel eens gehad. Met bepaalde nLite instellingen en addons. Ook wel eens met mijn Directx addon. Installeer directx eens een keer opnieuw anders. Zou maar zo kunnen helpen :)
Lees een topic is door ;)

Friends4U
Posts: 138
Joined: Sat Aug 19, 2006 4:51 am

Post by Friends4U » Wed Aug 23, 2006 3:33 pm

MEULC wrote:
Friends4U wrote:Ok....

Een geslipstreamde Windows XP SP2 PRO NL

[Hash: 813F585D1BA58F312987EF65F7C2B603] Augustus Updatepack = OK

Plus de volgende addon(s):

[Hash: FBE46FA13AD27CBF0A55F84DEC8CDE3B] Laptop Addon = OK
[Hash: 266D79C2EE0E6A27FA57000B96B4E40B] Framework Addon = OK
[Hash: A04C37294266FF41BADA5F5B6359A443] Audio Addon = OK
Dus de addon die ik op rapidshare heb gezet, die werkt nu?
Dan zet ik deze ook in de Addon Post.
Ja die is goed ;)

De enigste update die ik mis in je pack is: KB816093
Deze vind windows update namelijk na installatie.

Friends4U
Posts: 138
Joined: Sat Aug 19, 2006 4:51 am

Post by Friends4U » Wed Aug 23, 2006 4:04 pm

Bij nader inzien lijkt dat een fout te zijn, want na instaleren blijft hij daarom vragen... wellicht ligt dat aan een addon die ik gebruik.

User avatar
MEULC
Posts: 407
Joined: Tue Mar 08, 2005 8:58 am

Post by MEULC » Thu Aug 24, 2006 2:14 am

Die update is een update voor Jva Virual Machine.... Dus ik denk niet dat dat iets met mijn packs te maken heeft.
Als je twijfelt moet je enkel mijn pack en addons integreren, en kijken of er dan nog iets verschijnt op WU, maar volgens mij niet.

User avatar
Guillaume
Posts: 22
Joined: Sat Jul 08, 2006 6:42 am

Post by Guillaume » Thu Aug 31, 2006 5:51 pm

We zijn er nog steeds niet uit merk ik.

August Update + NoWGA + HD Audio
setuperr.log wrote:Fout:
Setup kan informatiebestand audioaddon niet openen.

Neem contact op met de systeembeheerder. De specifieke foutcode is 0x2 op regel 4294967295.
Daarna nog dat het 3 OLE-besturingsbestanden niet kan opnemen in het register:
eventcls.dll
swprv.dll
mofcomp.exe

Verder ook nog het probleem met IE en OE die niet in het startmenu opduiken.

User avatar
MEULC
Posts: 407
Joined: Tue Mar 08, 2005 8:58 am

Post by MEULC » Fri Sep 01, 2006 5:59 am

[Hash: 813F585D1BA58F312987EF65F7C2B603] Augustus Updatepack = OK
[Hash: FBE46FA13AD27CBF0A55F84DEC8CDE3B] Laptop Addon = OK
[Hash: 266D79C2EE0E6A27FA57000B96B4E40B] Framework Addon = OK
[Hash: A04C37294266FF41BADA5F5B6359A443] Audio Addon = OK


Deze zijn geverifieerd en getest. Deze bestanden werken.
-Zorg ervoor dat de MD5 Hash overeenkomt van het pack dat je d/l
-Zorg dat je in de integratir 'convert unicode to ansi' aanduidt

-> als niets werkt, dan is je XP source niet goed.

User avatar
Guillaume
Posts: 22
Joined: Sat Jul 08, 2006 6:42 am

Post by Guillaume » Fri Sep 01, 2006 12:24 pm

Tjah, dan moet je ook in het Post-SP2 Update Pack Addons topic naar de juiste addon verwijzen hè. De hash staat daar wel goed (daarom ging ik ervanuit dat het ook de goede link was), maar eenmaal gedownload is het de vorige foute versie nog..

User avatar
MEULC
Posts: 407
Joined: Tue Mar 08, 2005 8:58 am

Post by MEULC » Fri Sep 01, 2006 12:55 pm

De link is aangepast. Ik was dit inderdaad vergeten.

Locked