Release Winstyle NL Moonlight Editie 1.2

Discussion of Dutch translation of the Update Pack. Wees vrij om in het Nederlands te discussiëren!
Raoul90
Posts: 675
Joined: Thu Jan 17, 2008 10:29 am
Location: The Netherlands

Post by Raoul90 » Sun Apr 11, 2010 4:44 am

Hoe ik het doe:

RVM opstarten:
- Slipstream NL updatepack.
- Slipstream IE8 AddOn + Cosmetic AddOn

Als het klaar is, RVM afsluiten.

nLite opstarten:
- Slipstream nog wat AddOn's + WinstyleNL addon 1.2

Als het klaar is, nLite afsluiten.

Vervolgens kopieer ik alle resources naar de mijn map met XP-files erin. Daarna kopieer ik de patcher ook naar die map en start ik de patcher.

Dan werkt het bij mij.

Ik kreeg ook van die .sys files missing, ik heb toen alle spaties uit me map gehaald. Maar die bug zou eigenlijk gefixed zijn, wat volgens mij ook zo is.

VB:
Je gebruikt:
C:\Windows XP SP3\Unattended XP CD
als map, dan moet je het veranderen naar:
C:\WindowsXPSP3\UnattendedXPCD

geen-ID
Posts: 57
Joined: Wed Apr 07, 2010 2:54 pm

Post by geen-ID » Sun Apr 11, 2010 6:58 am

heel erg bedankt, bijna alles werkt nu. Er zitten alleen 2 foutjes in:

- de default theme is de standaard luna theme
(ik wil namelijk een andere default theme + andere default achtergrond)

- de tweede fout moet ik ff goed uitleggen:

als ik een windows 7 visual style toepas, werkt het wel, maar als ik dan op start druk, lopen de knoppen "afmelden" en "uitschakelen"en "search" door elkaar.

ps; het is echt super mooi, een mix van windows 7 en xp. Respect voor de makers hiervan ;)

Raoul90
Posts: 675
Joined: Thu Jan 17, 2008 10:29 am
Location: The Netherlands

Post by Raoul90 » Sun Apr 11, 2010 7:10 am

Het default theme moet je ook ff in de WinStyle.inf aanpassen (extract addon met 7zip):
Dan inf openen met kladblok.

Code: Select all

;WinStyle Theme
HKCU,"Software\Microsoft\Plus!\Themes\Current",,0x20000,"%%SystemRoot%%\resources\Themes\Standaard.theme"
Dat stukje moet je ff aanpassen naar je eigen .theme file, mijn theme heet Standaard.theme, dus dat zet ik daar dan ook neer. Dan werkt het.


Tweede snap ik niet wat je bedoelt, maar ff screenshot. En welke win7 visual style gebruik je?

geen-ID
Posts: 57
Joined: Wed Apr 07, 2010 2:54 pm

Post by geen-ID » Sun Apr 11, 2010 10:15 am

Ik heb WinStyle.inf aangepast en mijn theme erin gezet, maar nog steeds werkt het niet.

Voor de bug, kijk screenshot :D

http://i40.tinypic.com/1z1bfx4.png[/img]

dit is de theme: Aero Ultimate7 RC2.theme

User avatar
Mr.Fixit
Posts: 80
Joined: Mon Oct 27, 2008 12:08 pm

Post by Mr.Fixit » Sun Apr 11, 2010 7:21 pm

hey,

wow kleine desktop.. probeer eens je resolutie wat hoger te zetten..

miss 1024x768 ofzo... hmmm

geen-ID
Posts: 57
Joined: Wed Apr 07, 2010 2:54 pm

Post by geen-ID » Mon Apr 12, 2010 10:38 am

hallo,

helaas maakt het geen verschil welke resolutie ik gebruik.

Nog even twee vraagjes;

me standaard thema wilt maar niet lukken, ik probeer een windows 7.theme bestand als default thema te integreren in me xp pro, maar dat wil niet echt lukken. Kan iemand mij stap voor stap vertellen hoe dat moet.

Ik wil graag aan andere bootscreen integreren. Maar de meeste bootscreens die ik gevonden heb, doen het niet. Wie heeft een goed werkende bootscreen?

Raoul90
Posts: 675
Joined: Thu Jan 17, 2008 10:29 am
Location: The Netherlands

Post by Raoul90 » Mon Apr 12, 2010 10:40 am


User avatar
Mr.Fixit
Posts: 80
Joined: Mon Oct 27, 2008 12:08 pm

Post by Mr.Fixit » Mon Apr 12, 2010 10:52 am

de lbs patcher kan ook een custom of bootscreen naar keuze in je unattended slippen..

http://www.ryanvm.net/forum/viewtopic.php?t=7081

gebruik hiervoor de functie "XP-CD source integration"

wel eerst even het update pack slippen*

geen-ID
Posts: 57
Joined: Wed Apr 07, 2010 2:54 pm

Post by geen-ID » Mon Apr 12, 2010 11:02 am

thanks raoul :D

ook jij bedankt mr.fixit, alleen die bug van me theme is er nog steeds :(

User avatar
Mr.Fixit
Posts: 80
Joined: Mon Oct 27, 2008 12:08 pm

Post by Mr.Fixit » Mon Apr 12, 2010 11:07 am

kan je miss aub een link naar je thema posten..?

geen-ID
Posts: 57
Joined: Wed Apr 07, 2010 2:54 pm

Post by geen-ID » Mon Apr 12, 2010 11:15 am

oke, ik heb de thema op hotfile geplaatst, hier is de download link:

http://hotfile.com/dl/37600818/6331bbb/ ... e.rar.html

geen-ID
Posts: 57
Joined: Wed Apr 07, 2010 2:54 pm

Post by geen-ID » Mon Apr 12, 2010 1:51 pm

ik snap er echt helemaal niks van. Ik doe alles wat er staat aangegeven, doe alles stap voor stap maar nog steeds lukt het niet om een default thema+achtergrond integreren.

Raoul90
Posts: 675
Joined: Thu Jan 17, 2008 10:29 am
Location: The Netherlands

Post by Raoul90 » Mon Apr 12, 2010 2:46 pm

Nou gewoon het thema wat je wilt gebruiken (dus achtergrond + style + cursors etc.) toepassen op je huidige live installatie of een vmware, dan rechtermuisknop op bureaublad, bij het eerste scherm op "opslaan als" drukken, geef het thema een naam.

Nu moet je met de %OEM% map de wallpaper al naar de juiste map brengen (dit is: X:\$OEM$\$$\Web\Wallpaper, daar plaats je hem in).

Vervolgens moet je de style integreren of toevoegen aan volgende map:
X:\$OEM$\$$\Resources\Themes

Vervolgens de cursors/etc integreren of in de juiste map plaatsten.
X:\$OEM$\$$\Cursors

Vervolgens moet je in het winnt.sif antwoordbestand de volgende regel plakken:
[Shell]
CustomDefaultThemeFile ="%WinDir%\Resources\Themes\Naam.theme"
Naam.theme veranderen in de naam van het opgeslagen thema.

En dan het belangrijkste het thema wat je na de installatie wilt gebruiken moet natuurlijk ook in de X:\$OEM$\$$\Resources\Themes map aanwezig zijn + dus alle benodigdheden.

OemPreinstall moet ook in je winnt.sif antwoordbestand op Yes staan. Anders worden de OEM mappen niet gebruikt.

Nu zou het moeten werken.

geen-ID
Posts: 57
Joined: Wed Apr 07, 2010 2:54 pm

Post by geen-ID » Mon Apr 12, 2010 2:53 pm

heb ik gedaan, nog werkt het niet :(

Raoul90
Posts: 675
Joined: Thu Jan 17, 2008 10:29 am
Location: The Netherlands

Post by Raoul90 » Tue Apr 13, 2010 8:26 am

geen-ID wrote:heb ik gedaan, nog werkt het niet :(
Doe je het niet goed.

geen-ID
Posts: 57
Joined: Wed Apr 07, 2010 2:54 pm

Post by geen-ID » Tue Apr 13, 2010 10:50 am

haha, ja wel :P

geen-ID
Posts: 57
Joined: Wed Apr 07, 2010 2:54 pm

Post by geen-ID » Wed Apr 14, 2010 2:54 pm

haha, sorry, het is nu eindelijk gelukt om een eigen default thema te integreren! Het bleek dat ik een register fout had gemaakt.
Thx

ps; bootscreen integreren lukt nogsteeds niet

Raoul90
Posts: 675
Joined: Thu Jan 17, 2008 10:29 am
Location: The Netherlands

Post by Raoul90 » Wed Apr 14, 2010 3:16 pm

Je kan proberen alleen de volgende bestanden in de resources map te houden en dan te patchen:
- ntkrnlmp.exe.res
- ntkrnlpa.exe.res
- ntkrpamp.exe.res
- ntoskrnl.exe.res

Dat zijn volgens bij de bestanden voor het bootscreen.

geen-ID
Posts: 57
Joined: Wed Apr 07, 2010 2:54 pm

Post by geen-ID » Wed Apr 14, 2010 5:18 pm

thnx, alleen als ik die bestanden in een resource editor zet, krijg je bij de bitmaps alleen zwartje plaatje te zien. Kijk bij het plaatje.

http://i39.tinypic.com/otp1yr.png

Ik denk dat ik maar "live bootscreen patcher" integreer, dan kan ik via de Windows installatie de bootscreen toevoegen.

geen-ID
Posts: 57
Joined: Wed Apr 07, 2010 2:54 pm

Post by geen-ID » Wed Apr 28, 2010 2:09 pm

het is gelukt ;)

Locked