ELUpdatepack 1.3.3 24/12/2007

Discussion of the French translation of the Update Pack. La discussion en français est bienvenue!
Locked
elrico
Posts: 124
Joined: Sun Mar 11, 2007 2:24 pm
Contact:

ELUpdatepack 1.3.3 24/12/2007

Post by elrico » Mon Nov 26, 2007 5:29 pm

El UPDatepack 1.3.3 MàJ le 24 décembre. -Toutes les correctifs de sécurités pour XP + une sélection de correctifs optionnels!

Il est recommandé d'utiliser RVMintegrator 1.4.3 pour intégrer ce pack à votre CD de Windows XP. La prochaine version de RVMi étant en cours de test, le pack ne sera plus compatible avec Nlite à partir de sa sortie. Dans tout les cas rien ne vous empêchera d'utiliser Nlite par la suite.


ELUpdatePack Version 1.3.3
Téléchargement
41.5 Mo Hash MD5 : 91D9ECAC023B3D546DE63DDA9EB4717B

WMP 9 Addon Version 1.3
ELsys_WMP09_XP_PH_SP2_1.3_x86
2.24 Mo Hash MD5 : 3CA20DD2524306FFEB02AA7FC5735D19

MRT AddOn 1.36
ELsys_MRT_NT5_1.36_x86addon
8.17 Mo Hash MD5 : B7F376451BF6924686B193A9CEFDF2BE

MS update AddOn 1.3.0
Téléchargement
97.7 Ko Hash MD5 : B9E3076AB505F76E7738CA3F899FDCBD

MS update + Catalogue MU AddOn 1.3.0
Téléchargement
131 Ko Hash MD5 : 4B5ECC57EE47043528F08841B952FDAA

MS update AIO AddOn (MS update + Catalogue MU + WGA) 1.3.0
Téléchargement
749 Ko Hash MD5 : A5BA1E36DEF8AF5CFBB60C53F65DB7E2

WGA AddOn 1.7.59.1
Téléchargement
647 Ko Hash MD5 : 900746AEBCD80F5F54B559648581A941

FreeLaunchBar 1.1
Téléchargement
455 Ko Hash MD5 : D9B61CA9533D07C7CFD5652B72823D7A6

Changelog : (pour le pack seulement)

1.3.3 :
Ajout de:
http://support.microsoft.com/kb/925528
http://support.microsoft.com/kb/937930
Corrections mineurs

Pour la version 1.3.2a :
FIX pour KB942615 (une clef de registre)

Pour la version 1.3.2 :
KB937894
KB941568
KB942615 (IE6)
KB942840 (IE6)
KB944653 (secdrv -> remplace macrovision)

Pour la version 1.3.1 :
j'ajoute toute à l'heure

Pour la version 1.3.0 :
-Ajout des 2 MàJ de novembre (KB
-Mixage de l'addon IE6 et du pack

http://formassiste.info/downpack.php ... Sont en cours de test (mais j'ai peut de temps) des nouvelles version entièrement remaniée des addons suivant IE7 - WMP11 - WMP10 . Est prévus peut après une nouvelle version de l'addon .net 1.1. Tous ces addons sont remanié pour :
-une meilleur prise en charge de RVMi 1.5
-Compatibilité étendu avec toutes les versions de XP (MCE entre autre - sauf XP N, je ne possède pas cette version)
-Malheureusement certain addons ne seront plus compatible avec XP sans le pack intégré au préalable.
-Une version du pack est prévus pour supporté au mieux XP SP2 seconde édition, en attendant que je mette la main sur un CD XP SP2b (Merci de me faire signe si vous possédez un tel CD).
Last edited by elrico on Thu Dec 27, 2007 2:11 am, edited 4 times in total.

User avatar
locheloche
Posts: 5
Joined: Thu Oct 19, 2006 9:28 am

Post by locheloche » Sat Dec 01, 2007 12:32 pm

Petite question bête.
Qu'est-ce qui va empêcher la compatibilité avec nLite?
Un changement important dans RVMi ou quelques lignes à ajouter spécialement pour nLite?
Les add-ons seront ils aussi incompatibles avec nLite?

elrico
Posts: 124
Joined: Sun Mar 11, 2007 2:24 pm
Contact:

Post by elrico » Sat Dec 01, 2007 4:38 pm

Plusieurs nouvelles fonctions de rvmi :

-celle permettant de créer des .cab (pour gagner un peut de place et mieux gérer les fichiers complémentaires ils vont être placé dans un .cab pendant l'intégration)
-la fonction qui permet de lancer des commandes pendant l'intégration. (j'ai quelques idées à faire et j'aurais besoin de ça)

En faite pour la version 1.2.0 la compatibilité avait déjà été perdue : je plaçais des fichiers dans le CD sans modifier les fichiers d'installation de Windows. Nlite ce base sur ces fichiers. Donc il ne les copiait pas. J'ai corrigé ça à la 1.2.1 mais ça ne m'arrange pas : si je veut remplacer un de ces fichier par une nouvelle version c'est toute une histoire (par exemple prenons la KB933360, je suis obligé de dire à Nlite/RVMi de supprimer l'entrée à sont sujet dans les fichiers d'installations de Windows car elle à été remplacée par une nouvelle version -> KB942870).

Donc tout ça va me simplifier la maintenance du pack.

Pour las addons ce sera au cas par cas, Déjà tout les WMP/IE7 ce sera le cas. Mais je spécifierais bien la compatibilité avec tel et tel intégrateur.

De toute façon ce n'est pas très contraignant. Vous pourrez toujour utiliser Nlite par la suite.
Et je vous conseil vivement d'intégrer le pack dèjà avec RVMi. La dernière fois que j'ai testé Nlite, tout les fichiers n'avaient pas été mis à jour correctement sur le CD.

Prochaine version 1.3.1 du pack sous peut, qui prendra en compte entre autre la version "SP2a" de Win XP. Une version améliorant le support de XP SP2b verra le jour dès que j'aurais son CD sous la main.

User avatar
bober101
Posts: 923
Joined: Thu Feb 08, 2007 8:49 pm
Location: canadia!

Post by bober101 » Sat Dec 08, 2007 7:44 pm

jespere que les prochain updates seron sous le meme topic, car la section francaise du site est pele mele jai jamais vu sa...lol, sajirais juste de demander a un mod de nettoyer tout sa...cest normal que certain membre on de la misere a trouver koi integrer...merci
XP theme source patcher
patches/overwrites ure default xp visual resources

elrico
Posts: 124
Joined: Sun Mar 11, 2007 2:24 pm
Contact:

Post by elrico » Sat Dec 08, 2007 8:55 pm

Hello

En faite je fait un topic par génération (par exemple un pour 1.3.x, un pour 1.2.x etc, mais ça me dérange pas que les anciens soient bloqués).

De toutes façons les ancien fichiers sont supprimés, je devrais peut-être éditer mes posts, mais comment rediriger vers le dernier à chaque fois sans devoir éditer tous les post? La seul chose dont je suis sur c'est que le pack reste en version 1.3x jusqu'à la version 1.5 final de rvmi.

Bye

elrico
Posts: 124
Joined: Sun Mar 11, 2007 2:24 pm
Contact:

Post by elrico » Wed Dec 19, 2007 6:54 pm

Verson 1.3.2a dispo. Avec fix pour la mise à jour de IE6 qui bug.

Le seul "problème" connut : la fenêtre mise à jour du bureau s'affiche au premier boot. Il ne semble pas y avoir d'effet particulier et c'est sûrement dût au correctif KB937894. Je vais voir si il y a possibilité de corriger.

User avatar
kal
Moderator
Posts: 292
Joined: Sun Nov 06, 2005 4:23 pm
Location: Paris/FRANCE

Post by kal » Sat Jan 12, 2008 3:21 pm

Merci beaucoup pour ce pack, il marche nikel :D

Par contre, si j'ai envi d'intégrer les derniers hotfix dans ton pack, c'est difficile ?

Merci d'avance,
Kal

User avatar
kal
Moderator
Posts: 292
Joined: Sun Nov 06, 2005 4:23 pm
Location: Paris/FRANCE

Post by kal » Mon Jan 14, 2008 6:34 am

J'ai mis a jour l'update pack avec les deux updates de janvier. Ca interesse quelqu'un ?

Kal

elrico
Posts: 124
Joined: Sun Mar 11, 2007 2:24 pm
Contact:

Post by elrico » Mon Jan 14, 2008 7:57 pm

Salut KAL la dernière version est en cour de test. Si elle n'est pas dispo en final c'est qu'il faut adapter le patch TCPip à la nouvelle version du fichier.

Donc bientôt le pack va passer à RVMi 1.5 et sera compatible exclusivement avec ce dernier. Le numéro de version sera SP2.x.x (cela fait 3-4 mois que ce pack existe, mais en release candidate) pour XP SP2 et SP3.x.x (plus tard..) pour XP SP3.

Donc si dans un proche avenir (2-3 mois) tu as le courage de maintenir la version 1.x.x pour compatibilité avec Nlite tu es le bienvenue.

ELrico.

PS : le pack en version SP2.x.x sera uniquement intégrable avec RVMi 1.5 + mais rien ne vous empêchera d'utiliser Nlite par la suite. Disons juste que RVMi devra le logiciel d'intégration par défaut.

User avatar
kal
Moderator
Posts: 292
Joined: Sun Nov 06, 2005 4:23 pm
Location: Paris/FRANCE

Post by kal » Tue Jan 15, 2008 6:53 am

Yep elrico. J'ai aussi adapter le patch tcpip de sorte à ce qu'il fonctionne avec ton pack que je viens de mettre à jour. Voir ce thread :

http://www.ryanvm.net/forum/viewtopic.php?p=66744#66744

belfedia
Posts: 3
Joined: Tue Jan 15, 2008 8:40 am

Post by belfedia » Tue Jan 15, 2008 8:48 am

D'abord merci de réaliser ces packs qui me rendent d'immenses services !
Je les utilise avec windows XP pro SP2 mais depuis 2 packs environs j'ai des problemes d'usb qui quelque soit les drivers ou le matériel installé sont chroniquement détéctés en 1.0 au lieu de 2.0. Ce n'est pas trés grave mais sur le dernier pack j'ai eu un problème plus génant :

J'integre la version 1.3.3 du pack avec RVM_Integrator_1.4.3.exe
et j'obtiens à l'installation de windows une erreur récurente d'absence de kbdbhc.dll
J'intègre le pack avec Nlite1.4 et je n'ai aucun problème cela fonctionne trés bien.

Vu que vous déconseillez l'utilisation de Nlite je reste assez... dubitatif ? héhé, pouvez vous éclairer ma lanterne ?

thana
Posts: 36
Joined: Sun Jan 07, 2007 5:12 am

Post by thana » Tue Jan 15, 2008 9:32 am

J'utilise nlite depuis ... très longtemps et le pack n'a jamais posé de problème. Le pack est encore compatible nlite, par la suite la compatibilité ne sera plus mise en avant pour nlite, mais rien n'empêchera l'utilisation de nlite.

Fais tu l'intégration à partir d'une source propre d'xp ou à partir d'une version déjà nlité ? La seconde solution n'est pas trés stable chez moi, vaut mieux conserver son fichier de session et recommencer à chaque fois.

elrico
Posts: 124
Joined: Sun Mar 11, 2007 2:24 pm
Contact:

Post by elrico » Tue Jan 15, 2008 4:42 pm

@belfedia peut tu me préciser depuis quel version tu as des problèmes USB, les changements apporté a la partie USB sont depuis la version 1.3.3, et les précédents datent de trois plombes.
De plus au niveau USB, je fais attention et les correctifs incluent le sont tous dans le pack anglais (donc théoriquement pas de problèmes).

Pour kbdbhc.dll si tu as fait une seule intégration ré-essayes. Il ce peut (avec Nlite comme RVMi) et dans moins de 1% des cas, qu'un fichier sois corrompu pendant l'intégration ou la création de l'iso.

Comme le dit thana c'est mieux de partir d'un CD nickel à chaque fois, l'intégration ne sera pas beaucoup plus longue, et le résultat plus sur. Par contre la compatibilité Nlite risque d'être définitivement perdue pour l'intégration du pack et de certain addons. Mais le tout aura été bien testé avant.

belfedia
Posts: 3
Joined: Tue Jan 15, 2008 8:40 am

Post by belfedia » Wed Jan 16, 2008 12:28 pm

J'ai des problemes Usb depuis la version précédent la 1.3.3 (me souvient plus des chiffres). En fait, dés que je connecte un péripherique sur un port usb, windows me dit que cela fonctionnerait plus vite sur un port usb2.0

Si j'intègre avec Nlite, je n'ai plus ce message.

J'intègre à partir d'un xp SP2 base (pas une version trafiqué) et j'ai testé le pack 1.3.3 sur 2 xp pro SP2 différents et pas qu'une seule fois, 5 cd grillés plus tard j'ai tjrs le problème de kbdbhc.dll qui est récurant. A l'installation de windows, si je click sur annuler, l'install se passe bien quand mm ! c'est juste que ce message bloquant est... embettant.

Et avec Nlite tout va bien, pas de message à propos de KBDBHC.DLL :)

elrico
Posts: 124
Joined: Sun Mar 11, 2007 2:24 pm
Contact:

Post by elrico » Wed Jan 16, 2008 5:24 pm

OK, alors pour tes tests je te conseil vivement VMware (la version serveur est gratuite) ou n'importe quel machine virtuelle.

Je crois que personne d'autre n'as eut aucun de tes problèmes (je pense que j'aurais été mis au courant).. Peut tu me filer la liste addons et les log de RVMi? Si tu as effectué des changements dans tes méthodes d'intégration depuis la 1.3.2/1.3.2a? (par exemple mis à jour NLite? la 1.4.1 n'est pas très stable d'après ce que l'on m'a dit).

Je ferais quelque recherches demain soir. Je vais déjà demander ailleurs si quelqu'un n'a pas eut ces prob et me l'aurais caché.

thana
Posts: 36
Joined: Sun Jan 07, 2007 5:12 am

Post by thana » Wed Jan 16, 2008 6:02 pm

Nlite 1.4.1 me génère pas mal de problème d'intégration de fichiers, la 1.40 allait bien mais je ne la retrouve plus donc retour à la 1.35 :/

Pour les machines virtuelles tu as le choix entre vmware, virtualpc (gratuit de crosoft), virtualbox (gratuit aussi)...

belfedia
Posts: 3
Joined: Tue Jan 15, 2008 8:40 am

Post by belfedia » Wed Jan 16, 2008 8:39 pm

Je n'ai AUCUN problème avec Nlite ? pk me demandez vous si c'est stable? et j'utilise bien la 1.40.

Les problèmes ne viennent qu'avec l'utilisation de RVM_Integrator_1.4.3.exe

sinon le log de RVM ci dessous :

Code: Select all

14-01-2008 16¦14¦25
Log Startup @ 16:14:25 On 14-01-2008

16:14:25  - System Running: WIN_XP Service Pack 2
16:14:25  - RVMIntegrator v1.4.3
16:14:25  - D:\windowsxp\RVM_Integrator_1.4.3.exe
16:15:17  - 
16:15:17  - Source Drive         = D:\windowsxp\original
16:15:17  - Destination Drive    = D:\windowsxp\integration
16:15:17  - Destination Size     = 9048.02734375
16:15:17  - Working Directory    = D:\windowsxp\integration\I386
16:15:17  - Temp Directory       = D:\windowsxp\integration\I386\rvmtemp
16:15:17  - 
16:15:17  - Starting Integration
16:15:17  - 
16:15:17  - Copying Files To The Destination Directory.
16:15:17  -   Copying Working Directory...
16:17:11  - 6487  Files Copied in 113 Seconds
16:17:11  - 
16:17:11  - Checking Destination For OS Type.
16:17:11  - Windows XP Professionnel -  OEM SP1 Found
16:17:11  - Clearing any Read Only Attributes.
16:17:17  - 
16:17:19  - Extracting ELUpdatePack1.3.3.7z
16:17:19  -     MD5 Hash = 91d9ecac023b3d546de63dda9eb4717b
16:17:41  - 
16:17:41  - XP SP2 Needs To Be Slipstreamed...
16:17:41  - SlipStreaming SP2
16:18:45  - Windows XP Professionnel -  OEM SP2 Found
16:18:45  - 
16:18:45  - Gathering temp files
16:18:46  - Expanding driver.cab
16:20:27  - Expanding SP2.cab
16:20:42  - Copying files for driver.cab repackaging.
16:20:44  - Moving files for driver.cab repackaging.
16:20:45  - Integrating XP Professional Files.
16:20:45  - Compressing Files
16:23:52  - Shifting Stuff Around
16:23:52  - 
16:24:14  - Analyzing 1 Entry Files
16:24:14  - Processing elrico Update Pack v1.3.2   Build Date: 16/12/2007
16:24:16  - obsolete_files Found in entries.ini
16:24:16  - ExtraFileEdits Found in entries.ini
16:24:16  - Processing Sysoc.inf
16:24:16  -     Adding Components
16:24:16  - Processing svcpack.inf
16:24:16  -     removing obsolete hotfixes
16:24:16  -     adding ProductCatalogsToInstall
16:24:16  - Processing dosnet.inf
16:24:16  -     Modifying any SP2.cab areas in dosnet.inf
16:24:17  -     Editing [Files]
16:24:17  - Processing txtsetup.sif
16:24:17  -     Editing [Fileflags]
16:24:21  -     Editing [WinntDirectories]
16:24:21  -     Editing [SourceDisksFiles]
16:24:21  -     Modifying any SP2.cab areas in txtsetup.sif
16:24:26  - Processing [EditFile]
16:24:29  - Entire .ini Processing Completed in 15 Seconds
16:24:29  - Compressing and Moving Edited Files
16:24:30  - 
16:24:30  - Processing mmssetup.cab
16:24:30  - Expanding mmssetup.cab
16:24:30  - Processing entries.ini
16:24:30  - Rebuilding mmssetup.cab
16:24:34  - Rebuilding mmssetup.cab Complete.
16:24:34  - 
16:24:35  - 
16:24:35  - Calculating the amount of files to pack into driver.cab
16:24:45  - Rebuilding driver.cab
16:30:55  - Rebuilding drvindex.inf
16:30:55  - Rebuilding drvindex.inf Complete.
16:30:55  - Moving Files
16:30:55  - Cleaning Up.
16:30:55  - Replacing driver.cab
16:31:05  - Integration is at 100%, Cleaning Up
16:31:08  - Integration Completed.
16:31:08  - Total Integration Time = 836 Seconds
16:31:08  - ==================================================================================
16:31:08  - 
16:38:26  - 
16:38:26  - Creating ISO
16:38:26  - Command Line = C:\WINDOWSX\system32\cmd.exe /c C:\DOCUME~1\NANARD~1.BLA\LOCALS~1\Temp\~RvmInt\mkisofs.exe -joliet-long -iso-level 2 -N -d -relaxed-filenames -duplicates-once -D -boot-load-seg 0x7C0 -boot-load-size 4 -o "D:\windowsxp\windows.iso" -b rvmintegrator.img -hide rvmintegrator.img -hide boot.catalog -J -hide-joliet xpboot.img -hide-joliet boot.catalog -no-emul-boot -volid "Windows_XP_+" -sysid "Win32" "D:\windowsxp\integration"
16:38:26  - Using Internal mkisofs 2.01-bootcd.ru (i686-pc-mingw32)
16:38:48  - Size of boot image is 4 sectors -> No emulation
16:40:18  - Total translation table size: 2048
16:40:18  - Total rockridge attributes bytes: 0
16:40:18  - Total directory bytes: 678498
16:40:18  - Path table size(bytes): 2542
16:40:18  - 289089 extents written (564 MB)
16:40:18  - ISO Complete

Log Shutdown @ 16:44:21 On 14-01-2008
20:29:20  - Windows XP Professionnel -  SP2 Found


frank2243
Posts: 6
Joined: Tue Feb 12, 2008 5:31 pm

Post by frank2243 » Tue Feb 12, 2008 5:37 pm

L'intégration a très bien fonctionné avec nlite.

Quand est-ce que la prochaine version vas sortir?

thana
Posts: 36
Joined: Sun Jan 07, 2007 5:12 am

Post by thana » Tue Feb 12, 2008 5:59 pm

La prochaine version est en cours de tests, et une version finalisée sera disponible dès que rvmi le sera aussi.

frank2243
Posts: 6
Joined: Tue Feb 12, 2008 5:31 pm

Post by frank2243 » Tue Feb 12, 2008 6:44 pm

Qu'est-ce qu'il vas arriver avec les "Update pack" lors de la sortie du Service Pack 3 de Xp?

elrico
Posts: 124
Joined: Sun Mar 11, 2007 2:24 pm
Contact:

Post by elrico » Wed Feb 13, 2008 5:31 pm

Salut à tous,

la prochaine version est bien encours, rien n'est abandonné, mais ma "private life" a fait que la version du mois précédent est resté en RC.

La prochaine version verra les correctifs de sécurité pour IIS sortir du pack, peut de personne use Internet Information Server de MS, et cela allégera le pack.

Dans le courant du mois de mars, un bug tracker verra le jour, pour me permettre de suivre les éventuels problèmes sans avoir à parcourir de nombreux posts.

@Thana : merci bien :P

@belfedia pas réussir à re-produire ton problème et peut de temps :oops:

@frank2243 lors de la sortie du SP3 le pack continuera son bonhomme de chemin, une version SP2 sera maintenu tant que des personnes ne voudrons pas du SP3 (et le ferrons savoir). Une version SP3 verra le jour quelques mois après la sortie du SP3.
De toute façon dès que RVMi 1.5 est officialisé (pour la version française du pack!), le pack change de numérotation 1.X.X vers SP2.X.X, celui pour XP SP3 numéroté en... devinez :rolleyes:

Un petit effort allé :P

SP3.X.X (logique non??)

Tchao.

frank2243
Posts: 6
Joined: Tue Feb 12, 2008 5:31 pm

Post by frank2243 » Thu Feb 21, 2008 8:40 pm

Pourquoi ne pas mettre les versions RC à notre disposition comme ça certaines bonnes âmes pourraient les tester?

elrico
Posts: 124
Joined: Sun Mar 11, 2007 2:24 pm
Contact:

Post by elrico » Sat Feb 23, 2008 7:28 am

Question de temps, je préfère centraliser les RC à un unique endroit. Avant je les mettais sur un ou deux forums, mais c'est long et dure à suivre.

Pour le pack dispo ce soir ou demain. (j'ai fait un test supplémentaire pour vérifier un truc :)

belfedia j'ai réussit à reproduire le problème de l'usb (périphériques USB high Speed sur port usb 1) sous VMware. Le truc c'est qu'avec un Windows XP original (sans pack ni correctifs intégrés) c'est la même chose : conclusion VMware ne gère pas l'usb 2.0???
En tout cas jamais eut ce problème avec une carte mère USB 2.0 (en tout cas pas encore). Juste un truc certaine carte mère ont des ports usb 1 et 2 (des anciennes je le concède) donc faut voir...

Locked