[Important] No Unicode characters in paths...

Discussion of Turkish translation of the Update Pack. T�rk�e tartışmalalar başlamıştır!
Locked
User avatar
Siginet
Site Admin
Posts: 2894
Joined: Fri May 27, 2005 1:07 pm
Location: Planet Earth
Contact:

[Important] No Unicode characters in paths...

Post by Siginet » Thu Feb 21, 2008 1:19 am

MrNxDmX Brought it to my attention that when unicode characters are used in paths that the integrator gets confused. This isn't an issue with most languages... but some languages like Turkish use unicode characters a lot. So I just wanted to make sure I made a note of it that you should not use unicode paths or filenames. I hope this doesn't ruin anyones day. I tried my best to figure out a way around this... but I wasn't having any luck.
Image
--Siginet--

Techware
Your Virtual Technician
Computer Management Software

User avatar
entegre
Posts: 105
Joined: Mon May 07, 2007 2:39 am

Post by entegre » Thu Feb 21, 2008 4:57 am

tercüme edermisiniz arkadaşlar.

User avatar
ZEUS__
Posts: 108
Joined: Sat Feb 16, 2008 5:46 pm

Post by ZEUS__ » Thu Feb 21, 2008 7:04 am

moderatör arkadaş unicode karakterler için yol isimleri yazarken ya da klasör yaratırken hata verdiğini belirtmiş onun için açıklama.şu an için çözümü yok diyor.yol isimlerini yazarken Türkçe karakter kullanmayın diyor yani.ı,ü,ı,ğ gibi..atıyorum mesela;

"C:\benim_süper_şanlı_buğulu_xpmiçin" şeklinde bi klasör içinde çalışırsan hata verir diyor.
"C:\benim_super_sanli_bugulu_xpmicin" şeklinde yazın klasör isimlerini diyor..örneğe bak çay demle :)

ArArMiSiN
Posts: 71
Joined: Sun Feb 25, 2007 10:19 am

Post by ArArMiSiN » Thu Feb 21, 2008 7:07 am

hakkatten süper bi örnek :lol:

User avatar
byhexadecimal
Posts: 283
Joined: Thu Jun 21, 2007 6:31 pm
Location: Turkey / Ankara

Post by byhexadecimal » Thu Feb 21, 2008 7:48 am

:D

User avatar
nomadturk
Posts: 67
Joined: Fri Jan 04, 2008 8:53 am

Post by nomadturk » Thu Feb 21, 2008 7:49 am

Weird, i didn't have such a problem till today, till i saw this topic.
Though i am using nLite for most of the processes, I was integrating drivers from a folder with turkish characters in it till today. The only change i've made is that i have changed the file system from NTFS to FAT32. Maybe this is something related to that, eh?

User avatar
MrNxDmX
Moderator
Posts: 3112
Joined: Mon Jan 03, 2005 7:33 am

Post by MrNxDmX » Thu Feb 21, 2008 8:49 am

Arkadaşlar ZEUS__ verdiği örnekte göründüğü gibi, içerisinde i,ç,ü,ğ,ş,ö gibi karakterler bulunan klasör isimleriyle çalışırken problemler ile karşılaşıyoruz. RVM Integrator 1.5rc7ile çalışırken çok rastladım bu problemlere. Klasör ismini değiştirmek sorunu çözdü.
Bundan sonraki entegrasyonlarınızda bu konuya hassasiyet göstermeniz zaman kaybını önleyecektir (Sil yeniden başla entegrasyona)

Siginet'in söylediği ise, türkçe gibi unicode karakterleri çok kullanan dillerde bu tür problemlerin ortaya çıkmasıdır. Bir çok yöntemi denedik bu sorunu halledebilmek için ancak, sürekli aynı sonucu aldık, hatalar yani.

RVM Integrator 1.5in final sürümünün çıkması ile, bir çok kolaylıklar bizi bekleyecek. Şimdilik beklemedeyiz. En son rc sürümünü denemek isteyenler, dosyaya buradan ulaşabilirler: http://integrator.siginetsoftware.com/i ... ons&id=144

nomadturk, no its just about the folder name, not the file system :wink:
Siginet: Thanks for your post.

Locked