post sp3 pack update installation hang...HELP!

Discussion of Chinese translation of the Update Pack. 欢迎使用中文讨论!
Locked
drixoman
Posts: 8
Joined: Sat Dec 25, 2010 12:37 am

post sp3 pack update installation hang...HELP!

Post by drixoman » Sun Dec 26, 2010 10:40 pm

First of all, my Chinese is degrading too rapidly so sorry but I'm going to have to ask and respond in english...

I seem to having "installation" hang at the Please Wait section on the "first system bootup" part after integrating some more update that Windows Update found after I integrate the latest post-sp3 pack.

Here some background on my specific integration...

Believe it or not I have a original "Gold" SP0 disc from which I started off integrating the following using the latest nLite:
SP2
KB888111, KB909667, KB923293 (These three are specific to my vendor...it's said to be included in retail SP3 (but obviously I don't have that), but it's NOT included in the online distribution so I must include them before SP3 i guess)
SP3
post-sp3 pack

I had no problem with install till that point. It's just if I add more of the update found by WinUpdate the installation would not get to the User Creation part and stuck at Please Wait. Maybe those three hotfix that's causing the problem?(nLite warns me something about not able to add further hotfix without removing previous one when integrating sp3...)

Of course I been using virtual (Sun VirtualBox) with each test run; with the postSp3 pack integrated these are the update found by XP:

KB898461 (WUP requirement)
952069 , 973540 , 2378111 , 9564744 , 975558 , 977816 , 981997 , 954155 , 978695

^ Mind you some of those I found are in the Package list/change log, BUT some of those NOT. So I'm not sure if it's an integrating fail or something else.

Any help please!

User avatar
yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Sun Dec 26, 2010 11:11 pm

Check my posts.

http://www.ryanvm.net/forum/viewtopic.php?t=6500 - My Update Pack thread
I'm sorry I havn't translated the descriptions into English... Though...
In brief, I have seperated the update pack into several subcomponents, in order to satisfy various demands.

So please follow my following instructions:

Here you can get KB898461(Search for these file names in the original post):
MicrosoftUpdateSuite_7_4_7600_229_Addon_WGA_CHS.cab -OR- MicrosoftUpdateSuite_7_4_7600_229_Addon_CHS.cab
These 2 packs contain up-to-date Microsoft Update component and KB898461(since KB898461 is only required if you install updates via Windows Update/Microsoft Update)
The former includes also WGA, which is only needed if you *manually visit Windows Update site*.

For KB956744, get YumeYao_RDP_6_1_Update_Addon_CHS_1_0_0.cab -OR- YumeYao_RDP_7_0_Addon_CHS_1_0_0.7z

For KB981997, get YumeYao_MovieMaker_2_1_Update_Addon_CHS_1_0_0.cab -OR- YumeYao_MovieMaker_2_6_Addon_CHS_1_0_0.cab. Please notice the latter is taken from Vista thus the files are not digitally signed. So I suggest the former if you don't understand this.

For all other updates you listed out, they are for Windows Media Player, I don't provide an updated WMP9 pack, but you can get WMP10/11 from:
http://www.ryanvm.net/forum/viewtopic.php?t=2958



In addition, you can get(if you want):
IE8: http://www.ryanvm.net/forum/viewtopic.php?t=7128
VC Runtimes: http://www.ryanvm.net/forum/viewtopic.php?t=8563
XPS: http://www.ryanvm.net/forum/viewtopic.php?t=8473
.NET(requires VC Runtimes and XPS): http://www.ryanvm.net/forum/viewtopic.php?t=8516(Up to 4.0) -OR- http://www.ryanvm.net/forum/viewtopic.php?t=7696(Up to 3.5) each of them contains .NET with lower versions.


---- BTW ----
Don't try adding patches via nlite, it's always buggy...
Image
My work list(Hosted by dumpydooby)

drixoman
Posts: 8
Joined: Sat Dec 25, 2010 12:37 am

Post by drixoman » Mon Dec 27, 2010 12:39 am

Hi, thanks for your attention...

I can still moderately read chinese so if it's better for you to write in chinese you can...

Yes i used the first main one only(nLite ordering was correct)..haven't bother with the other ones yet... But it seems that I can't add in any actual hotfix .exe files without getting hanged, no matter what order i put them in...

I just can't figure out where is the problem...I can't really take out the 3 fix inbetween the service pack. So I guess the problem could be adding more hotfix without removing those 3?

User avatar
bphlpt
Posts: 1359
Joined: Sat Apr 19, 2008 1:11 am

Post by bphlpt » Mon Dec 27, 2010 3:44 am

Are you sure you need to add in those three before SP3? I would not think that would work. I would suggest to NOT do SP2, just do SP3, then do all the other addons you need. And remember, if you are using nLite, it is almost always better to try to do EVERYTHING in ONE RUN, because not only is adding patches with nLite buggy, as YumeYao said, but multiple runs with nLite also rarely works without problems.

Cheers and Regards

User avatar
yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Mon Dec 27, 2010 3:47 am

Yes, you'd better not add hotfix.exe via nlite, that's always buggy....

Just follow my instructions to add other packs(please don't use the source which you have used nlite to add patch.exe to), I'm sure you'll get a working up-to-date system.

-EDIT-
And... take bphlpt's suggestion. You shouldn't integrate KB888111, KB909667, KB923293 or SP2.
Image
My work list(Hosted by dumpydooby)

drixoman
Posts: 8
Joined: Sat Dec 25, 2010 12:37 am

Post by drixoman » Mon Dec 27, 2010 5:28 pm

Hi again

As i'm aware, sp3 does not included sp2..

and as for those 3 KBs, they are rather specific to my model and MS doesn't seem to have a very easy location to download them (I think they are by request only...). They came together in the same set with all my driver and stuff from Lenovo (I use a thinkpad t500). It specifically said in the readme that it's not included in the sp3 regular distributable. So as I am starting from sp0 i may not have a choice there...

I do believe what you said about nLite being buggy is reasonable so i'll keep that in mind... I can get it to work up until the post-sp3 pack. Any more seem to get me hang at please wait. I'm wondering maybe I can install the rest WUP listed thereafter on the spot as per this method: http://unattended.msfn.org/unattended.xp/view/web/24/

User avatar
yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Mon Dec 27, 2010 6:56 pm

I couldn't understand why did you insist the point that you'll have to integrate sp2 first then sp3.

Yes, sp3 does not include sp2, or the three hotfixes. But, sp3 SUPERSEDES them, which means, if you directly install/integrate sp3, you're supposed to succeed the operation, and you don't need to bother with them any more. I have been playing on this site since sp2, so I'm sure.


svcpack.inf method is bothering too. Most won't damage your install but some will. I still suggest you:
1. start from sp0, integrate sp3 directly.
2. integrate my packs, as suggested on post #2.

-EDIT-
To make it clearer: these 3 hotfixes you mentioned are not specific to your model. They are designed for function lacks or bugs in sp2. for example, KB888111 makes you able to install HD Audio Drivers upon what it offers - HD Audio Bus, KB909667 resolves the bugs on machines with USB-cameras, KB923293 allows you to use SD cards with a capacity of 4GB or more.
Image
My work list(Hosted by dumpydooby)

User avatar
bphlpt
Posts: 1359
Joined: Sat Apr 19, 2008 1:11 am

Post by bphlpt » Mon Dec 27, 2010 9:43 pm

If for some reason you feel sure that you need those 3 hotfixes, I haven't checked, but I would assume you can add them after SP3. If not, you almost certainly do NOT need them.

Cheers and Regards

drixoman
Posts: 8
Joined: Sat Dec 25, 2010 12:37 am

Post by drixoman » Mon Dec 27, 2010 10:04 pm

As i'm aware those 3 specific are not included in the standalone sp3 distributable...so i don't know if leaving them out means sp3 will fix those bug/feature...and also even though sp3 "supercede" sp2 i don't recall sp3 will fix the problem addressed in sp2 would it?

this is taken from one of those driver package readme with regard to those 3 KB, not sure if I'm interpreting it correctly:

"此补丁适用于WindowsXP SP2操作系统,此补丁不包含于微软独立发行的SP3补丁包中,如果先安装SP3补丁包,可能会造成无法正常安装此补丁的问题,所以请先安装此补丁后再行升级SP3,微软MSDN放出的集成SP3补丁包的WindowsXP包括此补丁。

also one of my driver (sound) seem to be "unhappy" without 888111 so i don't want to tamper that far...

I just tried to add the rest of the update through svcpack and got a 7B bsod...so much for that hope...

so i guess the only method i haven't consider is to just run those extraneous update after the package after install using something like RunOnceEx...I installed them after the post-sp3 pack in virtual without any problem...

User avatar
yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Mon Dec 27, 2010 10:36 pm

Forget all those.

Just integrate SP3 and the packs here.
Image
My work list(Hosted by dumpydooby)

drixoman
Posts: 8
Joined: Sat Dec 25, 2010 12:37 am

Post by drixoman » Thu Dec 30, 2010 12:24 am

Alright then.. I'll try those ( actually it's kinda hard as the drivers related stuff doesn't quite work with virtual...)

Locked