[Updated] XP SP3 Update Pack 02.10-01

Windows XP Professional Update Pack discussion.
Post Reply
User avatar
crashfly
Posts: 789
Joined: Thu Mar 13, 2008 11:39 pm
Location: Arkansas, USA

Post by crashfly » Sat Apr 26, 2008 10:00 pm

I use a similar procedure although not quite as detailed. I use a seperate "untouched" directory to copy to the work directory and make changes there. It cuts down on having to locate where everything is at. I still get issues, but problems are reduced with the "start over from scratch" rule.
A mind is like a parachute, it only functions when it is open.
--Anonymous

How to Ask Questions the Smart Way

User avatar
roirraW "edor"
Posts: 761
Joined: Sun Oct 15, 2006 2:25 pm

Post by roirraW "edor" » Sat Apr 26, 2008 10:19 pm

What just worked for me on a real machine (my first real machine test of SP3):

First used WMP11 Slipstreamer separately (outside of nLite or RVMI) to slipstream the latest WMP11 Installer + the updates that the WMP11 Slipstreamer web page list.

Then I used nLite and nLite only to perform the following (all the update packs/addons are listed last):

Code: Select all

[Main]
Env = 1.4.5 beta 2 - 2.0.50727.1434.Microsoft Windows NT 6.0.6001 Service Pack 1
Target = Windows XP Home Edition SP3 - 5.1.2600.5512 - English (United States)

[Tasks]
Remove Components
Unattended Setup
Hotfixes and Update Packs
Tweaks
Create a Bootable ISO
Options

[Components]
;# Keyboards #
Albanian keyboard
Arabic (101) keyboard
Arabic (102) AZERTY keyboard
Arabic (102) keyboard
Armenian Eastern keyboard
Armenian Western keyboard
Azeri Cyrillic keyboard
Azeri Latin keyboard
Belarusian keyboard
Belgian (Comma) keyboard
Belgian (Period) keyboard
Belgian French keyboard
Bengali (Inscript) keyboard
Bengali keyboard
Bosnian Cyrillic keyboard
Bosnian keyboard
Bulgarian (Latin) keyboard
Bulgarian keyboard
Canadian French (Legacy) keyboard
Canadian French keyboard
Canadian Multilingual Standard keyboard
Chinese (Simplified) - Microsoft Pinyin IME 3.0 keyboard
Chinese (Simplified) - NeiMa keyboard
Chinese (Simplified) - QuanPin keyboard
Chinese (Simplified) - ShuangPin keyboard
Chinese (Simplified) - US Keyboard keyboard
Chinese (Simplified) - ZhengMa keyboard
Chinese (Traditional) - Alphanumeric keyboard
Chinese (Traditional) - Array keyboard
Chinese (Traditional) - Big5 Code keyboard
Chinese (Traditional) - ChangJie keyboard
Chinese (Traditional) - DaYi keyboard
Chinese (Traditional) - New ChangJie keyboard
Chinese (Traditional) - New Phonetic keyboard
Chinese (Traditional) - Phonetic keyboard
Chinese (Traditional) - Quick keyboard
Chinese (Traditional) - Unicode keyboard
Chinese (Traditional) - US Keyboard keyboard
Croatian keyboard
Czech (QWERTY) keyboard
Czech keyboard
Czech Programmers keyboard
Danish keyboard
Devanagari - INSCRIPT keyboard
Divehi Phonetic keyboard
Divehi Typewriter keyboard
Dutch keyboard
Estonian keyboard
Faeroese keyboard
Farsi keyboard
Finnish keyboard
Finnish with Sami keyboard
French keyboard
FYRO Macedonian keyboard
Gaelic keyboard
Georgian keyboard
German (IBM) keyboard
German keyboard
Greek (220) keyboard
Greek (220) Latin keyboard
Greek (319) keyboard
Greek (319) Latin keyboard
Greek keyboard
Greek Latin keyboard
Greek Polytonic keyboard
Gujarati keyboard
Hebrew keyboard
Hindi Traditional keyboard
Hungarian 101-key keyboard
Hungarian keyboard
Icelandic keyboard
Inuktitut Latin keyboard
Irish keyboard
Italian (142) keyboard
Italian keyboard
Japanese Input System (MS-IME2002) keyboard
Japanese keyboard
Kannada keyboard
Kazakh keyboard
Korean Input System (IME 2000) keyboard
Korean keyboard
Kyrgyz Cyrillic keyboard
Latin American keyboard
Latvian (QWERTY) keyboard
Latvian keyboard
Lithuanian IBM keyboard
Lithuanian keyboard
Luxembourgish keyboard
Malayalam keyboard
Maltese 47-key keyboard
Maltese 48-key keyboard
Maori keyboard
Marathi keyboard
Mongolian Cyrillic keyboard
Nepali keyboard
Norwegian keyboard
Norwegian with Sami keyboard
Pashto keyboard
Polish (214) keyboard
Polish (Programmers) keyboard
Portuguese (Brazilian ABNT) keyboard
Portuguese (Brazilian ABNT2) keyboard
Portuguese keyboard
Punjabi keyboard
Romanian keyboard
Russian (Typewriter) keyboard
Russian keyboard
Sami Extended Finland-Sweden keyboard
Sami Extended Norway keyboard
Serbian (Cyrillic) keyboard
Serbian (Latin) keyboard
Slovak (QWERTY) keyboard
Slovak keyboard
Slovenian keyboard
Spanish keyboard
Spanish Variation keyboard
Swedish keyboard
Swedish with Sami keyboard
Swiss French keyboard
Swiss German keyboard
Syriac keyboard
Syriac Phonetic keyboard
Tamil keyboard
Tatar keyboard
Telugu keyboard
Thai Kedmanee (non-ShiftLock) keyboard
Thai Kedmanee keyboard
Thai Pattachote (non-ShiftLock) keyboard
Thai Pattachote keyboard
Turkish F keyboard
Turkish Q keyboard
Ukrainian keyboard
United Kingdom Extended keyboard
United Kingdom keyboard
United States-Dvorak for left hand keyboard
United States-Dvorak for right hand keyboard
United States-Dvorak keyboard
United States-International keyboard
Urdu keyboard
US English Table for IBM Arabic 238_L keyboard
Uzbek Cyrillic keyboard
Vietnamese keyboard
;# Languages #
;Arabic
Arabic (Algeria)
Arabic (Bahrain)
Arabic (Egypt)
Arabic (Iraq)
Arabic (Jordan)
Arabic (Kuwait)
Arabic (Lebanon)
Arabic (Libya)
Arabic (Morocco)
Arabic (Oman)
Arabic (Qatar)
Arabic (Saudi Arabia)
Arabic (Syria)
Arabic (Tunisia)
Arabic (U.A.E.)
Arabic (Yemen)
Divehi (Maldives)
Pashto
Syriac (Syria)
Urdu
;Armenian
Armenian
;Baltic
Estonian
Latvian
Lithuanian
;Central Europe
Albanian
Bosnian (Latin, Bosnia and Herzegovina)
Croatian
Croatian (Bosnia and Herzegovina)
Czech
Hungarian
Polish
Romanian
Serbian (Latin)
Serbian (Latin, Bosnia and Herzegovina)
Slovak
Slovenian
;Cyrillic
Azeri (Cyrillic)
Belarusian
Bosnian (Cyrillic, Bosnia and Herzegovina)
Bulgarian
FYRO Macedonian
Kazakh
Kyrgyz (Kyrgyzstan)
Mongolian (Mongolia)
Russian
Serbian (Cyrillic)
Serbian (Cyrillic, Bosnia and Herzegovina)
Tatar
Ukrainian
Uzbek (Cyrillic)
;Georgian
Georgian
;Greek
Greek
;Hebrew
Hebrew
;Indic
Bengali (India)
Gujarati (India)
Hindi
Kannada (India)
Konkani
Malayalam (India)
Marathi
Nepali (Nepal)
Punjabi (India)
Sanskrit
Tamil
Telugu (India)
;Japanese
Japanese
;Korean
Korean
;Simplified Chinese
Chinese (PRC)
Chinese (Singapore)
;Thai
Farsi
Thai
;Traditional Chinese
Chinese (Hong Kong S.A.R.)
Chinese (Macau S.A.R.)
Chinese (Taiwan)
;Turkic
Azeri (Latin)
Turkish
Uzbek (Latin)
;Vietnamese
Vietnamese
;Western Europe and United States
Afrikaans
Basque
Catalan
Danish
Dutch (Belgium)
Dutch (Netherlands)
English (Australia)
English (Belize)
English (Canada)
English (Caribbean)
English (Ireland)
English (Jamaica)
English (New Zealand)
English (Philippines)
English (South Africa)
English (Trinidad)
English (United Kingdom)
English (Zimbabwe)
Faeroese
Filipino
Finnish
French (Belgium)
French (Canada)
French (France)
French (Luxembourg)
French (Monaco)
French (Switzerland)
Frisian
Galician (Spain)
German (Austria)
German (Germany)
German (Liechtenstein)
German (Luxembourg)
German (Switzerland)
Icelandic
Indonesian
Inuktitut (Latin)
Irish
Italian (Italy)
Italian (Switzerland)
Luxembourgish
Malay (Brunei Darussalam)
Malay (Malaysia)
Maltese
Maori
Mapudungun
Mohawk
Northern Sotho
Norwegian (Bokmal)
Norwegian (Nynorsk)
Portuguese (Brazil)
Portuguese (Portugal)
Quechua (Bolivia)
Quechua (Ecuador)
Quechua (Peru)
Romansh
Sami, Inari (Finland)
Sami, Lule (Norway)
Sami, Lule (Sweden)
Sami, Northern (Finland)
Sami, Northern (Norway)
Sami, Northern (Sweden)
Sami, Skolt (Finland)
Sami, Southern (Norway)
Sami, Southern (Sweden)
Spanish (Argentina)
Spanish (Bolivia)
Spanish (Chile)
Spanish (Colombia)
Spanish (Costa Rica)
Spanish (Dominican Republic)
Spanish (Ecuador)
Spanish (El Salvador)
Spanish (Guatemala)
Spanish (Honduras)
Spanish (International Sort)
Spanish (Mexico)
Spanish (Nicaragua)
Spanish (Panama)
Spanish (Paraguay)
Spanish (Peru)
Spanish (Puerto Rico)
Spanish (Traditional Sort)
Spanish (Uruguay)
Spanish (Venezuela)
Swahili
Swedish
Swedish (Finland)
Tswana
Welsh
Xhosa
Zulu
;# Multimedia #
Music Samples
;# Network #
MSN Explorer
Windows Messenger
;# Operating System Options #
Manual Install and Upgrade
Tour
;# Directories #
DOCS
SUPPORT
VALUEADD
;# Compatibility #
Compat01
Compat02
Compat03
Compat04
Compat06
Compat07
Compat09
Compat11
Compat14
Compat16

[KeepFiles]
msconfig.exe

[RemoveFiles]
clock.avi
yahoo.bmp
swtchbrd.bmp

[Options]
ClassicSetup
BlackSetupBack
ProfilesDir = "%SystemDrive%\Documents and Settings"
TargetPath = "WINDOWS"
temp_dir = %USERPROFILE%\Local Settings\Temp
AdvTweaks

[Patches]
DoSFC

[Services2]

[Tweaks]
Boot and Shutdown-Ctrl-Alt-Del at logon-Disabled
Boot and Shutdown-Logon Page-Welcome screen
Boot and Shutdown-Numlock-On
Boot and Shutdown-Setup Prefetch-Cache-Applaunch and Boot enabled
Boot and Shutdown-Status Messages-Extended
Desktop-Internet Explorer icon-Show
Desktop-My Computer icon-Show
Desktop-My Documents icon-Show
Desktop-My Network Places icon-Hide
Desktop-Recycle Bin icon-Show
Desktop-Wrap icon titles-Enable
Explorer-Add 'Command Prompt' to folder context menu
Explorer-Associate additional file types with Notepad
Explorer-Restore previous folder windows at logon
Explorer-Show Statusbar in all windows
Internet Explorer-Enable Google URL-Search
Internet Explorer-Set Homepage-www.google.com
Internet Explorer-Set Internet Explorer to accept 10 connects at a time
Network-Allow receiving Remote Assistance-Disable
Network-Remote Desktop-Disable
Performance-Processor scheduling-Programs
Performance-Speed-up Access to AVI Media Files
Privacy-Remove Alexa
Security-Screensaver Password-Protection-Disabled
Start Menu-Control Panel-Display as a link
Start Menu-Do not use Personalized Menus
Start Menu-My Computer-Display as a link
Start Menu-My Documents-Display as a link
Start Menu-My Music-Display as a link
Start Menu-My Network Places-Don't display this item
Start Menu-My Pictures-Display as a link
Start Menu-Network Connections-Link to Network Connections folder
Start Menu-Number of programs on Start menu-10
Start Menu-Printers and Faxes-Display as a link
Start Menu-Show IE Favorites
Taskbar-Disable Language-Bar
Taskbar-Lock the Taskbar-No
Visual Effects-Active window tracking-Disable
Visual Effects-Animate windows when minimizing and maximizing-Enable
Visual Effects-Combo box animation-Enable
Visual Effects-Cursor shadow-Enable
Visual Effects-Display mouse pointer trails-Disable
Visual Effects-Fade out selection-Enable
Visual Effects-Gradient captions in windows-Enable
Visual Effects-Menu shadows-Enable
Visual Effects-Menu style-Normal
Visual Effects-Show translucent selection rectangle-Enable
Visual Effects-Show window contents while dragging-Enable
Visual Effects-Slide taskbar buttons-Enable
Visual Effects-Smooth edges of screen fonts-ClearType
Visual Effects-Smooth-scroll list boxes-Enable
Visual Effects-Use a background image for each folder type-Enable
Visual Effects-Use drop shadows for icon labels on the desktop-Enable
Windows Media Player-Accept Privacy Statement
Windows Media Player-Optimize fullscreen mode behavior

[Unattended]
DisableOem
ComputerType = Default
AutoLogon = anonymous user name
CustomLocales
DisableSRestore
MaximumDataStorePercentOfDisk = 12
RestorePointLife = 30
DesktopTheme = Windows XP style|Default (blue)|Normal size
AutoUpdates = 4
AutoUDay = 5
AutoUHour = 15
AUElevate
AUMinor
ProgFilesPath = "\Program Files"

[NetAdapter1]
connname = ""
macaddress = ""
ipaddress = "192.168.0.1"
subnetmask = "255.255.255.0"
defaultgateway = ""
dnsserver1 = ""
dnsserver2 = ""
winsserver = ""
netbiossetting = "0"
ipxnetworknumber = "00000000"
ipxnetworkframetype = "0xFF"

[GuiRunOnce]

[Drivers]

[Hotfixes]
E:\WinXPUpdate\RVM\RED_XP_SP3_UpdatePack_1.8.2.7z
E:\WinXPUpdate\RVM\IE7-WindowsXP-x86-enu - v7.0 dated 20071004.exe
E:\WinXPUpdate\RVM\DirectX_9.0c_End-User_Runtime_AddOn_0.3.4_-_redxii.7z
E:\WinXPUpdate\RVM\5er_KB893056_SP3_Addon.7z
E:\WinXPUpdate\RVM\xable_WGAV-v1.3_addon.cab
E:\WinXPUpdate\RVM\xable_WGAN-v1.2_addon.cab
E:\WinXPUpdate\RVM\NR_VGamesAIO_Addon_v1.3.7z
E:\WinXPUpdate\RVM\2.  Ricks_WindowsSidebar_AlkyXP1.1_AddOn.7z
E:\WinXPUpdate\RVM\Ricks_CCleaner2.06.567_AS_AddOn.rar
I then used the very latest DriverPacks Base Release Candidate with all of the latest DriverPacks. I used nLite to create an ISO and burn it to a DVDRW disc.

This installed perfectly with no issues or anomalies so far, although I just noticed that for some reason I didn't get a CCleaner desktop icon from the addon, which I normally do without tweaking anything.

Note that I integrated the official Microsoft Internet Explorer 7 installer, since:

1. There is some evidence that IE7 hotfixes are applied by SP3 even when SP3 is slipstreamed; i.e. SP3 not installed after IE7.

2. I'm more concerned about having a technically correct XP installation in case #1 above is true. If it's not true, it's no big deal to me that the IE7 hotfixes will be installed by Automatic Updates as soon as WU/MU is up to speed with SP3.

P.S. Don't make fun of me for still putting "Home" Edition on one of my computers. :shock: :oops: :P

benjamminzIS
Posts: 227
Joined: Fri Jan 12, 2007 8:07 am

Post by benjamminzIS » Sun Apr 27, 2008 1:27 am

[quote="roirraW "edor""]What just worked for me on a real machine (my first real machine test of SP3):

First used WMP11 Slipstreamer separately (outside of nLite or RVMI) to slipstream the latest WMP11 Installer + the updates that the WMP11 Slipstreamer web page list.

Then I used nLite and nLite only to perform the following (all the update packs/addons are listed last):

Code: Select all

[Hotfixes]
E:\WinXPUpdate\RVM\RED_XP_SP3_UpdatePack_1.8.2.7z
E:\WinXPUpdate\RVM\IE7-WindowsXP-x86-enu - v7.0 dated 20071004.exe
E:\WinXPUpdate\RVM\DirectX_9.0c_End-User_Runtime_AddOn_0.3.4_-_redxii.7z
E:\WinXPUpdate\RVM\5er_KB893056_SP3_Addon.7z
E:\WinXPUpdate\RVM\xable_WGAV-v1.3_addon.cab
E:\WinXPUpdate\RVM\xable_WGAN-v1.2_addon.cab
E:\WinXPUpdate\RVM\NR_VGamesAIO_Addon_v1.3.7z
E:\WinXPUpdate\RVM\2.  Ricks_WindowsSidebar_AlkyXP1.1_AddOn.7z
E:\WinXPUpdate\RVM\Ricks_CCleaner2.06.567_AS_AddOn.rar
I then used the very latest DriverPacks Base Release Candidate with all of the latest DriverPacks. I used nLite to create an ISO and burn it to a DVDRW disc.

This installed perfectly with no issues or anomalies so far, although I just noticed that for some reason I didn't get a CCleaner desktop icon from the addon, which I normally do without tweaking anything.

Note that I integrated the official Microsoft Internet Explorer 7 installer, since:

1. There is some evidence that IE7 hotfixes are applied by SP3 even when SP3 is slipstreamed; i.e. SP3 not installed after IE7.

2. I'm more concerned about having a technically correct XP installation in case #1 above is true. If it's not true, it's no big deal to me that the IE7 hotfixes will be installed by Automatic Updates as soon as WU/MU is up to speed with SP3.

P.S. Don't make fun of me for still putting "Home" Edition on one of my computers. :shock: :oops: :P[/quote]
I thought that if you integrate WGAN you don't need to integrate WGAV... is this not true? Is there another reason for integrating both? I have been integrating just WGAN and haven't had any issues, only a couple "suggested" updates are present in MSUpdate...
_coming soon, don't hold your breath

User avatar
roirraW "edor"
Posts: 761
Joined: Sun Oct 15, 2006 2:25 pm

Post by roirraW "edor" » Sun Apr 27, 2008 1:40 am

WGAV is for manually downloading redistributable Microsoft software, ones that they require validation for first anyway. Like if you go to the page to download WMP11, you'll have to validate first.

I *thought* WGAV was what Microsoft/Windows Update used as well. Now you've got me confused. :)

WGAN is the nag notifcation that XP can give if it determines your Windows isn't Genuine.

AFAIK these two components are completely separate and WGAN doesn't include WGAV. Someone please correct me if I'm wrong.

RickSteele
Posts: 288
Joined: Mon Oct 02, 2006 6:32 am
Location: Ottawa, Ontario, Canada

Post by RickSteele » Sun Apr 27, 2008 1:53 am

ronnie_t wrote:Finally. I got it, IE7 integrated from XP SP3 VLK. (no service packs integrated by me)

I searched and found that the error-message regarding the catalogs had to do with SYSSETUP.dll not being patched, So I had to manually added the following to entries_ie7.ini:
"I386\SYSSETUP.DLL|5.1.2600.5512|211753|73|72"

P.S. I did get a warning (for the first time) about the Battery-device not having signed/whql drivers, but I could just continue.
Wierd that the addon did not do this for you; for me that is one of the last tasks OnePiece's IE7 for Integrator only addon performs; to patch the SYSSETUP.dll.
Nice find/cure for you though, nevertheless!

chaoticyeshua
Posts: 14
Joined: Fri Jan 18, 2008 11:50 am

Post by chaoticyeshua » Sun Apr 27, 2008 2:26 am

Thanks everyone for your responses. I've got everything working great now and will be burning it sometime early this week! Everyone here always seems to be extremely helpful and I appreciate everyone's hard work on all of the projects here. Thank you, to everyone involved, whether you see this message or not.

User avatar
keloo05
Posts: 276
Joined: Mon Jun 26, 2006 10:04 pm
Location: Romania

Post by keloo05 » Sun Apr 27, 2008 8:25 am

roirraW "edor", you're wrong. You can look inside both archives to see the files they contain. WGAN includes WGAV. However, to be able to download from Microsoft, you can use WGAV only, but then WGAN will appear on WU or MU and it's your choice to install it or not.

RickSteele
Posts: 288
Joined: Mon Oct 02, 2006 6:32 am
Location: Ottawa, Ontario, Canada

Check it out

Post by RickSteele » Sun Apr 27, 2008 8:53 am

http://www.wincert.net/forum/index.php?showtopic=1737

OnePiece_IE7AddOn_2.1.0_INTL_For_WinXP.&.Win2k3_Only_for_RVMi.7z is actually OnePiece_IE7AddOn_2.1.1_INTL_For_WinXP.&.Win2k3_Only_for_RVMi according to the ini file.

updated April 25, 2008: adds compatability for 5512 (changelog is posted incorrectly labeling 2.1.1 as 2.0.5).

and:

OnePiece_IE7AddOn_2.1.1_ENU.7z

..also updated April 25, 2008
Last edited by RickSteele on Sun Apr 27, 2008 3:57 pm, edited 1 time in total.

benjamminzIS
Posts: 227
Joined: Fri Jan 12, 2007 8:07 am

Post by benjamminzIS » Sun Apr 27, 2008 3:52 pm

keloo05 wrote:roirraW "edor", you're wrong. You can look inside both archives to see the files they contain. WGAN includes WGAV. However, to be able to download from Microsoft, you can use WGAV only, but then WGAN will appear on WU or MU and it's your choice to install it or not.
that's what I thought... I'm using just the WGAN addon and can download updates/validation required software from MS and also have no WGA related items showing up in the "suggested" updates on WU.
_coming soon, don't hold your breath

kurmud
Posts: 3
Joined: Sun Apr 27, 2008 8:38 pm

Post by kurmud » Sun Apr 27, 2008 10:01 pm

hi, pardon my rustyness

i've slipped sp3 (nlite) onto sp2 vanilla, am I good to go with integrator w/(this pack), onepiece ie7, boooggy, 9.0c runtime?

benjamminzIS
Posts: 227
Joined: Fri Jan 12, 2007 8:07 am

Post by benjamminzIS » Sun Apr 27, 2008 11:13 pm

kurmud wrote:hi, pardon my rustyness

i've slipped sp3 (nlite) onto sp2 vanilla, am I good to go with integrator w/(this pack), onepiece ie7, boooggy, 9.0c runtime?
yes, should work great...

you can also do everything in one shot via nLite (ie: slipstream sp3, ie7 addon, dx9c addon...etc...etc...)
_coming soon, don't hold your breath

kurmud
Posts: 3
Joined: Sun Apr 27, 2008 8:38 pm

Post by kurmud » Sun Apr 27, 2008 11:24 pm

cool, thanks

bbmak
Posts: 57
Joined: Sat Feb 17, 2007 2:55 pm

Post by bbmak » Wed Apr 30, 2008 12:02 am

thank u dude. The post updated pack is great

jesscurt
Posts: 7
Joined: Thu Mar 13, 2008 4:55 pm

Thanks

Post by jesscurt » Wed Apr 30, 2008 7:53 am

Thanks for a great pack!

i have one question, after installing windows XP Pro with SP3 and this pack, i go to windows updates, and there is 1 update 'root certificates' is that normal, or have i missed something.

Thanks in advance

J

User avatar
roirraW "edor"
Posts: 761
Joined: Sun Oct 15, 2006 2:25 pm

Post by roirraW "edor" » Wed Apr 30, 2008 8:23 am

That's normal. That's an optional update so nothing Automatic Updates would download and install anyway, not that he his necessarily limiting his pack to just those.

User avatar
crashfly
Posts: 789
Joined: Thu Mar 13, 2008 11:39 pm
Location: Arkansas, USA

Post by crashfly » Wed Apr 30, 2008 11:14 am

It is possibly to download the latest "root certificates" update and install it as a part of the normal install process. I do it as a part of the "RunOnceEx" install that I do. Otherwise, it could be stuck in a couple of more places to not have to worry about it.
A mind is like a parachute, it only functions when it is open.
--Anonymous

How to Ask Questions the Smart Way

Fragbert
Posts: 338
Joined: Tue Jan 24, 2006 10:59 am

Post by Fragbert » Mon May 05, 2008 3:39 pm

Am I to use this update pack just like I would ryan's? Or do I treat it like an addon?

Using integrator 1.5.3, I get an error during text mode setup that I could not copy driver.cab when integrating as an update pack.

User avatar
roirraW "edor"
Posts: 761
Joined: Sun Oct 15, 2006 2:25 pm

Post by roirraW "edor" » Mon May 05, 2008 5:20 pm

I've tested it (alone other than SP3 RTM) with RVMI 1.5.3 and didn't get that issue.

You did slipstream SP3 RTM before trying to integrate this update pack, right? From the File menu of RVMI, there's a slipstream option.

Personally, I recommend slipstreaming and then burning/create an ISO of the result as every time in the future you use a SP3 update pack, you'll have to slipstream SP3 again unless you keep a "pure" SP3 source like this.

Fragbert
Posts: 338
Joined: Tue Jan 24, 2006 10:59 am

Post by Fragbert » Mon May 05, 2008 6:30 pm

SP3 was already previously slipstreamed. Integrating this updatepack as an addon in n-lite resulted in no issues. Works exactly as advertised. Very strange.

User avatar
roirraW "edor"
Posts: 761
Joined: Sun Oct 15, 2006 2:25 pm

Post by roirraW "edor" » Mon May 05, 2008 8:10 pm

Cool, and strange. Have you been able to reproduce it? I mean have you tried the RVMI integration of this update pack more than once and gotten the same result?

No other addons or DriverPacks. eh? I'm stumped.

User avatar
redxii
Posts: 395
Joined: Sun Dec 17, 2006 5:50 pm

Post by redxii » Tue May 06, 2008 10:28 pm

Is resetting WMI necessary on SP3?

Can't image why it would be at this point.

jesscurt
Posts: 7
Joined: Thu Mar 13, 2008 4:55 pm

Update

Post by jesscurt » Wed May 07, 2008 3:15 am

So far i have not needed to use wmi reset on sp3, so i dont think it would be needed.

I'm having 1 little problem, after slipstreaming XP CD SP1 with SP3, adding wmp11, IE7, WGAN, WGAV, and this pack.
When going to microsoft update site for the first time after install, i get an ActiveX promt. after that, all is fine.
Is there a way of removing that activeX promt for misrosoft update?
Besides that, all is working good.. have no updates needed at all.

Thanks in Advance

Jesse

User avatar
quest221
Posts: 39
Joined: Fri Nov 03, 2006 12:23 pm
Location: Shanghai China

Post by quest221 » Wed May 07, 2008 10:09 am

hi,redxii

I use your latest pack for xp_sp3_cn, and installed it in a VM.
Then I found the "Automatic Update" in control pannel is english, not Chinese, could you pls tell me how to change it to Chinese, which file should be replaced in you pack?
You can't say!!!

benjamminzIS
Posts: 227
Joined: Fri Jan 12, 2007 8:07 am

Re: Update

Post by benjamminzIS » Wed May 07, 2008 12:14 pm

jesscurt wrote:So far i have not needed to use wmi reset on sp3, so i dont think it would be needed.

I'm having 1 little problem, after slipstreaming XP CD SP1 with SP3, adding wmp11, IE7, WGAN, WGAV, and this pack.
When going to microsoft update site for the first time after install, i get an ActiveX promt. after that, all is fine.
Is there a way of removing that activeX promt for misrosoft update?
Besides that, all is working good.. have no updates needed at all.

Thanks in Advance

Jesse
If you are installing WGAN you do NOT need WGAV as it is included in WGAN...
_coming soon, don't hold your breath

SHO_GuN
Posts: 144
Joined: Fri Jun 30, 2006 11:26 pm

Re: Update

Post by SHO_GuN » Wed May 07, 2008 12:21 pm

jesscurt wrote:When going to microsoft update site for the first time after install, i get an ActiveX promt. after that, all is fine.
Is there a way of removing that activeX promt for misrosoft update?
This reg entry takes care of that for me:

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Stats\{6E32070A-766D-4EE6-879C-DC1FA91D2FC3}\iexplore]
"Flags"=dword:00000004

jesscurt
Posts: 7
Joined: Thu Mar 13, 2008 4:55 pm

Microsoft Update

Post by jesscurt » Wed May 07, 2008 8:00 pm

Entering the above Reg key fixed the problem.
Thank you

Jesse

IGIdeus
Posts: 10
Joined: Wed Apr 04, 2007 2:18 am

Re: Update

Post by IGIdeus » Thu May 08, 2008 1:49 am

SHO_GuN wrote:This reg entry takes care of that for me:

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Stats\{6E32070A-766D-4EE6-879C-DC1FA91D2FC3}\iexplore]
"Flags"=dword:00000004
Hi,

Can you explain a little bit more what the reg do?
I solved the issue by adding update.microsoft.com and *.update.microsoft.com to Trusted Zone via

.reg file

Code: Select all

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\Domains\microsoft.com]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\Domains\microsoft.com\update]
"http"=dword:00000002

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\Domains\microsoft.com\*.update]
"http"=dword:00000002
or .inf file

Code: Select all

HKCU,"Software\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\Domains\microsoft.com",,0x10
HKCU,"Software\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\Domains\microsoft.com\update","http",0x10001,02,00,00,00
HKCU,"Software\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\Domains\microsoft.com\*.update","http",0x10001,02,00,00,00
Best regards
IGIdeus

User avatar
redxii
Posts: 395
Joined: Sun Dec 17, 2006 5:50 pm

Post by redxii » Thu May 08, 2008 11:39 am

I only have English XP, so I wouldn't know how to solve any problems when trying to use it on another language.

2.0 released. Probably after this everyone will want to use RyanVM's.

User avatar
roirraW "edor"
Posts: 761
Joined: Sun Oct 15, 2006 2:25 pm

Post by roirraW "edor" » Thu May 08, 2008 4:28 pm

Might want to update the topic title. :wink:

bbmak
Posts: 57
Joined: Sat Feb 17, 2007 2:55 pm

Post by bbmak » Sun May 11, 2008 3:11 pm

My URL redirection got kidnapped after i integrate the xp sp3 pack :(

For example, when I typed ryanvm in the address bar(IE7, and Firefox 2.0.0.14), it will redirect me to http://www.kolmic.com.


However, when i install without this updated pack, i do not have problem with the redirection

I don't know if other people have the same problem?

User avatar
roirraW "edor"
Posts: 761
Joined: Sun Oct 15, 2006 2:25 pm

Post by roirraW "edor" » Sun May 11, 2008 3:33 pm

I haven't tried the very latest version. I definitely didn't have this problem with the old version. Interested to hear back if other people have had this problem or not.

w2sjw
Posts: 20
Joined: Fri Apr 13, 2007 5:31 pm

Post by w2sjw » Sun May 11, 2008 4:10 pm

I'm typing this from within the VM install I just finished using Red's v2.0.0.

No re-direct hijacking here... :wink:

bbmak
Posts: 57
Joined: Sat Feb 17, 2007 2:55 pm

Post by bbmak » Sun May 11, 2008 4:11 pm

my bad, this time i tried to install w/o the updated pack. I am still getting hijacked with url redirection to kolmic.com. I guess i need to integrate spyware remover with the installation files.

User avatar
roirraW "edor"
Posts: 761
Joined: Sun Oct 15, 2006 2:25 pm

Post by roirraW "edor" » Sun May 11, 2008 4:20 pm

I would be concerned about what you are installing that is causing that, rather than adding something to (hopefully) remove it.

User avatar
crashfly
Posts: 789
Joined: Thu Mar 13, 2008 11:39 pm
Location: Arkansas, USA

Post by crashfly » Sun May 11, 2008 8:44 pm

[quote="roirraW "edor""]I would be concerned about what you are installing that is causing that, rather than adding something to (hopefully) remove it.[/quote]
I second that motion.
A mind is like a parachute, it only functions when it is open.
--Anonymous

How to Ask Questions the Smart Way

User avatar
redxii
Posts: 395
Joined: Sun Dec 17, 2006 5:50 pm

Post by redxii » Tue May 13, 2008 9:22 pm

Is KB946627 necessary anymore? I removed it and IE6 doesn't crash, at least on the VLK ISO w/ 5512 integrated.

User avatar
roirraW "edor"
Posts: 761
Joined: Sun Oct 15, 2006 2:25 pm

Post by roirraW "edor" » Tue May 13, 2008 9:50 pm

redxii wrote:Is KB946627 necessary anymore? I removed it and IE6 doesn't crash, at least on the VLK ISO w/ 5512 integrated.
It was published 12/20/2007, so it should already be in SP3. http://www.microsoft.com/downloads/deta ... laylang=en

User avatar
ENU_user
Posts: 1253
Joined: Wed Jan 25, 2006 1:42 pm

Post by ENU_user » Tue May 13, 2008 10:08 pm

http://kbupdate.info/windows-xp-2008-05.php

post sp3, beginning to pile up ;)

User avatar
roirraW "edor"
Posts: 761
Joined: Sun Oct 15, 2006 2:25 pm

Post by roirraW "edor" » Tue May 13, 2008 10:17 pm

Thanks, redxii.

ChiefZeke
Posts: 767
Joined: Fri Mar 23, 2007 5:33 pm
Location: Victorville, California

Post by ChiefZeke » Thu May 15, 2008 1:06 am

Got it - keep up the good work. :D

User avatar
Stimpy
Posts: 499
Joined: Thu Dec 07, 2006 1:00 pm
Location: Denmark

Post by Stimpy » Thu May 15, 2008 5:50 am

Forgive me if I'm asking a silly question, but I was just looking at that link that ENU_user provided, and it seems that there are a few updates to SP3 installed systems, and was wondering why they are not included in this update pack?

User avatar
roirraW "edor"
Posts: 761
Joined: Sun Oct 15, 2006 2:25 pm

Post by roirraW "edor" » Thu May 15, 2008 6:45 am

Are you talking about the ones that just came out Tuesday?

User avatar
Stimpy
Posts: 499
Joined: Thu Dec 07, 2006 1:00 pm
Location: Denmark

Post by Stimpy » Thu May 15, 2008 8:08 am

I see some updated files released 8th of May. But as I said before, I could be being silly because of my lack of understanding on how and when MS make these files available.

User avatar
redxii
Posts: 395
Joined: Sun Dec 17, 2006 5:50 pm

Post by redxii » Thu May 15, 2008 5:37 pm

I didn't see them on Windows Update.

User avatar
roirraW "edor"
Posts: 761
Joined: Sun Oct 15, 2006 2:25 pm

Post by roirraW "edor" » Thu May 15, 2008 7:43 pm

Stimpy wrote:I see some updated files released 8th of May. But as I said before, I could be being silly because of my lack of understanding on how and when MS make these files available.
The only thing I find is May's Malicious Software Removal Tool, which has been updated in this update pack. Everything else I have listed in MU is for Office 2007.

The only previous thing I had for update to SP3 was the KB947864 for IE7, although there's an IE6 version too, as my non-SP3 XP still running on another computer lists that update as well.

redxii, will you be adding KB947864 to this pack, or are you waiting on Ryan to come out with his pack and are going to discontinue yours?

User avatar
redxii
Posts: 395
Joined: Sun Dec 17, 2006 5:50 pm

Post by redxii » Thu May 15, 2008 9:18 pm

I don't recall seeing a KB947864 on a fresh SP3 installation. I'll look again.. but for IE7, I can't include it for IE7 because SP3 doesn't include IE7.

User avatar
redxii
Posts: 395
Joined: Sun Dec 17, 2006 5:50 pm

Post by redxii » Thu May 15, 2008 9:38 pm

Nope, no KB947864 for IE6 SP3.

User avatar
roirraW "edor"
Posts: 761
Joined: Sun Oct 15, 2006 2:25 pm

Post by roirraW "edor" » Thu May 15, 2008 10:31 pm

redxii wrote:I don't recall seeing a KB947864 on a fresh SP3 installation. I'll look again.. but for IE7, I can't include it for IE7 because SP3 doesn't include IE7.
Right, yeah I knew you wouldn't add it for IE7 since SP3 doesn't include it.

So it must mean SP3 doesn't have the vulnerability unless IE7 is installed. Ah, actually KB947864 for IE6 was published 4/8/2008, so it was included in SP3 for IE6. Cool, now I understand. :D

Thanks for your patience, and sorry for any additional testing you did because of this.

User avatar
Stimpy
Posts: 499
Joined: Thu Dec 07, 2006 1:00 pm
Location: Denmark

Post by Stimpy » Fri May 16, 2008 6:24 am

ENU_user wrote:http://kbupdate.info/windows-xp-2008-05.php

post sp3, beginning to pile up ;)
This is the place where I have found references to fixes dated from the 5th of this month onwards. But I have no idea how you go about obtaining these fixes. There are at least 5 hotfixes specific to SP3 available since the 5th of May.

User avatar
roirraW "edor"
Posts: 761
Joined: Sun Oct 15, 2006 2:25 pm

Post by roirraW "edor" » Fri May 16, 2008 9:53 am

Stimpy wrote:
ENU_user wrote:http://kbupdate.info/windows-xp-2008-05.php

post sp3, beginning to pile up ;)
This is the place where I have found references to fixes dated from the 5th of this month onwards. But I have no idea how you go about obtaining these fixes. There are at least 5 hotfixes specific to SP3 available since the 5th of May.
If you're referring to these:

You cannot connect to a remote computer or start a remote application when you use Terminal Services Web Access or Remote Web Workspace on a Windows XP SP3-based computer

A Windows XP SP3-based computer loses wireless connectivity when it resumes from standby or from hibernation, or you receive an error message when you try to put the computer in standby or in hibernation

Error message when you try to install Windows XP SP3: "You do not have enough free disk space on %SystemDrive% to archive the uninstall files"

These three don't have an associated hotfix file. They have workaround instructions. They might or might not be able to be implemented in an update pack; I don't know enough about that stuff.

The first one is actually just instructing how to enable an ActiveX control which is disabled by default. Under SP2 you had to install this ActiveX control in order to enable it. SP3 includes it; it's just disabled by default.

The third one is just how to free up enough enough disk space when it's not available to backup files while installing SP3.

When you double-click the Internet Explorer 7 icon on the desktop after you install Windows XP SP3, Internet Explorer does not start, and a new Internet Explorer shortcut is created

Is just the instructions that if you already have IE7 installed on a SP2 XP and upgrade to SP3, you need to reinstall IE7 afterwards.

When you disable and then re-enable the LAN-side network adapter on a Windows XP SP3-based computer that is configured as a Connection Sharing host, a client computer on the network cannot access the Internet

Does have a hotfix, although you have to submit a request to Microsoft Online Customer Services to obtain it. I could only find the Russian version which is available here.

There are also two workaround instructions, which I'm assuming don't require the hotfix.

Post Reply