XPSP3_QFE_UpdatePack for Windows XP Post-SP3 20180109

Windows XP Professional Update Pack discussion.
Post Reply
User avatar
mr_smartepants
Posts: 824
Joined: Thu May 18, 2006 5:56 am
Location: Cambridgeshire, UK

Post by mr_smartepants » Tue Sep 01, 2009 10:38 am

Nevermind, I got it.
Rapidshare has a size download limit. I was impatient. ;)
So far so good. No errors yet...
Image
Some heroes don't wear capes, they wear Kevlar and dog-tags!

adric
Posts: 582
Joined: Mon May 21, 2007 5:51 am

Post by adric » Tue Sep 01, 2009 11:05 am

Hi,

Can someone tell me what I need to do in order to cleanly exclude a few KBxxxxxx updates that are included in this update pack?

I will be using RVMI to do the integration.

Thanks, Al

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Tue Sep 01, 2009 12:43 pm

http://www.esnips.com/doc/fc59b98f-a1db ... 9_20090830

a mirror for who have trouble with rapidshare.
Image
My work list(Hosted by dumpydooby)

mindwarper
Posts: 255
Joined: Mon Jul 25, 2005 9:56 pm
Location: Netherlands

Post by mindwarper » Tue Sep 01, 2009 2:54 pm

user_hidden wrote:@mr. smartepants

i don't have the files locally at present so i can't upload to another host.

if anyone wants to post an alt link go ahead.

btw, the .MSI installer weirdness will be fixed in next release.
what MSI weirdness do you mean?
do you refer to the issues others have been repaorting with installing Office 2003?

I actually re-installed my PC last weekend, using the 1.0.8 then, no issues here...


@yumeyao: congrats for 1000 posts :D

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Tue Sep 01, 2009 4:06 pm

@mindwarper

yes the office2003 installs and others actually.
it seems the installs go silent sometimes but the programs do install properly.

mercyground
Posts: 18
Joined: Mon Mar 03, 2008 6:50 pm

Post by mercyground » Tue Sep 01, 2009 6:49 pm

yumeyao wrote:http://www.esnips.com/doc/fc59b98f-a1db ... 9_20090830

a mirror for who have trouble with rapidshare.
Getting bad link from that site fyi.

/me goes back to kicking rapidcrap.

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Tue Sep 01, 2009 8:48 pm

@mercyground,
forgot to move it to a public folder. esnips sucks recent days it always uploads files to default unshared folder. (In the past there was a choice to upload files to which i was browsing).

@mindwarper,
thx :wink:
Image
My work list(Hosted by dumpydooby)

marzsyndrome
Posts: 239
Joined: Sun May 28, 2006 6:01 am

Post by marzsyndrome » Fri Sep 04, 2009 4:04 pm

What hotfixes/addons should one comment-out/remove if they're using the N version (aka the WMP-free version)?

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Fri Sep 04, 2009 4:27 pm

marzsyndrome wrote:What hotfixes/addons should one comment-out/remove if they're using the N version (aka the WMP-free version)?
this update pack is desined for the regular and not N version of windowsXP. unfortunately i don't have the time to go through the pack and inform what needs to be removed.

User avatar
DaRk MaDnEsS
Posts: 168
Joined: Fri Oct 10, 2008 4:15 pm
Location: Port Said,Egypt

Post by DaRk MaDnEsS » Fri Sep 04, 2009 4:52 pm

user_hidden wrote:
marzsyndrome wrote:What hotfixes/addons should one comment-out/remove if they're using the N version (aka the WMP-free version)?
this update pack is desined for the regular and not N version of windowsXP. unfortunately i don't have the time to go through the pack and inform what needs to be removed.
well i think it should work

as this update pack doesn't have updates for WMP << i think

you should test it your self and tell us

User avatar
beats
Posts: 772
Joined: Tue Nov 27, 2007 4:11 am
Location: Netherlands

Post by beats » Fri Sep 04, 2009 4:54 pm

@marzsyndrome
IIRC, KB952069, KB971557 are both related to the Windows Media Format Runtimes (not sure if the Media Runtimes are also not part of XP/N), and KB973540 is for WMP itself.

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Fri Sep 04, 2009 7:18 pm

DaRk MaDnEsS wrote: as this update pack doesn't have updates for WMP << i think
yup pack has all updates for WMP9 as that is what is built into XP-SP3

User avatar
=[FEAR]=JIGSAW
Posts: 392
Joined: Mon Feb 18, 2008 11:54 am
Location: Cape Town, South Africa

Post by =[FEAR]=JIGSAW » Sat Sep 05, 2009 2:38 am

user_hidden wrote:@mr. smartepants

btw, the .MSI installer weirdness will be fixed in next release.
so i take it that version 1.0.9_20090830 does not have a fix yet ???
should i wait for the next release??? ... also getting that problem with some programs that disappears from the screen while installing.

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Sat Sep 05, 2009 7:03 am

=[FEAR]=JIGSAW wrote:
user_hidden wrote:@mr. smartepants

btw, the .MSI installer weirdness will be fixed in next release.
so i take it that version 1.0.9_20090830 does not have a fix yet ???
should i wait for the next release??? ... also getting that problem with some programs that disappears from the screen while installing.
the fix is in 1.1.0 beta which will be released for patch tuesday.

User avatar
mr_smartepants
Posts: 824
Joined: Thu May 18, 2006 5:56 am
Location: Cambridgeshire, UK

Post by mr_smartepants » Sat Sep 05, 2009 2:42 pm

ready, willing, and waiting to beat on that beta for ya! :D
Image
Some heroes don't wear capes, they wear Kevlar and dog-tags!

sittingduck77
Posts: 11
Joined: Wed Dec 17, 2008 3:38 am

Post by sittingduck77 » Sun Sep 06, 2009 5:43 am

1.09 gives me an SFC warning when I plug in a flash drive for the first time after a fresh install. Never had this before. Using RVMI for integrating.

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Tue Sep 08, 2009 7:51 pm

updated 1.10 20090908 ......

Mann41
Posts: 22
Joined: Fri May 16, 2008 10:27 pm

Post by Mann41 » Wed Sep 09, 2009 7:05 am

thanks for the prompt update but is there an alternative link besides rapidshare :wink:

zilan
Posts: 82
Joined: Fri Sep 04, 2009 12:49 am

Post by zilan » Wed Sep 09, 2009 7:58 am

Mann41 wrote:thanks for the prompt update but is there an alternative link besides rapidshare :wink:

Code: Select all

http://gambaz.holbergprisen.info/sulap/0x14/XPSP3_QFE_UpdatePack_1.1.0_20090908.7z
link for only 36 hours, and after that will be deleted, so be quick :D

Mann41
Posts: 22
Joined: Fri May 16, 2008 10:27 pm

Post by Mann41 » Wed Sep 09, 2009 9:04 am

thanks zilan :D downloading now :D

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Wed Sep 09, 2009 9:14 am

Image
My work list(Hosted by dumpydooby)

pdl808
Posts: 58
Joined: Sat Dec 01, 2007 3:13 pm
Location: Milpitas, CA USA

Post by pdl808 » Wed Sep 09, 2009 10:38 am

Did you consider adding KB970653-v3, Time Zone update?

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Wed Sep 09, 2009 10:44 am

why did you consider he didn't include KB970653?
Image
My work list(Hosted by dumpydooby)

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Wed Sep 09, 2009 3:21 pm

pdl808 wrote:Did you consider adding KB970653-v3, Time Zone update?
has been included in the updatepack since v1.07 !

User avatar
=[FEAR]=JIGSAW
Posts: 392
Joined: Mon Feb 18, 2008 11:54 am
Location: Cape Town, South Africa

Post by =[FEAR]=JIGSAW » Wed Sep 09, 2009 6:04 pm

Thx for the new update
much appreciated ;)

pdl808
Posts: 58
Joined: Sat Dec 01, 2007 3:13 pm
Location: Milpitas, CA USA

Post by pdl808 » Wed Sep 09, 2009 6:43 pm

yumeyao wrote:why did you consider he didn't include KB970653?
Because v3 is not in the changelog.

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Wed Sep 09, 2009 7:21 pm

pdl808 wrote:
yumeyao wrote:why did you consider he didn't include KB970653?
Because v3 is not in the changelog.
i do not add version numbers.
if there is a version update i do it silently.
run qfecheck.exe on your system and you will see v3 is installed.

User avatar
Knowone
Posts: 77
Joined: Tue Sep 04, 2007 8:42 am

Post by Knowone » Thu Sep 10, 2009 2:02 am

Not only excellent stuff, but lightning quick delivery as well! Big thanks.
Important is more than knowledge imagination
--Einal Bertstein

zilan
Posts: 82
Joined: Fri Sep 04, 2009 12:49 am

Post by zilan » Thu Sep 10, 2009 12:14 pm

user_hidden wrote:
clandren wrote:
user_hidden wrote: Addon_RegTweaks_Utilities_1.49.7z
just curious where did you get this addon? i tried searching for it but nothing came up

my own personal registry tweaks and utilities :wink:
can i have this add on? thanks :)

pdl808
Posts: 58
Joined: Sat Dec 01, 2007 3:13 pm
Location: Milpitas, CA USA

Post by pdl808 » Fri Sep 11, 2009 3:06 pm

I did a new build using UpdatePack_1.1.0 without any other addons. QFE Check says: “KB955069: This hotfix should be reinstalled”.

I added KB955069 to my build using nlite. This fixed the problem. Also, nlite said “The installation was reduced by 0.11 MB”.

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Sat Sep 12, 2009 8:53 am

pdl808 wrote:I did a new build using UpdatePack_1.1.0 without any other addons. QFE Check says: “KB955069: This hotfix should be reinstalled”.

I added KB955069 to my build using nlite. This fixed the problem. Also, nlite said “The installation was reduced by 0.11 MB”.
problem with YOUR integration.
KB955059 is installed fine.

Jay
Posts: 81
Joined: Tue Aug 15, 2006 4:38 pm

Post by Jay » Sun Sep 13, 2009 4:42 pm

Thanks user_hidden as Ryan is so busy
you have saved the day for us with your excellent work :D

sittingduck77
Posts: 11
Joined: Wed Dec 17, 2008 3:38 am

Post by sittingduck77 » Mon Sep 14, 2009 9:37 am

I get the same thing as pdl808 - QFE check says that KB955069 should be reinstalled. I accept that it is a problem at my end and not in the pack. However, I'm integrating the pack into an official MSDN SP3 version of XP using latest stable RMVI, so my guess would be that others would also experience thisl.

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Mon Sep 14, 2009 1:08 pm

sittingduck77 wrote:I get the same thing as pdl808 - QFE check says that KB955069 should be reinstalled. I accept that it is a problem at my end and not in the pack. However, I'm integrating the pack into an official MSDN SP3 version of XP using latest stable RMVI, so my guess would be that others would also experience thisl.
i just did a test in a VM.

My update pack + MSDN XPSP3 GRTMVOL using RVMi 1.6b2.1
no other addons or tweaks.

QFEcheck shows all updates on system !

origgman
Posts: 13
Joined: Tue May 13, 2008 10:06 am

A few mirrors (Mediafire + + +)

Post by origgman » Mon Sep 14, 2009 4:11 pm

Last edited by origgman on Mon Sep 14, 2009 4:28 pm, edited 3 times in total.

Botus
Posts: 161
Joined: Sat Dec 22, 2007 12:47 pm
Location: UK

Post by Botus » Mon Sep 14, 2009 4:14 pm

I think thats where the difference lies...

I nearly posted earlier, I guessed you would only use 1.6b2.1

are they are using 1.61 ???

I was struggling ages back with some issues (problem my end I think).... I NOW only use 1.6b2.1 and it works great for me.

User avatar
beats
Posts: 772
Joined: Tue Nov 27, 2007 4:11 am
Location: Netherlands

Post by beats » Mon Sep 14, 2009 4:17 pm

As a general rule of thumb: always use the latest RVMi (thus 1.6.1 b2.1). Unless stated otherwise. ;)

User avatar
*Reaper*
Posts: 594
Joined: Sat Feb 04, 2006 11:01 am

Post by *Reaper* » Mon Sep 14, 2009 7:39 pm

Anybody other than me showing kb971961 on Microsoft Update?

Ran qfecheck says: KB971961 current on system....

Maybe a reg entrie problem?

Or maybe it just doesn't like me! :D

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Mon Sep 14, 2009 8:08 pm

*Reaper* wrote:Anybody other than me showing kb971961 on Microsoft Update?

Ran qfecheck says: KB971961 current on system....

Maybe a reg entrie problem?

Or maybe it just doesn't like me! :D
you probably also added IE8 in your integration which itself would require
another version of KB971961 for Jscript 5.8 and not the one in the pack which is for IE6 for Jscript 5.7......hence your MU/WU nag

perhaps you are using a non current IE8 addon. i am sure that onepiece's
has been updated with that update.

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Mon Sep 14, 2009 9:30 pm

this little util can check the updates on your WindowsXP system

Installed_hotfixes.exe

File: Installed_Hotfixes.exe
CRC-32: 3344b031
MD4: 488196ea64d74fac5f98b2e2bcbda7e0
MD5: 9767fb89ef7350dc91d0cb7c5944af19
SHA-1: 9f491452427d34a90b8fc1b6d005b4559acf4573

soporific
Posts: 47
Joined: Mon Aug 13, 2007 7:10 am

Post by soporific » Tue Sep 15, 2009 8:05 pm

User-hidden, thanks heaps for this. I am building my first DVD using your update pack instead of RyamVM's 1.03 pack from January 2009. I will let you know how it goes.

cosy
Posts: 278
Joined: Tue Apr 18, 2006 11:56 pm

Post by cosy » Wed Sep 16, 2009 7:01 am

just tested this one on a new Cd and it works perfectly, thank you very much

User avatar
alban
Posts: 194
Joined: Sun Feb 08, 2009 11:20 am
Location: aL

Post by alban » Thu Sep 17, 2009 9:01 pm

Maybe this is not the proper place to ask this question but hope someone will answer, since I use User-hidden update and I like it very much cause it's all perfect now except 1 small thing which will be my question:

Any1 knows how to add a new background wallpaper on desktop, dot like the regular one?

User avatar
beats
Posts: 772
Joined: Tue Nov 27, 2007 4:11 am
Location: Netherlands

Post by beats » Fri Sep 18, 2009 4:04 am

Either copy the wallpaper to $OEM$\$1\ and import the registry settings below:

Code: Select all

Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Control Panel\Desktop]
"Wallpaper"="%SystemRoot%\My Wallpaper.bmp"
"WallpaperStyle"="0" ;0= Centered (Default), 1=Tiled, 2=Streched
(you can force this with a policy as well):

Code: Select all

Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]
"Wallpaper"="%SystemRoot%\My Wallpaper.bmp"
"WallpaperStyle"="0" ;0= Centered (Default), 1=Tiled, 2=Streched
Or make a theme, put it in your $OEM$\$$\Resources\Themes\ directory and add/modify the following lines in WINNT.SIF's [Shell] section:

Code: Select all

[Shell]
CustomDefaultThemeFile="%SystemRoot%\Resources\Themes\My Theme.theme"
DefaultThemesOff=No

sittingduck77
Posts: 11
Joined: Wed Dec 17, 2008 3:38 am

Post by sittingduck77 » Sat Sep 19, 2009 4:39 am

Just for the record: After switching to latest betaof RVMI, the above described issue with one update needing reinstalling was resolved. Will use latest beta from now on. Thanks.

User avatar
vmanda
Posts: 1634
Joined: Wed Apr 18, 2007 12:25 pm
Location: TM.Romania

Post by vmanda » Sat Sep 19, 2009 8:16 am

user_hidden wrote:this little util can check the updates on your WindowsXP system

Installed_hotfixes.exe

File: Installed_Hotfixes.exe
CRC-32: 3344b031
MD4: 488196ea64d74fac5f98b2e2bcbda7e0
MD5: 9767fb89ef7350dc91d0cb7c5944af19
SHA-1: 9f491452427d34a90b8fc1b6d005b4559acf4573
Also a very nice tool to obtain informations about KBxxxxxx updates integrated or installed in yours XP ,
contents, description and download links to yours installed KB's on MS site, etc., are Nirsoft WinUpdatesList.

adric
Posts: 582
Joined: Mon May 21, 2007 5:51 am

Post by adric » Sun Sep 20, 2009 6:34 am

adric wrote:Hi,

Can someone tell me what I need to do in order to cleanly exclude a few KBxxxxxx updates that are included in this update pack?

I will be using RVMI to do the integration.

Thanks, Al
Considering the silence to my question, is it correct to assume that one cannot change the QFE update pack to exclude an update during integration?

I'm afraid my search requests on this subject were not very successful and that is the reason I asked my question here.

Thanks, Al

User avatar
5eraph
Site Admin
Posts: 4620
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Sun Sep 20, 2009 7:03 am

It depends on the updates you wish to remove, adric. The update pack is not intended to be easily modified, but taken as a whole.

deadbugx
Posts: 2
Joined: Sun Sep 20, 2009 7:00 am

Problem with MU after deploying update pack

Post by deadbugx » Sun Sep 20, 2009 7:37 am

I've taken WXP SP3 and integrated this pack (WindowsXP Post-SP3 Update Pack (QFE) Version 1.1.0 20090908) using v1.6 of RVMi.

I've then slipstream WMP (using boooggy's slipstreamer) and IE7 (using nlite).

Testing the install in a VM is fine except that Microsoft Update doesn't work. It reports error code 0x800B0100. I've tried regsvr32 on softpub.dll, wintrust.dll, initpki.dll and mssip32.dll (as suggested by a KB article) and also I've stopped and restarted the crypto service (as suggested elsewhere) but with no luck.

Is anyone else seeing this problem?

adric
Posts: 582
Joined: Mon May 21, 2007 5:51 am

Post by adric » Sun Sep 20, 2009 7:39 am

5eraph wrote:It depends on the updates you wish to remove, adric. The update pack is not intended to be easily modified, but taken as a whole.
Okay, fair enough. I guess I'll give xable 's pack a try and see if that will suffice for me. I just did not want some of the optional updates offered by WU that are included in the QFE pack such as WGA etc. Ryan's update pack was great while it lasted.

Thanks, Al

Post Reply