Page 5 of 6

Posted: Mon Apr 13, 2009 2:09 pm
by OnePiece Alb
Hello SwapsRulez, I'm reading carefully for days what to write, but you know the fault of my English are a little confused them, so I was waiting for Nonno Fabio, which I explained the best thing,

however for now if you find problems with WMP9 ????, using nLite to remove WMP9 from the CD (IE6 and WMP9 are built exactly like WinXP, so you think that nLite and so removes them without problems) and see below are still problems ?????

Posted: Tue Apr 14, 2009 12:38 am
by SwapsRulez
OnePiece Alb wrote:Hello SwapsRulez, I'm reading carefully for days what to write, but you know the fault of my English are a little confused them, so I was waiting for Nonno Fabio, which I explained the best thing,

however for now if you find problems with WMP9 ????, using nLite to remove WMP9 from the CD (IE6 and WMP9 are built exactly like WinXP, so you think that nLite and so removes them without problems) and see below are still problems ?????
Thanks for the reply mate. I want to keep WMP in the OS. :( Its a necessary component. Also is there any way to remove whole MSI of MSXML and that 9seriesd.wmz file.
Thanks in advance. :)

Posted: Tue Apr 14, 2009 12:44 am
by OnePiece Alb
See the Dosnet.inf
[Files]
xmleula.rtf
and present or not?


the last line should be as them?
d1,wucltui.dll
d1,wucltui.mui
d1,wups.dll
d1,wups2.dll
d1,wuweb.dll
d1,xmleula.rtf
d1,xpob2res.dll

Posted: Tue Apr 14, 2009 10:06 am
by SwapsRulez
Thank you for replying mate.
d1,xenrlinf.cab
d1,xenroll.dll
d1,xenrx86.dll
d1,xiffr3_0.dll
d1,xjis.nls
d1,xlisten.dll
d1,xmleula.rtf
d1,xolehlp.dll
d1,xpob2res.dll
d1,xr_dc230.ppd
d1,xrdt1354.ppd
d1,xtel.dll
d1,xvoice.dll
d1,yahoo.bmp
d1,zapotec.bmp

[CmdConsFiles]
autochk.exe
autofmt.exe

Here's that part of the dosnet.inf file. That file entry is present.

if you need some log files or any other files. Just ask me, I'll provide you those. :D

Thanks

Posted: Tue Apr 14, 2009 11:33 am
by Kelsenellenelvian
I tiold you to remove all of those....

Delete the offending file names lines. xmleula.rtf & 9seriesd.wmz

Posted: Tue Apr 14, 2009 12:34 pm
by Kelsenellenelvian
Found some more instances of it...

OPMW2kUP.inf
;xmleula.rtf,,,32

skins.inf
;9SeriesDefault.wmz,9SeriesD.wmz

These need to go too.

Posted: Tue Apr 14, 2009 12:47 pm
by SwapsRulez
Kelsenellenelvian wrote:I tiold you to remove all of those....

Delete the offending file names lines. xmleula.rtf & 9seriesd.wmz
Naah, I did it. The last reply was for onepience. I did what he asked me for. Check my reply to your answer on first post of this page.
Kelsenellenelvian wrote:Found some more instances of it...

OPMW2kUP.inf
;xmleula.rtf,,,32

skins.inf
;9SeriesDefault.wmz,9SeriesD.wmz

These need to go too.
I need to try these. Wait.... Don't go anywhere. I'm trying. :P

Thanks for the keeping the constant help. :)

Posted: Tue Apr 14, 2009 2:12 pm
by SwapsRulez
Update:

I tried just like you told me. Also checked for those 2 strings in extracted files using ultraedit "Find in files" search method. Removed all entries of those files. Integrated with RMVi 1.6, made ISO and tried installing it on VirtualBox.

Now, LOL... LMAO... ROFL... It asked me for msxml4.dl_ :lol: When again I clicked OK, browse the file and clicked ok. After some 30 seconds, progress bar stopped and BOOM... restarted!!!

It didn't even reached "Installing Start Menu Items" to check the problem of 9seriesd.wmz :P

Anyways, thanks a bunch for helping. I guess time to give up or can I get the update pack without that shit MSXML :(

Thanks a bunch. :)

Posted: Tue Apr 14, 2009 3:06 pm
by OnePiece Alb
attach your txtsetup.sif and Layout.inf


who see them and the destination ?????????????, believe that your Destination is not cdrom_is,

but must be one of these?
cdrom_id
cdrom_ia
cdrom_iw

If you then change entries.ini in

Code: Select all

;This section contains version info for nLite & RyanVM Integrator
[general]
builddate=2009/04/13
description=OnePiece's Post-SP4 Update Pack for Windows 2000 Server
language=ALL
ServicePack=SP4
title=OnePiece's Post-SP4 Update Pack for Windows 2000 Server
version=2009
website=http://www.microsoft.com/technet/security/current.aspx
Windows=2000 Server

;This section allows you to edit things that normally would not be possible to edit.
[ExtraFileEdits] 
OPMW2kUP.inf|cdrom_ip|cdrom_is|1
wmp.inf|cdrom_ip|cdrom_i%Your destination%|1
roxio.inf|cdrom_ip|cdrom_i%Your destination%|1
skins.inf|cdrom_ip|cdrom_i%Your destination%|1
mymusic.inf|cdrom_ip|cdrom_i%Your destination%|1

Posted: Wed Apr 15, 2009 2:44 am
by SwapsRulez
I'm not sure where to check

cdrom_id
cdrom_ia
cdrom_iw

But I'm attaching the dosnet.inf, layout.inf and txtsetup.sif files before integration and after integration.

Have a look at them.

Before Integration: http://www.mediafire.com/download.php?c3m3tgijyjn

After Integration: http://www.mediafire.com/download.php?zkqnyymwyzz

Thanks in advance. :)

Posted: Thu Apr 16, 2009 11:59 am
by SwapsRulez
*Knock Knock* Is anyone here? :(

Posted: Thu Apr 16, 2009 1:11 pm
by OnePiece Alb
extract Update pack, change the eitres.ini with this http://ifile.it/aum49z0, since files in update pack with winrar 7zip ect ect


Cd in a clean update pack integrates with RVMi, after integrating again OnePiece_Repair_Win2kSP4_UP_for_Windows_2000_Server_AddOn.7z, and test if VM does not go then I do not know what to say, the Riggi are those of SP4 will be ok for each cd win2k

OnePiece_Repair_Win2kSP4_UP_for_Windows_2000_Server_AddOn.7z
http://ifile.it/tavk8f9
Hash MD5 CF09EAFC381440EDBD961DF1D85C8CCF


if not for something clear, then wait Nonno Fabio serve you and says he better

Posted: Fri Apr 17, 2009 2:16 am
by SwapsRulez
OnePiece Alb wrote:extract Update pack, change the eitres.ini with this http://ifile.it/aum49z0, since files in update pack with winrar 7zip ect ect


Cd in a clean update pack integrates with RVMi, after integrating again OnePiece_Repair_Win2kSP4_UP_for_Windows_2000_Server_AddOn.7z, and test if VM does not go then I do not know what to say, the Riggi are those of SP4 will be ok for each cd win2k

OnePiece_Repair_Win2kSP4_UP_for_Windows_2000_Server_AddOn.7z
http://ifile.it/tavk8f9
Hash MD5 CF09EAFC381440EDBD961DF1D85C8CCF


if not for something clear, then wait Nonno Fabio serve you and says he better

http://ifile.it/aum49z0 ---> File not found :(

Posted: Fri Apr 17, 2009 2:20 am
by ccl0
click on Request Download Ticket noob

Posted: Sun Apr 26, 2009 6:23 pm
by budzos
I just wanted to say thanks Onepiece for the great update pack! I have always liked 2000 Pro and this makes my installs so smooth and simple.
budzos

Posted: Sun Jun 14, 2009 1:59 am
by armond
Hi,
Any plan to maintaining this update pack?
Thanks.

Posted: Sun Jun 14, 2009 5:43 am
by Alleine
Well, why still using Windows 2K? Really I think Windows Vista and 7 are not a good alternative to users with an old computer, but Windows XP can help in this case.

Posted: Mon Jun 15, 2009 2:27 am
by nonno fabio
Sorry for the delay but it's only lack of time: Onepiece's already working on new release

Posted: Mon Jun 15, 2009 3:02 am
by Kelsenellenelvian
Alleine wrote:Well, why still using Windows 2K? Really I think Windows Vista and 7 are not a good alternative to users with an old computer, but Windows XP can help in this case.
Because SOME people still use much older hardware and its better than win98.

No leave us alone and go play with yourself in the corner.

Posted: Fri Jun 19, 2009 4:12 pm
by Kelsenellenelvian
YAY Thank you very much!

Posted: Sat Jun 20, 2009 3:11 am
by AndyMutz
thank you!

-andy-

Posted: Sat Jun 20, 2009 11:11 pm
by budzos
Thanks ,
budzos

Posted: Thu Jul 16, 2009 8:34 am
by nonno fabio
new release (see changelog)
nonno fabio wrote:fixed IE icon issue
means this:

Image

Posted: Fri Sep 04, 2009 5:26 am
by at0mic
Used UpdatePack 3.6.0 about 6 months ago to install Windows 2000 Server and it worked perfectly.

I was just about to download UpdatePack 4.0 for another server I'm setting up and noticed "Update Pack is intended for Windows 2000 Professional only (for Windows 2000 Server you could try this small addon)".

I didn't notice anything like that when I downloaded UpdatePack 3.6.0. Did UpdatePack 3.6.0 also have a problem with Windows 2000 Server? Its been working ok for 6 months so does that mean it doesn't have this problem?

What is the problem when the Update Pack when used with Windows 2000 Server? I'm might use the old UpdatePack 3.6.0 again with the new server if 4.0 has a problem.

Posted: Fri Sep 04, 2009 11:55 am
by nonno fabio
at0mic wrote:Used UpdatePack 3.6.0 about 6 months ago to install Windows 2000 Server and it worked perfectly.

I was just about to download UpdatePack 4.0 for another server I'm setting up and noticed "Update Pack is intended for Windows 2000 Professional only (for Windows 2000 Server you could try this small addon)".

I didn't notice anything like that when I downloaded UpdatePack 3.6.0. Did UpdatePack 3.6.0 also have a problem with Windows 2000 Server? Its been working ok for 6 months so does that mean it doesn't have this problem?

What is the problem when the Update Pack when used with Windows 2000 Server? I'm might use the old UpdatePack 3.6.0 again with the new server if 4.0 has a problem.
http://www.ryanvm.net/forum/viewtopic.php?p=91691#91691

Posted: Mon Sep 07, 2009 5:43 am
by at0mic
Yeah I read all that but it doesn't answer all questions. It explains about setup errors but is that the only problem?

If I get Windows 2000 Server setup to complete, does that mean I dont have the error? Or are there any post install problems?

Posted: Mon Sep 07, 2009 11:01 am
by nonno fabio
It is possible that the setup hasn't found some file during installation and this could cause future problems.

It's safer to rebuild the updated Windows source adding the compatibility addon and reinstall it if possible

Posted: Thu Oct 08, 2009 5:51 am
by hammer11
hi
i used latest pack
all goes well for w2k pro
Wu asks for kb891861 partially (only 7.7 mb) for server 7 Adv Server
any b noticed it or not?
thanks

Re: Onepiece Win2k postSP4 UpdatePack v4.2.0-091023

Posted: Fri Oct 23, 2009 8:17 am
by nonno fabio
@hammer11:
I assume you've entirely read first post:
nonno fabio wrote:...
*Only for Nlite users: 3 files from this addon are oddly recognized from Nlite as older compared to those contained on w2k CD and they are not updated. If you don't want to modify Nlite settings as Xable suggests here below (thanks to him), you must integrate this addon too, otherwise WU asks you for missing hotfix :
OnePiece_Repair_Win2000_SP4_Update_Pack_4.2.0_ENU.7z
http://www.adrive.com/public/7759866ff3 ... 0796e.html
http://www.uploadjockey.com/download/52 ... 2.0_ENU.7z
Hash MD5 8EBDA32656A8C5D08E5099187B32A2BD
Size: 193.5 Kb (198174 bytes)
...

Posted: Wed Jan 27, 2010 7:19 pm
by Kelsenellenelvian
Its been awhile...

Is there an update coming in the future? Or has this pack pretty much reached completion?

Posted: Thu Jan 28, 2010 2:36 am
by nonno fabio
Onepiece tries to release a new pack at least every 2 months, if new hotfixes have been released.
Actually the W2k pack is late but I guess that within a few days it will come out, with IE6 new files, etc.

Posted: Sat Jan 30, 2010 5:14 am
by nonno fabio
done ;)

Posted: Tue Feb 23, 2010 11:33 am
by dmanuele
Failed RyanVM slipstream (RVM_Integrator_1_6_1b2_1) using "OnePiece.Win2kSP4.UpdatePack.4.4.0.ENU.7z" to update Windows 2000 OEM disk (originally with SP1), after (apparently successfully) slipstreaming SP4 using update.exe (Microsoft's process).

While running Ryan Integrator as above, I get a request for the Windows 2000 SP4 Network Install File ("SP4 for Windows 2000 needs to be slipstreamed into the destination.")
Note that the log file seems to indicate finding an SP4-integrated source:
"- English - Windows 2000 Professional x86 - OEM SP4 Found"

When I provide the location of W2KSP4_EN.EXE, the Service Pack 4 Setup window pops up showing only the command line switch options and the "OK" button. Selecting OK leads to a Service Pack Error window with the following text: "The service pack level of the source is the same as it was before integration began. Make sure you have the proper rights to the folder you're attempting to slipstream to." And, of course, the ever-helpful "OK" buton. Selecting OK closes Ryan Integrator. The full log is as follows:

2010-02-21_15.16.27
Log Startup @ 15:16:27 local time, on February 21, 2010.

Running OS: WIN_2000 Service Pack 4 X86
RVMIntegrator v1.6.1 beta2.1

"D:\SS\RVM\RVM_Integrator_1.6.1b2.1.exe"

15:17:07 - English - Windows 2000 Professional x86 - OEM SP4 Found
15:18:32 - English - Windows 2000 Professional x86 - OEM SP4 Found
15:18:32 -
15:18:32 - Source Location = D:\SS\W2K+SP4
15:18:32 - Destination Path = D:\SS\W2k+SP4+
15:18:32 - Destination Size = 54.18 GB
15:18:32 - Working Directory = D:\SS\W2k+SP4+\I386
15:18:32 - Temp Directory = D:\SS\W2k+SP4+\I386\rvmtemp
15:18:32 -
15:18:32 - Starting Integration
15:18:32 -
15:18:32 - Copying Files To The Destination Directory.
15:18:32 - Copying Working Directory...
15:19:14 - 5411 Files Copied in 31 Seconds
15:19:14 -
15:19:14 - Checking Destination For OS Type.
15:19:14 - English - Windows 2000 Professional x86 - OEM RTM Found
15:19:14 -
15:19:14 - Extracting OnePiece.Win2ksp4.updatepack.4.4.0.enu.7z
15:20:04 - MD5 Hash = 14b8199c4061b876969d2cdc50f2f915
15:20:04 - Clearing any Read Only Attributes.
15:20:04 -
15:20:05 - SP4 for Windows 2000 needs to be slipstreamed into the destination.
15:20:05 - Asking user for SP4 network install file...
18:36:50 - Slipstreaming SP4: W2KSP4.EXE
18:37:47 -
18:37:47 - Verifying service pack level of destination...
18:37:47 - English - Windows 2000 Professional x86 - OEM RTM Found
18:37:47 -
18:37:47 - ERROR: Service pack level of destination has not changed and is too low for chosen update pack.
18:37:47 - Notifying user and terminating program with exit code 1...

Log Shutdown @ 2010-02-21 19:41:45 local time.

I got essentially the same result if I tried to cancel out of the request for SP4, or if I use my original Windows 2000 OEM with SP1 (without SP4 integrated), or if I do not use a destination directory. I have tried this with similar results from an AMD system running Win2k+SP4 and from an Intel system running WinXP+SP3.

Anybody see what I'm doing wrong? I sure don't. Help?

Posted: Mon Apr 19, 2010 3:16 am
by nonno fabio
major update (see changelog)

Posted: Tue Apr 27, 2010 6:05 pm
by dziubek
I have the same error as dmanuele

Code: Select all

2010-04-27_20.20.07
Log Startup @ 20:20:07 local time, on April 27, 2010.

Running OS: WIN_XP Dodatek Service Pack 3 X86
RVMIntegrator v1.6.1 beta2.1

"F:\RyanVM_Integrator\RVM_Integrator_1.6.1b2.1.exe" 

20:20:07  - English - Windows 2000 Professional x86 -  SP4 Found
20:20:15  - English - Windows 2000 Professional x86 -  SP4 Found
20:20:15  - 
20:20:15  - Source Location      = E:\Win2000Sp4EN
20:20:15  - Destination Path     = E:\CD
20:20:15  - Destination Size     = 8.84 GB
20:20:15  - Working Directory    = E:\CD\I386
20:20:15  - Temp Directory       = E:\CD\I386\rvmtemp
20:20:15  - 
20:20:15  - Starting Integration
20:20:15  - 
20:20:15  - Copying Files To The Destination Directory.
20:20:15  -   Copying Working Directory...
20:22:50  - 5404  Files Copied in 154 Seconds
20:22:50  - 
20:22:50  - Checking Destination For OS Type.
20:22:50  - English - Windows 2000 Professional x86 -  RTM Found
20:22:50  - 
20:22:50  - Extracting onepiece.win2ksp4.updatepack.4.6.0.enu.7z
20:24:02  -     MD5 Hash = a0c252fc564bf73626ec492df46862da
20:24:02  - Extracting OnePiece_Win2k_RevolutionsPack_AddOn_ENU.7z
20:24:03  -     MD5 Hash = 77de6f19436b7a56ab49c6fc4c6c075a
20:24:03  - Clearing any Read Only Attributes.
20:24:04  - 
20:24:04  - SP4 for Windows 2000 needs to be slipstreamed into the destination.
20:24:04  - Asking user for SP4 network install file...
20:38:55  - Slipstreaming SP4:  W2KSP4_EN.EXE
20:39:30  - 
20:39:30  - Verifying service pack level of destination...
20:39:30  - English - Windows 2000 Professional x86 -  RTM Found
20:39:30  - 
20:39:30  - ERROR: Service pack level of destination has not changed and is too low for chosen update pack.
20:39:30  - Notifying user and terminating program with exit code 1...

Log Shutdown @ 2010-04-27 20:39:40 local time.

Posted: Wed Apr 28, 2010 9:00 am
by nonno fabio
In a few W2k sources RVMIntegrator doesn't recognize Service Pack level.
It occured also with an italian W2k: I don't know how this is related to UpdatePack because is not reproductable, probably this should be pointed out in Integrator thread or in Siginet's forum.

You could test if you have same issues using Nlite.

Posted: Tue May 04, 2010 9:17 am
by dziubek
Thank you.
I used nLite, the integration proceeded without any problems.

Posted: Tue May 04, 2010 1:49 pm
by Vista
Hello,
thank you for your great pack,
is this pack for Windows 2000 PRO Without SP4 or With SP4 ???

thank you,
Vista

Posted: Tue May 04, 2010 3:33 pm
by DaRk MaDnEsS
Vista wrote:Hello,
thank you for your great pack,
is this pack for Windows 2000 PRO Without SP4 or With SP4 ???

thank you,
Vista
with sp4

Posted: Thu May 13, 2010 4:15 am
by nonno fabio
new release (see changelog)

Posted: Thu May 13, 2010 1:01 pm
by pdl808
The Win2kSP4.UpdatePack.4.7.0 download fails the MD5 hash check.

Posted: Thu May 13, 2010 3:15 pm
by nonno fabio
sorry, should be fixed now

Posted: Thu May 13, 2010 3:22 pm
by pdl808
The hash check problem is fixed. Thanks for all your work.

Posted: Thu May 13, 2010 7:03 pm
by pdl808
I did a new build using Win2kSP4.UpdatePack.4.7.0. It appears to be perfect. MU lists no high priority or optional updates.

Posted: Mon May 24, 2010 5:45 am
by Kelsenellenelvian
Hey nonno?

Before this has a chance to go final will you please add a shortcut for mrt somewhere?

(Preferably in the control panel)

Posted: Tue May 25, 2010 2:49 am
by nonno fabio
yes, we can ;)

It can also be added in this version, by adding this code:

Code: Select all

[Version]
Signature="$Windows NT$"

[DefaultInstall]
AddReg     = KB890830.AddReg

[KB890830.AddReg]
   HKCR,"CLSID\%MRT_GUID%",,%REG_SZ%,"@%11%\MRT.exe,-101"
   HKCR,"CLSID\%MRT_GUID%","System.Software.MRT",%REG_SZ%,"Internal"
   HKCR,"CLSID\%MRT_GUID%","InfoTip",%REG_EXPAND_SZ%,"@%11%\MRT.exe,-109" ;;"Welcome to the Microsoft Windows Malicious Software Removal Tool"
   HKCR,"CLSID\%MRT_GUID%","{305CA226-D286-468e-B848-2B2E8E697B74} 2",%REG_DWORD%,"5"
   HKCR,"CLSID\%MRT_GUID%","LocalizedString",%REG_EXPAND_SZ%,"@%11%\MRT.exe,-101"
   HKCR,"CLSID\%MRT_GUID%","System.ApplicationName",%REG_SZ%,"Malicious.Removal.Tool"
   HKCR,"CLSID\%MRT_GUID%\DefaultIcon",,%REG_EXPAND_SZ%,"%11%\MRT.exe,-0"
   HKCR,"CLSID\%MRT_GUID%\Shell\Open\Command",,%REG_EXPAND_SZ%,"%11%\MRT.exe"
   HKLM,"%KEY_WIN_CURVER%\explorer\ControlPanel\NameSpace\%MRT_GUID%",,%REG_SZ%,"@%11%\MRT.exe,-101"

[strings]
   MRT_GUID = "{72A2A18F-FC2B-4F74-92DA-7091EF4584E8}"
   MRT_Version = "18C7629E-5F96-4BA8-A2C8-31810A54F5B8"
   
   ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
   KEY_WIN_CURVER = "Software\Microsoft\Windows\CurrentVersion"

   REG_EXPAND_SZ=0x00020000
   REG_SZ=0x00000000
   REG_DWORD=0x00010001
   REG_BINARY=0x00000001
   REG_MULTI_SZ = 0x00010000
   REG_DWORD_NOCLOBBER = 0x00010003
   Reg_SZ_NOCLOBBER = 0x00000002
   REG_BINARY_NOCLOBBER = 0x00000003
   REG_MULTI_SZ_APPEND = 0x0001000A
   REG_MULTI_SZ_NOCLOBBER = 0x00010002
   REG_MULTI_SZ_DELVAL = 0x00010006
   REG_ADDREG_APPEND = 0x00010008
   REG_EXPAND_SZ_NOCLOBBER = 0x00020002
   REG_NONE = 0x00020001
   VALUE_NOT_SET = 0x00000010
   VALUE_NOT_SET_NOCLOBBER = 0x00000012
in OPMW2kUP.inf file, under [KB890830.AddReg]. Under [strings] you must add the MRT_GUID and MRT_Version you find inside the code, remaining strings are already there.

We're not sure that @%11%\MRT.exe,-109 command works flawlessly. If so, change it with

Code: Select all

HKCR,"CLSID\%MRT_GUID%","InfoTip",%REG_EXPAND_SZ%,"Welcome to the Microsoft Windows Malicious Software Removal Tool" 
N.B.

Posted: Fri Jun 11, 2010 8:53 am
by nonno fabio
new release.

Now DirectX 9.0c is included. DX UpdatePack is no more needed, but please integrate updatepack alone if you use RVMi

Posted: Fri Jun 11, 2010 2:56 pm
by jsp
Many many Thanks sir.
This is your greet present to Ryanvm community.
pl accept my kind regard

Posted: Mon Jun 14, 2010 12:26 pm
by nonno fabio
[quote name='PaulAuckNZ' date='14 June 2010 - 05:01 AM' timestamp='1276484479' post='927724']
It looks like KB982381 (update for IE6)is in the update pack, but it still shows on the windowsupdate site, when you check
[/quote]

nope:

Image

Posted: Mon Jun 28, 2010 12:09 am
by Kelsenellenelvian
I really hate to be a bother but can you make a removal for:

Microsoft.NET Framework v1.1 SP1 - June 2010?

Please?