How to permanently disable this padlock nonsense in W7?

Forum for anything else which doesn't fit in the above forums. Site feedback, random talk, whatever, are welcome.
Post Reply
marzsyndrome
Posts: 239
Joined: Sun May 28, 2006 6:01 am

How to permanently disable this padlock nonsense in W7?

Post by marzsyndrome » Mon Feb 11, 2013 4:22 pm

I've noticed that when I use certain programs (for example, Microangelo and Bat-To-Exe Converter) to create new files out of them, these new files will sport a little padlock over their icon.

Googling up, it's related to file permissions and about how padlocked files represent "private" files residing inside a "non-private" folder.

Thing is, this obviously only matters to PCs with multiple users, and I am the sole user (and henceforth administrator) of my PC. I have seen plenty of instructions on how to manually adjust the permission settings for each file but nothing relating to changing the default setting to begin with so that I never see this blasted padlock on any new files I make again. I really couldn't give a flying fig that I mix "private" and "non-private" files together at times - it can't be helped and frankly I don't wish to constantly be reminded of it.

Windows 7 SP1, in case anyone's wondering.

User avatar
crashfly
Posts: 789
Joined: Thu Mar 13, 2008 11:39 pm
Location: Arkansas, USA

Post by crashfly » Mon Feb 11, 2013 5:06 pm

It may be a problem with your parent folder permissions. I had a similar problem when trying to setup a samba share. Even when trying to let "everyone" access the share, most of the files could not be accessed due to being not "owned" by everyone. When you create new files inside of a folder, those files tend to inherit the folder permissions. If the file is not set to inherit those permissions, then you get the weird private files inside a non-private folder issue.

Easiest fix for me was to go to the root of the drive, select the properties for that drive, then select the security tab. Hit the advanced button at the bottom of that tab. A new window shows up, go to the owner tab. Take ownership for yourself (including all sub folders, etc). If you are not worried about someone else getting access to your computer, you can set the permissions to allow everyone access. (It might work with just giving yourself full access to all files and folders, but if it doesn't, go for an "everyone" approach.)
A mind is like a parachute, it only functions when it is open.
--Anonymous

How to Ask Questions the Smart Way

marzsyndrome
Posts: 239
Joined: Sun May 28, 2006 6:01 am

Post by marzsyndrome » Tue Feb 12, 2013 5:31 am

Sounds like an option. Although.... I did also wonder whether a more extreme route would do the trick too.

Namely, making a copy of the DLL which houses the icon(s) - in this instance ntshrui.dll - and reshacking the icons in question out of existence. And then carefully renaming the original file and putting the new file in its former place.

I'm not sure how well Windows would handle it or if it would prefer to still read those particular resources in the DLL but with empty icons instead, but I'm sure it wouldn't harm the system too much to try.

Post Reply