RyanVM Integrator v1.2.2 continually crashes

Forum for anything else which doesn't fit in the above forums. Site feedback, random talk, whatever, are welcome.
Post Reply
Bazza
Posts: 48
Joined: Wed Jun 14, 2006 8:55 pm
Location: Australia

RyanVM Integrator v1.2.2 continually crashes

Post by Bazza » Sat Jun 17, 2006 12:29 am

Running the Integrator on WinXP Pro SP1 and I'm trying to apply RyanVM's Update pack v2.0.6 & a bunch of addons to a WinXP Pro SP2 source CD.

Selecting the updatepack & the addons results in:

Code: Select all

AppName: rvm_integrator_1.2.2.exe	 AppVer: 1.2.2.0	 ModName: ntdll.dll
ModVer: 5.1.2600.1217	 Offset: 00033aed
The Integrator inifile:

Code: Select all

[Settings]
Source=C:\XPP_CD
Destination=C:\XPP_CD_1
UpdatePack=C:\RVM Integrator\RVMUpdatePack2.0.6.cab
ExternalRun=
ParametersRun=
IsoFile=
IsoBinFile=
IsoVolume=
IsoExtTool=
IsoExtCmd=
IsoIntExt=Internal
IsoCmdLine=mkisofs

[Switches]
IKnowWhatImDoing=4

[AddonPacks]
Foxy_WGA-Notify_RemoveAddon_v1.0.cab=C:\RVM Integrator\Addons
MrsP_Disable_WinPicFax_Addon_v1.1_WinXP2k3.cab=C:\RVM Integrator\Addons
Foxy_dotNET_1.1_and_2.0_SVCPACK_Addon_v1.0.cab=C:\RVM Integrator\Addons
microsoft_java_addons.cab=C:\RVM Integrator\Addons
JRE507_Addon.cab=C:\RVM Integrator\Addons
Boooggy_WMAddon.cab=C:\RVM Integrator\Addons
Shockwave_v101116_Addon.cab=C:\RVM Integrator\Addons
Jondar_RegeditCPL_Addon_v1.0.cab=C:\RVM Integrator\Addons
Kels_AutoPlay_addon_v5.2.3790.67.CAB=C:\RVM Integrator\Addons
Kels_BubblePop_OpenSubFolder_addon_1.0.5.cab=C:\RVM Integrator\Addons
Kels_ClearType_addon_v1.1.CAB=C:\RVM Integrator\Addons
Kels_CMDHere_addon_v1.4.cab=C:\RVM Integrator\Addons
Kels_CPY2CLIP_addon_v1.CAB=C:\RVM Integrator\Addons
Kels_DirectX_CPL_addon_v9.0c.CAB=C:\RVM Integrator\Addons
Kels_FindTarget_addon_v1.1.CAB=C:\RVM Integrator\Addons
Kels_MemTest_addon_v1.cab=C:\RVM Integrator\Addons
Kels_MSConfig_addon_v1.CAB=C:\RVM Integrator\Addons
Kels_OpenExpert_addon_v1.4.CAB=C:\RVM Integrator\Addons
Kels_Pserv_addon_v2.6.CAB=C:\RVM Integrator\Addons
Kels_RegUnReg_addon_v1.1.cab=C:\RVM Integrator\Addons
Kels_Runtimes_addon_v1.2.CAB=C:\RVM Integrator\Addons
Kels_TimeZone_addon_v2.1.30.0.CAB=C:\RVM Integrator\Addons
Kels_TweakUI_Addon_v2.10.0.0.cab=C:\RVM Integrator\Addons
MrsP_Famous_Fonts_Addon_v1.1.cab=C:\RVM Integrator\Addons
MrsP_FileCase_ShellExt_Addon_v1.2.7.28.cab=C:\RVM Integrator\Addons
MrsP_MSGreet_Fonts_Addon_v1.1.cab=C:\RVM Integrator\Addons
MrsP_MSPub_Fonts_Addon_v1.1.cab=C:\RVM Integrator\Addons
MrsP_MSWorks_Fonts_Addon_v1.1.cab=C:\RVM Integrator\Addons
MrsP_WinXP_Fonts_Addon_v1.1.cab=C:\RVM Integrator\Addons
RogueSpearAddonsISScript.cab=C:\RVM Integrator\Addons
Xable_ContextAttributes-v1.1_addon.cab=C:\RVM Integrator\Addons
Xable_HashTab-v1.9_addon.cab=C:\RVM Integrator\Addons
Xable_PathCopy-v1.1_addon.cab=C:\RVM Integrator\Addons
The Integrator log:

Code: Select all

Source Drive      = C:\XPP_CD
Destination Drive = C:\XPP_CD_1
Destination Size  = 71454.00390625

Starting Integration
Copying Files To The Destination Directory.
6771 Files Copied in 94 Seconds
Checking Destination For OS Type.
Windows XP Professional With SP2 Found
Clearing any Read Only Attributes.
Extracting RVMUpdatePack2.0.6.cab
    MD5 Hash = CE3E3AEEDFA8A2EA2342D33BC857DDEB
Extracting Foxy_WGA-Notify_RemoveAddon_v1.0.cab
    MD5 Hash = 383CE7D2D07D6A9DD96090DFB1440995
Extracting MrsP_Disable_WinPicFax_Addon_v1.1_WinXP2k3.cab
    MD5 Hash = C4AD9CC9E873B604EBE0C29CDB2C78C8
DrWatson log:

Code: Select all

Application exception occurred:
        App: C:\RVM Integrator\RVM_Integrator_1.2.2.exe (pid=264)
        When: 17/06/2006 @ 11:15:25.915
        Exception number: 80000007

*----> State Dump for Thread Id 0xf00 <----*

eax=01370000 ebx=00000001 ecx=00001000 edx=00000000 esi=00000000 edi=0000012c
eip=7ffe0304 esp=0012e11c ebp=0012e654 iopl=0         nv up ei pl nz na pe nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00000202

function: <nosymbols>
        7ffe02f2 0000             add     [eax],al
        7ffe02f4 0000             add     [eax],al
        7ffe02f6 0000             add     [eax],al
        *SharedUserSystemCall:
        7ffe02f8 0000             add     [eax],al
        7ffe02fa 0000             add     [eax],al
        7ffe02fc 0000             add     [eax],al
        7ffe02fe 0000             add     [eax],al
        7ffe0300 8bd4             mov     edx,esp
        7ffe0302 0f34             sysenter
FAULT ->7ffe0304 c3               ret
        7ffe0305 9c               pushfd
        7ffe0306 810c2400010000   or      dword ptr [esp],0x100
        7ffe030d 9d               popfd
        7ffe030e c3               ret
        7ffe030f 8bd4             mov     edx,esp
        7ffe0311 0f05             syscall
        7ffe0313 c3               ret
        7ffe0314 9c               pushfd
        7ffe0315 810c2400010000   or      dword ptr [esp],0x100
        7ffe031c 9d               popfd
Initially I thought it was the # of files I selected, so I integrated 1 pack/addon at time ... without restarting the integrator itself. However, it failed when I tried the 2nd addon, ie. the UpdatePack & the 1st addon worked OK.

DrWatson log:

Code: Select all

function: ntdll!RtlZeroHeap
        77f82e6e 7203             jb      ntdll!RtlZeroHeap+0x44d (77f82e73)
        77f82e70 8d48ff           lea     ecx,[eax-0x1]
        77f82e73 8d50ff           lea     edx,[eax-0x1]
        77f82e76 3bca             cmp     ecx,edx
        77f82e78 751f             jnz     ntdll!RtlZeroHeap+0x473 (77f82e99)
        77f82e7a 8b5764           mov     edx,[edi+0x64]
        77f82e7d 8b148a           mov     edx,[edx+ecx*4]
        77f82e80 83c208           add     edx,0x8
        77f82e83 3bf2             cmp     esi,edx
        77f82e85 7412             jz      ntdll!RtlZeroHeap+0x473 (77f82e99)
FAULT ->77f82e87 0fb75af8         movzx  ebx,word ptr [edx-0x8] ds:0023:fffffff8=????
        77f82e8b 3b5d0c           cmp     ebx,[ebp+0xc]
        77f82e8e 736f             jnb     ntdll!RtlZeroHeap+0x4d9 (77f82eff)
        77f82e90 8b12             mov     edx,[edx]
        77f82e92 3bf2             cmp     esi,edx
        77f82e94 75f1             jnz     ntdll!RtlZeroHeap+0x461 (77f82e87)
        77f82e96 8b5d0c           mov     ebx,[ebp+0xc]
        77f82e99 c1e805           shr     eax,0x5
        77f82e9c c1e905           shr     ecx,0x5
        77f82e9f 48               dec     eax
        77f82ea0 89450c           mov     [ebp+0xc],eax
So far the only way I can get the Integrator to work is to stop/start it after integrating each & every UpdatePack/Addon.

Is this a known bug or just me &/or my PC?

Cheers
Bazza...

User avatar
Siginet
Site Admin
Posts: 2894
Joined: Fri May 27, 2005 1:07 pm
Location: Planet Earth
Contact:

Post by Siginet » Sat Jun 17, 2006 12:39 am

I know the error you are getting has something to do with grabbing the md5 checksum of the files. I don't know why you are getting this error. Maybe it has something to do with WinXP SP1? I know I have coded the md5 hash checking a little differently in v1.3 of the integrator that is soon to be released. Maybe you will have better luck with it when it comes out.

Sorry I can't be more helpful. :(

Try removing the space in this path:
C:\RVM Integrator
It shouldn't be an issue... but it can't hurt to try.
Image
--Siginet--

Techware
Your Virtual Technician
Computer Management Software

Bazza
Posts: 48
Joined: Wed Jun 14, 2006 8:55 pm
Location: Australia

Post by Bazza » Sat Jun 17, 2006 1:54 am

Siginet,

Thanks for your reply. Tried renaming the dir to: RVM_Int , however, as you suspected it didn't fix the problem.

:?: I presume that integrating each update/addon individually is OK, ie. each change to wininit.sif, etc. is APPENDED to, rather than overwriting the previous addon.

Cheers
Bazza...

Bazza
Posts: 48
Joined: Wed Jun 14, 2006 8:55 pm
Location: Australia

Post by Bazza » Sat Jun 17, 2006 2:51 am

Siginet,

Check your PM.

Bazza...

fearphage
Posts: 41
Joined: Mon Jun 12, 2006 1:58 pm
Location: Austin, TX

Post by fearphage » Sun Jun 18, 2006 3:11 am

I had the same problem for 2 days. Do you have both .Net Frameworks installed? Maybe it has to do with SP1. I was using it with XP (no service packs) when i saw the issue. Then I fully upgraded everything (except wga) and haven't experienced one crash since.

Bazza
Posts: 48
Joined: Wed Jun 14, 2006 8:55 pm
Location: Australia

Post by Bazza » Mon Jun 19, 2006 12:13 am

fearphage,

Do you have both .Net Frameworks installed?

Yes I do.

Then I fully upgraded everything (except wga)...

That's exactly what I'm trying to do.

Post Reply