[Drawback in every XP cd]: Medal of Honor's OpenGL error

Forum for anything else which doesn't fit in the above forums. Site feedback, random talk, whatever, are welcome.
Post Reply
User avatar
moataz
Posts: 133
Joined: Tue Nov 21, 2006 4:03 am
Location: Egypt
Contact:

[Drawback in every XP cd]: Medal of Honor's OpenGL error

Post by moataz » Wed Dec 27, 2006 3:59 pm

There is a Problem with the game "Medal Of Honor".
It starts then exit by itself.

I know unfamiliar method to run the game with (original version of windows xp sp2)

But with My Cd and i think, every (unofficial version of windows xp sp2) ; it does not work even after this unfamiliar method

Please .. :oops:

try to run the game and tell me what you get !

Thanks to all the forum's members, but help me also !!!
Last edited by moataz on Thu Dec 28, 2006 3:36 pm, edited 3 times in total.
XP Light, 8.1 Right Developer

User avatar
UtCollector
Posts: 464
Joined: Sun Apr 09, 2006 8:31 pm
Contact:

Post by UtCollector » Wed Dec 27, 2006 5:36 pm

Hmm grafix sucked when it came out.. But gameplay is nice.

scandisk you drivers the slow way and than run defrag. Make sure you have the needed harddrive space left to. Try reinstalling you're vga driver. Ore even reinstall windows.

If you vga kaart uses a power cable (Molex if i'm right) check if it's connected right. Even try a nother 1! I did have a broken povercable once. Every 3d using game would crach back to my desktop. (Oh if you are going to check if the cabble is connected right DONT forget to turn of you pc fist!...)

You could try and do a full install of the game again. If you try and run the game without the cd.. Than make sure you use the right game.exe fix...

Oh make sure that you got directx installed

User avatar
moataz
Posts: 133
Joined: Tue Nov 21, 2006 4:03 am
Location: Egypt
Contact:

Post by moataz » Thu Dec 28, 2006 1:46 am

Did you hear about OpenGL problem of this game ?
If not, maybe you couldn't help me
GLW_StartOpenGL() - could not load OpenGL subsystem
.. thank you
XP Light, 8.1 Right Developer

User avatar
RaGhul
Posts: 375
Joined: Wed Nov 01, 2006 5:56 pm
Location: San Diego, CA

Post by RaGhul » Thu Dec 28, 2006 2:54 am

I have a client who's a Medal of Honor freak, and we ran into this also.

Turns out, OpenGL was kinda new at the time MOHAA came out, as were the drivers for it. This is where the problems are coming from. After gleaming the net, I found 2 bona-fide solutions:

1. Get SciTech GLDirect.
This app bypasses OpenGL and goes straight thru the DirectX drivers. Problem though. It's just a trial. You'll need to fork-up $30 to get the full version. Here's the trial link:
http://www.scitechsoft.com/products/pro ... nload.html

2. Driver.
I definitely recommend this one. You'll save money, and TRULY fix the problem. First, make sure you COMPLETELY uninstall any drivers you have in Add/Remove Components. Restart. Then, install the latest driver. IMPORTANT: Be sure to shut off your antivirus while installing. Restart again.

Some AVs are known to cause conflicts with nvidia drivers.


TRY #2 AND LET ME KNOW HOW IT GOES!!
:wink:

User avatar
moataz
Posts: 133
Joined: Tue Nov 21, 2006 4:03 am
Location: Egypt
Contact:

Post by moataz » Thu Dec 28, 2006 3:21 am

Do you mean uninstall every driver in device manager ?
What is latest driver i should look for and install ?
XP Light, 8.1 Right Developer

Post Reply