[RELEASE] Boooggy's WMP 11 direct integration solution

Discuss & post Update Pack addons here.
Post Reply
User avatar
compstuff
Posts: 464
Joined: Fri Aug 11, 2006 3:25 pm
Location: Florida

Post by compstuff » Thu Mar 26, 2009 6:40 pm

I have run across an odd issue and although I imagine it is something I'm doing I figured I would bring up here for any ideas... I was testing some IE8 addons when I noticed the following:

My usual integration method is RVMI with all my addons and calling Booogy's WMP11 Integrator in the same session... I have done this counteless times with no problems and I pretty much always used MrNxDmx NR_IE7en_Addon_2.0.4a.7z .

When I was trying the IE8 I used everything the same except with NO IE7 integration and got
an advanced INF install error for WMP11: <c:\program files\windows media player\WMPEnc.exe /regserver> reason: system cannot find the file specified.

Well I did 2 new integrations: one with IE7 and one without and sure enough the one with IE7 works perfectly but the without fails again... I am using the follwoing addons:

ARemoval_LANG_DirDeleteAddon.cab
BRemoval_WINNTUPG_DirDeleteAddon_v1.1.cab
CPatchAddon_SFC_OS_v14.7z
EPatchAddon_TCPIP_100_v14d.7z
FNR_UPHC_Addon.cab
Java6u13.exe
Kels_CPLBonus_addon_v9.2.6.rar
RedDXRuntimes_0.7.0_32bit.exe
RedDXManaged_1.1.0.exe
Ricks_SpywareBlaster4.1_addon_90225.7z
SFX_KLite_Mega_470.exe
SFX_QT-LITE_280.exe
ShockWave_Slim_11.5.0.595_AddOn.cab
SpyBotSD_1.6.2_AddOn.cab
Stimpy_JD976_DotNetFx_3in1_Addon_v2.2.7z
WGA_Validation_AddOn_1.9.9.1_-_redxii.7z
YAdobe_Acrobat_Reader_9.1.0_AddOn.cab

Any thoughts would be welcome...

User avatar
boooggy
Posts: 1297
Joined: Tue Aug 16, 2005 2:20 am
Location: Bucharest, Romania

Post by boooggy » Fri Mar 27, 2009 3:45 pm

compstuff
i tried this
first fresh xpsp3 source integrated only wmp11 then installed in vmware, no errors
then integrated using nlite: update pack, ie8 by onepiece and then wmp11 using my slippy, same no errors.

pegasus
Posts: 151
Joined: Tue Jul 08, 2008 12:48 am

Post by pegasus » Fri Mar 27, 2009 4:05 pm

@compstuff: Try integrating a fresh xpsp3 w/ just the latest update pack, IE8 & wmp11 & see if you get any error. Also try integrating it without AV or Antispyware application running in the background & let us know.

User avatar
crashfly
Posts: 789
Joined: Thu Mar 13, 2008 11:39 pm
Location: Arkansas, USA

Post by crashfly » Mon Apr 13, 2009 6:46 pm

Hey boooggy, I think you have done a wonderful job with the WMP11 slipstreamer It has saved me time and trouble. I would like to make a request though. Not directly for the slipstreamer, but more for the web page used to download the slipstreamer.

I notice you have each of the most current updates required to make WMP11 up to date. Would it be possible to put approximate dates on those hotfixes so that one can quickly check to see if any new ones have been added? I think it would simplify some of the process for those of us who use your slipstreamer.

Thanks again for your wonderful work.
A mind is like a parachute, it only functions when it is open.
--Anonymous

How to Ask Questions the Smart Way

User avatar
5eraph
Site Admin
Posts: 4621
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Mon Apr 13, 2009 7:15 pm

You could check for new posts in the Windows Media Player 11 Hotfixes thread on boooggy's forum. He always posts a new reply with details when the hotfix list changes. ;)

The last change to the list was 2009/02/25.

ccl0
Posts: 817
Joined: Tue Jan 02, 2007 1:56 am

Post by ccl0 » Mon Jul 27, 2009 1:14 am

hello boooggy, might i offer a suggestion?


instead of linking these

http://support.microsoft.com/kb/941569/

http://support.microsoft.com/kb/952069/

http://support.microsoft.com/kb/954154/

you could possibly link this instead (or add directions on your page as to what a person needs to click on in the above links)

http://www.microsoft.com/technet/securi ... 8-076.mspx

http://www.microsoft.com/technet/securi ... 8-054.mspx

http://www.microsoft.com/technet/securi ... 7-068.mspx


b/c it took me quite some time to figure out where exactly to download them.

all the other hotfix links had the downloads on the same page as you go to, but those 3 above did not.

Botus
Posts: 161
Joined: Sat Dec 22, 2007 12:47 pm
Location: UK

Post by Botus » Mon Aug 31, 2009 5:22 am

hello boooggy, I was just checking my list of patches was up to date when I saw differences in yumeyao's list of patches vs yours


he has:

"Added KB973442, replaces KB954067. " you still list both?

and

"Added KB943604, which contains updated files of KB911564, KB925398 and KB954600. " you don't use?

User avatar
boooggy
Posts: 1297
Joined: Tue Aug 16, 2005 2:20 am
Location: Bucharest, Romania

Post by boooggy » Mon Aug 31, 2009 10:21 am

first hotfix
u have the answer here: http://www.boooggy.org/forum/viewtopic. ... p=462#p462

and for second....i dont use cause its adding wmp 9 to windows xp N editons. and as it is stated on my site i dont support windows xp N.

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Mon Aug 31, 2009 11:12 am

@boooggy
wmvcore.dll is superseded by KB952069.

and for x64 version, i believe it has exactly same files as x86, but it seems their catalogs cannot be shared. I'm not sure for this, but for users who disable SFC and remove catalogs, KB954067 is totally useless then.

@Botus
KB943604 contains necessary files of WMP9 for Windows XP N editions.

Here I use it because this addon installs wmp plugin for non-IE browsers(Npdsplay.dll for player, Npdrmv2.dll Npwmsdrm.dll for drm-management). For Windows XP, it has these files natively but for Windows Server 2003 it doesn't. To make this addon both xp/2k3 compatible, I have to include this component.

In order to make files digital signatured, I have to use KB943604 because these files of XP SP2 and SP3 differ. Addtionally, KB943604 has 3 security update included(strmdll.dll of KB954600, Npdsplay.dll of KB911564, Dxmasf.dll of KB925398), so don't you think this is a reduction of list?:wink:
Image
My work list(Hosted by dumpydooby)

User avatar
boooggy
Posts: 1297
Joined: Tue Aug 16, 2005 2:20 am
Location: Bucharest, Romania

Post by boooggy » Mon Aug 31, 2009 12:48 pm

ok i agree on x86 but for x64 this is not applicable

Botus
Posts: 161
Joined: Sat Dec 22, 2007 12:47 pm
Location: UK

Post by Botus » Tue Sep 01, 2009 12:21 pm

thank you both for adding details :D , being think not sure I got the clarity :oops:

so on win XP 32 bit, KB954067 isn't strictly necessary as later patches include both of the files it has within?

or to keep SFC happy best left in?

Tareek
Posts: 13
Joined: Fri Mar 19, 2010 6:03 am
Location: California, USA

Post by Tareek » Thu Mar 25, 2010 4:14 am

hi booogy ,
i slipstreamed Wmp 11 and below hotfixes into a MultiOEM_XP disc . i integrated following hotfixes : X:\CDVD_nL\XP_Hotfixes\WinMediaPlyr11_Hotfixes_x86 | windowsmedia11-kb928788-x86-intl.exe | windowsmedia11-kb929399-v2-x86-intl.exe | windowsmedia11-kb929773-x86-intl.exe | windowsmedia11-kb931756-x86-intl.exe | windowsmedia11-kb932390-x86-intl.exe | windowsmedia11-kb933547-x86-intl.exe | windowsmedia11-kb935551-x86-intl.exe | windowsmedia11-kb935552-x86-intl.exe | windowsmedia11-kb935957-x86-intl.exe | windowsmedia11-kb938232-x86-intl.exe | windowsmedia11-kb939209-x86-intl.exe | WindowsMedia11-KB939683-x86-ENU.exe | windowsmedia11-kb941282-x86-intl.exe | windowsmedia11-kb942264-x86-intl.exe | windowsmedia11-kb943335-x86-intl.exe | windowsmedia11-kb944110-x86-intl.exe | windowsmedia11-kb944882-x86-intl.exe | windowsmedia11-kb945381-x86-intl.exe | windowsmedia11-kb946665-x86-intl.exe | windowsmedia11-kb950478-x86-intl.exe | windowsmedia11-kb954067-x86-intl.exe | windowsmedia11-kb954069-x86-intl.exe | WindowsMedia11-KB954154-x86-ENU.exe | windowsmedia11-kb973442-x86-intl.exe | WindowsXP-KB941569-x86-ENU.EXE | WindowsXP-WindowsMedia-KB952069-v2-x86-ENU.exe | WindowsXP-WindowsMedia-KB954155-x86-ENU.exe | WindowsXP-WindowsMedia-KB968816-x86-ENU.exe | WindowsXP-WindowsMedia-KB973540-x86-ENU.exe .
but this hotfix created error, so i integrated without it : windowsmedia-kb895181-x86-enu.exe .
ur proggy was instructing to post here.

User avatar
boooggy
Posts: 1297
Joined: Tue Aug 16, 2005 2:20 am
Location: Bucharest, Romania

Post by boooggy » Fri Mar 26, 2010 3:35 pm

tareek
i see that the fix that gave the error is not for wmp 11. that fix is for wmp 9 and 10.
please only use the hotfixes that are listed on my site.

ChiefZeke
Posts: 767
Joined: Fri Mar 23, 2007 5:33 pm
Location: Victorville, California

Post by ChiefZeke » Sun Apr 04, 2010 5:11 pm

Along with XP Pro w/SP3 I had also installed XP Pro x64 w/SP2 prior to trying out Win7 32- and 64-bit.

I have used the RyanVM Integrator (RVM_Integrator_1.6.1 beta 2.1) many times in the past to keep my XP Pro CD's up-to-date; have also used DriverPacks and Boooggy's WMP11 slipstreamer in conjunction with Ryan.

In November 2009 I used RyanVMi to slipstream XP Pro x64 and SP2 and addons to create a new integrated CD.

Recently I've been reviewing what's been happening at http://www.ryanvm.net/forum/viewforum.php?f=9 and noticed that others had commented on using Boooggy's WMP11 Integrator on XP Pro x64 so I decided to try it. (At the time I was unaware the WMP11 Slipstreamer would work for x64.) :(

So I downloaded the x64 version of WMP11 (wmp11-windowsxp-x64-enu.exe) and then searched Microsoft for x64 updates as none were listed at http://www.boooggy.org/slipstreamer/ - only the x86 items were shown.

The following are the updates/patches/hotfixes I integrated along with WMP11 for x64 into the XP Pro x64 source that had been recently updated with the update pack: 5er_UpdatePack_XPx64SP2_2010-03_2.7z and a few addons.

WindowsMedia11-KB929399-v2-x64-INTL.exe
windowsmedia11-kb935551-x64-intl.exe
WindowsMedia11-KB936782-x64-ENU.exe
WindowsMedia11-KB939683-x64-ENU.exe
WindowsMedia11-KB941569-x64-ENU.exe
windowsmedia11-kb943335-x64-intl.exe
windowsmedia11-kb944882-x64-intl.exe
windowsmedia11-kb945170-x64-intl.exe
windowsmedia11-kb946665-x64-intl.exe
WindowsMedia11-KB954154-x64-ENU.exe
windowsmedia11-kb957301-x64-intl.exe
WindowsMedia11-KB959772-x64-ENU.exe
WindowsMedia11-KB973540-x64-ENU.exe

The WMP11 Slipstreamer worked just fine and no errors occured; DRIVER.CAB was created and files were added to \AMD64. Great work done by Boooggy and n7Epsilon for the WMP11 Slipstreamer. :D

The issue I have is with the list of updates shown above. I have no idea if it is complete and/or if required items are missing. Is there a comprehensive list for WMP11 updates as part of XP Pro x64 posted or available somewhere? Maybe it's time for two lists: x86 and x64?

WMP11 Slipstreamer is great!! :wink:

User avatar
5eraph
Site Admin
Posts: 4621
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Sun Apr 04, 2010 9:59 pm

boooggy's hotfix list is current with the exception of KB974905, which is available by request and not listed but may be included for x86 and x64.

The list is almost the same when used for x64. The differences are:Therefore, you should discard the following files:
  • WindowsMedia11-KB936782-x64-ENU.exe
    windowsmedia11-kb943335-x64-intl.exe
    windowsmedia11-kb945170-x64-intl.exe
    windowsmedia11-kb946665-x64-intl.exe
    windowsmedia11-kb957301-x64-intl.exe
    WindowsMedia11-KB959772-x64-ENU.exe
And you should download at least the bulleted files that follow:

ChiefZeke
Posts: 767
Joined: Fri Mar 23, 2007 5:33 pm
Location: Victorville, California

Post by ChiefZeke » Mon Apr 05, 2010 6:30 pm

5eraph,

Great :D

Thanks for the information, I downloaded all those on your list and removed the others you said were not needed.

While Boooggy's list may be up-to-date the download file name includes either x86 or x64 in it and the user should be made aware of this so as to download the file needed for the appropriate operating system.

Again, thanks for the list.

chiners_68
Posts: 55
Joined: Wed Sep 13, 2006 5:57 am

Post by chiners_68 » Thu Jun 10, 2010 7:18 am

KB968816 MS09-047: Description of the security update for Windows Media Format Runtime, Windows Media Services, and Media Foundation: September 8, 2009

has been replaced by KB978695

pdl808
Posts: 58
Joined: Sat Dec 01, 2007 3:13 pm
Location: Milpitas, CA USA

Post by pdl808 » Fri Jun 25, 2010 6:56 pm

Media Player 11 - new version released 2010-06-22.

http://www.microsoft.com/downloads/deta ... 66114010ca

User avatar
mr_smartepants
Posts: 824
Joined: Thu May 18, 2006 5:56 am
Location: Cambridgeshire, UK

Post by mr_smartepants » Sat Jun 26, 2010 3:28 am

Nice find. I wonder what they changed.
Image
Some heroes don't wear capes, they wear Kevlar and dog-tags!

jaynbe
Posts: 277
Joined: Mon Apr 27, 2009 1:37 pm

Post by jaynbe » Sat Jun 26, 2010 9:16 am

mr_smartepants wrote:Nice find. I wonder what they changed.
Windows Media Player 11 full version (11.0.5721.5262 released 2010-06-22)
Most updates now natively integrated, remaining only:
kb954155
kb973442
kb973540
kb974905
kb978695

User avatar
vodacuza
Posts: 274
Joined: Fri Jan 22, 2010 3:19 pm
Location: Fukushima 3rd reactor

Post by vodacuza » Sun Sep 19, 2010 7:08 pm

yes but for 64 bits platform , there is stil the old one... 2008 release

:cry:

ChiefZeke
Posts: 767
Joined: Fri Mar 23, 2007 5:33 pm
Location: Victorville, California

Post by ChiefZeke » Mon Sep 20, 2010 12:35 am

The solution is to use the WMP11 slipstreamer but substitute windowsmedia11 x64 hotfixes for the x86 versions - works just fine. :D

Last time I checked there were 15 x64 updates - latest dated 11 June 2010 - have not checked for the latest updates to add to my collection. :lol:

User avatar
mr_smartepants
Posts: 824
Joined: Thu May 18, 2006 5:56 am
Location: Cambridgeshire, UK

Post by mr_smartepants » Mon Sep 20, 2010 1:49 am

I can't get KB975558-X86 to integrate properly via the wmp11 slipstreamer. Adding it to the list causes the slipstreamer to crash.
I have to add it via svcpack or ROE. Probably because it's an XP & wmp11 patch.
Image
Some heroes don't wear capes, they wear Kevlar and dog-tags!

User avatar
5eraph
Site Admin
Posts: 4621
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Mon Sep 20, 2010 2:30 am

boooggy is aware of the issue. :)

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Wed Sep 22, 2010 5:53 am

An old issue but I'd like to give it some light:
KB954069 - The x64 version of this hotfix contains wmvencod.dll of x64 version.

Most libraries and executables of WMP11 x64 are not native x64 binaries, they are as same as x86 ones. wmvencod.dll is x86, too. So this hotfix won't work correctly.

In case you are wondering, and confused, you can download WMF SDK here(in column of most left):
http://msdn.microsoft.com/en-us/windows/bb190307.aspx
It really contains same WMF installer as the old 2006 WMP11 installer contains(distinguishing from the new 2010-06-22 ver.).

So it's M$ that messes up it.
Image
My work list(Hosted by dumpydooby)

User avatar
boooggy
Posts: 1297
Joined: Tue Aug 16, 2005 2:20 am
Location: Bucharest, Romania

Post by boooggy » Tue Oct 12, 2010 9:02 am

version updated to 1.4.3.0
please read first post

User avatar
5eraph
Site Admin
Posts: 4621
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Tue Oct 12, 2010 9:30 am

Thank you. Excellent timing. Will test soon. :)

newsposter
Posts: 1131
Joined: Wed Sep 14, 2005 11:31 am

Post by newsposter » Fri Oct 15, 2010 4:09 pm

great. I'll assume that the hotfix list is accurate for the most recent msft release of the WMP 11 installer.

Does anyone have a direct-from-msft download link for KB9786956??

And would kb975558 be an OS level patch or a WMP patch?
Last edited by newsposter on Sat Oct 16, 2010 12:06 am, edited 1 time in total.

ChiefZeke
Posts: 767
Joined: Fri Mar 23, 2007 5:33 pm
Location: Victorville, California

Post by ChiefZeke » Fri Oct 15, 2010 5:33 pm

newsposter wrote:great. I'll assume that the hotfix list is accurate for the most recent msft release of the WMP 11 installer.
Would be nice if the hotfix listed also included the 64-bit updates for WMP11. I presently have 16 dated between April 2010 and June 2010 but I have no idea how up-to-date it is.

Anyone know of a possible location of such a list?

User avatar
5eraph
Site Admin
Posts: 4621
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Sat Oct 16, 2010 1:20 am

newsposter wrote:Does anyone have a direct-from-msft download link for KB9786956??

And would kb975558 be an OS level patch or a WMP patch?
I'll assume you mean KB978695 for XPx86SP3—the number you give contains a typo. And KB975558 is a WMP patch.
ChiefZeke wrote:Would be nice if the hotfix listed also included the 64-bit updates for WMP11. I presently have 16 dated between April 2010 and June 2010 but I have no idea how up-to-date it is.

Anyone know of a possible location of such a list?
The list is the same for x64, ChiefZeke. The only updates currently missing from the list are the request only KB974905 and the high priority update KB2378111 which may be troublesome for the current slipstreamer.
Last edited by 5eraph on Sat Oct 16, 2010 1:40 am, edited 3 times in total.

User avatar
n7Epsilon
Moderator
Posts: 624
Joined: Thu Feb 17, 2005 1:37 am
Location: Cairo, Egypt

Post by n7Epsilon » Sat Oct 16, 2010 1:25 am

Actually, MS updated the article and changed the x64 hotfix. The new one seems to work properly with the current slipstreamer.

The new file is: WindowsMedia11-KB2378111-x64-ENU.exe (dfecc3533634989d87e55dfe7d00aa58)

ChiefZeke
Posts: 767
Joined: Fri Mar 23, 2007 5:33 pm
Location: Victorville, California

Post by ChiefZeke » Sat Oct 16, 2010 10:57 pm

n7Epsilon wrote:Actually, MS updated the article and changed the x64 hotfix. The new one seems to work properly with the current slipstreamer.

The new file is: WindowsMedia11-KB2378111-x64-ENU.exe (dfecc3533634989d87e55dfe7d00aa58)
Thanks for the info - downloaded it and added it my my folder holding x64 updates. :D

ChiefZeke
Posts: 767
Joined: Fri Mar 23, 2007 5:33 pm
Location: Victorville, California

Post by ChiefZeke » Mon Sep 19, 2011 4:58 pm

WMP11 Slipstreamer 1.4.3.0 installed in XP Pro w/SP3, XP Pro x64 w/SP2, and Win7 Ultimate 64-bit w/SP1.

RVM_Integrator_1.6.1 beta 2.1 being used to update XP Pro x64 w/SP2 with 5er_UpdatePack_XPx64SP2_2011-09_1.7z, various addons, and wmp11-windowsxp-x64-enu.exe and hotfixes for WMP11.

The source is folder: Windows XP Pro x64 with SP2 CD which is a copy of the CD.

The RyanVM Integrator is in its own folder and used by all operating systems.

RyanVM Integrator > Advanced > Check mark in box for Run a Program After Integration > \WMP11Slipstreamer\WMP11Slipstreamer.exe > check mark in box Leave Integartor Open.

RyanVM Integrator > Main > Integrate completes succesfully and WMP11 Slipstreamer is started.

Basic options > are filled in as appropriate for slipstreaming the 64-bit version of WMP11 and hotfixes > Integrate > Error message appears: WMP11 Slipstreamer has encountered a problem and needs to close. We are sorry for the inconvenience; Close > WMP11 Slipstreamr exits the scene.

Problem occurs in all operating systems listed above so I would conclude it must be a WMP11 Slipstreamer problem as opposed to a glitch in the operating system involved. No log files created.

WMP11 Slipstreamer - hotfixes I was attemting to integrate:

windowsmedia11-kb929399-v2-x64-intl.exe
windowsmedia11-kb935551-x64-intl.exe
windowsmedia11-kb936782-x64-enu.exe
windowsmedia11-kb939683-x64-enu.exe
windowsmedia11-kb941569-x64-enu.exe
windowsmedia11-kb944882-x64-intl.exe
windowsmedia11-kb946665-x64-intl.exe
windowsmedia11-kb952069-x64-enu.exe
windowsmedia11-kb954154-x64-enu.exe
windowsmedia11-kb954155-x64-enu.exe
windowsmedia11-kb973540-x64-enu.exe
windowsmedia11-kb978695-x64-enu.exe
windowsmedia11-kb2378111-x64-enu.exe
windowsserver2003.windowsxp-kb979482-x64-enu.exe

ChiefZeke
Posts: 767
Joined: Fri Mar 23, 2007 5:33 pm
Location: Victorville, California

Post by ChiefZeke » Sun Oct 23, 2011 1:13 am

Still no reply to my problem so I decided to try and use the WMP Slipstreamer without hotfixes; just opted to have WMP 11 itself integrated. So using wmp11-windowsxp-x64-enu.exe I tried again - stll failed. Tried in XP Pro x64 w/SP1 and in Win7 Ultimate 64-bit w/SP1.

So, the problem appears to be with the WMP11 Slipstreamer itself - all indications are it's not even starting.

Anyone have any ideas?

User avatar
n7Epsilon
Moderator
Posts: 624
Joined: Thu Feb 17, 2005 1:37 am
Location: Cairo, Egypt

Post by n7Epsilon » Sun Oct 23, 2011 2:45 am

Sorry for not replying, but real life has had me occupied for a very long time now.

I have a passing idea, do you have installed the 32-bit version of .NET framework ?

User avatar
shiner
Posts: 655
Joined: Sun Nov 08, 2009 4:18 am
Location: SE Asia

Post by shiner » Sun Oct 23, 2011 7:48 am

OT

hey, n7Epsilon,

nice to see you drop by and post again.
"You can lead a horse to water, but you can't make it drink."

User avatar
boooggy
Posts: 1297
Joined: Tue Aug 16, 2005 2:20 am
Location: Bucharest, Romania

Post by boooggy » Mon Oct 24, 2011 5:50 am

zeke
i played with slipppy on an untoched xpx64 pro and slippy didnt return any errors.
can u please try first wmp slipstreamer and then the rest?
thx in advance

ps
sorry for long time reply
real life ......

User avatar
ricktendo64
Posts: 3213
Joined: Mon May 22, 2006 12:27 am
Location: Honduras

Post by ricktendo64 » Mon Oct 24, 2011 10:14 am

boooggy you should think about adding KB970159 to your slipstreamer to replace the older one in the WMP11 installer

You can find them here

ChiefZeke
Posts: 767
Joined: Fri Mar 23, 2007 5:33 pm
Location: Victorville, California

Post by ChiefZeke » Mon Oct 24, 2011 5:23 pm

n7Epsilon wrote:Sorry for not replying, but real life has had me occupied for a very long time now.

I have a passing idea, do you have installed the 32-bit version of .NET framework ?
In XP Pro x64 and Win7 Ultimate x64 I have the 64-bit versions of the .NET Framework installed, includes .NET Framework 4.0 in Win7.

If that is not what you were asking about please clarify.

ChiefZeke
Posts: 767
Joined: Fri Mar 23, 2007 5:33 pm
Location: Victorville, California

Post by ChiefZeke » Mon Oct 24, 2011 5:27 pm

boooggy wrote:zeke
i played with slipppy on an untoched xpx64 pro and slippy didnt return any errors.
can u please try first wmp slipstreamer and then the rest?
thx in advance

ps
sorry for long time reply
real life ......
Boooooggy,

Please clarify. I did mention above that I ran the slipstreamer to intergrate ONLY WMP11 after I had run the RyanVM and updated things and it failed. :cry:

User avatar
bphlpt
Posts: 1372
Joined: Sat Apr 19, 2008 1:11 am

Post by bphlpt » Mon Oct 24, 2011 6:27 pm

Chief, I believe that boooggy meant to try and do the slipstreamer FIRST on an untouched x64 source then do the rest and let him know what happens.

Cheers and Regards

ChiefZeke
Posts: 767
Joined: Fri Mar 23, 2007 5:33 pm
Location: Victorville, California

Post by ChiefZeke » Mon Oct 24, 2011 6:30 pm

If it helps, I just tried from the beginning. The Ryan VM log file:

15:08:48 - Checking Destination For OS Type.
15:08:48 - English - Windows XP Professional x64 - Retail SP2 Found
15:08:48 -
15:08:48 - Extracting 5er_UpdatePack_XPx64SP2_2011-10_1.7z
15:09:07 - MD5 Hash = 56f55db2e7dcabc0e0d82057b18a21d1
15:09:07 - Extracting RedDXRuntime_0.9.0_Addon_3264AIO.7z
15:09:08 - MD5 Hash = 4c0c240c450acc1d0682b3fdd32a52d7
15:09:08 - Extracting 5er_IE8_Addon_2011-08_1_x64.7z
15:09:12 - MD5 Hash = 0fef748d47e8aca25d8330ce25e11869
15:09:12 - Extracting Addon_Microsoft_Silverlight_4.0.60831.0.7z
15:09:14 - MD5 Hash = 98de54a97fb7775b902671b012565313
15:09:14 - Extracting DirectXRuntimes-201006-Addon-64.cab
15:09:14 - CabLite.dll::CabExtractAsync reports completion

Code: Select all

15:09:14  -     MD5 Hash = 47a2c155c27f2bddebfceaab374577f4
15:09:14  - Extracting ELiTE_dotNetFx40_Addon.7z
15:09:19  -     MD5 Hash = 5ce8ea050400ce1e6ad7d21f27e42c55
15:09:19  - Extracting MicrosoftRuntimeLibraries-148-Addon.7z
15:09:21  -     MD5 Hash = ff1c24227377f2b62ded089de6546721
15:09:21  - Extracting NeoSmart_TweakUI_x64_Addon_v2.2.rar
15:09:21  -     MD5 Hash = d0b1211ae3a4bac1790c44cc8e127a2a

Calling the WMP11 Slipstreamer failed as before. I'm assuming none of the addons could be the problem. Anymore suggestions?

User avatar
bphlpt
Posts: 1372
Joined: Sat Apr 19, 2008 1:11 am

Post by bphlpt » Mon Oct 24, 2011 6:37 pm

Did you:
bphlpt wrote:... try and do the slipstreamer FIRST on an untouched x64 source and then do the rest and let him know what happens.
Cheers and Regards

ChiefZeke
Posts: 767
Joined: Fri Mar 23, 2007 5:33 pm
Location: Victorville, California

Post by ChiefZeke » Tue Oct 25, 2011 1:01 am

Win7 Ultimate 64-bit w/SP1

That's not how I read the request but just in case; I copied the XP Pro x64 w/SP2 source to a different location and started the WMP11 Slipstreamer 1.4.3.0.

Selected \WMP11 Slipstreamer\wmp11-windowsxp-x64-enu.exe and then pointed to the copied location; \Windows XP Pro x64 with SP2 CD. No hotfixes were selected and the Integrate button selected.

Immediately got error message: WMP11 Slipsteamer has stopped working. A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available. Close program.

Even edited the folder name to remove the spaces and again I got the same error message.

I did have Process Explorer 15.05 open and under the Process column > svchost.exe with indented file: WerFault.exe in \Windows\SysWOW64\WerFault.exe -u -p 4720 -s 1364

Anymore ideas?

User avatar
boooggy
Posts: 1297
Joined: Tue Aug 16, 2005 2:20 am
Location: Bucharest, Romania

Post by boooggy » Tue Oct 25, 2011 4:44 am

wierd...
what i did was to copy a untouched xp x64 to hdd
then started slippy
selected wmp11 installer and wmp hotfixes
no errors.

User avatar
5eraph
Site Admin
Posts: 4621
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Tue Oct 25, 2011 4:58 am

No problems here within XPx64SP2 installed with pack 2011-08_1. dotNET x64 2 through 4 are installed here for testing. I can't test within Vista or Win7 (no sources to install).

dotNET x64 should always include 32-bit binaries, n7Epsilon. Which version of dotNET does the slipstreamer require: (1.1, 2, 3, 3.5, 4)? Contrary to what I've read, nLite will not run when only dotNET 4 is installed. It specifically requires dotNET 2.

Which versions of dotNET do you have installed when testing under XPx64SP2, ChiefZeke: (1.1, 2, 3, 3.5, 4, all)?

User avatar
bphlpt
Posts: 1372
Joined: Sat Apr 19, 2008 1:11 am

Post by bphlpt » Tue Oct 25, 2011 7:33 am

boooggy wrote:wierd...
what i did was to copy a untouched xp x64 to hdd
then started slippy
selected wmp11 installer and wmp hotfixes
no errors.
@boooggy, maybe you could share your EXACT paths and commands you used for this simple test that Chief could also try to duplicate? Just a thought to come up with a way to eliminate differences in order to find the problem.

Cheers and Regards

ChiefZeke
Posts: 767
Joined: Fri Mar 23, 2007 5:33 pm
Location: Victorville, California

Post by ChiefZeke » Tue Oct 25, 2011 6:04 pm

5eraph - I have all versions of DotNet installed, as appropriate, in my various versions of Windows.

Just to provide information before there are any more questions I did the following:

XP Pro xSP3 - source was XP Pro w/SP3 CD

Started RyanVM Integrator > Updated and addons > WMP11 Slipstreamer > Updated and Hotfixes > Driver Packs > added > Make ISO > Successful

Win7 Ultimate 64-bit w/SP1 - source was same XP Pro w/SP3 CD

Started RyanVM Integrator > Updated and addons > WMP11 Slipstreamer > Updated and Hotfixes > Driver Packs > added > Make ISO > Successful

So, there was no problem with WMP11 slipstreamer when run from either Windows, 32-bit or 64-bit, version. In both instances the same copy of the WMP11 Slipstreamer was invoked. (It is installed in a location common to all of my operating system.)

Again, the only difference when the problem occurs is I am updating XP Pro x64 w/SP2; everything else is in the same location and the various updates/addons are 64-bit and Driver Packs is not callled for 64-bit integrating.

How this helps.

User avatar
boooggy
Posts: 1297
Joined: Tue Aug 16, 2005 2:20 am
Location: Bucharest, Romania

Post by boooggy » Wed Oct 26, 2011 8:59 am

zeke
please do this
copy your fresh and untouched source of xp x64 to your hdd.
start wmp11 slipstreamer and point it to your source.
please report the results.
thx

User avatar
bphlpt
Posts: 1372
Joined: Sat Apr 19, 2008 1:11 am

Post by bphlpt » Wed Oct 26, 2011 11:39 am

@boooggy,

To be clear, do you mean

XP x64 RTM
XP x64 SP1
XP x64 SP2

Because if I read Zeke's post correctly, there seems to be a different result for him between SP1 and SP2, but I could be wrong.

Cheers and Regards

Post Reply