[Tool]XPtsp v1.0.10 beta X

Discuss & post Update Pack addons here.
Post Reply
User avatar
bober101
Posts: 923
Joined: Thu Feb 08, 2007 8:49 pm
Location: canadia!

[Tool]XPtsp v1.0.10 beta X

Post by bober101 » Sat Jul 05, 2008 3:54 am

plz visit http://www.wincert.net/forum/index.php?showtopic=3842



NOTE:that this is the succession of V'ISO made by Ricktendo64
Last edited by bober101 on Sun Sep 28, 2008 5:03 pm, edited 16 times in total.

User avatar
mr_smartepants
Posts: 824
Joined: Thu May 18, 2006 5:56 am
Location: Cambridgeshire, UK

Post by mr_smartepants » Sat Jul 05, 2008 3:03 pm

BTW, for those who don't know. This tool (XP Theme Source Patcher) replaces Ricktendo's V'ISO tool.
Image
Some heroes don't wear capes, they wear Kevlar and dog-tags!

User avatar
bober101
Posts: 923
Joined: Thu Feb 08, 2007 8:49 pm
Location: canadia!

Post by bober101 » Sat Jul 05, 2008 3:25 pm

whoops,ill add this to 1st post,also i have made a small update plz re-dl this.(thx to amnesia)
XP theme source patcher
patches/overwrites ure default xp visual resources

User avatar
bober101
Posts: 923
Joined: Thu Feb 08, 2007 8:49 pm
Location: canadia!

Post by bober101 » Tue Jul 22, 2008 11:07 am

updated.
XP theme source patcher
patches/overwrites ure default xp visual resources

User avatar
dougiefresh
Posts: 948
Joined: Wed May 11, 2005 5:05 pm
Location: Murfreesboro, Tennessee
Contact:

Post by dougiefresh » Sat Sep 06, 2008 4:51 am

Bober's Link to Previous Version:
WinCert Forum thread: Here

Download: XPtsp.v1.0.10b7.exe
MD5: B3F4892B0A14238099FBACC4B6416FE6, Size: 43.5mb

Original Post: September 4, 2008 @ 4:45pm
Hey, everybody! I have gotten a fair chunk of code completed, along with debugging it. I wish for people to beta-test it. I've gotten permission from Bober to use version 1.0.10 beta 8 as it's version number. So here it is:

Download Link: XPtsp v1.0.10b8
MD5: 8C49F21F9E2965E0F7806AB84A6E1EF9, Size: 28.4mb

Special features of this beta:
- UXTHEME.DLL can be patched directly by the script. (based on Zacam's patch)
- New Aero cursors can be installed by the script, along with modified themes using the new cursors.
- Resources and the patcher can be included in the XP source. (Repatcher not written yet)
- Option to include the OEM Info Generator at startup. (Not written yet)
- Option to change GUI Setup resolution to 1024x768, 1280x800, 1280x1024, 1440x900, 1600x1200, 1680x1050, 1920x1200, 2560x1600 (all resolutions based on Zacam's patches)

Things to note about this release:
- The script doesn't overwrite the AutoPlay files yet....
- No version checking takes place in this beta, so if updated components that aren't updated through Windows Update (like Ricktendo's Windows Easy Transfer add-on or ENU_user's Movie Maker upgrade add-on) are included, patching these components may not result in the expected results.
- The "Live System Patching" code has not been written yet.
- Page 2 is not shown, because of the above reason.
- Page 6 has not been completed, but will indicate completion of the integration.
- If the archive is put in the XP source folder, the script will pick up the folder that the archive resides in and use it as the default folder. Otherwise, source folder will be blank.
- OEM Info Generator produces a message box indicating it was launched, but doesn't do anything else.
- Repatcher hasn't been written yet, so adding the resource files to the source doesn't really accomplish anything right now.
- I've mashed it down as much as I can using 7zip.... (in case anyone is interested - Beta 7 uses WinRAR)

I don't seem to have the time to fully test this because of long hours at work, so I'm asking (almost begging) people to check and evaluate this release. I need to know if the script produces the same or similar results in the XP source as version 1.0.10b7, preferably with an XP SP2/3 without an Update Pack (although with an Update Pack would be interesting as well). Any assistance would be appreciated! Thanks!

EDIT (1.5hr after): Bober has updated some resources, but I don't know which ones.
EDIT (2hr after): Fixed problem with Source browse button.

Original Post: September 5th, 2008 at 4:02am
I've fixed the download link to the program. Last night, I lost my net connection. It came back on sometime after I went to bed. So I couldn't fix the foobar that I made....

I've received 3 reports. The first is that the Browse button doesn't work properly. I've fixed this. The second is that the script creates a CAB file containing the resources, regardless of whether the user wants the resources included. I've fixed this by pointing the script's archival code to the proper folder. A side effect of the 2nd bug reported happens during Setup, where Setup complains about missing files. It's because the Aero cursors and the script files aren't included in the XPTSP.CAB file that the script creates. The 3rd bug will be fixed by fixing the 2nd.

When I get home today (it's 4am here), I will compile another version.

Today's Post:
I've fixed all three previously mentioned problems, as well as implemented the AutoPlay copying code, as I forgot it in my inital release. I also added a progress bar during compression so that the user won't be wondering what's going on... I also realized that if a repatcher was written, it would need the tools that the archive came with, so XPTSP.INF has been updated to include those...

However, I didn't get a chance to release the new code, so please have some patience.... Thanks!
Last edited by dougiefresh on Sun Sep 14, 2008 8:04 am, edited 2 times in total.
Visit me at home: http://xptsp.filetap.com

User avatar
dougiefresh
Posts: 948
Joined: Wed May 11, 2005 5:05 pm
Location: Murfreesboro, Tennessee
Contact:

Post by dougiefresh » Sat Sep 06, 2008 7:21 pm

Download: XPtsb_v1.0.10.9.exe
MD5: 5383C38208F962450868E2C1D2F27CEE, Size: 28.3mb

Changes in this version:
- All three previously mentioned problems are fixed.
- Implemented the AutoPlay copying code, as I forgot it in my inital release.
- Added a progress bar during compression so that the user won't be wondering what's going on...
- Realized that when a repatcher was written, it would need the tools that the archive came with, so XPTSP.INF has been updated to include those...
- Re-organized the code so that related functions would be grouped together.
- Moved some code from the script itself to XPTSP.INI for future expandability.... (yeah, I know it looks weird)

EDIT: Re-uploaded because the AutoPlay files were missing....
EDIT: Fixed the code to properly detect Pro, since " XP " is on the second line, not the first...
Visit me at home: http://xptsp.filetap.com

User avatar
dougiefresh
Posts: 948
Joined: Wed May 11, 2005 5:05 pm
Location: Murfreesboro, Tennessee
Contact:

Post by dougiefresh » Sun Sep 07, 2008 3:10 pm

Ok, I've been working on this all morning, so here's what's up at the moment. I've got the Browse button fixed, as well as rewrote the OS type detection code. It no longer looks for specific files, but looks at the EULA.TXT instead. I've fleshed out Page 6 and included code to create an ISO. I also replaced CABARC (which I put in there) with MAKECAB (which came with beta 7), mostly because CABARC was badly mangling my XP source. I'm working on testing the code right now, so please be patient. Thanks!
Last edited by dougiefresh on Sun Sep 07, 2008 3:23 pm, edited 1 time in total.
Visit me at home: http://xptsp.filetap.com

User avatar
mr_smartepants
Posts: 824
Joined: Thu May 18, 2006 5:56 am
Location: Cambridgeshire, UK

Post by mr_smartepants » Sun Sep 07, 2008 3:16 pm

@dougiefresh,
Did you see my bug report here?
EULA.txt scan needs refinement.
Image
Some heroes don't wear capes, they wear Kevlar and dog-tags!

User avatar
dougiefresh
Posts: 948
Joined: Wed May 11, 2005 5:05 pm
Location: Murfreesboro, Tennessee
Contact:

Post by dougiefresh » Sun Sep 07, 2008 3:25 pm

mr_smartepants: I did see your bug report. I have fixed the code so that it scans for "Home Edition", "Professional" or "Media Center". I just need to run another test, seeing as a recent addition to the code resulted in errors.... Give me about an hour. Thanks!
Visit me at home: http://xptsp.filetap.com

User avatar
bober101
Posts: 923
Joined: Thu Feb 08, 2007 8:49 pm
Location: canadia!

Post by bober101 » Sun Sep 07, 2008 4:09 pm

n e ways i really appreciate ure hard work on this dougie.thx.
XP theme source patcher
patches/overwrites ure default xp visual resources

User avatar
dougiefresh
Posts: 948
Joined: Wed May 11, 2005 5:05 pm
Location: Murfreesboro, Tennessee
Contact:

Post by dougiefresh » Sun Sep 07, 2008 4:16 pm

It appears that I have to manually fix the WBEM problem, too.... This might take a little while longer than expected....

EDIT: I've followed these directions to temporarily fix the problem during testing. I will try to incorporate the add-on by MrNxDmX into the script.

EDIT2: Installation is proceeding normally. I fixed the WBEM problem in the script, as well as included the INI files that were left out.
Visit me at home: http://xptsp.filetap.com

User avatar
dougiefresh
Posts: 948
Joined: Wed May 11, 2005 5:05 pm
Location: Murfreesboro, Tennessee
Contact:

Post by dougiefresh » Sun Sep 07, 2008 6:23 pm

I've actually had some time to test and correct bugs & problems as I found them, and I found some whoppers! I've fixed them and compiled the newest version. Here it is:

Download Link: XPtsp v1.0.10.10
MD5: CE5AF82A943149558754A431CAC85C65, Size: 27.7mb

I've got the WBEM fix coded in the script, as well as fixed the UXTHEME patching problem. I also saw duplicated AutoPlay files, so I removed all duplicated files from those folders and made sure the code was updated to reflect this. I don't think there are any more problems, however, please test this package and let me know if you encounter any problems. Thanks for your patience, everybody!

EDIT: Oh, yeah, I remember a report about Home and Pro files mixed in, I'm pretty sure I fixed that by pulling files from beta 7.
Visit me at home: http://xptsp.filetap.com

arco
Posts: 137
Joined: Fri Aug 04, 2006 1:50 pm
Location: Netherlands

Post by arco » Mon Sep 08, 2008 1:18 pm

Nice very nice tool now. Thanks for this.

cosy
Posts: 278
Joined: Tue Apr 18, 2006 11:56 pm

Post by cosy » Tue Sep 09, 2008 5:56 am

can someone let me know whether or not one can use this as an Addon?
I cant get the difference to XPtsp.v1.0.10b8batch.addon.rar "XPtsp.v1.0.10b8batch.addon.rar"
Thank you

User avatar
bober101
Posts: 923
Joined: Thu Feb 08, 2007 8:49 pm
Location: canadia!

Post by bober101 » Tue Sep 09, 2008 8:25 am

XPtsp.v1.0.10b8batch.addon.rar is the addon and XPtsp.v1.0.10b8batch.exe is the manual patcher. and
XPtsp v1.0.10.10 is the new gui interface.

http://www.wincert.net/forum/index.php?showtopic=3842
XP theme source patcher
patches/overwrites ure default xp visual resources

User avatar
dougiefresh
Posts: 948
Joined: Wed May 11, 2005 5:05 pm
Location: Murfreesboro, Tennessee
Contact:

Post by dougiefresh » Sun Sep 14, 2008 8:00 am

Original Post from Sept 9, 2008:
New GUI Version v1.0.10.10a is now available.

What's Changed:
- Instead of using EULA to determine OS type, TXTSETUP.SIF is searched for the necessary strings to identify Home or Pro. If Pro is identified, MEDIACTR.CAB is looked for to determine whether it is MCE.
- WBEM and UXTHEME code has been fixed and confirmed operational.
- Included all resource changes that are included in 1.0.10.8 batch version.

Original Post from Sept 10, 2008:
I've uploaded .10b, which has the debugging statements removed to enable the rest of the patching code. Sorry about that. (EDIT: The debugging code omitted everything but the UXTHEME patch, which is the last thing I was working on.)

Original Post from Sept 11, 2008:
GUI Version 1.0.10b10c has been released.

What's Changed:
- Since the cursors got deleted from GUI beta 10b, they are re-included.
- File structure changed to move cursors out of Extra folder.
- UXTHEME and WBEM fixes now work correctly.
- OEM Info Generator batch now is run silently with a GUI notification window.

Original Post from Yesterday:
Ok, I've recompiled the archive after making the detection changes and reverting the resources back to batch beta 8. Here it is:
Download Page: XPtsp v1.0.10 beta 10d
MD5: DE0D6DF6C4E3752BD9128496DC9567EB, Size: 28.8mb
Visit me at home: http://xptsp.filetap.com

User avatar
dougiefresh
Posts: 948
Joined: Wed May 11, 2005 5:05 pm
Location: Murfreesboro, Tennessee
Contact:

Post by dougiefresh » Sun Sep 28, 2008 4:45 pm

Ok, since it's looking like WinCert is stable again, the discussion doesn't seem to going to be moved any time soon. Just thought y'all would like to know.
Visit me at home: http://xptsp.filetap.com

User avatar
bober101
Posts: 923
Joined: Thu Feb 08, 2007 8:49 pm
Location: canadia!

Post by bober101 » Sun Sep 28, 2008 5:01 pm

well i dont think any one really red this topic or even used the tools, if they did, they were already accustom to them via wincert.ill just simply put a link to wincert's forum in 1 st post.will be easier like this.
XP theme source patcher
patches/overwrites ure default xp visual resources

Post Reply