[Addon] Windows Media Player 10 for XP/MCE/2k3 3.4.5

Discuss & post Update Pack addons here.
Post Reply
yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

[Addon] Windows Media Player 10 for XP/MCE/2k3 3.4.5

Post by yumeyao » Fri Feb 06, 2009 7:02 am

Windows Media Player 10 With Windows Media Connect 2 & Windows Media 11 Runtimes
For Windows XP/MCE/2k3, Last Updated 2011/6/29

Description:
  • This addon will replace your Windows Media Player Component in your windows installation CD with its contents.

    This version is named V3.
    V1 is based on Ryan's work, i translated it into Chinese that time.
    V2 is somehow similar to Onepiece's WMP11 Addon. We did the same thing that is modifying the default wmp.inf and associated files rather than Ryan & boooggy's "Install WMP9 then Install WMP10/11" method.(although we achieve file copying via different ways)
    Both V1 and V2 are only in Chinese/Japanese. Now since some people need a up-to-date WMP 10 Addon, so I decide to also release V3 in English.

    Here is V3. It has several points over V2:
    1. Compatibility with XP/MCE/2k3 in one Addon. MCE Updates included. for 2k3, M$ does not install skins but this addon does.
    2. Windows Media Formats, DRM Management, WUDF and other runtimes are Version 11(ripped from WMP11).
    3. Obsolete files are removed. They are either utility to migrate DRM stuffs or a file with several KiloBytes which is used to overwrite the old file.
    4. Addon structure: File Copy handling and Registry improvements
Contents: Credits:
  • nonno fabio and OnePiece Alb, without their wmp/ie7 addon i wouldn't have realized it's possible to handle file copying like this.
    (although i managed to achieve it when i released V2, but my method is kinda "cheating"...)
  • Ryan and boooggy, for their first-hand wmp addons. although they are old yet still good.
Download: Notes:
  • Integrate this addon on a source without any other people's WMP addon.
  • Known Issues:
    • On Windows 2003, MTP driver is not signed, so that you should follow the wizard and click on "next" to install driver for your MTP devices.
Changelog:
  • Version 3.4.5 - 2011/06/29
    Added KB970159.
  • Version 3.4.4 - 2010/10/12
    Added KB2378111.
  • Version 3.4.3 -2010/09/14
    Added KB975558.
  • Version 3.4.2 -2010/09/02
    Fixed an issue created in V3.4.1 that MP3 files could't get played.
  • Version 3.4.1 -2010/08/12
    Preserved l3codecx.ax, for it is needed in some very rare situations.
  • Version 3.4.0 - 2010/07/15
    Updated WMP11 Runtimes to 11.0.5721.5262, replaces KB928788, KB929399, KB929773, KB932390, KB933547, KB935551, KB935552, KB939209, KB941569, KB944882, KB952069, KB954069.
    Re-worked WUDF component(which installs MTP drivers).
    Minor other fixes, including an removing entry for Windows 2003, and several dummy file fixing for smaller final size.
    If you also use my IE8 addon, please update it to latest too.
  • Version 3.3.2 - 2010/06/09
    Added KB978695, replaces KB968816.
    Minor fix on shipped MP3 encoder/decoder.(l3codecp.acm)
  • Version 3.3.1 -2010/01/16
    Added KB974905.
  • Version 3.3.0 - 2009/10/17
    Tweaks updated.
    Fixed an issue when a non-admin user initializes first logon, error message "INF error" pops.
    Added KB954155.
    Excluded strmdll.dll from this addon because it causes digital signature issue.
    Fixed winnt(32).exe based install issue on windows server 2003.
  • Version 3.2.1 - 2009/09/10
    Added KB968816.
  • Version 3.2.0 - 2009/08/21
    Added KB954069.
    Added KB973442, replaces KB954067.
    Added KB973540, replaces KB945381.

    Fixed the issue of integration by nlite. Now this addon can work as expected no matter it is integrated on XP or 2003, by nlite or RVMi.
    setuperr.log issue fixed by adding dll files with empty DllRegister Function.
    Fixed MTP related WUDF service's installation again, to avoid conflicts.
    Adding some files to [FileFlags] of txtsetup.sif to avoid failure of copying file on winnt.exe(or winnt32.exe) based install.
    Removed an useless registry entry which is intended to overwrite old WMP 10 service(wudf01000).
  • Version 3.1.1 - 2009/03/25
    Added KB943604, which contains updated files of KB911564, KB925398 and KB954600.
    Fixed an error I created during maintenance that 2k3 complains about missing files, leading to installation failure.
  • Version 3.1.0 - 2009/03/15
    MTP issue fixed.
    Fixes an issue if integrated upon my wmp11 addon, catalogs for wmp11 not removed as expected.
  • Version 3.0.2 - 2009/02/08
    Changes are made to give it ability to be integrated upon my wmp11 addon.
    Tweak.DelReg(removes unnecessary context menu items) not worked as expected.
    Other minor fixes.
  • Version 3.0.1 - 2009/02/08
    Fix a typo(resulting in DRM components registration failing).
    To fix this error on a live system with previous version integrated, choose "start menu" -> "run", then type "regsvr32 /s msscp.dll" and press enter. then again "start menu" -> "run", type "regsvr32 /s msnetobj.dll" then press enter.
  • Version 3.0 - 2009/02/06
    Initial release.
Last edited by yumeyao on Tue Jun 28, 2011 10:26 pm, edited 45 times in total.
Image
My work list(Hosted by dumpydooby)

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Sun Feb 08, 2009 2:45 am

updated. a spelling mistake fixed.

A screenshot in Virtual Machine here: :lol:
Image
Image
My work list(Hosted by dumpydooby)

User avatar
HELLPELL
Posts: 1
Joined: Tue May 27, 2008 9:03 pm
Location: In HELL !
Contact:

Post by HELLPELL » Sun Feb 08, 2009 10:44 am

Thank you very mush :D

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Sun Feb 08, 2009 11:01 am

updated again... for my wmp11 addon's releasing.
Image
My work list(Hosted by dumpydooby)

User avatar
reall1ty
Posts: 7
Joined: Fri Dec 26, 2008 8:18 am

Post by reall1ty » Sun Feb 08, 2009 6:03 pm

Thank you very much! WMP10 Forever:D
after test:
i've found 2 bugs (in ryan addon was too)
1. My Creative Zen Micro no work, windows want drivers but with
normal windows media player 10 or 11 is install by default like mtp device
Image
2. If i play MPEG-1 or MPEG-2 files i get this window:
Image
Image
Image
--------
about codecs: for play MPEG-1 or MPEG-2 files i use GPL MPEG-1.2 DirectShow Decoder Filter 0.1.2
system: xpsp3 with last updatepack, addons: ie7 v.2.0.4, dx9c nov2008, wmp10
Now i restore my previously system
I Hope update will be soon!

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Sun Feb 08, 2009 11:02 pm

@reall1ty:
a quick reply:
on the first bug: can you try my wmp11 addon? if it doesn't work then it's an addon bug, if it work then it's a improper combination of wmp10/11. i have tried all my portable media devices but no luck they are all too old to be used with MTP...

on the second: can you upload the video somewhere in case i can't reproduce your issue. i'm gonna a home-member party. so i don't have time to test now. will test later.
---edit---
i see the second video clip is mpeg2.... will try.... but the first one, why does it have an avi extension?
---edit2---
a quick test on VM:
Image
both these 2 clips plays well.
Ryan's pack + this wmp addon.
-and-
Ryan's pack + this wmp addon + code65536's DX9 runtime.
will test on a real pc later.
Image
My work list(Hosted by dumpydooby)

User avatar
reall1ty
Posts: 7
Joined: Fri Dec 26, 2008 8:18 am

Post by reall1ty » Fri Feb 13, 2009 7:13 pm

i'am back (was in army)
video for test:
http://www.mediafire.com/file/dzymbz2dw ... uality.avi

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Thu Feb 19, 2009 6:00 am

this video is played normally on my test in VM.
Image
My work list(Hosted by dumpydooby)

ayanamist
Posts: 7
Joined: Wed Feb 21, 2007 5:57 am

Post by ayanamist » Thu Feb 19, 2009 11:01 pm

well done! thank you

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Sun Mar 15, 2009 3:43 pm

updated.
with MTP issue and another minor issue fixed.

@reall1ty:
sorry i failed to reproduce your issue...
Image
My work list(Hosted by dumpydooby)

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Wed Mar 25, 2009 8:15 pm

updated.
Image
My work list(Hosted by dumpydooby)

eethball
Posts: 56
Joined: Thu Mar 01, 2007 2:31 pm

Post by eethball » Wed May 06, 2009 4:33 pm

YumeYao. Thanks for the great pack. Everything seems to be working great. I did have one question though. I noticed that your addon sets teh "Windows Driver Foundation - User-mode Driver Framework" service Startup type to Automatic as opposed the default value of Manual. After installing various applications (Office, document management software, ect) I started receiving an error message when my computer was on a fresh reboot when the Press Ctrl + Alt + Delete to logon screen was up, and that service is the culprit. I set it to manual and then the problem goes away. It's set in wmdm.inf with the line that says the following... Thanks again for all your work.

Code: Select all

HKLM,"SYSTEM\CurrentControlSet\Services\WudfSvc",Start,0x10001,02,00,00,00

Zosimos
Posts: 16
Joined: Wed May 02, 2007 2:41 pm

Post by Zosimos » Wed May 06, 2009 9:14 pm

Ah, since I was using a direct bookmark I didn't even know about this thread. So, you made a 'hybrid' instead of a pure WMP 10 addon. What are the advantages of using the WMP 11 libraries? Do those play more formats than the WMP 10 libraries? Doesn't that bring along the extra DRM code that makes WMP 11 unattractive to so many people?

What problems could the setup error log messages cause? Will the installer think that the install failed and abort instead of terminate normally?

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Fri Aug 21, 2009 8:16 am

Zosimos wrote:Ah, since I was using a direct bookmark I didn't even know about this thread. So, you made a 'hybrid' instead of a pure WMP 10 addon. What are the advantages of using the WMP 11 libraries? Do those play more formats than the WMP 10 libraries? Doesn't that bring along the extra DRM code that makes WMP 11 unattractive to so many people?

What problems could the setup error log messages cause? Will the installer think that the install failed and abort instead of terminate normally?
WMP11 libraries won't play more formats because no encoding improvement is made between WMP10 and WMP11. Yet optimisticly they will perform better and WMP11 libraries have a better support on HD-DVD and Blu-ray movies, in which VC-1 is used.

For the DRM stuff, I don't know much about it but I guess it does. Would you explain how it's unpopular so I could roll it back to that of WMP10 in the future.

The main reason why I use WMP11 libraries is:
On windows XP MCE, an update is required(KB900325), which offers a set of libraries titled with so-called Windows Media Format 10.5, in which many files are that of WMP11(but has a lower sub version number than WMP11). However this update limits further update as M$ has never released a hotfix or update which can be applied upon it. Additionally, M$ recommends MCE users install Windows Media Format 11 to require further support.

And for the setuperr.log. It's because WMP is considered as a native component of Windows therefore some actions upon registering its components are "hard-coded" in syssetup.inf(which M$ prevents user's editing unless syssetup.dll is cracked), this would cause some obsolete files cannot get registered by the "hard-coded" commands.
It won't break or terminate or fail windows install.
And this issue is fixed now. I'm updating this addon right after I finish updating my Chinese stuffs.
Image
My work list(Hosted by dumpydooby)

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Fri Aug 21, 2009 11:02 am

eethball wrote:YumeYao. Thanks for the great pack. Everything seems to be working great. I did have one question though. I noticed that your addon sets teh "Windows Driver Foundation - User-mode Driver Framework" service Startup type to Automatic as opposed the default value of Manual. After installing various applications (Office, document management software, ect) I started receiving an error message when my computer was on a fresh reboot when the Press Ctrl + Alt + Delete to logon screen was up, and that service is the culprit. I set it to manual and then the problem goes away. It's set in wmdm.inf with the line that says the following... Thanks again for all your work.

Code: Select all

HKLM,"SYSTEM\CurrentControlSet\Services\WudfSvc",Start,0x10001,02,00,00,00
yeah you are right.

It's solved in the latest version.
Image
My work list(Hosted by dumpydooby)

eethball
Posts: 56
Joined: Thu Mar 01, 2007 2:31 pm

Post by eethball » Thu Sep 10, 2009 9:51 am

If you have some time do you think you could update this addon with the files updated in the KB968816 security update? Thanks for everything.

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Thu Sep 10, 2009 10:48 am

updated.

don't be so impaitient :wink:. I'll update is as soon as I finishes updating chinese stuffs.
Image
My work list(Hosted by dumpydooby)

eethball
Posts: 56
Joined: Thu Mar 01, 2007 2:31 pm

Post by eethball » Thu Sep 10, 2009 11:42 am

Impatient? I gave you almost 2 whole days ;) j/k bud. Thanks again for everything.

PhenomXP
Posts: 2
Joined: Wed Sep 23, 2009 8:43 am
Location: Romania/Bucharest

Post by PhenomXP » Fri Sep 25, 2009 7:20 am

Nice addon.I don't like WMP11,and 10 is perfect.Thx;)
Image

bobotlito
Posts: 57
Joined: Mon Oct 22, 2007 10:32 am
Location: singapore

Post by bobotlito » Thu Oct 01, 2009 11:45 am

d best addon.
thank you for this :)

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Sat Oct 17, 2009 9:44 am

updated.
Image
My work list(Hosted by dumpydooby)

bobotlito
Posts: 57
Joined: Mon Oct 22, 2007 10:32 am
Location: singapore

Post by bobotlito » Sun Oct 18, 2009 10:56 am

once again, thank you very much 8)

eethball
Posts: 56
Joined: Thu Mar 01, 2007 2:31 pm

Post by eethball » Wed Nov 04, 2009 9:35 am

bobotlito wrote:once again, thank you very much 8)
I second this. It is greatly appreciated.

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Sat Jan 16, 2010 12:00 pm

updated with KB974905 added.
Image
My work list(Hosted by dumpydooby)

eethball
Posts: 56
Joined: Thu Mar 01, 2007 2:31 pm

Post by eethball » Thu Jan 21, 2010 11:22 am

Thanks a lot yumeyao, works great.

jtan2000
Posts: 5
Joined: Thu Jan 14, 2010 11:39 am

Post by jtan2000 » Sun Mar 07, 2010 10:51 pm

Hi, I think the YumeYao_WMP10_Addon_ENU_V3_3_1 file DL1 is corrupted.



Version 3.3.1
YumeYao_WMP10_Addon_ENU_V3_3_1.7z DL1 DL2
MD5: 9571a12747e3517f0b93d00c95cc69cd


http://www.esnips.com/doc/d4e9f811-bcf7 ... ENU_V3_3_1

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Sun Mar 07, 2010 11:19 pm

really. It seems it was corrupted along with my WMP11 addon, as someone else has reported.

---edit----
mirror1 is replaced with a mediafire link.
Image
My work list(Hosted by dumpydooby)

ya.vosya
Posts: 3
Joined: Sun Mar 28, 2010 10:32 am

Post by ya.vosya » Sun Apr 04, 2010 9:48 am

yumeyao

please make the addition without "Windows Media 11 Runtimes"

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Wed Jun 09, 2010 6:53 am

updated.
My network is being fixed, in the meantime, only rapidshare link available. mediafire and esnips mirrors will be added soon.
Image
My work list(Hosted by dumpydooby)

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Fri Jun 11, 2010 9:50 am

updated the post. Please refer to Known Issues section.
Image
My work list(Hosted by dumpydooby)

User avatar
trippinferret
Posts: 58
Joined: Thu Jul 31, 2008 9:27 pm
Location: Lakewood, N.S.W. Australia

Setup Intro

Post by trippinferret » Thu Jun 24, 2010 3:33 am

Hi YumeYao

Thanks for this great update pack and maintaining it for so long, just an idea can you please include the WMP10 setup intro in a future release it would top off an excellent player.


Yeh I did mean the guide on the first run, "did not know what it was called" I will try your suggestion.

Thanks.
Last edited by trippinferret on Thu Jun 24, 2010 10:16 am, edited 1 time in total.

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Thu Jun 24, 2010 4:53 am

What's the "WMP10 setup intro"? Did you mean the guide on first run?

To enable the guide on first run, just modify wmp.inf in this addon:
Add a semicolon at the head of these lines each:
HKCU,"%KEY_WMP%\Preferences","FirstRun",0x10001,0
HKCU,"%KEY_WMP%\Preferences","SyncPlaylistAdded",0x10001,1
Image
My work list(Hosted by dumpydooby)

User avatar
shiner
Posts: 655
Joined: Sun Nov 08, 2009 4:18 am
Location: SE Asia

Post by shiner » Fri Jun 25, 2010 6:19 am

Version 3.3.2
YumeYao_WMP10_Addon_ENU_V3_3_2.7z DL1 DL2 DL3
MD5: 9571a12747e3517f0b93d00c95cc69cd
Is this MD5 correct?
I just dl'ed from DL3, the archive seems OK but the MD5 doesn't match.
I get:

File: YumeYao_WMP10_Addon_ENU_V3_3_2.7z
CRC-32: 20c42888
MD4: db7f1bac58e853fe971d23cbc4e14c98
MD5: 46710aa0330e63a2497520f9b2213881
SHA-1: 80fc0209e458fd20fa2338ee1fc27047c897b980


Oh, and Thanks!
"You can lead a horse to water, but you can't make it drink."

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Fri Jun 25, 2010 6:48 am

yes, I mistook on the topic. Fixed.
Image
My work list(Hosted by dumpydooby)

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Thu Jul 15, 2010 5:02 pm

updated.
Image
My work list(Hosted by dumpydooby)

User avatar
trippinferret
Posts: 58
Joined: Thu Jul 31, 2008 9:27 pm
Location: Lakewood, N.S.W. Australia

Post by trippinferret » Sat Jul 17, 2010 6:07 pm

Hi yumeyao

Thanks for this great addon, tried your suggestion and it worked perfectly.

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Thu Aug 12, 2010 7:03 am

updated.
Image
My work list(Hosted by dumpydooby)

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Thu Sep 02, 2010 3:17 pm

updated.
Image
My work list(Hosted by dumpydooby)

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Tue Sep 14, 2010 2:03 pm

updated.
Image
My work list(Hosted by dumpydooby)

User avatar
trippinferret
Posts: 58
Joined: Thu Jul 31, 2008 9:27 pm
Location: Lakewood, N.S.W. Australia

Post by trippinferret » Tue Sep 14, 2010 7:26 pm

Hi yumeyao

Thanks for still supporting this media player and thanks again for the update.

bobotlito
Posts: 57
Joined: Mon Oct 22, 2007 10:32 am
Location: singapore

Post by bobotlito » Tue Sep 28, 2010 1:09 am

i love this addon very much.
really appreciate your hard work.
thanks a lot. :)

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Tue Oct 12, 2010 2:38 pm

updated.
Image
My work list(Hosted by dumpydooby)

bobotlito
Posts: 57
Joined: Mon Oct 22, 2007 10:32 am
Location: singapore

Post by bobotlito » Wed Oct 13, 2010 5:59 am

hello yumeyao,

once again, thank you for updating.

filesonic: whew,.. managed to download after about 30 trials :x

but it's worth it. :)

User avatar
George King
Posts: 34
Joined: Mon Dec 01, 2008 10:25 am
Location: cs-CZ

Post by George King » Wed Jan 26, 2011 6:02 am

Can someone make a mediafire mirror?

User avatar
5eraph
Site Admin
Posts: 4618
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Wed Jan 26, 2011 2:54 pm

MediaFire Mirror:

User avatar
George King
Posts: 34
Joined: Mon Dec 01, 2008 10:25 am
Location: cs-CZ

Post by George King » Wed Jan 26, 2011 5:07 pm

Thanks a lot

User avatar
ricktendo64
Posts: 3213
Joined: Mon May 22, 2006 12:27 am
Location: Honduras

Post by ricktendo64 » Mon May 23, 2011 5:21 pm

File deleted, thanks for the mirror

User avatar
5eraph
Site Admin
Posts: 4618
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Mon May 23, 2011 8:00 pm

You're welcome. Mirror has been added to first post to make it easier to find.

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Tue Jun 28, 2011 10:27 pm

updated.
Image
My work list(Hosted by dumpydooby)

bobotlito
Posts: 57
Joined: Mon Oct 22, 2007 10:32 am
Location: singapore

Post by bobotlito » Fri Jul 01, 2011 5:26 am

Thanks a lot. :D

Post Reply