[Addon] Microsoft .NET Framework Family 3.5 SP1 - 20131008

Discuss & post Update Pack addons here.
Post Reply
User avatar
mr_smartepants
Posts: 824
Joined: Thu May 18, 2006 5:56 am
Location: Cambridgeshire, UK

Post by mr_smartepants » Sat Jun 20, 2009 3:29 pm

As long as the .net install takes place prior to those apps being installed, you should have no problems because this .net installer takes care of all the registry entries without the need of a restart.
Image
Some heroes don't wear capes, they wear Kevlar and dog-tags!

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Sat Jun 20, 2009 4:13 pm

jaynbe wrote:My question was related to CDburnerXP wich needs dotNET2.0 prior to install.
But Paint.net and Areca (backup prog) also need this.
But I agree that there are other options, one can change habits.
convert those installs to happen not from svcpack(t13) but during ROE after the .net install and you will be fine.

tamas970
Posts: 16
Joined: Wed Feb 06, 2008 4:05 am

Post by tamas970 » Thu Jun 25, 2009 2:56 am

KB963707 (Update to .NET Framework 3.5 Service Pack 1 for the .NET Framework Assistant 1.0 x86) Came out, and I couldn't install it. User_hidden, could you please include this one in the pack too?

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Thu Jun 25, 2009 8:16 am

tamas970 wrote:KB963707 (Update to .NET Framework 3.5 Service Pack 1 for the .NET Framework Assistant 1.0 x86) Came out, and I couldn't install it. User_hidden, could you please include this one in the pack too?
that update will ONLY install if you use firefox browser.
it will not be included in the pack.

In the .NET Framework 3.5 SP1, the .NET Framework Assistant enables Firefox to use the ClickOnce technology that is included in the .NET Framework. The .NET Framework Assistant is added at the computer level so that its functionality can be used by all users at the computer level instead of at the user level. As a result, the Uninstall button is unavailable in the Firefox Add-ons menu because standard users are not permitted to uninstall machine-level components.

tamas970
Posts: 16
Joined: Wed Feb 06, 2008 4:05 am

Post by tamas970 » Fri Jun 26, 2009 2:58 am

Thx for the deatailed info User_hidden:) I have opera on that machine, I don't know why Microsoft Update thought i should install it :shock:

jaynbe
Posts: 277
Joined: Mon Apr 27, 2009 1:37 pm

Post by jaynbe » Fri Jun 26, 2009 3:21 am

It seems MS is pushing kb963707 to all systems with dotNET3.5; even though I have only IE8 on a fresh install (no other browsers)

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Fri Jun 26, 2009 7:58 am

jaynbe wrote:It seems MS is pushing kb963707 to all systems with dotNET3.5; even though I have only IE8 on a fresh install (no other browsers)
yes it will prompt on most systems but will NOT install.

a MS snafu !

User avatar
avexmode
Posts: 47
Joined: Tue Sep 16, 2008 3:12 pm

Post by avexmode » Mon Jun 29, 2009 1:48 am

Can you please make a non-rs link for RVMi. I don't know BUT for some weird reason I cannot finished downloading this in rs. when its almost 97% it stop. It already happened twice using IDM and jdownloader.

Jimvr4
Posts: 7
Joined: Sat Sep 13, 2008 8:49 pm

Post by Jimvr4 » Mon Jun 29, 2009 11:53 am

I've been trying to use nLite to integrate the kb963707 fix. Should I be using RVMi or does it matter?

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Mon Jun 29, 2009 12:15 pm

Jimvr4 wrote:I've been trying to use nLite to integrate the kb963707 fix. Should I be using RVMi or does it matter?
haven't looked at it since it is a frivolous update for firefox browser.

i would presume that during integration firefox would have to be installed at svcpack(t13) then my net35 installer at the ROE stage and then the KB863707 after that to take effect. otherwise KB963707 won't install.

integrating the hotfix with nlite would probably place it to run at t13 and that is why at the end of your install kb963707 isn't installed.

User avatar
beats
Posts: 772
Joined: Tue Nov 27, 2007 4:11 am
Location: Netherlands

Post by beats » Mon Jun 29, 2009 2:10 pm

avexmode wrote:It already happened twice using IDM and jdownloader.
Try downloading from RS without a download manager, since RS doesn't like them too much (unless you get a payed account).
user_hidden wrote:integrating the hotfix with nlite would probably place it to run at t13 and that is why at the end of your install kb963707 isn't installed.
I did try kb963707 manually from cmdlinex.txt (t12) and it worked flawless. But I've integrated kb963707 in my NetFXAIO now, so that's even better. ;)

adam555
Posts: 3
Joined: Mon May 04, 2009 8:47 am

great one

Post by adam555 » Mon Jun 29, 2009 2:13 pm

Works like a charm, no probs here...
And the whole installation seems a lot faster then Stimpy's AIO Pack
-Installed with RunOnceEx using -ai1 switch-
THX... :rolleyes:

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Wed Jul 15, 2009 3:06 pm

updated v1.01 20090705 .....

User avatar
DaRk MaDnEsS
Posts: 168
Joined: Fri Oct 10, 2008 4:15 pm
Location: Port Said,Egypt

Post by DaRk MaDnEsS » Thu Jul 16, 2009 7:26 am

is kb963707 included ?? or no

if not is there any way to hide it in windows update

and thx for the addon

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Thu Jul 16, 2009 7:30 am

DaRk MaDnEsS wrote:is kb963707 included ?? or no

if not is there any way to hide it in windows update

and thx for the addon
it is not included.
kb963707 will only install if firefox is installed.
it will fail otherwise.
personally i think MS snafu'd on this one pushing it to non-firefox pc's.

when i have some time i will look into how to stub the registry to stop the MU nag.

User avatar
armond
Posts: 263
Joined: Tue Sep 13, 2005 11:43 am
Location: Glendale, CA USA

Post by armond » Thu Jul 16, 2009 12:24 pm

Hi, user_hidden,
When integrating this addon with the Onepiece XP Post-SP3 AIO Update Pack v2.6.0, I'm receiving a lot of error messages after install. Messages like "*.dll could not be loaded" or "The program could not be loaded because *.dll was not found". This is my first problem with Onepiece update pack.
I'm only using Onepiece XP Post-SP3 Update Pack with this addon. I guess that sysoc.inf doesnt execute correctly.
Any suggestions?
Thanks.

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Thu Jul 16, 2009 2:16 pm

what package did you integrate with onepiece update pack?
meaning did you use the Addon or the standalone installer.
if you used the standalone installer make sure you are installing from RunOnceEx.
If you are using the Addon perhaps my addon and onepiece package RunOnceEx are in conflict.
If the conflict is at ROE than the addon can be openned and set to another key than SETUP.

maybe there are some others that use Onepiece pack and can tell you what key they use for a non conflicting ROE install.

User avatar
armond
Posts: 263
Joined: Tue Sep 13, 2005 11:43 am
Location: Glendale, CA USA

Post by armond » Thu Jul 16, 2009 2:52 pm

Thanks for your reply.
You told that the addon is not for SVCPACK. Really why?
Then, Are there any way to run it from SVCPACK?
This is a very nice addon and I want to use it.
Thanks.

User avatar
beats
Posts: 772
Joined: Tue Nov 27, 2007 4:11 am
Location: Netherlands

Post by beats » Thu Jul 16, 2009 3:53 pm

kb963707 will only install if firefox is installed.
it will fail otherwise.
With all the respect, but what makes you think so? I use a selfmade .Net AIO, with KB963707 integrated, and it installs just fine.

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Thu Jul 16, 2009 4:08 pm

beats wrote:
kb963707 will only install if firefox is installed.
it will fail otherwise.
With all the respect, but what makes you think so? I use a selfmade .Net AIO, with KB963707 integrated, and it installs just fine.

I can not get KB963707 to install on my systems nor on any VM's !
I have as well integrated it into the net35sp1 stand alone MSI and during
install it will fail as well.

I can sit here all day and maually try and instal or goto MU and try and it will fail every time.

I agree it is kind of strange. I haven't spent too much time on this project
but if there is an answer I would love to incorporate it.

Maybe PM me a link to your pack so i can see.

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Thu Jul 16, 2009 4:13 pm

armond wrote:Thanks for your reply.
You told that the addon is not for SVCPACK. Really why?
Then, Are there any way to run it from SVCPACK?
This is a very nice addon and I want to use it.
Thanks.
NO svcpack(t13) install for net family 3.5sp1 or you will get all types of errors on install and perhaps unknown problems afterwards.

The addon download will add the installer to a RunOnceEx sequence.
It is placed at the key SETUP. You would have to check with OnePiece
what keys he uses so we can suggest one for you. To be safe you can unpack the addon, uncab the inf file and change the SETUP key to XXX.
recab the inf then repack the addon. That should presumably suffice and place the install last or near last in the ROE process.

User avatar
beats
Posts: 772
Joined: Tue Nov 27, 2007 4:11 am
Location: Netherlands

Post by beats » Thu Jul 16, 2009 4:17 pm

Ok, I'll upload it somewhere tomorrow at work (100MB upstream FTW), since I don't have that much upstream at home, and PM you the link.

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Thu Jul 16, 2009 4:37 pm

beats wrote:Ok, I'll upload it somewhere tomorrow at work (100MB upstream FTW), since I don't have that much upstream at home, and PM you the link.
appreciate it so i can see what is going on.

in the mean time i just downloaded and installed Firefox 3.5.1.
ran KB963707 after and this is the error:
"None of the products that are addressed by this software update are installed on this computer. Click Cancel to exit setup."

removing firefox :!:

User avatar
DaRk MaDnEsS
Posts: 168
Joined: Fri Oct 10, 2008 4:15 pm
Location: Port Said,Egypt

Post by DaRk MaDnEsS » Thu Jul 16, 2009 7:28 pm

user_hidden wrote:
beats wrote:Ok, I'll upload it somewhere tomorrow at work (100MB upstream FTW), since I don't have that much upstream at home, and PM you the link.
appreciate it so i can see what is going on.

in the mean time i just downloaded and installed Firefox 3.5.1.
ran KB963707 after and this is the error:
"None of the products that are addressed by this software update are installed on this computer. Click Cancel to exit setup."

removing firefox :!:
same happend to me it installed through windows update but can't install it manually and sorry for making trouble to you :rolleyes:

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Thu Jul 16, 2009 8:22 pm

DaRk MaDnEsS wrote:same happend to me it installed through windows update but can't install it manually and sorry for making trouble to you :rolleyes:
no trouble whatsoever.

like all i would like to get to the bottom of this, to either find out why or why not it does or does not install on some systems. even just to stub the registry for the MU nag.

User avatar
beats
Posts: 772
Joined: Tue Nov 27, 2007 4:11 am
Location: Netherlands

Post by beats » Sat Jul 18, 2009 7:18 am

user_hidden wrote:appreciate it so i can see what is going on.
You've got a PM. ;)

User avatar
Stefhan
Posts: 78
Joined: Sun Feb 18, 2007 10:16 pm
Location: Groningen (NL)

Post by Stefhan » Sat Jul 18, 2009 11:04 am

I've got the solution for the KB963707 appearing in MU

MU only checks if this file exist or not:

Code: Select all

%SystemRoot%\Microsoft.NET\Framework\v3.5\Windows Presentation Foundation\DotNetAssistantExtension\MicrosoftDotNetFrameworkAssistant.xpi
It can be an empty file.

If you want to check it out for yourself:
you need to have .net35sp1 and firefox 3.5.1 installed.
the hotfixinstaller also checks if this reg. key exists:
HKCR\CLSID\ec8030f7-c20a-464f-9b0e-13a3a9e97384\
only then you can install the hotfix.

User avatar
beats
Posts: 772
Joined: Tue Nov 27, 2007 4:11 am
Location: Netherlands

Post by beats » Sat Jul 18, 2009 3:28 pm

Stefhan wrote:you need to have .net35sp1 and firefox 3.5.1 installed.
the hotfixinstaller also checks if this reg. key exists:
HKCR\CLSID\ec8030f7-c20a-464f-9b0e-13a3a9e97384\
only then you can install the hotfix.
Interesting find. I just checked, but I don't have ec8030f7-c20a-464f-9b0e-13a3a9e97384 in HKCR\CLSID. Or anywhere else in the registry for that matter. Yet I do have KB963707, Net 3.5sp1 and Firefox 3.5.1 installed. :?

User avatar
Stefhan
Posts: 78
Joined: Sun Feb 18, 2007 10:16 pm
Location: Groningen (NL)

Post by Stefhan » Sat Jul 18, 2009 4:23 pm

@ Beats
Maybe there's another clsid or specific requirement that also works.
Or maybe it's because the integrated kb963707 from your custom .net3.5 is forced to install.
The main thing is that someone can install the hotfix so it can be monitored, and that key did the trick for me.

User avatar
beats
Posts: 772
Joined: Tue Nov 27, 2007 4:11 am
Location: Netherlands

Post by beats » Sat Jul 18, 2009 4:39 pm

Microsoft should do a re-release of the 3.5sp1 package AND stick to their own MSI packaging guidelines. With the AIP I've made I can't slipstream a few of the hotfix MSP files (it would save at least 15MB for the SFX). Well, it works, but then WU/MU thinks I don't have KB951847 installed. Somehow, some of the MSP's mess up the MSI's. Running them from 'baseline.dat' however, does work as intended. The NetFX distribution is a freaking mess. lol.

User avatar
compstuff
Posts: 464
Joined: Fri Aug 11, 2006 3:25 pm
Location: Florida

Post by compstuff » Sat Jul 18, 2009 8:47 pm

Stefhan wrote:I've got the solution for the KB963707 appearing in MU

MU only checks if this file exist or not:

Code: Select all

%SystemRoot%\Microsoft.NET\Framework\v3.5\Windows Presentation Foundation\DotNetAssistantExtension\MicrosoftDotNetFrameworkAssistant.xpi
It can be an empty file.
I created an empty file as mention and it worked like a charm... no more KB963707 appearing in MU
THANKS :D

User avatar
laddanator
Posts: 131
Joined: Thu Jan 17, 2008 9:26 pm
Location: virginia

Empty file

Post by laddanator » Sat Jul 18, 2009 10:08 pm

I created an empty file as mention and it worked like a charm... no more KB963707 appearing in MU
THANKS
Sorry if I sound like a noob but what kinda empty file did you create like a batch file or something to run at t-13 sorry if I missed something
"I'LL BE BACK"

User avatar
compstuff
Posts: 464
Joined: Fri Aug 11, 2006 3:25 pm
Location: Florida

Post by compstuff » Sat Jul 18, 2009 10:32 pm

no no much easier than that Lad ...just created an emtpy text file and renamed it to MicrosoftDotNetFrameworkAssistant.xpi during a simple test and it worked as stated so now (I have very limited skills) I will create a cmd file that runs during runonceex:

Code: Select all

type nul>"C:\WINDOWS\Microsoft.NET\Framework\v3.5\Windows Presentation Foundation\DotNetAssistantExtension\MicrosoftDotNetFrameworkAssistant.xpi"

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Sat Jul 18, 2009 11:31 pm

added a v1.02 which is the same as 1.01 but has KB963707 MU nag supression fix for those that do not have Firefox installed.

thanks goes to STEFHAN for pointing it out.
Last edited by user_hidden on Sat Jul 18, 2009 11:38 pm, edited 1 time in total.

User avatar
compstuff
Posts: 464
Joined: Fri Aug 11, 2006 3:25 pm
Location: Florida

Post by compstuff » Sat Jul 18, 2009 11:36 pm

user_hidden wrote:added a v1.02 which is the same as 1.01 but has KB963707 MU nag supression fix for those that do not have Firefox installed.

thanks goes to STEFHAN for pinting it out.
Where did you add it???

Never mind... I must have caught you while you were updating... THANKS VERY MUCH FOR THIS!!!

User avatar
laddanator
Posts: 131
Joined: Thu Jan 17, 2008 9:26 pm
Location: virginia

Fix

Post by laddanator » Mon Jul 20, 2009 10:26 am

I've got the solution for the KB963707 appearing in MU

MU only checks if this file exist or not:
Code:
%SystemRoot%\Microsoft.NET\Framework\v3.5\Windows Presentation Foundation\DotNetAssistantExtension\MicrosoftDotNetFrameworkAssistant.xpi

It can be an empty file.

If you want to check it out for yourself:
you need to have .net35sp1 and firefox 3.5.1 installed.
the hotfixinstaller also checks if this reg. key exists:
HKCR\CLSID\ec8030f7-c20a-464f-9b0e-13a3a9e97384\
only then you can install the hotfix.
Very good fix I dont use firefox much anyway but one thing I notice in firefox the update shows up under tool>add-ons>extensions but you still cannot enable it and says not compatiable with 3.5.1 so really this fix just removes the update from showing up in MU or am I missing something

Thank you for this fix
"I'LL BE BACK"

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Re: Fix

Post by user_hidden » Mon Jul 20, 2009 1:42 pm

laddanator wrote: Very good fix I dont use firefox much anyway but one thing I notice in firefox the update shows up under tool>add-ons>extensions but you still cannot enable it and says not compatiable with 3.5.1 so really this fix just removes the update from showing up in MU or am I missing something

Thank you for this fix

1.02 does NOT add KB963707 but only supresses the MU nag for it.

User avatar
laddanator
Posts: 131
Joined: Thu Jan 17, 2008 9:26 pm
Location: virginia

Post by laddanator » Tue Jul 21, 2009 3:58 pm

user_hidden WROTE
1.02 does NOT add KB963707 but only supresses the MU nag for it
Good deal, will this hotfix become a true install in future releases of this addon like I said I dont use firefox much anyway, just O C D in me for everything to be installed correctly lol

Thanks user_hidden for this addon I just started using it last week and I have to tell you this one is the best by far thanks so much
"I'LL BE BACK"

User avatar
niuus
Posts: 15
Joined: Mon Dec 24, 2007 5:16 pm

Post by niuus » Wed Jul 22, 2009 8:47 am

Since i haven't got lucky yet with any NET framework addon in XP64, i'm gonna try this and post the results. Fingers crossed!
"Piensa y actúa, comienza por ti"
"Think and act, begin with yourself"

MoBo: Fatal1ty F-I90HD / CPU: C2Q 6600 2.4@2.8GHz / RAM: Corsair 6GB DDR2@800 / Video: Radeon HD2600XT / OS: XP SP3+

User avatar
DaRk MaDnEsS
Posts: 168
Joined: Fri Oct 10, 2008 4:15 pm
Location: Port Said,Egypt

Post by DaRk MaDnEsS » Wed Jul 22, 2009 9:51 am

niuus wrote:Since i haven't got lucky yet with any NET framework addon in XP64, i'm gonna try this and post the results. Fingers crossed!
well i think most of this addon has removed X64 from it to make it a little size

i think there is some files that gets removed maybe some one will tell you how to do it

User avatar
niuus
Posts: 15
Joined: Mon Dec 24, 2007 5:16 pm

Post by niuus » Wed Jul 22, 2009 10:22 am

DaRk MaDnEsS wrote:
niuus wrote:Since i haven't got lucky yet with any NET framework addon in XP64, i'm gonna try this and post the results. Fingers crossed!
well i think most of this addon has removed X64 from it to make it a little size

i think there is some files that gets removed maybe some one will tell you how to do it
Well, didn't worked. Know one that works?
"Piensa y actúa, comienza por ti"
"Think and act, begin with yourself"

MoBo: Fatal1ty F-I90HD / CPU: C2Q 6600 2.4@2.8GHz / RAM: Corsair 6GB DDR2@800 / Video: Radeon HD2600XT / OS: XP SP3+

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Wed Jul 22, 2009 6:08 pm

niuus wrote:Since i haven't got lucky yet with any NET framework addon in XP64, i'm gonna try this and post the results. Fingers crossed!
This is an x86 (32bit) Windows XP ONLY !

It is marked as such in the first post.

User avatar
niuus
Posts: 15
Joined: Mon Dec 24, 2007 5:16 pm

Post by niuus » Fri Jul 24, 2009 6:53 pm

user_hidden wrote:
niuus wrote:Since i haven't got lucky yet with any NET framework addon in XP64, i'm gonna try this and post the results. Fingers crossed!
This is an x86 (32bit) Windows XP ONLY !

It is marked as such in the first post.
It's ok, i just had a glimmer of hope :P
"Piensa y actúa, comienza por ti"
"Think and act, begin with yourself"

MoBo: Fatal1ty F-I90HD / CPU: C2Q 6600 2.4@2.8GHz / RAM: Corsair 6GB DDR2@800 / Video: Radeon HD2600XT / OS: XP SP3+

jaynbe
Posts: 277
Joined: Mon Apr 27, 2009 1:37 pm

Post by jaynbe » Mon Jul 27, 2009 1:58 pm

niuus,
you could look here (second post in the topic)
http://www.ryanvm.net/forum/viewtopic.php?t=6419
I hope this will work for you

User avatar
DaRk MaDnEsS
Posts: 168
Joined: Fri Oct 10, 2008 4:15 pm
Location: Port Said,Egypt

Post by DaRk MaDnEsS » Wed Jul 29, 2009 5:14 am

well you should try this topic

it should include what you need

http://www.wincert.net/forum/index.php? ... entry52055

User avatar
galileo
Posts: 106
Joined: Sun Apr 22, 2007 8:11 pm
Location: Charlotte, NC USA

Post by galileo » Sun Aug 02, 2009 1:29 pm

@user_hidden

...might want to take a look at your 1.02 version "Install.vbs" at line 108...it generates a VBScript error when installing to a drive other than "C:"...see below:

FSO.CopyFile "dotNET35SP1\KB963707\MicrosoftDotNetFrameworkAssistant.xpi", "C:\Windows\Microsoft.NET\Framework\v3.5\Windows Presentation Foundation\DotNetAssistantExtension\",TRUE

...you have hard coded the drive letter into the script... :wink:...might want to "tweak" that one... :D

And, as always, THANKS, for your personal effort and graciousness in offering your time to....well, the world!!!

galileo

User avatar
Pasha_ZZZ
Posts: 242
Joined: Thu Jul 13, 2006 6:27 am
Location: Russia, Slobodskoy

Post by Pasha_ZZZ » Mon Aug 03, 2009 4:07 am

galileo wrote:@user_hidden
...might want to take a look at your 1.02 version "Install.vbs" at line 108...it generates a VBScript error when installing to a drive other than "C:"
& there is another problem - my Windows installs into non-default directory. Solution:
Replace

Code: Select all

Dim BitsState, SpoolerState, BitsMode, SpoolerMode
Set ws = WScript.CreateObject("WScript.Shell")
with

Code: Select all

Dim BitsState, SpoolerState, BitsMode, SpoolerMode, WSE, SR
Set ws = WScript.CreateObject("WScript.Shell")
Set WSE = ws.Environment("Process")
SR = WSE("SystemRoot")
& replace

Code: Select all

FSO.CopyFile "dotNET35SP1\KB963707\MicrosoftDotNetFrameworkAssistant.xpi", "C:\Windows\Microsoft.NET\Framework\v3.5\Windows Presentation Foundation\DotNetAssistantExtension",TRUE
with

Code: Select all

FSO.CopyFile "dotNET35SP1\KB963707\MicrosoftDotNetFrameworkAssistant.xpi", SR & "\Microsoft.NET\Framework\v3.5\Windows Presentation Foundation\DotNetAssistantExtension",TRUE

User avatar
Pasha_ZZZ
Posts: 242
Joined: Thu Jul 13, 2006 6:27 am
Location: Russia, Slobodskoy

Post by Pasha_ZZZ » Mon Aug 03, 2009 5:18 am

Or you can download repacked addon here:
<link removed>
You can download version 1.02.1 at the 1st post.
Last edited by Pasha_ZZZ on Mon Aug 03, 2009 11:29 am, edited 1 time in total.

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Mon Aug 03, 2009 8:33 am

thanks guys (galileo & pasha_zzz) it was a very quick fix that was done when released. just wasn't thinking when I placed the absolute path.

i will update the installers.

check first post version 1.02.1 .....

User avatar
SymSpaceT
Posts: 114
Joined: Thu Jan 24, 2008 5:56 pm

Post by SymSpaceT » Mon Aug 03, 2009 5:06 pm

Hello folks,

I have a couple of noob questions:

1. why isn't .Net 1.1 included?

2. So this is a "switchless" (less the two switches) installer to be put either in RunonceEx or GuiRunOnce (with one of the switches)?

3. (Generic) What is the difference between RunonceEx and GuiRunOnce?


Thanks for your time:

SST

Post Reply