[Release] .NET 2.0-3.0-3.5 GDR/QFE TRUE addons xp/2k3 x86

Discuss & post Update Pack addons here.
User avatar
vioplujjnsjzfg
Posts: 131
Joined: Mon Jul 07, 2008 12:07 pm

Post by vioplujjnsjzfg » Fri Aug 27, 2010 10:57 am

First of all, I can't believe I just found this 'True' Addon.:mrgreen: I was excited to give it a try, but
have noticed a few peculiarities. I currently use User_Hidden's Update Pack and integrated it,
along with this update on a clean SP3 image with RVMi. Next, I use nLite to apply tweaks and
a few addons. However, when I use this Addon, I am now getting a separate 'Windows
Update' shortcut (in addition to the Microsoft Update shortcut) in my Start Menu.

Is this normal behavior, or is something else happening that's causing this?

User avatar
nonno fabio
Posts: 1627
Joined: Mon Jun 06, 2005 10:36 am
Location: Northern Italy
Contact:

Post by nonno fabio » Sun Aug 29, 2010 9:52 am

vioplujjnsjzfg wrote:First of all, I can't believe I just found this 'True' Addon.:mrgreen: I was excited to give it a try, but
have noticed a few peculiarities. I currently use User_Hidden's Update Pack and integrated it,
along with this update on a clean SP3 image with RVMi. Next, I use nLite to apply tweaks and
a few addons. However, when I use this Addon, I am now getting a separate 'Windows
Update' shortcut (in addition to the Microsoft Update shortcut) in my Start Menu.

Is this normal behavior, or is something else happening that's causing this?
.net 3.5 addon don't add WU/MU shortcuts. Maybe some IE tweak in Nlite...?
Don't ask for a different configuration of Onepiece's XP AIO Update Pack: use one of the existing vanilla XP UpdatePack with your preferred addons instead

AndreyPopov
Posts: 54
Joined: Mon Sep 24, 2007 8:25 am

Post by AndreyPopov » Mon Aug 30, 2010 8:23 am

Windows Update shortcut is by default

Microsoft Update may be added by nLite Tweaks section
Windows Update shotrcut hide also avaible by nLite Tweaks section.

WHEH you aooly nLite tweaks section before or after addon integraion?

I ALWAYS use nLite Tweaks section after ALL addon inegration!

User avatar
=[FEAR]=JIGSAW
Posts: 385
Joined: Mon Feb 18, 2008 11:54 am
Location: Cape Town, South Africa

Post by =[FEAR]=JIGSAW » Tue Aug 31, 2010 4:56 am

Don't think this have anything to do with nLite.....

I don't use nLite at all .... only RVMI & also get both (WU/MU) shortcuts in start menu ....

could just be an addon i'm using ???

ya.vosya
Posts: 3
Joined: Sun Mar 28, 2010 10:32 am

Post by ya.vosya » Thu Sep 02, 2010 11:59 pm

nonno fabio

Errors in MedCtrOC.log (Win XP MCE2005)
________________________________________________

Self-registering assemblies ...
-------------------------------
No file to process in inf section [EHome_Self_Registering]
Executing line "C: \ WINDOWS \ system32 \ regsvr32.exe / s C: \ WINDOWS \ system32 \ sbe.dll"
Warning: Process Return Value is 0x00000005 -> Access is denied.

Error: Failed to apply command to sbe.dll (return value: 0x00000005).

Executing line "C: \ WINDOWS \ system32 \ regsvr32.exe / s C: \ WINDOWS \ system32 \ quartz.dll"
Warning: Process Return Value is 0x00000005 -> Access is denied.

Error: Failed to apply command to quartz.dll (return value: 0x00000005).

Executing line "C: \ WINDOWS \ system32 \ regsvr32.exe / s C: \ WINDOWS \ system32 \ encdec.dll"
Warning: Process Return Value is 0x00000005 -> Access is denied.

Error: Failed to apply command to encdec.dll (return value: 0x00000005).

Executing line "C: \ WINDOWS \ system32 \ regsvr32.exe / s C: \ WINDOWS \ system32 \ VBICodec.ax"
Warning: Process Return Value is 0x00000005 -> Access is denied.

Error: Failed to apply command to VBICodec.ax (return value: 0x00000005).

Executing line "C: \ WINDOWS \ system32 \ regsvr32.exe / s C: \ WINDOWS \ system32 \ WSTPager.ax"
Warning: Process Return Value is 0x00000005 -> Access is denied.

Error: Failed to apply command to WSTPager.ax (return value: 0x00000005).

Executing line "C: \ WINDOWS \ system32 \ regsvr32.exe / s C: \ WINDOWS \ system32 \ WSTRenderer.ax"
Warning: Process Return Value is 0x00000005 -> Access is denied.

Error: Failed to apply command to WSTRenderer.ax (return value: 0x00000005).

Executing line "C: \ WINDOWS \ system32 \ regsvr32.exe / s C: \ WINDOWS \ system32 \ Mpeg2Data.ax"
Warning: Process Return Value is 0x00000005 -> Access is denied.

Error: Failed to apply command to Mpeg2Data.ax (return value: 0x00000005).

Executing line "C: \ WINDOWS \ system32 \ regsvr32.exe / s C: \ WINDOWS \ system32 \ msvidctl.dll"
________________________________________________

any ideas?

User avatar
OnePiece Alb
Posts: 525
Joined: Sat Sep 01, 2007 7:01 pm
Location: Albania
Contact:

Post by OnePiece Alb » Fri Sep 03, 2010 1:05 am

Do this with NetFx20.inf
http://www.ryanvm.net/forum/viewtopic.p ... 929#106929


or
extract the addon, and add this line in entries.ini

Code: Select all

;This section allows you to edit things that normally would not be possible to edit.
[ExtraFileEdits] 
NETFX20.inf|wbem,com,netfx11|wbem,com,SonicDVDandCDBurning,netfx11|1
Ciao.

ya.vosya
Posts: 3
Joined: Sun Mar 28, 2010 10:32 am

Post by ya.vosya » Fri Sep 03, 2010 2:48 am

OnePiece Alb

Code: Select all

in:
[NETFX11]
OptionDesc = "Microsoft. NET Framework"
Tip = "Microsoft. NET Framework"
Modes = 0,1,2,3
Needs = wbem, com, SonicDVDandCDBurning

Code: Select all

in:
[NETFX20]
OptionDesc = "Microsoft. NET Framework"
Tip = "Microsoft. NET Framework"
Modes = 0,1,2,3
Needs = wbem, com, SonicDVDandCDBurning, netfx11
This does not work:)

User avatar
OnePiece Alb
Posts: 525
Joined: Sat Sep 01, 2007 7:01 pm
Location: Albania
Contact:

Post by OnePiece Alb » Fri Sep 03, 2010 2:59 am

@All
Nonno Fabio and holidays (will return after 3 weeks), with my English (Google traslantor), there it impossible to explain certain things that are a bit delicate to explain

@ya.vosya
respect to the dotnet addon, then he meant that something is not right there in your CD

read this post here http://www.ryanvm.net/forum/viewtopic.p ... 893#106893 try to do so, Skram not found problems http://www.ryanvm.net/forum/viewtopic.p ... 975#106975

Ciao.

nikanuka
Posts: 11
Joined: Wed Aug 05, 2009 8:17 am
Location: georgia

Post by nikanuka » Wed Oct 13, 2010 3:05 am

there are 2 new updates for .NET
please update

nikanuka
Posts: 11
Joined: Wed Aug 05, 2009 8:17 am
Location: georgia

Post by nikanuka » Thu Oct 14, 2010 3:25 am

Security Update for Microsoft .NET Framework 2.0 SP2 and 3.5 SP1 on Windows Server 2003 and Windows XP x86 (KB2418241)


Security Update for Microsoft .NET Framework 3.5 SP1 on Windows XP, Windows Server 2003, Windows Vista, Windows Server 2008 x86 (KB2416473)

User avatar
nonno fabio
Posts: 1627
Joined: Mon Jun 06, 2005 10:36 am
Location: Northern Italy
Contact:

Post by nonno fabio » Thu Oct 14, 2010 12:14 pm

updated .Net true addons are already done and tested.

They will be released as soon as possible.
Don't ask for a different configuration of Onepiece's XP AIO Update Pack: use one of the existing vanilla XP UpdatePack with your preferred addons instead

theodoresdr
Posts: 7
Joined: Thu Oct 21, 2010 7:19 am

Post by theodoresdr » Fri Oct 22, 2010 5:35 pm

When is the new updated addon expected to be released?
We are all looking forward to it...

Thanks for the great job!

User avatar
nonno fabio
Posts: 1627
Joined: Mon Jun 06, 2005 10:36 am
Location: Northern Italy
Contact:

Post by nonno fabio » Sat Oct 23, 2010 5:41 am

they aren't officially released yet but already available in voidseesaw's onepiece repository http://voidseesaw.com/onepiece/
Don't ask for a different configuration of Onepiece's XP AIO Update Pack: use one of the existing vanilla XP UpdatePack with your preferred addons instead

pdl808
Posts: 58
Joined: Sat Dec 01, 2007 3:13 pm
Location: Milpitas, CA USA

Post by pdl808 » Sun Oct 24, 2010 10:11 pm

Can somebody explain how to download the files from voidseesaw's onepiece repository?

When I click on any of the links, all I get is a screen full of non English characters.

User avatar
nonno fabio
Posts: 1627
Joined: Mon Jun 06, 2005 10:36 am
Location: Northern Italy
Contact:

Post by nonno fabio » Mon Oct 25, 2010 2:34 am

In FF right-click the desired link and choose "save target as..."
Don't ask for a different configuration of Onepiece's XP AIO Update Pack: use one of the existing vanilla XP UpdatePack with your preferred addons instead

pdl808
Posts: 58
Joined: Sat Dec 01, 2007 3:13 pm
Location: Milpitas, CA USA

Post by pdl808 » Tue Oct 26, 2010 12:26 am

Thanks for the info and all of your work.

Vista
Posts: 137
Joined: Tue Aug 23, 2005 8:02 pm

Post by Vista » Tue Oct 26, 2010 7:42 am

@nonno fabio, or anyone please answer, when i install .net 3.5 or 4.0 from file downloaded ms it automatically installs .net 1.0 , 1.1, 2.0 Sp1, 3.0 Sp1 ,3.5, and installs .net 4.0 .

so my question is if i integrate "OnePiece_Microsoft.NET_Framework_v4.0.30320.1_True_AddOn.cab " does it install .net 1.0, 1.1, 2.0, 3.0, 3.5 and install .net 4.0 ?? or does it just install .net 4.0 ??

or do i have to integrate
1. Microsoft.NET_Framework_v1.1.4322.2463.1_True_AddOn_ENU.cab
2. OnePiece_Microsoft.NET_Framework_v3.5.30729.196.2_True_AddOn_ENU.cab (includes 2.0, 3.0)
3. OnePiece_Microsoft.NET_Framework_v4.0.30320.1_True_AddOn_ENU.cab

to get all the .net version ??

User avatar
OnePiece Alb
Posts: 525
Joined: Sat Sep 01, 2007 7:01 pm
Location: Albania
Contact:

Post by OnePiece Alb » Tue Oct 26, 2010 7:57 am

serve to integrate all three addon

OnePiece_Microsoft.NET_Framework_v1.1.4322.2470_True_AddOn_ENU.cab
OnePiece_Microsoft.NET_Framework_v3.5.30729.3644_True_AddOn_ENU.cab
OnePiece_Microsoft.NET_Framework_v4.0.30319.206_True_AddOn_ENU.cab

Ciao.

Botus
Posts: 161
Joined: Sat Dec 22, 2007 12:47 pm
Location: UK

Post by Botus » Tue Oct 26, 2010 8:57 am

OnePiece Alb wrote: integrate all three addon....

OnePiece_Microsoft.NET_Framework_v4.0.30319.206_True_AddOn_ENU.cab
your net 4 looks older than the one Vista shows in post above > OnePiece_Microsoft.NET_Framework_v4.0.30320.1_True_AddOn_ENU.cab ???

and re voidseesaw's onepiece repository in IE8 save tartget as tries to give me a file that might be the right one but with file extension .htm ???

Vista
Posts: 137
Joined: Tue Aug 23, 2005 8:02 pm

Post by Vista » Tue Oct 26, 2010 10:05 pm

@Botus, i also got the .htm files, just rename to .cab and you are ok,
could anyone post the MD5 hash of the following files , so we could compare MD5 hash of new .net files available in voidseesaw's onepiece repository .

and why is the the new .net 4.0 available in voidseesaw's , has old version number then the old one.

1.OnePiece_Microsoft.NET_Framework_v1.1.4322.242470_True_AddOn_ENU
(C226E6ACF112375D7A85FF414B90B822)
2. OnePiece_Microsoft.NET_Framework_v3.5.30729.3644_True_AddOn_ENU
(D5B0A431E54A972D5838D23F9D778825)
3. OnePiece_Microsoft.NET_Framework_v4.0.30319.206_True_AddOn_ENU
(607269D8A530ACEC3CA77B714D58942F)
4.OnePiece_Microsoft.NET_Framework_v2.0.50727.3618_True_AddOn_ENU
(9F3CEFF3BFF80CB46D628A025A019EBF)
5. OnePiece_Microsoft.NET_Framework_v3.0.6920.4016.1_True_AddOn_ENU.cab
(F0AE7045C8F5FC42F0142FF7C83651A8)

@onepeice, could you please update the standalone IE8_addon and WMP_addon and other standalone packs if there any updates for them this month,

User avatar
nonno fabio
Posts: 1627
Joined: Mon Jun 06, 2005 10:36 am
Location: Northern Italy
Contact:

Post by nonno fabio » Wed Oct 27, 2010 10:15 am

From these releases, .net addons includes public hotfixes only. Odd but true, often WindowsUpdate doesn't recognize its own MS. .net request-only updates, so newer .net updates installation from WU/MU fails and you get an error message.

So new addons will have lower but safer version numbers. If you need higher versions, add optional QFE updates addon, but remember in this case you'll probably need to reinstall .net framework in case of new .net hotfixes

EDIT: 1st post updated
Don't ask for a different configuration of Onepiece's XP AIO Update Pack: use one of the existing vanilla XP UpdatePack with your preferred addons instead

User avatar
=[FEAR]=JIGSAW
Posts: 385
Joined: Mon Feb 18, 2008 11:54 am
Location: Cape Town, South Africa

Post by =[FEAR]=JIGSAW » Wed Oct 27, 2010 2:41 pm

Thanks

theodoresdr
Posts: 7
Joined: Thu Oct 21, 2010 7:19 am

Post by theodoresdr » Sat Oct 30, 2010 12:12 pm

Really silly question but after integration of the updated addon, Windows Components Wizard look like this

Image

The .NET Framework icon is replaced by this grey rhombus...

Is this normal or is there something wrong with my nlite session?
Would that create any problems with the framework installation?

Thanks!

User avatar
=[FEAR]=JIGSAW
Posts: 385
Joined: Mon Feb 18, 2008 11:54 am
Location: Cape Town, South Africa

Post by =[FEAR]=JIGSAW » Sun Oct 31, 2010 5:36 am

I'm using RVMI & my icons have always been like that (grey) with no problems to the stall / program.

I don't know how "nonno" got his to look different in his first post ???

User avatar
George King
Posts: 34
Joined: Mon Dec 01, 2008 10:25 am
Location: cs-CZ

Post by George King » Sun Oct 31, 2010 6:10 am

The answer is really easy. Icon index is saved in AddOnRes.dll

Look into INFs

Code: Select all

IconIndex    = *, AddOnRes.dll, 146
These addons doesn´t include AddOnRes.dll. I know the file is presented in AIO Update Pack and in some others addons...

And all working 100% without icon, its not a bug or something else.

theodoresdr
Posts: 7
Joined: Thu Oct 21, 2010 7:19 am

Post by theodoresdr » Sun Oct 31, 2010 9:09 am

The thing is that in August I created another cd with nlite using an earlier version of the .NET Framework addon (OnePiece_Microsoft.NET_Framework_v3.5.30729.196.2_True_AddOn_ENU.cab), where Windows Component Wizard looked exactly like nonno's screenshot.

So I wondered if it was the integration of other addons that resulted to this.

User avatar
nonno fabio
Posts: 1627
Joined: Mon Jun 06, 2005 10:36 am
Location: Northern Italy
Contact:

Post by nonno fabio » Wed Nov 03, 2010 11:42 am

If you really need those icons extract AddOnRes.dll file from XP UpdatePack and copy it inside .net addon, then add in entries.ini file these lines:

Code: Select all

;This section contains entries that need to go into the [Files] section of dosnet.inf
[Dosnet_Files]
d1,AddOnRes.dll

Code: Select all

;This section contains entries that need to go into the [WinntDirectories] section of txtsetup.sif
[Txtsetup_Files]
AddOnRes.dll = 100,,,,,,,32,0,0

Code: Select all

;This section contains a list of files in i386 which should be compressed at the very
;beginning of the integration process
[i386_compress]
rvmtemp\extracted\AddOnRes.dll
Don't ask for a different configuration of Onepiece's XP AIO Update Pack: use one of the existing vanilla XP UpdatePack with your preferred addons instead

Zoom7000
Posts: 98
Joined: Fri Jan 26, 2007 7:11 pm

Post by Zoom7000 » Thu Jan 20, 2011 7:57 am

nonno fabio, you said in the first post that this will give a working .Net Framework before T-13 however, the one program that I am installing that has .Net dependancies, Paint.NET 3.5.6, still fails to install. I have tried with Elite's Paint.NET addon with the same failure. It works for me when I use jd976's old .Net 3.5 AIO, but doesn't work with either your 3.5 True Addon or yumeyao's AIO.

Can you shed any light on this?

User avatar
nonno fabio
Posts: 1627
Joined: Mon Jun 06, 2005 10:36 am
Location: Northern Italy
Contact:

Post by nonno fabio » Thu Jan 20, 2011 12:13 pm

Got no time for an accurate testing but it seems that Paint.net setup routine need a running windows to work. Other programs requiring .net, like powershell, installs at T-13 without problems with Onepiece's addon and also Paint.net setup works flawlessly on a Xp installed from an updated source. I don't know why it works with jd976's old addon...
Don't ask for a different configuration of Onepiece's XP AIO Update Pack: use one of the existing vanilla XP UpdatePack with your preferred addons instead

User avatar
tr011_tmn
Posts: 4
Joined: Fri Aug 29, 2008 4:03 am
Location: Russia, Tyumen

Post by tr011_tmn » Wed Feb 02, 2011 2:26 am

nonno fabio good day. Apologize for my English. Encountered the following problem.
Integrate your addon ". Net 2.0 SP2 full in windose Server 2003 R2.
Integration is a great success, as well as installation. But after installing windose Update prompts you to install two updates:
WindowsServer2003-KB980195-x86-RUS and WindowsServer2003-KB2416400-x86-RUS.
Without integration your addon such a request does not appear.
Specifically set them again, and found that to write in the registry:
-KB980195:

Code: Select all

HKLM,"SOFTWARE\Microsoft\Internet Explorer\ActiveX Compatibility\{0002E510-0000-0000-C000-000000000046}","Compatibility Flags",0x10001,00,04,00,00
-KB2416400:

Code: Select all

HKLM,"SOFTWARE\Classes\SearchAssistantOC.SearchAssistantOC\CLSID",,0x0,"{2E71FD0F-AAB1-42c0-9146-6D2C4EDCF07D}"
HKLM,"SOFTWARE\Classes\SearchAssistantOC.SearchAssistantOC.1\CLSID",,0x0,"{2E71FD0F-AAB1-42c0-9146-6D2C4EDCF07D}"
HKLM,"SOFTWARE\Classes\ShellNameSpace.ShellNameSpace\CLSID",,0x0,"{2F2F1F96-2BC1-4b1c-BE28-EA3774F4676A}"
HKLM,"SOFTWARE\Classes\ShellNameSpace.ShellNameSpace.1\CLSID",,0x0,"{2F2F1F96-2BC1-4b1c-BE28-EA3774F4676A}"
HKLM,"SOFTWARE\Microsoft\Internet Explorer\ActiveX Compatibility\{183C259A-0480-11D1-87EA-00C04FC29D46}","Compatibility Flags",0x10001,00,04,00,04
Tell me where in your addon affected by these lines that would get rid of the query windose Update to install the updates.
Why you are cry,Oh my god,
Fucking this world,Devil is wrote

User avatar
nonno fabio
Posts: 1627
Joined: Mon Jun 06, 2005 10:36 am
Location: Northern Italy
Contact:

Post by nonno fabio » Wed Feb 02, 2011 3:46 am

Hi, DotNet Addon has nothing to do with this. You can verify by yourself by opening every .inf file inside the addon that these lines are not present.
It seems related to IE8 updates and maybe it has something to do with this http://www.wincert.net/forum/index.php? ... entry69990
Don't ask for a different configuration of Onepiece's XP AIO Update Pack: use one of the existing vanilla XP UpdatePack with your preferred addons instead

spawn
Posts: 88
Joined: Sat May 23, 2009 3:31 am

Post by spawn » Fri Feb 25, 2011 10:15 am

is there packs for x64?

User avatar
nonno fabio
Posts: 1627
Joined: Mon Jun 06, 2005 10:36 am
Location: Northern Italy
Contact:

Post by nonno fabio » Sun Feb 27, 2011 10:38 am

Don't ask for a different configuration of Onepiece's XP AIO Update Pack: use one of the existing vanilla XP UpdatePack with your preferred addons instead

maur0
Posts: 21
Joined: Fri Mar 12, 2010 11:08 am

Post by maur0 » Mon Feb 28, 2011 9:55 am

hi nonno fabio are plan to create this add-on framework to version x64 edition for xp x64 and 2003 x64 ?

User avatar
nonno fabio
Posts: 1627
Joined: Mon Jun 06, 2005 10:36 am
Location: Northern Italy
Contact:

Post by nonno fabio » Tue Mar 01, 2011 2:30 am

No, sorry
Don't ask for a different configuration of Onepiece's XP AIO Update Pack: use one of the existing vanilla XP UpdatePack with your preferred addons instead

User avatar
nonno fabio
Posts: 1627
Joined: Mon Jun 06, 2005 10:36 am
Location: Northern Italy
Contact:

Post by nonno fabio » Fri Apr 15, 2011 6:58 pm

updated
Don't ask for a different configuration of Onepiece's XP AIO Update Pack: use one of the existing vanilla XP UpdatePack with your preferred addons instead

User avatar
=[FEAR]=JIGSAW
Posts: 385
Joined: Mon Feb 18, 2008 11:54 am
Location: Cape Town, South Africa

Post by =[FEAR]=JIGSAW » Sun Apr 17, 2011 5:11 am

Thanks

User avatar
laddanator
Posts: 131
Joined: Thu Jan 17, 2008 9:26 pm
Location: virginia

KB2416447

Post by laddanator » Sun Apr 17, 2011 5:41 pm

Hello, after using the new 3.5 netframe true addon with the 1.1 true add on, a new 1.1 update is showing up in MU..KB2416447 and it was released in 2010 so not sure if something in the new 3.5 netframe addon is doing this or what? Thanks nonno fabio for the addons. Clean source XP Home. If I do not use the 3.5 true addon and just use the 1.1 ture addon, I do not get this nag for the KB2416447 update
"I'LL BE BACK"

User avatar
OnePiece Alb
Posts: 525
Joined: Sat Sep 01, 2007 7:01 pm
Location: Albania
Contact:

Post by OnePiece Alb » Sun Apr 17, 2011 5:57 pm

Hi laddanator, every netfx*.cab & netfx*.inf in Update Pack and in addons DotNet35 & DotNet11 and have the same Hash MD5, and I test or fate with the Update Pack (v4.4.0 or v4.5.0) ENU and ITA, everything was Ok

Ciao.

krick
Posts: 8
Joined: Sat Jun 13, 2009 12:19 am

Post by krick » Sat Apr 23, 2011 5:14 pm

I'm using Windows XP Professional x64 Edition SP2.

I want to slipstream dotnet 2.0 using nLite.

I'm not completely clear on whether I need to integrate dotnet 1.1 first...

http://www.ryanvm.net/forum/viewtopic.php?t=6512

Please advise.

Nevermind. I did a bit of digging and I believe that Windows Server 2003 shipped with .NET 1.1. And since XP Pro x64 is based on Server 2003, it probably already has 1.1 as well.

User avatar
nonno fabio
Posts: 1627
Joined: Mon Jun 06, 2005 10:36 am
Location: Northern Italy
Contact:

Post by nonno fabio » Thu Jun 16, 2011 3:21 am

updated
Don't ask for a different configuration of Onepiece's XP AIO Update Pack: use one of the existing vanilla XP UpdatePack with your preferred addons instead

User avatar
nonno fabio
Posts: 1627
Joined: Mon Jun 06, 2005 10:36 am
Location: Northern Italy
Contact:

Post by nonno fabio » Thu Aug 25, 2011 3:05 am

Updated with august hotfixes
Don't ask for a different configuration of Onepiece's XP AIO Update Pack: use one of the existing vanilla XP UpdatePack with your preferred addons instead

Rodommoc
Posts: 13
Joined: Thu Sep 14, 2006 4:59 pm
Location: PA

Post by Rodommoc » Thu Sep 15, 2011 9:16 am

All of your links are dead. They say the file was removed. Is it somewhere else?

User avatar
nonno fabio
Posts: 1627
Joined: Mon Jun 06, 2005 10:36 am
Location: Northern Italy
Contact:

Post by nonno fabio » Fri Sep 16, 2011 8:12 am

I guess Onepiece is updating them. Try here in the meantime.
Don't ask for a different configuration of Onepiece's XP AIO Update Pack: use one of the existing vanilla XP UpdatePack with your preferred addons instead

Rodommoc
Posts: 13
Joined: Thu Sep 14, 2006 4:59 pm
Location: PA

Post by Rodommoc » Fri Sep 16, 2011 9:58 am

Im doing 2 Server 2003 CDs STD & ENT with the following packs:
Addon_AdobeReader_1011.7z
Addon_Java_Runtime_7_update_00.7z
OnePiece_IE8_Win2K3SP2_v2.8.0_AddOn_ENU.7z
OnePiece_Microsoft.NET_Framework_v4.0.30319.237_True_AddOn_ENU.cab
OnePiece_Win2K3_Post-SP2_UpdatePack_v3.7.0_ENU.7z
_OnePiece_Microsoft.NET_Framework_v3.5.30729.3644.3_True_AddOn_ENU.cab

BTS driver packs.

After the install I checked the Components in Add/Remove Programs and the .NET 2.0 has a 0.0MB

And when I run MU I'm showing 26 updates including .Net 3, 3.5, & 4

KB958147
KB982168
KB246871

The same thing happened with Server 2003 STD as well as ENT

What am I missing or doing wrong?
Should I be adding the packs separately?

User avatar
nonno fabio
Posts: 1627
Joined: Mon Jun 06, 2005 10:36 am
Location: Northern Italy
Contact:

Post by nonno fabio » Mon Sep 19, 2011 8:38 am

try this: extract W2k3 UpdatePack, .net v3.5 and .net v4.0 addos then change every netfx*.inf and netfx*.cab in updatepack with newer ones from true addons.
Recompress again (better with CabTool) the Updatepack then integrate it with RVMi in an untouched w2k3 SP2 source with nothing else.
Test in a VM and report. If it works, add the other stuff (better one by one, if you want to identificate the culprit) and retest. Thank you
Don't ask for a different configuration of Onepiece's XP AIO Update Pack: use one of the existing vanilla XP UpdatePack with your preferred addons instead

Rodommoc
Posts: 13
Joined: Thu Sep 14, 2006 4:59 pm
Location: PA

Post by Rodommoc » Thu Sep 22, 2011 5:01 pm

nonno fabio wrote:try this: extract W2k3 UpdatePack, .net v3.5 and .net v4.0 addos then change every netfx*.inf and netfx*.cab in updatepack with newer ones from true addons.
Recompress again (better with CabTool) the Updatepack then integrate it with RVMi in an untouched w2k3 SP2 source with nothing else.
Test in a VM and report. If it works, add the other stuff (better one by one, if you want to identify the culprit) and retest. Thank you
I did this and now I’m getting this error:

ERROR: No entries*.ini found, Exiting

I tried numerous methods of slipstreaming:
Just the .net pack by itself, the 3.5 only, the 3.5 & the 4.0, & the 2.0 with 3.0 & 4.0 with nothing else
Tried a new Source d/l'ed from Microsoft
Then I did your method of extracting the packs and that is where I get the above error.
I read that replacing the netfx with a vanilla one before creating the ISO would work, it didn't.
I tried with & without driverpacks
With and without winnt.sif answer file

All the same result:
.net framework has 0.0mb in add/remove programs

XP works great; I just can’t get Server 2003 to work.
Any ideas would be much appreciated.
Mark

User avatar
nonno fabio
Posts: 1627
Joined: Mon Jun 06, 2005 10:36 am
Location: Northern Italy
Contact:

Post by nonno fabio » Fri Sep 23, 2011 2:44 am

.net works same way in XP and in Server 2003, is the same structure.

All of them are already included in W2k3 AIO updatepack, even if not updated, and they work flawlessly.

To recompress UpdatePack, highlight all files in folder, right-click and select "add to archive..." option in 7-zip/winrar/etc. menu

EDIT: A suggestion: you can see progress bars without clicking anything if you apply Classic mode Windows Setup tweak (in Nlite options)
Don't ask for a different configuration of Onepiece's XP AIO Update Pack: use one of the existing vanilla XP UpdatePack with your preferred addons instead

Asim_Omer
Posts: 44
Joined: Tue Oct 11, 2011 9:09 am

Post by Asim_Omer » Sat Oct 15, 2011 12:36 am

I can't download at all from Skydrive. Can you please upload to other file hosting service?

Edit: Never mind i downloaded from voidseesaw repository.

z033913
Posts: 7
Joined: Sat Mar 19, 2011 10:15 am

Post by z033913 » Sat Dec 24, 2011 5:38 am

one suggestion,why not update the vc runtime library in the addon.

Post Reply