Welcome to Windows XP Service Pack 4

Forum to discuss Update Packs created by community members for the various Windows operating systems.
Post Reply
harkaz
Posts: 693
Joined: Fri Nov 16, 2012 10:23 am
Location: GR
Contact:

Post by harkaz » Sat Nov 01, 2014 7:35 am

@widhie75 KB931906 is not included.
KB923789 supserseded.
KB953155 included.
KB957097 superseded.
KB952069 superseded.
KB972270 superseded.
KB2536276 superseded.
KB2564958 included.
KB931125 revoked by Microsoft/not included.
KB2864063 included.
KB2898715 included.
KB2892075 included.
KB2834904-v2 superseded.
KB2893294 included.
KB2909210 included.

harkaz
Posts: 693
Joined: Fri Nov 16, 2012 10:23 am
Location: GR
Contact:

Post by harkaz » Sat Nov 01, 2014 7:36 am

@everyone Please test whether .NET Framework updates can be installed.

widhie75
Posts: 2
Joined: Sat Oct 18, 2014 9:33 pm

Post by widhie75 » Sat Nov 01, 2014 8:09 am

harkaz wrote:@everyone Please test whether .NET Framework updates can be installed.
About .NET Framework 4...... After install & restart, I found some fail notification inside dos box.... but I don't remember exactly, it scrolling fast.

I also not sure if .NET Framework 4 will 100% working (or not).

harkaz
Posts: 693
Joined: Fri Nov 16, 2012 10:23 am
Location: GR
Contact:

Post by harkaz » Sat Nov 01, 2014 8:11 am

@widhie75 The .NET Framework 4 Extended updates should not fail in the fixed Final version.

The same goes for .NET Framework 3.5 updates.

Actually I wait for confirmation that .NET Framework servicing works fine to proceed with the post-sp4 update pack.

If there are issues I will issue a fix immediately.

darkrats
Posts: 37
Joined: Wed May 14, 2014 11:49 am

Post by darkrats » Sat Nov 01, 2014 1:31 pm

The SP4 package installs on my XP system with only one required intervention by me:

When it is doing the "running processes before install" a message pops up saying "needs to stop HTTP SSL service" before continuing.
I click on the Continue button and the installation proceeds to the end without any other problems.

I checked after the reboot and .NET framework 1.1 and 3.5 are checked as installed (under add or remove Windows components). 4.0 is there but not checked.
I haven't put a check there to see if it installs, yet. Previously, 2.0 was listed under installed programs, but now I don't see any .NET framework version listed there.
Instead, .NET framework versions are listed under add or remove Windows components.

Note: Previously I was running Symantec Endpoint Protection and the SP4 install always crashed my system, unless I stopped all Symantec processes and drivers first.
This time around, I am running AVG AntiVirus, with all of its processes running, and the install did not crash. Very happy about that.

Missed the "ported to XP" updates for October. Will you be able to resume posting these for November?
Your SP4 work is starting to be mentioned in a lot of other forums, with almost all positive remarks, except from those who think no one should be still using XP.
Let's hope that MS doesn't throw a fit about your endeavor. If they won't support us, they should just leave us alone.

Thanks once again, for all the time you've put into SP4.

harkaz
Posts: 693
Joined: Fri Nov 16, 2012 10:23 am
Location: GR
Contact:

Post by harkaz » Sat Nov 01, 2014 3:39 pm

I have to reupload the XP SP4 Final again because I fixed an issue with .NET Framework 3.5 update installation. Started reuploading now!

For those that downloaded previous SP4 Final build I will prepare a fixit .reg file so that you don't download SP4 all over again.

The updated ported-to-XP installers and Windows XP post-sp4 update packs will be available soon.

My upload speed is 100KB/s maximum and I need it to upload Windows XP SP4 Source files which are more than 13 GB in size. So, if anyone is willing to help me with the torrent (of the new version that will be available in a few hours) I would much appreciate that.

harkaz
Posts: 693
Joined: Fri Nov 16, 2012 10:23 am
Location: GR
Contact:

Post by harkaz » Sat Nov 01, 2014 5:04 pm

This fixit file MUST be used ONLY BY THOSE WHO DOWNLOADED AND INSTALLED THE 28 OCTOBER 2014 FINAL VERSION:

(UPDATED LINK:)

http://www.mediafire.com/view/kp81p9819 ... _fixit.reg
Last edited by harkaz on Sun Nov 02, 2014 6:48 am, edited 1 time in total.

User avatar
PJAmerica
Posts: 124
Joined: Thu Oct 03, 2013 12:05 pm

Post by PJAmerica » Sat Nov 01, 2014 5:11 pm

harkaz wrote:I have to reupload the XP SP4 Final again because I fixed an issue with .NET Framework 3.5 update installation. Started reuploading now!

For those that downloaded previous SP4 Final build I will prepare a fixit .reg file so that you don't download SP4 all over again.

The updated ported-to-XP installers and Windows XP post-sp4 update packs will be available soon.

My upload speed is 100KB/s maximum and I need it to upload Windows XP SP4 Source files which are more than 13 GB in size. So, if anyone is willing to help me with the torrent (of the new version that will be available in a few hours) I would much appreciate that.
PM me with direct link when they are on torrent and I will seed like crazy.

harkaz
Posts: 693
Joined: Fri Nov 16, 2012 10:23 am
Location: GR
Contact:

Post by harkaz » Sat Nov 01, 2014 6:11 pm

@PJAmerica Sent you PM.

User avatar
PJAmerica
Posts: 124
Joined: Thu Oct 03, 2013 12:05 pm

Post by PJAmerica » Sat Nov 01, 2014 6:31 pm

harkaz wrote:@PJAmerica Sent you PM.
Downloading now. :)

Charliej
Posts: 3
Joined: Tue Oct 07, 2014 10:29 am

Post by Charliej » Sat Nov 01, 2014 9:48 pm

Hello Mates!
Excellent work......
Thanks so much
Is the Torrent available yet for the new SP4 with the NET Framework fix integrated in?

User avatar
5eraph
Site Admin
Posts: 4618
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Sun Nov 02, 2014 1:19 am

Yes.
harkaz wrote:A new version of SP4 Final is being uploaded to address this specific issue.
An updated magnet URI is available in the first post.

acus
Posts: 92
Joined: Wed May 19, 2010 2:41 pm
Location: italy

Post by acus » Sun Nov 02, 2014 4:07 am

harkaz wrote:This fixit file MUST be used ONLY FOR THOSE WHO DOWNLOADED AND INSTALLED THE 28 OCTOBER 2014 FINAL VERSION:

http://www.adrive.com/public/prkHTM/netfx35_fixit.reg
Please could you upload to another site? adrive is "busy". thanks

Kurt_Aust
Posts: 96
Joined: Fri Jul 25, 2008 6:23 pm
Location: Sydney, Australia

Post by Kurt_Aust » Sun Nov 02, 2014 5:45 am

Have you considered adding Xdelta files so that people only need download the minor changes between versions?

Make patch:
xdelta3.exe -e -s old_file new_file delta_file

Apply patch:
xdelta3.exe -d -s old_file delta_file new_file

harkaz
Posts: 693
Joined: Fri Nov 16, 2012 10:23 am
Location: GR
Contact:

Post by harkaz » Sun Nov 02, 2014 6:42 am

A new link for netfx35_fixit.reg:
http://www.mediafire.com/view/kp81p9819 ... _fixit.reg

@Kurt_Aust Thanks for your advice. I will use it if anything goes wrong again (I hope not!) :)

harkaz
Posts: 693
Joined: Fri Nov 16, 2012 10:23 am
Location: GR
Contact:

Post by harkaz » Sun Nov 02, 2014 6:45 am

@ricktendo I am building the Post-sp4 update pack and I was wondering whether the latest XPS files in your addon do work in Windows XP ENU.

In addition, how can I extract the MS delta-compressed update files (named 0,1,2,3,...)? Decompression tools that come with Windows 7 cannot perform the extract.

adric
Posts: 581
Joined: Mon May 21, 2007 5:51 am

Post by adric » Mon Nov 03, 2014 7:06 am

widhie75 wrote:Hy Harkaz,

I just download final version SP4, and then run 'AutoPatcher'.
I found there are still many 'security update' not yet included in SP4.

for example:
KB931906, KB923789, KB953155, KB957097, KB952069, KB972270, KB2536276, KB2564958, KB931125, KB2864063, KB2898715, KB2892075, KB2834904-v2, KB2893294, KB2909210 ...... and many more still need to update by AutoPatcher.

my question:
Are these 'security update' (KBxxxxxxx) already included & automatically installed in Final Service Pack 4 ?
or is it maybe AutoPatcher can not fully detect it?
Autopatcher doesn't always do a good job of removing the superseded detections from its scripts. It depends on the maintainers as to how much research effort they put into the scripts. That is why you will most likely see fixes marked missing when you build a new system with a clean update pack.

Here is an example of what AP uses for detecting KB2564958

Code: Select all

[DetectionRegistry]
RegistryPath=HKLM\SOFTWARE\Microsoft\Updates\Windows XP\SP4\KB2564958
KeyName=Type
KeyValue=Update

[DetectionFile]
FilePath=windows:\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}
FileName=KB2564958.CAT
FileVersion=ANY
FileMD5=ANY
If neither of these detections are found on the system, then AP assumes the fix is not installed. It may also be that the update pack doesn't set that reg entry or include the cat. These detections are the ones created when you install the fix manually or via WU.

harkaz
Posts: 693
Joined: Fri Nov 16, 2012 10:23 am
Location: GR
Contact:

Post by harkaz » Tue Nov 04, 2014 2:58 pm

Windows XP SP4 Source files have been uploaded to the "Unofficial SP4 Source Files" Drive folder.
The compress folder must reside in the root folder of the C: partition (C:\)


You can use these source files to build your own SP4 builds for other languages.

No documentation is provided.

The certificate used to sign the files is not provided. You will have to create your own certificate.

I have removed A LOT of junk from the compress folder and the download size has minimized to 1.6 GB.

This folder has been the base for XP SP4 development all these months.

User avatar
ricktendo64
Posts: 3213
Joined: Mon May 22, 2006 12:27 am
Location: Honduras

Post by ricktendo64 » Tue Nov 04, 2014 4:44 pm

Thanks harkaz, is there a tutorial on creating a certificate (in Windows) without the need for Linux

User avatar
alban
Posts: 194
Joined: Sun Feb 08, 2009 11:20 am
Location: aL

Post by alban » Tue Nov 04, 2014 5:19 pm

Hi there, I downloaded "WindowsXP-USP4-x86-ENU.exe (recommended)" and I have integrated in to my Windows XP SP3 Corporate with nLite just like I did with SP3, after the integration finished the corporate edition turn in to Media Center edition !!! however I created a boot usb which I used to do with SP3, but it wont work, I do this process since 2010 I never have a problem and it works like a charm with "user hidden" and "One Piece" update pack.

Can anyone please tell me how do I integrate this package in to the install CD/DVD.

Thank you.

long-lurker
Posts: 177
Joined: Thu Nov 22, 2012 10:17 am

Post by long-lurker » Tue Nov 04, 2014 5:30 pm

you could continue using the user_hidden pack and just add the below to it -
http://www.ryanvm.net/forum/viewtopic.php?t=10479

User avatar
alban
Posts: 194
Joined: Sun Feb 08, 2009 11:20 am
Location: aL

Post by alban » Tue Nov 04, 2014 5:39 pm

Anyone else with better solution ? :-)

harkaz
Posts: 693
Joined: Fri Nov 16, 2012 10:23 am
Location: GR
Contact:

Post by harkaz » Wed Nov 05, 2014 7:59 am

nLite reports it as MCE because it looks for some media center INF files. It's not MCE unless you have slipstreamed it to a MCE disk.

For USB Bootable disk, what program did you use to create it? Many programs, like Rufus and WinNTSetup, do work fine.

You can also find a video tutorial about slipstreaming in the Documentation\Windows Deployment Guide folder at the Google Drive link.

@ricktendo64 I haven't tried it in Windows, but similar steps should apply.

biro
Posts: 8
Joined: Tue Oct 07, 2014 3:39 pm
Location: GR

Post by biro » Wed Nov 05, 2014 10:04 am

Hi
I test sp4 with professional version
and during setup ask for urlmon.dll.
I slipstream sp4 with nlite,
and just seen that this file isn't copied at all.
I thought starter version have this problem
or i do something wrong?
just to mention it
i continue test it

harkaz
Posts: 693
Joined: Fri Nov 16, 2012 10:23 am
Location: GR
Contact:

Post by harkaz » Wed Nov 05, 2014 11:59 am

This is indeed an issue, I have reproduced it. I have created a fix, but since the urlmon.dl_ can be downloaded already seperately it may not be necessary to upload a new EXE.

UPDATE: I will upload the new EXE files to GDrive only.

Delta patches will be also provided.

User avatar
ricktendo64
Posts: 3213
Joined: Mon May 22, 2006 12:27 am
Location: Honduras

Post by ricktendo64 » Wed Nov 05, 2014 3:27 pm

Outbreaker fond a problem with the previous webfolders installer, when he installed office 2007 afterwards he received an error. I have revised the installer to NOT remove the XML's so this error should no longer occur

http://adf.ly/1713566/webfldrs
MD5: 0fb9c004df50d6d7809e404e1d7261a1

biro
Posts: 8
Joined: Tue Oct 07, 2014 3:39 pm
Location: GR

Post by biro » Wed Nov 05, 2014 3:55 pm

harkaz wrote:This is indeed an issue, I have reproduced it. I have created a fix, but since the urlmon.dl_ can be downloaded already seperately it may not be necessary to upload a new EXE.

UPDATE: I will upload the new EXE files to GDrive only.

Delta patches will be also provided.
Actually i press skip there, but in the first boot i got a loop reset.
I dont know yet the cause, i have use after slipsteaming sp4 some driverpacks, so i dont know if the cause is a driver from DP or
a faulty HD (i install in a old 20GB HD), or something else,
but with external OS i look inside system32 folder and
there is a urlmon.dll file about 560k size, half size from this for starter,
if you decompress manually

User avatar
Kelsenellenelvian
Moderator
Posts: 4383
Joined: Tue Nov 30, 2004 8:32 pm
Location: Pocatello, ID
Contact:

Post by Kelsenellenelvian » Wed Nov 05, 2014 4:02 pm

alban wrote:Hi there, I downloaded "WindowsXP-USP4-x86-ENU.exe (recommended)" and I have integrated in to my Windows XP SP3 Corporate with nLite just like I did with SP3, after the integration finished the corporate edition turn in to Media Center edition !!! however I created a boot usb which I used to do with SP3, but it wont work, I do this process since 2010 I never have a problem and it works like a charm with "user hidden" and "One Piece" update pack.

Can anyone please tell me how do I integrate this package in to the install CD/DVD.

Thank you.
Is your source clean and genuine?

harkaz
Posts: 693
Joined: Fri Nov 16, 2012 10:23 am
Location: GR
Contact:

Post by harkaz » Wed Nov 05, 2014 4:03 pm

@biro This must be a problem with the urlmon.dll/url.dll version. Please check file versions for both files on the SP4 CD, then use a bootable CD-ROM to check the file version on the system about to be installed - that crashes). DO NOT PRESS SKIP!

@ricktendo64 Thanks for the update, I will rebuild the sp4cmp.cat with the new webfldrs.msi file. Scratch that. I will just sign the webfldrs file itself.

User avatar
alban
Posts: 194
Joined: Sun Feb 08, 2009 11:20 am
Location: aL

Post by alban » Wed Nov 05, 2014 5:30 pm

Hi all.
This is what I used to do, when I got my Windows XP it was with SP2 already integrated and I was able to update it because it was genuine, when SP3 was shipped I used nLite to slipstream the SP3 and this is how it looks no nLite:
Image
after sp3 I did all the updates through windows update, the I find out about this forum and I used rayan's update pack then users hidden after that, I also used to put in some of the anddons and here is the list which I did all the time:

1. Ricks-YumeYao_IE8_Addon_Nosetuperr_ENU_1_4_33
2. Kels_CPLBonus_v13.2_addon
3. Ricks-YumeYao_MicrosoftVC7891012RuntimeLibraries_MixedAddon_2_2_3
4. 5er_SecCtrTweaks_Addon (Remove Windows XP Security Center)
5. Kels_VistaDriveIndicator_addon_v2.2_uninstallable
6. OnePiece_Windows_Media_Player_11_True_AddOn_v2.7.0

I also did some tips and tweaks with nLine and I will show you the list bu I'm not going to Include my windows license key:

Code: Select all

[Main]
Env = 1.4.9.3 - 2.0.50727.5420.Microsoft Windows NT 6.1.7601 Service Pack 1
Target = Windows XP Professional SP3 - 5.1.2600.5512 - English (United States)

[Tasks]
Remove Components
Unattended Setup
Tweaks
Options

[Components]
;# Applications #
Briefcase
Internet Games
;# Keyboards #
Armenian Eastern keyboard
Armenian Western keyboard
Azeri Cyrillic keyboard
Azeri Latin keyboard
Belarusian keyboard
Belgian (Comma) keyboard
Belgian (Period) keyboard
Belgian French keyboard
Bengali (Inscript) keyboard
Bengali keyboard
Canadian French (Legacy) keyboard
Canadian French keyboard
Canadian Multilingual Standard keyboard
Chinese (Simplified) - Microsoft Pinyin IME 3.0 keyboard
Chinese (Simplified) - NeiMa keyboard
Chinese (Simplified) - QuanPin keyboard
Chinese (Simplified) - ShuangPin keyboard
Chinese (Simplified) - US Keyboard keyboard
Chinese (Simplified) - ZhengMa keyboard
Chinese (Traditional) - Alphanumeric keyboard
Chinese (Traditional) - Array keyboard
Chinese (Traditional) - Big5 Code keyboard
Chinese (Traditional) - ChangJie keyboard
Chinese (Traditional) - DaYi keyboard
Chinese (Traditional) - New ChangJie keyboard
Chinese (Traditional) - New Phonetic keyboard
Chinese (Traditional) - Phonetic keyboard
Chinese (Traditional) - Quick keyboard
Chinese (Traditional) - Unicode keyboard
Chinese (Traditional) - US Keyboard keyboard
Czech (QWERTY) keyboard
Czech keyboard
Czech Programmers keyboard
Danish keyboard
Devanagari - INSCRIPT keyboard
Divehi Phonetic keyboard
Divehi Typewriter keyboard
Dutch keyboard
Estonian keyboard
Faeroese keyboard
Farsi keyboard
Finnish keyboard
Finnish with Sami keyboard
Gaelic keyboard
Georgian keyboard
Greek (220) keyboard
Greek (220) Latin keyboard
Greek (319) keyboard
Greek (319) Latin keyboard
Greek keyboard
Greek Latin keyboard
Greek Polytonic keyboard
Gujarati keyboard
Hebrew keyboard
Hindi Traditional keyboard
Hungarian 101-key keyboard
Hungarian keyboard
Icelandic keyboard
Inuktitut Latin keyboard
Irish keyboard
Japanese Input System (MS-IME2002) keyboard
Japanese keyboard
Kannada keyboard
Kazakh keyboard
Korean Input System (IME 2000) keyboard
Korean keyboard
Kyrgyz Cyrillic keyboard
Latin American keyboard
Latvian (QWERTY) keyboard
Latvian keyboard
Lithuanian IBM keyboard
Lithuanian keyboard
Luxembourgish keyboard
Malayalam keyboard
Maltese 47-key keyboard
Maltese 48-key keyboard
Maori keyboard
Marathi keyboard
Mongolian Cyrillic keyboard
Nepali keyboard
Norwegian keyboard
Norwegian with Sami keyboard
Pashto keyboard
Polish (214) keyboard
Polish (Programmers) keyboard
Portuguese (Brazilian ABNT) keyboard
Portuguese (Brazilian ABNT2) keyboard
Portuguese keyboard
Punjabi keyboard
Romanian keyboard
Russian (Typewriter) keyboard
Russian keyboard
Sami Extended Finland-Sweden keyboard
Sami Extended Norway keyboard
Slovak (QWERTY) keyboard
Slovak keyboard
Spanish keyboard
Spanish Variation keyboard
Swedish keyboard
Swedish with Sami keyboard
Syriac keyboard
Syriac Phonetic keyboard
Tamil keyboard
Tatar keyboard
Telugu keyboard
Thai Kedmanee (non-ShiftLock) keyboard
Thai Kedmanee keyboard
Thai Pattachote (non-ShiftLock) keyboard
Thai Pattachote keyboard
Ukrainian keyboard
Urdu keyboard
Uzbek Cyrillic keyboard
Vietnamese keyboard
;# Languages #
;Armenian
Armenian
;Baltic
Estonian
Latvian
Lithuanian
;Central Europe
Czech
Hungarian
Polish
Romanian
Slovak
;Cyrillic
Azeri (Cyrillic)
Belarusian
Bulgarian
Kazakh
Kyrgyz (Kyrgyzstan)
Mongolian (Mongolia)
Russian
Tatar
Ukrainian
Uzbek (Cyrillic)
;Georgian
Georgian
;Greek
Greek
;Hebrew
Hebrew
;Indic
Bengali (India)
Gujarati (India)
Hindi
Kannada (India)
Konkani
Malayalam (India)
Marathi
Nepali (Nepal)
Punjabi (India)
Sanskrit
Tamil
Telugu (India)
;Japanese
Japanese
;Korean
Korean
;Simplified Chinese
Chinese (PRC)
Chinese (Singapore)
;Thai
Farsi
Thai
;Traditional Chinese
Chinese (Hong Kong S.A.R.)
Chinese (Macau S.A.R.)
Chinese (Taiwan)
;Turkic
Azeri (Latin)
Uzbek (Latin)
;Vietnamese
Vietnamese
;Western Europe and United States
Afrikaans
Basque
Catalan
Danish
Dutch (Belgium)
Dutch (Netherlands)
English (Australia)
English (Belize)
English (Canada)
English (Caribbean)
English (Ireland)
English (Jamaica)
English (New Zealand)
English (Philippines)
English (South Africa)
English (Trinidad)
English (Zimbabwe)
Faeroese
Filipino
Finnish
French (Belgium)
French (Canada)
French (Luxembourg)
French (Monaco)
Frisian
Galician (Spain)
German (Liechtenstein)
German (Luxembourg)
Icelandic
Indonesian
Inuktitut (Latin)
Irish
Luxembourgish
Malay (Brunei Darussalam)
Malay (Malaysia)
Maltese
Maori
Mapudungun
Mohawk
Northern Sotho
Norwegian (Bokmal)
Norwegian (Nynorsk)
Portuguese (Brazil)
Portuguese (Portugal)
Quechua (Bolivia)
Quechua (Ecuador)
Quechua (Peru)
Romansh
Sami, Inari (Finland)
Sami, Lule (Norway)
Sami, Lule (Sweden)
Sami, Northern (Finland)
Sami, Northern (Norway)
Sami, Northern (Sweden)
Sami, Skolt (Finland)
Sami, Southern (Norway)
Sami, Southern (Sweden)
Spanish (Argentina)
Spanish (Bolivia)
Spanish (Chile)
Spanish (Colombia)
Spanish (Costa Rica)
Spanish (Dominican Republic)
Spanish (Ecuador)
Spanish (El Salvador)
Spanish (Guatemala)
Spanish (Honduras)
Spanish (International Sort)
Spanish (Mexico)
Spanish (Nicaragua)
Spanish (Panama)
Spanish (Paraguay)
Spanish (Peru)
Spanish (Puerto Rico)
Spanish (Traditional Sort)
Spanish (Uruguay)
Spanish (Venezuela)
Swahili
Swedish
Swedish (Finland)
Tswana
Welsh
Xhosa
Zulu
;# Multimedia #
Music Samples
;# Network #
Client for Netware Networks
Communication tools
Connection Manager
MSN Explorer
Netmeeting
Peer-to-Peer
Windows Messenger
;# Operating System Options #
Blaster/Nachi removal tool
Desktop Cleanup Wizard
Help and Support
Search Assistant
Security Center
Tour
;# Services #
Messenger
Remote Registry
;# Compatibility #

[KeepFiles]
msconfig.exe

[RemoveFiles]
clock.avi
yahoo.bmp
swtchbrd.bmp

[Options]
ProfilesDir = "%SystemDrive%\Documents and Settings"
TargetPath = "WINDOWS"
temp_dir = %USERPROFILE%\Local Settings\Temp
AdvTweaks

[Patches]
TcpIp = 1000
DoUxTheme
DoSFC

[Services2]

[Tweaks]
Boot and Shutdown-Logon Page-Welcome screen
Desktop-Internet Explorer icon-Show
Desktop-My Computer icon-Show
Desktop-My Documents icon-Show
Desktop-My Network Places icon-Show
Desktop-Recycle Bin icon-Show
Explorer-Change Windows Explorer folder view-Icons
Explorer-Classic Control Panel
Explorer-Disable Accessibility keyboard shortcuts
Explorer-Disable Prefix: Shortcut to
Explorer-Disable shortcut arrow
Explorer-Show Statusbar in all windows
Explorer-Show the full path in the Address Bar
Internet Explorer-Enable Google URL-Search
Internet Explorer-Set Homepage-www.google.com
Internet Explorer-Set Internet Explorer to accept 10 connects at a time
Network-Allow receiving Remote Assistance-Disable
Network-Disable automatic search for network folders and printers
Network-Remote Desktop-Disable
Performance-Disable Last accessed Timestamp on files
Performance-Disable Tracking of Broken Shortcut Links
Performance-Do not cache thumbnails
Privacy-Disable Error Reporting
Privacy-Remove Alexa
Security-Disable Screensaver
Security-Screensaver Password-Protection-Disabled
Start Menu-Clear most recently opened documents list on logoff
Start Menu-Disable Highlight newly installed programs
Start Menu-Do not use Personalized Menus
Start Menu-Reduce popup delay
Start Menu-Remove Search For People from Search
Start Menu-Remove Search the Internet from Search
Start Menu-Remove Set Program Access and Defaults
Start Menu-Remove Windows Catalog shortcut
Start Menu-Remove Windows Update shortcut
Taskbar-Disable Group similar Taskbar buttons
Taskbar-Disable Hide inactive icons
Taskbar-Disable Language-Bar
Taskbar-Lock the Taskbar-Yes
Visual Effects-Animate windows when minimizing and maximizing-Disable
Visual Effects-Combo box animation-Disable
Visual Effects-Cursor shadow-Disable
Visual Effects-Fade out selection-Disable
Visual Effects-Menu animation-Slide
Visual Effects-Menu shadows-Disable
Visual Effects-Tooltip animation-Disable
Visual Effects-Use a background image for each folder type-Enable
Visual Effects-Use drop shadows for icon labels on the desktop-Enable

[Unattended]
DisableOem
ComputerType = Automatic
HibernationNo
AutoLogon = PC
CustomLocales
DisableSRestore
MaximumDataStorePercentOfDisk = 12
RestorePointLife = 30
DefaultStartPanelOff
DesktopTheme = Windows 7 style|Default|Tahoma
AutoUpdates = 4
AutoUDay = 5
AutoUHour = 15
ProgFilesPath = "\Program Files"

[DesktopThemes]
E:\XP\Seven\Seven.msstyles

[NetAdapter1]
connname = ""
macaddress = ""
ipaddress = "192.168.0.1"
subnetmask = "255.255.255.0"
defaultgateway = ""
dnsserver1 = ""
dnsserver2 = ""
winsserver = ""
netbiossetting = "0"
ipxnetworknumber = "00000000"
ipxnetworkframetype = "0xFF"

[GuiRunOnce]

[Drivers]

[Hotfixes]

Code: Select all

;
; nLite private info

[Personal]
TimeZone = (GMT+01:00) Sarajevo, Skopje, Warsaw, Zagreb
CDKey = "xxxxxxxxxxxxxxxxxxxxxxxx"
ComputerName = WS
Organization = WorkStation
Language = English (United States)
Locale = English (United States)
Location = 236
Keyboard = US
LanguageGroup = 13,2,5,6,1
DomainAdmin = 
DomainPass = 
Expirepassword = 0
JoinDomain = 
JoinWorkgroup = Workgroup
Owner = aL

[Users]
Administrator|Admin|aLvision.NET|True|Administrators|`|False|True|True
Guest|||False|Guests||True|False|False
PC|aL|aLvision.NET|True|Administrators||True|False|True
I also use driver pack and I integrate some of the driver package for windows xp at the end, then I use WinSetupFromUSB_1-3_x64 to create my usb stick and the job is done worked for years like this never have a problem.

I did the same process with yours SP4 I did the integration with nLite and all the rest with the description and it does not work it boots ok it formats the partition but when it starts to copy the files it stops with some error ( I dot remember what it was ), here is the picture of SP4 on nLite:

Image[/quote]

harkaz
Posts: 693
Joined: Fri Nov 16, 2012 10:23 am
Location: GR
Contact:

Post by harkaz » Wed Nov 05, 2014 5:33 pm

@alban The copy files error must be the urlmon.dll file missing.
The fixed SP4 will be available soon. I know the issue with nLite detection, it happens due to nLite's detection algorithm design (it merely checks if all MCE INF files are there, not if the FreeStyle component exists in the sysoc.inf file). Simply ignore it.

biro
Posts: 8
Joined: Tue Oct 07, 2014 3:39 pm
Location: GR

Post by biro » Wed Nov 05, 2014 5:37 pm

in CD there are inside i386 folder
url.dll version 8.0.6001.23580
and no urlmon.dll

in installed there is
urlmon.dll 6.0.2900.5512
url.dll 8.0.6001.23580
so setup find a urlmon.dll from other source inside a cab maybe
when i press skip file

User avatar
Kelsenellenelvian
Moderator
Posts: 4383
Joined: Tue Nov 30, 2004 8:32 pm
Location: Pocatello, ID
Contact:

Post by Kelsenellenelvian » Wed Nov 05, 2014 5:41 pm

alban wrote: 1. Ricks-YumeYao_IE8_Addon_Nosetuperr_ENU_1_4_33
2. Kels_CPLBonus_v13.2_addon
3. Ricks-YumeYao_MicrosoftVC7891012RuntimeLibraries_MixedAddon_2_2_3
4. 5er_SecCtrTweaks_Addon (Remove Windows XP Security Center)
5. Kels_VistaDriveIndicator_addon_v2.2_uninstallable
6. OnePiece_Windows_Media_Player_11_True_AddOn_v2.7.0
The inclusion of 1 and 6 (Maybe also 4?) is likely where your problems are lying...

1 and 6 are already in there....

harkaz
Posts: 693
Joined: Fri Nov 16, 2012 10:23 am
Location: GR
Contact:

Post by harkaz » Wed Nov 05, 2014 5:43 pm

@biro The problem is url.dll I have designed the SP4 installation to use IE6 base files and replace them when install completes with their IE8 versions. Check for the url.dll and upd0018.dll entries in txtsetup.sif and tell me what's there.
Last edited by harkaz on Wed Nov 05, 2014 5:53 pm, edited 2 times in total.

User avatar
alban
Posts: 194
Joined: Sun Feb 08, 2009 11:20 am
Location: aL

Post by alban » Wed Nov 05, 2014 5:44 pm

harkaz wrote:@alban The copy files error must be the urlmon.dll file missing.
The fixed SP4 will be available soon. I know the issue with nLite detection, it happens due to nLite's detection algorithm design (it merely checks if all MCE INF files are there, not if the FreeStyle component exists in the sysoc.inf file). Simply ignore it.
Thank you harkez I cant wait for the fix, I just did the slipstream in the old fashion with cmd commands what do you think will It work or it will be better to wait till you fix it?

harkaz
Posts: 693
Joined: Fri Nov 16, 2012 10:23 am
Location: GR
Contact:

Post by harkaz » Wed Nov 05, 2014 5:45 pm

@alban Wait for the fix. This will also fix some other issues with webfldrs.msi and Office 2007.

User avatar
alban
Posts: 194
Joined: Sun Feb 08, 2009 11:20 am
Location: aL

Post by alban » Wed Nov 05, 2014 5:48 pm

Kelsenellenelvian wrote:
alban wrote: 1. Ricks-YumeYao_IE8_Addon_Nosetuperr_ENU_1_4_33
2. Kels_CPLBonus_v13.2_addon
3. Ricks-YumeYao_MicrosoftVC7891012RuntimeLibraries_MixedAddon_2_2_3
4. 5er_SecCtrTweaks_Addon (Remove Windows XP Security Center)
5. Kels_VistaDriveIndicator_addon_v2.2_uninstallable
6. OnePiece_Windows_Media_Player_11_True_AddOn_v2.7.0
The inclusion of 1 and 6 (Maybe also 4?) is likely where your problems are lying...

1 and 6 are already in there....
I did not know that harkaz SP4 includes IE8 and WMP 11, thank you Kelsenellenelvian, by the way I love your releases, especially WPI.

User avatar
Kelsenellenelvian
Moderator
Posts: 4383
Joined: Tue Nov 30, 2004 8:32 pm
Location: Pocatello, ID
Contact:

Post by Kelsenellenelvian » Wed Nov 05, 2014 5:52 pm

Thank you very much, try the veal i'll be here till Thursday.. :P

biro
Posts: 8
Joined: Tue Oct 07, 2014 3:39 pm
Location: GR

Post by biro » Wed Nov 05, 2014 5:56 pm

harkaz wrote:@biro The problem is url.dll I have designed the SP4 installation to use IE6 base files and replace them when install completes with their IE8 versions. Check for the url.dll and upd0018.dll entries in txtsetup.sif and tell me what's there.
with notepad+ search
Search "url.dll" (4 hits in 1 file)
F:\I386\TXTSETUP.SIF (4 hits)
Line 5736: msdaurl.dll = 100,,,,,,,,3,3
Line 8720: url.dll = 100,,,,,,,,3,3,,1,2
Line 11139: upd0018.dll = 100,,,,,,,2,0,0,url.dll,1,2
Line 13725: url.dll , 44

Search "upd0018.dll" (1 hit in 1 file)
F:\I386\TXTSETUP.SIF (1 hit)
Line 11139: upd0018.dll = 100,,,,,,,2,0,0,url.dll,1,2

harkaz
Posts: 693
Joined: Fri Nov 16, 2012 10:23 am
Location: GR
Contact:

Post by harkaz » Wed Nov 05, 2014 6:01 pm

The txtsetup.sif is normal. Assuming the upd0018.dll is the IE6 version (could you check this as well with 7zip or similar tool?) this problem must be caused by the urlmon.dll file skip.

biro
Posts: 8
Joined: Tue Oct 07, 2014 3:39 pm
Location: GR

Post by biro » Wed Nov 05, 2014 6:04 pm

harkaz wrote:The txtsetup.sif is normal. Assuming the upd0018.dll is the IE6 version (could you check this as well with 7zip or similar tool?) this problem must be caused by the urlmon.dll file skip.
yes its 6.0.2900.5512

also for
Search "urlmon.dll" (4 hits in 1 file)
F:\I386\TXTSETUP.SIF (4 hits)
Line 8721: urlmon.dll = 100,,,,,,,,3,3,,1,2
Line 8722: urlmon.mui = 100,,,,,,,270,0,0,urlmon.dll.mui
Line 11141: upd0020.dll = 100,,,,,,,2,0,0,urlmon.dll,1,2
Line 13726: urlmon.dll , 44

and upd0020.dll is the ie6 version

actually forced skipped because it is not in CD at all

i put manually urlmon.dll and "loop reset" stopped and finalized the setup

harkaz
Posts: 693
Joined: Fri Nov 16, 2012 10:23 am
Location: GR
Contact:

Post by harkaz » Thu Nov 06, 2014 8:35 am

Started uploading the fixed version files.

Checksums, delta patches and new torrent file will be added soon.

User avatar
Kelsenellenelvian
Moderator
Posts: 4383
Joined: Tue Nov 30, 2004 8:32 pm
Location: Pocatello, ID
Contact:

Post by Kelsenellenelvian » Thu Nov 06, 2014 8:37 am

Hey harkaz? what are the changes in the last 2 releases? (The fixed official ones) Also thank you again in mentioning me in the creds..

harkaz
Posts: 693
Joined: Fri Nov 16, 2012 10:23 am
Location: GR
Contact:

Post by harkaz » Thu Nov 06, 2014 8:41 am

The first fixed final release fixed .NET Framework 4.0 servicing and lodctr installation. It also changed the way Rosebud v12 was installed.
The second fixed final release fixed an issue with .NET Framework 3.5 servicing that was introduced during the first fix attempt.
The third fixed final release fixes the missing urlmon.dll (issue caused during the second fix attempt) and fixes Office 2007 and Rosebud v12 interaction.

User avatar
Kelsenellenelvian
Moderator
Posts: 4383
Joined: Tue Nov 30, 2004 8:32 pm
Location: Pocatello, ID
Contact:

Post by Kelsenellenelvian » Thu Nov 06, 2014 8:42 am

Thanks

harkaz
Posts: 693
Joined: Fri Nov 16, 2012 10:23 am
Location: GR
Contact:

Post by harkaz » Thu Nov 06, 2014 9:17 am

Checksum and torrent download information now available.

The Delta patch will be uploaded later (for WindowsXP-USP4-x86-ENU.exe only).

The GDrive upload will complete in a few hours.

User avatar
GH0st
Posts: 535
Joined: Wed Nov 05, 2014 9:31 am
Location: Virginia, USA

FIRST POST

Post by GH0st » Thu Nov 06, 2014 10:28 am

Hey guys, I just registered to this forum, though I been READING for years and years. I used to be one of the more aggressive beta testers with Nuhi back when he was making nLite, so have done a million installs of XP ... and I still love this OS!

With that said, I would like to say THANK YOU ALL, for all the update packs and especially for all the impressive work put into the USP4, which I have recently installed ... and this is why I'm posting for the first time!
~~~~~~~~~~~~~

Just did a fresh install, taken notes on some issues, which may have already been fixxed, but one that no one has mentioned yet.

To start, I used my original source of xp, being WinXP Pro (Corporate) SP0, I used RyanVM Integrator to slip stream official SP3 into this, then used nLite to mildly tweak and add intel INF's and AHCI drivers prior to making ISO. I used RUFUS 1.4.10 to put it all on a USB for install. Once at desktop I pulled the USP4 to desktop and ran it. All went well with no ERRORS noted in Event Viewer, just a few yellow marks. (EDIT to add: Thus making this the CLEANEST install of XP ever)

There was an issue with dotnet3, which seems you have sorted out. Though I noticed that it didnt install WIC (Windows Imaging Componant) by itself, which is needed for dotnet3. I just used my trusty AIO Pack by SEREBY which always does a flawless job.

Next real issue for me is an odd one. Has to do with the TIME as noted on the desktop clock and a difference in the time as noted by some applications. So, I am on the East Coast USA, so -5 Eastern Time (US & Canada) is the option selected for me. But in my ESET Nod32 the clock is 6 hours off, 6 hours ahead. So desktop time is 10am now, ESET reports as 4pm. This is the same as seen in another program called "PeerBlock". I have played around with setting in the "Date and Time" and "Regional and Language options" sections of the control panel, with nothing seeming to be out of place. No changes made, fix this minor issue.

There was some minor tweaks used in nLite, that didnt carry forward for some reason, these are minor and don't really warrant posting.

Normally I am very pleased with user_hidden's update pack, the real reason I decided to use this USP4 was the inclusion of Stefan Kanthak's security enhancements, which I thought would end with great success ... and I was right! This really does make the entire system feel tight!

Makes me wish user-hidden would take the flash and such, out of his main pack, keeping all the updates through May2014, then include Stephan's fixxes which is dated Jun2014. Then one could just edit their registry and get the POS updates, should they want. Then use the AIO pack noted above, for a perfect install!

Anyway, I have some more to add, soon! Just wanted to again, say THANK YOU ALL for your continued work, I really love it all!

User avatar
GH0st
Posts: 535
Joined: Wed Nov 05, 2014 9:31 am
Location: Virginia, USA

Security Enhancements

Post by GH0st » Thu Nov 06, 2014 10:38 am

Here are some Enhanced Security Options I include with every install I do. I have had great success with them all!

*** Posting them for your consideration ***

1) This is a GREAT tool, highly recommended: Seconfig XP. Select the "For home" option, then "Apply", reboot!

2) Been using this for years, nice security tool Windows Worms Doors Cleaner 1.4.1 Select options, reboot!

3) Then add the following manually to your registry. (some may already be present)

**Harden TCPIP Stack**
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
*[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\AFD\Parameters]
"DisableAddressSharing"=dword:00000001
"DynamicBacklogGrowthDelta"=dword:00000010
"EnableDynamicBacklog"=dword:00000001
"MaximumDynamicBacklog"=dword:00004000
"MinimumDynamicBacklog"=dword:00000010

*[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TcpIp\Parameters]
"DisableIPSourceRouting"=dword:00000002
"EnableAddrMaskReply"=dword:00000000
"EnableDeadGWDetect"=dword:00000000
"EnableICMPRedirect"=dword:00000000
"EnableMulticastForwarding"=dword:00000000
"EnablePMTUDiscovery"=dword:00000000
"IPEnableRouter"=dword:00000000
"KeepAliveTime"=dword:000493e0
"NoNameReleaseOnDemand"=dword:00000001
"PerformRouterDiscovery"=dword:00000000
"SynAttackProtect"=dword:00000002
"TcpMaxConnectResponseRetransmissions"=dword:00000002
"TcpMaxDataRetransmissions"=dword:00000002
"TcpMaxHalfOpen"=dword:000001f4
"TcpMaxHalfOpenRetried"=dword:00000096
"TcpMaxPortsExhausted"=dword:00000001
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Time again to reboot!

4) Now install CryptoPreventSetup its a Free tool, select the "Default- Set it and forget it" protection. reboot! V9 is out and it tries to install itself as a service, and you got to monkey around with it ... so I still use version 7.4.21

5) Lastly, the AntiVirus of your choice. I pefer Eset Nod32 v8.0.319.0. I bought a license of ebay, 1pc,3yr, $15.00) Recently tested the v9 and then latest v10, not great on Xp ... still recommend v8.0.319.0, this has light feeling, low latency.

Time again to reboot! ... get behind a router ... Now you can connect to the web for the first time!

*** Blackvipers Super Tweaks *** can help you achieve best performance!

Edit: Links verified 13Apr18
Last edited by GH0st on Fri Apr 13, 2018 6:50 am, edited 23 times in total.

iakoboss7
Posts: 3
Joined: Thu Nov 06, 2014 8:41 am
Location: GR

Post by iakoboss7 » Thu Nov 06, 2014 10:39 am

hello, i see you have included WindowsXP-KB942288-v3-x86.exe

BUT you havent included its update: WindowsXP-KB958655-v2-x86-ENU.exe

http://www.microsoft.com/en-us/download ... px?id=9641

its not needed? its supposed to be a fix for the kb942288-v3

long-lurker
Posts: 177
Joined: Thu Nov 22, 2012 10:17 am

Re: FIRST POST

Post by long-lurker » Thu Nov 06, 2014 11:18 am

GH0st wrote:Normally I am very pleased with user_hidden's update pack, the real reason I decided to use this USP4 was the inclusion of Stefan Kanthak's security enhancements, which I thought would end with great success ... and I was right! This really does make the entire system feel tight!

Makes me wish user-hidden would take the flash and such, out of his main pack, keeping all the updates through May2014, then include Stephan's fixxes which is dated Jun2014.
i second that :)
i've removed the flash (i prefer my own unintended install, i agree that flash should be up-to-date with new installs), but i haven't been able to find out how to do the security enhancements and have the fingers crossed that somebody has picked that up as a project...

Post Reply