Onepiece XP Post-SP3 AIO Update Pack FINAL

Windows XP Professional Update Pack discussion.
Post Reply
User avatar
Atari800xl
Posts: 345
Joined: Sun Dec 30, 2012 5:46 pm
Location: NL

Post by Atari800xl » Sat Nov 15, 2014 2:47 am

Just wanted to add that downloading the latest DXUPAC.EXE is working again from the "box" folder (for some reason, it didn't work for the last few months. That's "dxupac.exe" only, the other files were fine).
Not sure if you (or "they") changed anything, but downloading from "box" is always very convenient for me (even from XP), I bookmarked it and check it regularly. I think Box has the clearest file list, and when sorted by date, the latest stuff is always on top.
https://app.box.com/s/lwfwd77nw0ctrdi7h ... 7868676209
Thanks!

User avatar
OnePiece Alb
Posts: 525
Joined: Sat Sep 01, 2007 7:01 pm
Location: Albania
Contact:

Post by OnePiece Alb » Sat Nov 15, 2014 4:53 am

Box has a limit of 10 GB in a month, so just download UpdatePack only 50 times and after closing for 1 month, and there are 24 GB of data (UpdatePack & AddOn in all Language) so ehhhh, instead the links (are also direct links) of SkyDrive and Google Drive are always OK

Ciao.
Image Image Image

User avatar
Outbreaker
Posts: 703
Joined: Tue Aug 21, 2007 8:06 am

Post by Outbreaker » Sat Dec 06, 2014 10:14 am

HI,
Is there a reason why the KB923845 update was added in the Windows Server 2003 UpdatePack but not in the Windows XP UpdatePack?

User avatar
OnePiece Alb
Posts: 525
Joined: Sat Sep 01, 2007 7:01 pm
Location: Albania
Contact:

Post by OnePiece Alb » Sat Dec 06, 2014 10:40 am

Outbreaker wrote:HI,
Is there a reason why the KB923845 update was added in the Windows Server 2003 UpdatePack but not in the Windows XP UpdatePack?
Image
Image Image Image

User avatar
Atari800xl
Posts: 345
Joined: Sun Dec 30, 2012 5:46 pm
Location: NL

Post by Atari800xl » Tue Dec 09, 2014 11:46 pm

Thanks again OnePiece, I just found the new 12/09 updates in your "Box" folder. I'll build a new POS Addon today (actually starting to enjoy that...)

EDIT: As long as I'm posting, just want to add this, might be interesting for others:
For a couple of months now, I've been having strange problems trying to download dxupac.exe from the "box" folder. A direct download by clicking on the exe, or clicking on the item named "download" (spelled out) never worked. This could just as well be because of things on my end, but now I finally found a way that always works: when I tick (select) the tiny box at the end of the "dxupac.exe" line (next to the little "comment" and "more options" checkboxes), and select a random other file (a .cmd, for example), and then click the large download arrow at the top left, everything's OK!! So I have to select at least two files.
Strange, but at least it works! I never had any trouble downloading the updates themselves (from the UpdatePack subfolders), only with dxupac.exe. Oh well, just wanted to share that.

User avatar
Atari800xl
Posts: 345
Joined: Sun Dec 30, 2012 5:46 pm
Location: NL

Post by Atari800xl » Fri Dec 12, 2014 4:52 am

Hmm, maybe I'm spamming the thread with my "Thank you's", but I wanted to give a big Thanks to OnePiece and Nonno Fabio for creating the latest XP Final pack 20141210. I saw the new stuff trickle in to the "Box" folder this morning, a very nice surprise! 8)

User avatar
Atari800xl
Posts: 345
Joined: Sun Dec 30, 2012 5:46 pm
Location: NL

Post by Atari800xl » Fri Dec 12, 2014 5:06 am

So I downloaded the new 1.05 Final pack, and also downloaded the separate INTL and Dutch folders, to create my own Final Pack, just to see if I could do it.
When comparing the two, only this file comes up:
"muweb.cat".
So to be clear: this files is in the full "1.05" download, but it's not present if I make the pack with DXUPAC myself. Is that a problem?
Thanks again...

EDIT: Just finished creating my new XP iso, compared the 2 versions (one made with ready-made 1.05 final pack +POS, other one made from self-made 1.05 final pack +POS), they're identical, muweb.cat is not inside either one of them, so I guess it's not needed. Only wondering now why it's in the full 1.05 pack...

User avatar
OnePiece Alb
Posts: 525
Joined: Sat Sep 01, 2007 7:01 pm
Location: Albania
Contact:

Post by OnePiece Alb » Fri Dec 12, 2014 8:44 am

Hi Atari800xl, ignore the muweb.cat, in general is in the muweb.cab, but since Windows does not report the muweb.dll as unsigned, you can ignore it, in poor words is an irrelevant (not Important) detail

for info, first it always updates (OneDrive, private not public) and Google Drive (UpdatePacks INTL are in Google Drive since yesterday), because from Google Drive (Google Drive is really the best) move\copy files with the remote on other servers, always have a backup, using the remote i move 10 GB of data per minute, I have backups of all files in more (Third Party) servers like
https://www.oboom.com/folder/AE4BJ774
https://userscloud.com/go/xfz7qp0u0nm7/
https://www.tusfiles.net/go/nrbbkkhh6chk/
etc etc etc

Ciao a tutti.
Last edited by OnePiece Alb on Fri Dec 12, 2014 10:17 pm, edited 1 time in total.
Image Image Image

User avatar
OnePiece Alb
Posts: 525
Joined: Sat Sep 01, 2007 7:01 pm
Location: Albania
Contact:

Post by OnePiece Alb » Fri Dec 12, 2014 10:17 pm

@All
Although I do not see problems http://www.tgcom24.mediaset.it/2014/vid ... 1496.shtml as we already said http://www.wincert.net/forum/topic/9773 ... /?p=113091 we realized the problem and we register\configure PlayReady manually, OPMWXPUP.inf from UpdatePack v1.0.5 FINAL
[Silverlight_ProcessesToRun]
11,,regsvr32.exe,,,"/S ""%16422%\%SilverlightDir%\xapauthenticodesip.dll"""
11,Setup,SLMSCCRL.exe,,300,
11,,cmd.exe,,,"/C DEL /F /Q ""%11%\Setup\SLMSCCRL.exe"""
;;;; Starting from version 5.1.31010.0 do not (Support) work in Windows XP SP3
;11,,RUNDLL32.exe,,,"""%16422%\%SilverlightDir%\%Silverlight_ProductVersion%\SLMSPRBootstrap.dll"",SetupPlayReadyData"
;;;; However proceed manually
11,,cmd.exe,,,"/C MD ""%16419%\Microsoft\PlayReady"""
11,,reg.exe,,,"ADD HKLM\SOFTWARE\Microsoft\PlayReady /v DataPath /t REG_SZ /d ""%16419%\Microsoft\PlayReady"" /f"
and watching their reports http://answers.microsoft.com/en-us/wind ... 5d819cac0b maybe is that their problem

in poor words after integration of OnePiece's Windows XP Post-SP3 Update Pack v1.0.5 FINAL everything looks OK, but for those who find problems with SilverLight v5.1.31010.0 (KB3011970) or want to use the latest version of the Silverlight officially supported in WinNT 5.x (Windows XP/2003 etc etc), after integration of UpdatePack just use OnePiece_Remove_Silverlight_AddOn.cab with RVMi, and then integrate with nLite or RVMi the OnePiece_Microsoft_Silverlight_v5.1.30514.0_True_AddOn_INTL.cab, or simply just after UpdatePack integrate with nLite or RVMi the OnePiece_Microsoft_Silverlight_v5.1.30514.0_for_WinXP_Post-SP3_UpdatePack_FINAL_INTL.7z

Ciao a tutti.
Image Image Image

User avatar
Atari800xl
Posts: 345
Joined: Sun Dec 30, 2012 5:46 pm
Location: NL

Post by Atari800xl » Sat Dec 13, 2014 2:25 am

OnePiece Alb wrote:Google Drive is really the best
Thanks for mentioning all the extra download alternatives. I will remember that Google Drive is the best (and first) download location.

What I like about the "Box" folder, is that it can sort by date (and the bookmark I made has "details view" encoded into the url), so I can always quicly check for new uploads (eg. it says "Uploaded Today"), and full filenames and sizes are always visible.
The other download alternatives have less clear filelists, but of course this is just my personal opinion.
Thanks again for sharing!

User avatar
Atari800xl
Posts: 345
Joined: Sun Dec 30, 2012 5:46 pm
Location: NL

Post by Atari800xl » Sat Dec 13, 2014 4:41 am

Too bad about the Silverlight trouble. Three days ago, I made a new XP from Final Pack 1.04 (the previous one) and the December POS Addon (selfmade with DXUPAC). Let me clearly say that this version works PERFECTLY!!!

Yesterday, I made another new XP, this time with Final Pack 1.05 instea of 1.04 (POS Addon was the same). During setup, I got an error from Silverlight setup. This is what OnePiece was talking about, I guess.
The most convenient way to resolve this was to use OnePiece's last suggestion: I started with my XP folder that had Final 1.05 and POS Addon integrated. After that, I used nLite to add
OnePiece_Microsoft_Silverlight_v5.1.30514.0_for_WinXP_Post-SP3_UpdatePack_FINAL_INTL.7z
as OnePiece suggested. But nLite throws an error, saying "missing opw2k3up.inf".

So for now, I'm staying with the working version I mentioned first (Final 1.04 + December POS Addon), until I found the best way to prevent the Silverlight problems. Of course, I will try the other OnePiece suggestions, but I just think it's too bad the brand new 1.05 pack has this problem.
Still, a lot of thanks to OnePiece's hard work!!!

cosy
Posts: 278
Joined: Tue Apr 18, 2006 11:56 pm

Post by cosy » Sat Dec 13, 2014 7:01 am

@Atari800xl
wouldn't be a simple way to make a Cd with 1.05 and then install on a live installation !your" much needed sliverlight?

User avatar
Atari800xl
Posts: 345
Joined: Sun Dec 30, 2012 5:46 pm
Location: NL

Post by Atari800xl » Sat Dec 13, 2014 7:24 am

Cosy, I haven't used CD's in years :-) (USB only, using Win8PESE and WinNTSetup)

...but of course, I know what you mean. I just took a long walk with my dogs, and had some ideas as well...
(1) I guess I could simply turn off the (botched?) Silverlight in Final 1.05, by using this section in winnt.sif:
[Components]
Silverlight = Off
Then later, in my PostInstall (which I use anyway..), I could manually (and silently, I hope) install Silverlight.

(2) I used the ready-made Dutch pack 1.05 by OnePiece, but also (for fun) I build it myself yesterday, using DXUPAC.exe and the INTL and Dutch folders. Then I compared the two, they were virtually the same (except for muweb.cat, mentioned a few posts back).
So now my question for OnePiece is: is it simple for me to just replace the "Silverlight.exe" from the current INTL folder, with a version I saved previously? I saved the INTL and Dutch folders for all Final Pack versions this year, so could I just replace the version?
That would be quite handy, but I'm not sure if there are other settings I need to change?

User avatar
OnePiece Alb
Posts: 525
Joined: Sat Sep 01, 2007 7:01 pm
Location: Albania
Contact:

Post by OnePiece Alb » Sat Dec 13, 2014 8:19 am

Is everything Ok them, just make sure you use the latest version of DXUPAC.exe
(Redownload DXUPAC.exe, Hash MD5 69B1DB167AFD0D60CCC38ADC53409B0E)


should not exist any kind of error during setup, if you see an error during setup, has only to do with the (is only a problem of) UpdatePack or AddOn or the Integration or Edit\Modification of the CD, not with the version of Silverlight or other

if you want you can put in the source diretory Silverlight.exe (Microsoft Silverlight (KB2977218) http://download.microsoft.com/download/ ... rlight.exe )
Atari800xl wrote: OnePiece_Microsoft_Silverlight_v5.1.30514.0_for_WinXP_Post-SP3_UpdatePack_FINAL_INTL.7z
as OnePiece suggested. But nLite throws an error, saying "missing opw2k3up.inf".
is an AIO AddOn for XP and 2003, nLite not ok with ExtraFileEdits, use the RVMi and you will be OK

for this reason in the addon there also [EditFile] (disable, as a second choice)

Code: Select all

;This section allows you to edit things that normally would not be possible to edit.
[ExtraFileEdits] 
OPMWXPUP.inf|"5.1.31010.0"|"5.1.30514.0"|0
OPW2K3UP.inf|"5.1.31010.0"|"5.1.30514.0"|0

;[EditFile]
;OPMWXPUP.inf,Strings,UpdateStrings
;OPW2K3UP.inf,Strings,UpdateStrings
;
;[UpdateStrings]
;Silverlight_ProductVersion        = "5.1.30514.0"
Ciao.
Image Image Image

User avatar
OnePiece Alb
Posts: 525
Joined: Sat Sep 01, 2007 7:01 pm
Location: Albania
Contact:

Post by OnePiece Alb » Sat Dec 13, 2014 10:08 am

@Atari800xl
Ok, Redownload everything in folder INTL is now the Silverlight v5.1.31211.0, so you do everything from the beginning

Ciao.
Image Image Image

User avatar
Atari800xl
Posts: 345
Joined: Sun Dec 30, 2012 5:46 pm
Location: NL

Post by Atari800xl » Sat Dec 13, 2014 10:57 am

OnePiece, you are THE BEST!!!
Will redo all, like you said, just give me a couple of hours (not at home right now).
I'll edit this post, or start new one. Just wanted to thank you as soon as possible. AMAZING JOB!!!

User avatar
OnePiece Alb
Posts: 525
Joined: Sat Sep 01, 2007 7:01 pm
Location: Albania
Contact:

Post by OnePiece Alb » Sat Dec 13, 2014 1:14 pm

@All

1 - Download the DXUPAC.exe http://www.ryanvm.net/forum/viewtopic.php?t=7622
2 - Create a new folder, example C:\UpdatePack
3 - extract OnePiece's Windows XP Post-SP3 Update Pack v1.0.5 FINAL ENU in C:\UpdatePack
4 - rename in C:\UpdatePack\OnePiece_WinXP_Post-SP3_UpdatePack_ENU
5 - copy the new Silverlight.exe in C:\UpdatePack
6 - run the DXUPAC, choose to create the XP Update Pack English, indicate the C:\UpdatePack
7 - click Start, and wait for the DXUPAC to finish his work

Image

Ciao a tutti.
Image Image Image

User avatar
Atari800xl
Posts: 345
Joined: Sun Dec 30, 2012 5:46 pm
Location: NL

Post by Atari800xl » Sat Dec 13, 2014 2:40 pm

OnePiece, your post above this one, appeared just I was doing my other testing:
(1) I downloaded again the full Final 1.05 (to be sure), then did a new RyanVMi integration run, then did a setup. Still had the error (procedure not found, etc). I wanted to do this test first, to make sure there was not a new version of 1.0.5 or something. (And to confirm that the standard 1.0.5 did not work for me).
(2) Then I downloaded latest DXUPAC. It was even newer that the one you mentioned above, I have 1.2.2.4 now (the hash you mentioned was for 1.2.2.2. To be clear: I used 1.2.2.4, then download all the latest stuff from INTL and DUTCH folders, and created a new "Final 1.0.5-NEWBUILD-20141213".
Then I did my usual: nlite slightly (classic setup screen, remove help system), DPBase (add SATA drivers), add to my multiboot-ready-ISO-template, remove LANG folder, add HOSTS, etc. etc, install with Win8PESE and WinNTSetup.

********* SUCCESS !!!! *********

I was testing this just as you made your previous post, so now I followed those steps as well. At first I didn't understand step (4), but I guess you mean: Make a subfolder "OnePiece_WinXP_Post-SP3_UpdatePack_ENU" (or "NLD" in my case) in C:\UpdatePack, and move all the extracted files in there).
Well, that seems to work as well, so everything's PERFECT again!!!!!!!!!! I'm so happy!!!!

User avatar
Atari800xl
Posts: 345
Joined: Sun Dec 30, 2012 5:46 pm
Location: NL

Post by Atari800xl » Mon Dec 15, 2014 1:22 pm

Thanks for the new Final 1.06 packs! So I guess this is the "Fixed" 1.05 pack (with new Silverlight), or are there other changes as well?

User avatar
OnePiece Alb
Posts: 525
Joined: Sat Sep 01, 2007 7:01 pm
Location: Albania
Contact:

Post by OnePiece Alb » Mon Dec 15, 2014 7:58 pm

Atari800xl wrote:Thanks for the new Final 1.06 packs! So I guess this is the "Fixed" 1.05 pack (with new Silverlight), or are there other changes as well?
in 1.0.6 (is a release like Beta, will be released soon) is only update the Silverlight http://www.ryanvm.net/forum/viewtopic.p ... 030#139030

better use the DXUPAC v1.2.2.5, where is fixed a bug in entries.ini, Thanks to a report of a Italian User

Ciao.
Image Image Image

User avatar
Atari800xl
Posts: 345
Joined: Sun Dec 30, 2012 5:46 pm
Location: NL

Post by Atari800xl » Tue Dec 16, 2014 12:24 am

So if I understand correctly: 1.05 final is now "superseded", and the 1.06 version I saw on the fileservers yesterday, is also superseded already (it was a beta, like you said). Indeed, now I see it has already been moved to the "Archive" folder.
OK, that explains why I hadn't seen an official 1.06 announcement yet.

OnePiece, it is so good to see that you keep on producing new versions, even when it is so much work, and things go wrong sometimes. I hope you will keep it up, it must be frustrating sometimes!

I will do a rebuild of the Updatepack, made from INTL and Dutch with the new DXUPAC 1.2.2.5, I am just curious to compare entries.ini with my last build (which also worked perfectly, it had the "fixed" Silverlight already).

User avatar
OnePiece Alb
Posts: 525
Joined: Sat Sep 01, 2007 7:01 pm
Location: Albania
Contact:

Post by OnePiece Alb » Tue Dec 16, 2014 2:15 am

DXUPAC 1.2.2.5 = OnePiece UpdatePack v1.0.6 (Final Release,already in the server now), UpdatePack v1.0.6 update Silverlight and Fixed bug in entries.ini
Atari800xl wrote:I am just curious to compare entries.ini

Code: Select all

HKLM,"SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon\Notify\RailNotification"
in 
HKLM,"SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\Notify\RailNotification"

Ciao.
Image Image Image

User avatar
Atari800xl
Posts: 345
Joined: Sun Dec 30, 2012 5:46 pm
Location: NL

Post by Atari800xl » Tue Dec 16, 2014 3:12 am

OnePiece, you will tell me when you get sick of my Thank You's, won't you?

Thanks for telling us what the glitch was (saves me some time, but I actually *like* playing around with this stuff).

It's typical, though, that it's just a single space that caused problems ("WindowsNT"/"Windows NT"). It's my personal experience too, that it's always spaces, zeroes and ones that cause the biggest problems.

You're the best, hope you have a wonderful Christmas, I wish I could buy you a beer (or other favorite beverage)!!!

spoof
Posts: 7
Joined: Thu Oct 09, 2014 5:47 am

Sorry for double posting

Post by spoof » Wed Dec 17, 2014 4:49 am

Actually I have already posted this in win server 2003 thread.
All download links for OnePiece Win2K3 Post-SP2 UpdatePack v7.2.0 ENU
are invalid. Could you please upload it again, OnePiece ? Thanks
I always use your update packs. Thanks for your hard work.

User avatar
OnePiece Alb
Posts: 525
Joined: Sat Sep 01, 2007 7:01 pm
Location: Albania
Contact:

Re: Sorry for double posting

Post by OnePiece Alb » Wed Dec 17, 2014 6:05 am

spoof wrote:Actually I have already posted this in win server 2003 thread.
All download links for OnePiece Win2K3 Post-SP2 UpdatePack v7.2.0 ENU
are invalid. Could you please upload it again, OnePiece ? Thanks
I always use your update packs. Thanks for your hard work.
OnePiece Alb wrote: for info, first it always updates (OneDrive, private not public) and Google Drive (UpdatePacks INTL are in Google Drive since yesterday), because from Google Drive (Google Drive is really the best) move\copy files with the remote on other servers, always have a backup, using the remote i move 10 GB of data per minute, I have backups of all files in more (Third Party) servers like
https://www.oboom.com/folder/AE4BJ774
https://userscloud.com/go/xfz7qp0u0nm7/
https://www.tusfiles.net/go/nrbbkkhh6chk/
etc etc etc

Ciao a tutti.
Image Image Image

User avatar
alsyundawy
Posts: 99
Joined: Mon Jun 28, 2010 5:47 pm

Post by alsyundawy » Fri Dec 19, 2014 7:38 am

can i req for old addons like vista boot loading bar & blue task manager for XP? becouse all link dead :D

User avatar
OnePiece Alb
Posts: 525
Joined: Sat Sep 01, 2007 7:01 pm
Location: Albania
Contact:

Post by OnePiece Alb » Fri Dec 19, 2014 1:12 pm

alsyundawy wrote:can i req for old addons like vista boot loading bar & blue task manager for XP?
You should use the DX's UpdatePack/Addon Creator to create latest Boot_Screen Addon
alsyundawy wrote:becouse all link dead :D
??????????? are in more than 10 different server, look the mirror in first post of the topic

Ciao.
Image Image Image

User avatar
Outbreaker
Posts: 703
Joined: Tue Aug 21, 2007 8:06 am

Post by Outbreaker » Mon Dec 22, 2014 4:47 pm

Could it be that this IE.inf file entry "setup.ini," should be "%50%\setup.ini,"?

Code: Select all

[Base.StartMenu.UpdateIni]
setup.ini, progman.groups,,"IE_INTERNET=%MSIEXPLORE_PROGGROUP%"
setup.ini, IE_INTERNET,,""%MSINETWIZ_DESC%"",,,
setup.ini, progman.groups,,"X_GROUP="
setup.ini, X_GROUP,,""%MSIEXPLORE_DESC%""
setup.ini, X_GROUP,,""Windows Explorer""
setup.ini, progman.groups,,"IECOMPAT=%MSIEXPLORE_DESC%"
setup.ini, IECOMPAT,,""%MSIEXPLORE_COMPAT%""

User avatar
OnePiece Alb
Posts: 525
Joined: Sat Sep 01, 2007 7:01 pm
Location: Albania
Contact:

Post by OnePiece Alb » Mon Dec 22, 2014 7:39 pm

Outbreaker wrote:Could it be that this IE.inf file entry "setup.ini," should be "%50%\setup.ini,"?

Code: Select all

[Base.StartMenu.UpdateIni]
setup.ini, progman.groups,,"IE_INTERNET=%MSIEXPLORE_PROGGROUP%"
setup.ini, IE_INTERNET,,""%MSINETWIZ_DESC%"",,,
setup.ini, progman.groups,,"X_GROUP="
setup.ini, X_GROUP,,""%MSIEXPLORE_DESC%""
setup.ini, X_GROUP,,""Windows Explorer""
setup.ini, progman.groups,,"IECOMPAT=%MSIEXPLORE_DESC%"
setup.ini, IECOMPAT,,""%MSIEXPLORE_COMPAT%""
http://msdn.microsoft.com/en-us/library ... 85%29.aspx
http://www.ryston.com/x/INF_web/up_ini_f.htm
Image Image Image

User avatar
Outbreaker
Posts: 703
Joined: Tue Aug 21, 2007 8:06 am

Post by Outbreaker » Mon Dec 22, 2014 11:39 pm

Should the setup.ini file not being modified? Because my setup.ini file was not modified at all after the WIndows XP installation. :?

User avatar
OnePiece Alb
Posts: 525
Joined: Sat Sep 01, 2007 7:01 pm
Location: Albania
Contact:

Post by OnePiece Alb » Tue Dec 23, 2014 3:31 am

I would not worry, that's one thing Mirosoft, those line are in ie.inf at least 20 years, there is no mistake them (only in case if you think you've found a BUG in IE4, because as i said\believe those are line them since then or perhaps even earlier) or nothing to improve them (at least in the case that you think to do better than Microsoft), so who is the point
Image Image Image

User avatar
Outbreaker
Posts: 703
Joined: Tue Aug 21, 2007 8:06 am

Post by Outbreaker » Tue Dec 23, 2014 8:59 am

Thanks this makes now more sense. :)

User avatar
Atari800xl
Posts: 345
Joined: Sun Dec 30, 2012 5:46 pm
Location: NL

Post by Atari800xl » Thu Jan 15, 2015 3:14 am

OnePiece Alb, thanks for the new POSreadys updates in de "box" (and other) folders.
KB3019215, KB3021674, KB3020393, ready for a new (local) POS Addon. :D

cosy
Posts: 278
Joined: Tue Apr 18, 2006 11:56 pm

Post by cosy » Fri Jan 16, 2015 5:31 am

@Atari800xl
are those small updates worthy the time to make a new update-pack?

User avatar
Atari800xl
Posts: 345
Joined: Sun Dec 30, 2012 5:46 pm
Location: NL

Post by Atari800xl » Fri Jan 16, 2015 5:52 am

Well, cosy, that's for everybody to decide for themselves. Who can really tell what's fixed and what's not. That's what I'm always wondering with updates (w7 and w81 as well).
For me, it's actually a hobby to create a new XP iso every month. Years ago, I always looked up to people who could build their own updated iso's, and now with help from OnePiece (and others here) we can! I create a new localized POS Addon every month, then create the new iso with OnePiece's final XP updatepack 1.06 and the POS Addon.

But you're right of course, there were only a few tiy updates this time. Well, Microsoft did take a 2 week Christmas holiday, so it's only half month worth of stuff.
I just really liked to have a 2015 XP!!

cosy
Posts: 278
Joined: Tue Apr 18, 2006 11:56 pm

Post by cosy » Fri Jan 16, 2015 1:39 pm

@Atari800xl
so then all the best and happy new year

User avatar
Atari800xl
Posts: 345
Joined: Sun Dec 30, 2012 5:46 pm
Location: NL

Post by Atari800xl » Wed Feb 11, 2015 1:00 pm

OnePiece, thanks for the february updates in the "box" (and other) folders. Much appreciated once more!!!

User avatar
Atari800xl
Posts: 345
Joined: Sun Dec 30, 2012 5:46 pm
Location: NL

Post by Atari800xl » Fri Feb 13, 2015 10:26 am

I have some font rendering problems now in my browsers (both IE and FF). Not sure if this is caused by the february POS updates (can hardly imagine..), but I never had this problem before.
Anyone of you have had similar trouble?
(I will investigate more in the meantime).

User avatar
5eraph
Site Admin
Posts: 4619
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Fri Feb 13, 2015 10:36 am

You're not alone, Atari800xl.

User avatar
OnePiece Alb
Posts: 525
Joined: Sat Sep 01, 2007 7:01 pm
Location: Albania
Contact:

Post by OnePiece Alb » Fri Feb 13, 2015 10:52 am

If KB3013455 creates problems, simply remove from the list the WindowsXP-KB3013455-x86-embedded-ENU.exe (or NLD or DEU or ITA tc etc) when you use the DXUPAC.exe

Ciao.
Image Image Image

User avatar
Atari800xl
Posts: 345
Joined: Sun Dec 30, 2012 5:46 pm
Location: NL

Post by Atari800xl » Fri Feb 13, 2015 11:02 am

Thank you so very much for your ultra-fast replies, 5eraph and OnePiece!!

Sorry, I missed the 11 feb QFE post on the same subject.

Once again, thanks for your replies, you're saving me a lot of time in testing etc. (I already had 2 laptops setup with new/previous iso, for comparing etc., but would NEVER have suspected KB3013455).

THANKS!!! I will make a new POSReady addon without it.

User avatar
Atari800xl
Posts: 345
Joined: Sun Dec 30, 2012 5:46 pm
Location: NL

Post by Atari800xl » Fri Feb 13, 2015 12:40 pm

I just HAVE to thank you guys once more!
You know, to me it's still quite amazing to believe I can build those wonderful (localized!) Update and Addon packs (I still remember the time I looked up to anybody with these skills). Thanks to your excellent tools (DXUPAC, RyanVMi, etc) and help here on this forum, even I can do it :-)

So I repeated the whole cycle (make POS addon, without KB3013455 this time, add Final XP and POS addon to XPSP3 with RyanVMi, use DPbase, use a bit of nLite'ing, build everything into my [multiboot] iso, boot Win8PESE, use WinNTSetup to install XP, start PostInstall). I even had dinner in the meantime!

So after less that 2 hours, everything's well again. Well, not 100% of course, we still need a new KB3013455, I wonder if MS will ever release it?! (You don't think they're doing this on purpose, do you!!!?)

THANKS!!!

User avatar
Atari800xl
Posts: 345
Joined: Sun Dec 30, 2012 5:46 pm
Location: NL

Post by Atari800xl » Thu Feb 19, 2015 1:55 pm

It seems there's a fix for Vista, but not for POS yet.
user_hidden reported this on MDL, maybe he'll post here as well.
I sure hope we'll get a fix as well...

User avatar
Atari800xl
Posts: 345
Joined: Sun Dec 30, 2012 5:46 pm
Location: NL

Post by Atari800xl » Mon Feb 23, 2015 9:01 am

OnePiece, did you check out harkaz' patch for KB3013455?
My guess is you're not a "fan" of making this patch work (somehow) for all localized versions? But I'm still interested in your thoughts on this, again my guess is you'd rather wait for an official new Microsoft fixed update? Or should we just keep skipping KB3013455 for our POS packs?
Thanks for any thoughts on this...

User avatar
OnePiece Alb
Posts: 525
Joined: Sat Sep 01, 2007 7:01 pm
Location: Albania
Contact:

Post by OnePiece Alb » Mon Feb 23, 2015 1:08 pm

Hi Atari800xl, http://www.ryanvm.net/forum/viewtopic.p ... 208#137208 in poor words UpdatePack never modify any file in CD

is a personal choice of each user (so i can not tell you what to do), by me personally i do not modify any files in the CD (because there is no need to do so)

however i believe you can ignore the KB3013455 for our POS packs, because if it was so important (as in the case of the update of IE) i think Microsoft would have already released the Fix

Ciao.
Image Image Image

User avatar
Atari800xl
Posts: 345
Joined: Sun Dec 30, 2012 5:46 pm
Location: NL

Post by Atari800xl » Mon Feb 23, 2015 1:45 pm

OnePiece Alb wrote:i believe you can ignore the KB3013455 for our POS packs
Thank you very much for taking the time to respond, I will follow your advice!

User avatar
Atari800xl
Posts: 345
Joined: Sun Dec 30, 2012 5:46 pm
Location: NL

Post by Atari800xl » Tue Mar 10, 2015 2:05 pm

I just seached for new updates on catalog.update.microsoft.com.
8 updates found, among them KB3034344, I extracted it and saw win32k.sys inside.
That's as far as my skill goes, but I hope one of you guys can tell us if this is a fix for the botched february win32k.sys update?
I certainly hope so!! (But fear the worst...)
I'll wait for OnePiece's uploads before I'll make a new POS Addon pack...

User avatar
Outbreaker
Posts: 703
Joined: Tue Aug 21, 2007 8:06 am

Post by Outbreaker » Tue Mar 10, 2015 10:50 pm

@OnePiece Alb
If i uninstall the "Microsoft Update" in the "Add/Remove WIndows Components" should i not be redirected to "http://windowsupdate.microsoft.com" instead of "http://update.microsoft.com"?

EDIT:
Here is the fix for it:
Open the file "OPMWXPUP.inf" and
Replace this (2 times):

Code: Select all

	DelFiles       = MicrosoftUpdate.Files
With this:

Code: Select all

	DelFiles       = MicrosoftUpdate.Files, DataStore.Files
And replace this:

Code: Select all

	11,,tskill.exe,,,"wuauclt"
With this:

Code: Select all

	11,,taskkill.exe,,,/IM "wuauclt.exe" /F

User avatar
Atari800xl
Posts: 345
Joined: Sun Dec 30, 2012 5:46 pm
Location: NL

Post by Atari800xl » Wed Mar 11, 2015 4:10 am

So nobody tested the new win32k.sys yet? (KB3034344)
I thought "everybody" would be all over this one :-)
(Hey, XP's not dead, is it? :-)

Anyhow, I'm at work now, but did download the new OnePiece POS updates (thanks for that!), along with the latest DXUPAC.exe, so as soon as I can, I'll make a new POS Addon and test the new stuff! That will be around 10 hours from now, now who will beat me to it? :-)
(to tell us if the font rendering is fixed).

User avatar
Outbreaker
Posts: 703
Joined: Tue Aug 21, 2007 8:06 am

Post by Outbreaker » Wed Mar 11, 2015 4:26 am

Yes the new KB3034344 update has fixed the Front bug. ;-)
harkaz did also released a fix for this back in February.

Post Reply