[Request] Font installing

Discuss & post Update Pack addons here.
Post Reply
Eiffel
Posts: 73
Joined: Fri Nov 03, 2006 3:36 am

[Request] Font installing

Post by Eiffel » Tue Nov 21, 2006 4:19 am

Hi ! Can somebody tell me how can I integrate some fonts ? There is an EU update pack for XP http://download.microsoft.com/download/ ... update.EXE

And I want to have them integrated (replacing old Arial and Times New Roman ) and also installing some new fonts I use. I've done something wich copies them in font folders but they are not recognized by windows. Must register them... and I don't know how.

Mitsuko Aninikkou
Posts: 210
Joined: Tue Dec 13, 2005 12:52 pm
Location: The Netherlands (But running US WinXP, in case it comes up)

Post by Mitsuko Aninikkou » Tue Nov 21, 2006 9:24 am

Here's something I whipped up quickly.. no experience with registering files, so this is my best guess (no error messages, atleast)
You can install it directly from the inf, but you'll have to move FontInst.cab to a subdir called "i386" first.
If someone could please try it and let me know if it works..

Edit: Version 1.1 is up.. this should 'register' the fonts in the registry, but I don't see why they'd need to be registered, seeing as Arial and Times New Roman are pretty standard and would be registered already. This thing should work correctly now though...

Name: Mitsuko_FontUpdateAddon.7z
Size: 1.022 KB
Version: 1.1
MD5: 5A3182B4E2B4987ABB1C8B9C2C6CEC92
Link: http://rapidshare.com/files/4262477/Mit ... on.7z.html
Link 2: http://www.uploading.com/files/ISMO04R4 ... on.7z.html

Mitsuko Aninikkou
Posts: 210
Joined: Tue Dec 13, 2005 12:52 pm
Location: The Netherlands (But running US WinXP, in case it comes up)

Post by Mitsuko Aninikkou » Tue Nov 21, 2006 9:45 am

Damn, misread the first post a bit; my pack contains some redundant information, but it'll show you how to register the fonts you want to add.

User avatar
ricktendo64
Posts: 3214
Joined: Mon May 22, 2006 12:27 am
Location: Honduras

Post by ricktendo64 » Tue Nov 21, 2006 9:53 am

@Mitsuko Aninikkou: Cool did not think I could use RegisterDLLs for font Registering... :) I been having this problem installing fonts from INF and also From TXT Setup and not having either them registering for a while now, but I hope this works on a real format install and not only on a DefaultInstall

Nice Going

Mitsuko Aninikkou
Posts: 210
Joined: Tue Dec 13, 2005 12:52 pm
Location: The Netherlands (But running US WinXP, in case it comes up)

Post by Mitsuko Aninikkou » Wed Nov 22, 2006 4:23 am

Actually, it doesn't show any error messages.. but I don't think it does anything. For some reason you got the old version 1.0; the new one uses AddReg, which should be correct (though redundant for Arial and Times New Roman, but I'll leave it up for reference)

Eiffel
Posts: 73
Joined: Fri Nov 03, 2006 3:36 am

Post by Eiffel » Wed Nov 22, 2006 8:44 am

Thanks, I will test them.

User avatar
ahmerkhan
Posts: 400
Joined: Mon Aug 28, 2006 8:02 am
Location: Pakistan
Contact:

Post by ahmerkhan » Mon Nov 27, 2006 5:39 am

I tried to make my own by reading "MRs Peel's Fonts installer Tutorial"....Ricktendo64 guide me very on how to use Mrs Peels Templete...

Thankyou rick :)

Lemonzest
Posts: 114
Joined: Tue Mar 07, 2006 8:19 am

Post by Lemonzest » Mon Nov 27, 2006 4:25 pm

thats all good for ttf fonts, but how about system bitmap fonts ending in .fon? how do i install and register them unattended?
AMD Athlon64 3000+ @2.4GHz, DFI Lanparty UT NF3 250Gb, 2x1024MB Geil Value Ram PC3200
ATI Radeon X800XT VIVO, SyncMaster 913N LCD, Logitech MX518, Creative Audigy2 ZS
Enermax Noisetaker 485W, Western Digital SATA 160GB, Windows Server 2003 R2 Standard

User avatar
MrNxDmX
Moderator
Posts: 3112
Joined: Mon Jan 03, 2005 7:33 am

Post by MrNxDmX » Mon Nov 27, 2006 7:07 pm

I will post my addon in 2 hours. Testing now.

User avatar
MrNxDmX
Moderator
Posts: 3112
Joined: Mon Jan 03, 2005 7:33 am

Post by MrNxDmX » Mon Nov 27, 2006 9:47 pm

Here is mine: "European Union Expansion Font Update" Addon
Tested on a turkish windows xp sp2, and working. No errors about fonts, and they are registered.

Edit: This is just the fonts update. Replaces older ones. All microsoft built.
Maybe Ryan includes this in his next pack.

Eiffel
Posts: 73
Joined: Fri Nov 03, 2006 3:36 am

Post by Eiffel » Tue Nov 28, 2006 3:34 am

May be - i already ask him, but no answer...

User avatar
MrNxDmX
Moderator
Posts: 3112
Joined: Mon Jan 03, 2005 7:33 am

Post by MrNxDmX » Tue Nov 28, 2006 4:08 am

I talked him on msn, and he said he will include this one in next update pack.

Post Reply