RyanVM Update Pack 1.3.1 - Released August 24, 2005

Questions about Update Pack making? Ask here.
Acheron
Posts: 389
Joined: Thu Nov 25, 2004 4:05 pm
Location: The Netherlands
Contact:

Post by Acheron » Sun Sep 04, 2005 4:17 pm

Finally success.

I've created an addon pack with full Windows Update V6 /Microsoft Update support, standard redirecting to Microsoft Update.

However only for Dutch Windows XP:

http://rapidshare.de/files/4728748/Micr ... k.cab.html

:wink:
Last edited by Acheron on Tue Sep 20, 2005 4:48 am, edited 1 time in total.

User avatar
RyanVM
Site Admin
Posts: 5190
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Sun Sep 04, 2005 6:48 pm

hp38guser wrote:I was sick of not having Windows Update redirected to the new Microsoft Update site:

Ryan, you need to distribute datastor.edb with your pack and copy it to %windir%\SoftwareDistribution\Datastore This file contains all settings you make when visiting the Windows Update site. It also contains the Microsoft Update url :lol: (think of redirecting to ryanvm.net)
I'm gonna test this, however I don't know if this file is system-specific.
YOU ROCK!

User avatar
Siginet
Site Admin
Posts: 2894
Joined: Fri May 27, 2005 1:07 pm
Location: Planet Earth
Contact:

Post by Siginet » Sun Sep 04, 2005 7:14 pm

Tight! Now I need that in English pack. :D
Image
--Siginet--

Techware
Your Virtual Technician
Computer Management Software

User avatar
glent
Posts: 223
Joined: Tue Dec 21, 2004 3:32 pm
Location: UK

Post by glent » Tue Sep 06, 2005 5:35 am

Mo matter what i do , I still dont have unlocker on my right click
I have redownloading all packs and have all tried versions RC7,RC8 and RC9 with the same result, I have even tried using only the addon pack and not the media player one. I also started over with XP Pro RTM and slipstreamed SP2 into it, Unlocker is in system32 and all the sysinteral apps work fine. Any ideas?

mindwarper
Posts: 255
Joined: Mon Jul 25, 2005 9:56 pm
Location: Netherlands

Post by mindwarper » Tue Sep 06, 2005 9:29 am

glent wrote:Mo matter what i do , I still dont have unlocker on my right click
I have redownloading all packs and have all tried versions RC7,RC8 and RC9 with the same result, I have even tried using only the addon pack and not the media player one. I also started over with XP Pro RTM and slipstreamed SP2 into it, Unlocker is in system32 and all the sysinteral apps work fine. Any ideas?
Yes I have come accross the same issue from time to time, not always though...

go read here:
viewtopic.php?t=457

User avatar
glent
Posts: 223
Joined: Tue Dec 21, 2004 3:32 pm
Location: UK

Post by glent » Tue Sep 06, 2005 1:42 pm

Hmm just made another cd with Xpize and a few regtweaks and now its working again ....weird

dale5605
Posts: 282
Joined: Mon Aug 15, 2005 10:26 pm

Post by dale5605 » Tue Sep 06, 2005 4:40 pm

I think ryan mentioned already that he would work on it.

User avatar
Mavericks choice
Posts: 273
Joined: Wed Nov 24, 2004 3:39 am
Location: Downunder

Post by Mavericks choice » Wed Sep 07, 2005 7:20 am

All good here with Ryan's pack, just a couple of pnp driver dramas integrating with NLite but off topic here.
The Man from Aus

RBCC
Posts: 8
Joined: Tue Sep 06, 2005 7:54 pm

Post by RBCC » Wed Sep 07, 2005 10:25 pm

What hotfixes from august are NOT included in 1.3.1? John
Would like help to build my own packs!

User avatar
MrNxDmX
Moderator
Posts: 3112
Joined: Mon Jan 03, 2005 7:33 am

Post by MrNxDmX » Wed Sep 07, 2005 11:03 pm

the ones released after 9th of august are not in this pack
EDIT: I may be wrong.Sorry if so.

User avatar
surcix
Posts: 30
Joined: Fri Mar 04, 2005 5:16 pm

Post by surcix » Thu Sep 08, 2005 1:59 pm

so... i've searched the forum but nothing usefull. is there any way to speed up the t39 delay so that everest or aida32 or any other programs will still recognize the installed updates, and show that they are installed ???

dale5605
Posts: 282
Joined: Mon Aug 15, 2005 10:26 pm

Post by dale5605 » Thu Sep 08, 2005 4:05 pm

surcix wrote:so... i've searched the forum but nothing usefull. is there any way to speed up the t39 delay so that everest or aida32 or any other programs will still recognize the installed updates, and show that they are installed ???
Disable SFC and remove the cat files. Microsoft Update, Everest, etc. will all report that all the hotfixes are properly installed. There will be no slowdown during install.

User avatar
surcix
Posts: 30
Joined: Fri Mar 04, 2005 5:16 pm

Post by surcix » Thu Sep 08, 2005 5:03 pm

thanks man.
one more thing. those this trick work after installing windows with all the cat files ??? meaning.... if i install windows and i have all the cat files in the system32/catroot folder, can they be deleted safely, and still be recognized by everest and wu ???

User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

Post by dgelwin » Thu Sep 08, 2005 5:25 pm

buletov wrote:OK to save you the effort of doing search:
...myself wrote:I see no reason to delete svcpack pack folder;
The annoying thing why you would do this is the T-39 minute delay;
Which is solved by solely editing the svcpack.in_ cabinet.

How to do it?

Copy and expand the svcpack.ca_ file somewhere;
Under the section [ProductCatalogsToInstall], add ; in the front of all unwanted catalog files
Save changed and compress back the file, then place new file back to I386 folder.
I find myself quoting buletov a lot but hey it's because this metod works :D oh and yes after you delete the entries you can safely delete the cat files, there no longer needed if they arent going to be signed
Don't sweat petty things....or pet sweaty things

dale5605
Posts: 282
Joined: Mon Aug 15, 2005 10:26 pm

Post by dale5605 » Thu Sep 08, 2005 9:40 pm

Yes surcix, you can also do it post-install as long as SFC is disabled.

User avatar
surcix
Posts: 30
Joined: Fri Mar 04, 2005 5:16 pm

Post by surcix » Fri Sep 09, 2005 9:26 am

10x man !!!

User avatar
orcoxp
Posts: 532
Joined: Sun Apr 17, 2005 2:05 pm
Location: Ontario, Canada

Post by orcoxp » Tue Sep 13, 2005 11:48 pm

Ryan, I'm a little confused on something

RVMAddonsFull_1.0.cab includes these 3 files for the Remote Desktop Client.

MSTSC.CH_ --> MSTSC.CHM
MSTSC.EX_ --> MSTSC.EXE
MSTSCAX.DL_ --> MSTSCAX.DLL

Which is great, but I can't seem to see where these files are being called from? But it seems to be updated.

Also, the INF file calls for SafeDisc.AddReg but the entry does not exist
Chris Thomson
AKA OrcoXP

PHP/MySQL/phpMyAdmin 2 & 3 successfully running simultaneously on XP SP3 IIS.

User avatar
RyanVM
Site Admin
Posts: 5190
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Wed Sep 14, 2005 5:24 pm

They're extracted directly to i386. As for the missing registry section, thanks for noticing. I'll take care of that in the next release.

For the record, I'm not going to be releasing an update as long as MRT is the only thing that's been updated. If MS does end up releasing this month's security update later, I'll put out a new release then.

dale5605
Posts: 282
Joined: Mon Aug 15, 2005 10:26 pm

Post by dale5605 » Wed Sep 14, 2005 5:31 pm

RyanVM wrote:They're extracted directly to i386. As for the missing registry section, thanks for noticing. I'll take care of that in the next release.

For the record, I'm not going to be releasing an update as long as MRT is the only thing that's been updated. If MS does end up releasing this month's security update later, I'll put out a new release then.
Doesn't flash player 8 count enough for a new pack? :cry: :cry: :cry:

User avatar
orcoxp
Posts: 532
Joined: Sun Apr 17, 2005 2:05 pm
Location: Ontario, Canada

Post by orcoxp » Wed Sep 14, 2005 7:12 pm

RyanVM wrote:They're extracted directly to i386. As for the missing registry section, thanks for noticing. I'll take care of that in the next release.

For the record, I'm not going to be releasing an update as long as MRT is the only thing that's been updated. If MS does end up releasing this month's security update later, I'll put out a new release then.
Was that missing registry entries for both?

I can understand the point of now putting out a new build for one update...but hows about a Medium Addon pack in the meantime?

I monkey'd a Medium Addon pack together on my own, but I would rather have one from you...I trust it more...lol

Oh, BTW this is the first time I ever made a CAB file...yaaay me!

One other thing...can we make a new thread just for praise and thanks?
It's getting a little tedious and time consuming to have to keep sifting through comments like "Thanks guys!", "You guys ROCK!" and "I want you to have my baby". :wink:
We could even make it a rule and ban people for doing it!!!

How to win friends and influence people...make an awesome XP Post-SP3 update pack!!!
Chris Thomson
AKA OrcoXP

PHP/MySQL/phpMyAdmin 2 & 3 successfully running simultaneously on XP SP3 IIS.

ViVa

Post by ViVa » Wed Sep 14, 2005 7:13 pm

dale5605 wrote:
RyanVM wrote:They're extracted directly to i386. As for the missing registry section, thanks for noticing. I'll take care of that in the next release.

For the record, I'm not going to be releasing an update as long as MRT is the only thing that's been updated. If MS does end up releasing this month's security update later, I'll put out a new release then.
Doesn't flash player 8 count enough for a new pack? :cry: :cry: :cry:
Yeh Ryan, please release 1.3.2 as we want the latest MRT + Flash player! :rolleyes: :rolleyes: :lol: :D

User avatar
RyanVM
Site Admin
Posts: 5190
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Wed Sep 14, 2005 10:07 pm

Flash 8 will be in the next release, but I'm still going to wait until the next security update.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

ViVa

Post by ViVa » Thu Sep 15, 2005 2:07 pm

I was kidding :P

User avatar
RyanVM
Site Admin
Posts: 5190
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Thu Sep 15, 2005 5:13 pm

I'm aware of that :)
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

Vince227

Post by Vince227 » Fri Sep 16, 2005 9:02 pm

I started with the original XPsp2 CD from MS. and all i did was run the integrate fixes from nlite and choose ryvm update pack 1.3.1 no integrate drivers, no hotfixes, no unattened, no patches, no tweaks.

I then choose create ISO. I burnt the CD then after installing the files xp reboots with an error has been encounter that prevents setup from countinuing, one of the components that windows needs to continue setup could not be installed.
A components file does not match the verification information present in the component manifest.


here is more detail: sxs.dll syntax error in manifest or policy file "d:\i386\asms\10\msft\windows\GDIPLUS.man" on line 4

I dont know if its a simple fix since I'm new and this is my first post, but I do hope there is a solution cause I would really like to run this well patched CD.
I post this in another section also but was not sure which one this belongs in, also there was no reply.

SOMEBODY PLEASE HELP dont know where to go from here.

THANK YOU in ADVANCE for your help.

User avatar
surcix
Posts: 30
Joined: Fri Mar 04, 2005 5:16 pm

Post by surcix » Sat Sep 17, 2005 3:51 pm

when will the next pack be released ???? i would like to reinstall my winxp but i would also like to install it whit the next version of the pack. pls hlp

ViVa

Post by ViVa » Sun Sep 18, 2005 7:26 pm

surcix wrote:when will the next pack be released ???? i would like to reinstall my winxp but i would also like to install it whit the next version of the pack. pls hlp
"When it's done."

Or even, if you looked a couple of posts above:
RyanVM
Posted: Thu Sep 15, 2005 3:07 am
Flash 8 will be in the next release, but I'm still going to wait until the next security update.

dale5605
Posts: 282
Joined: Mon Aug 15, 2005 10:26 pm

Post by dale5605 » Sun Sep 18, 2005 7:50 pm

Can someone perhaps make an addon for flash 8?

User avatar
boooggy
Posts: 1297
Joined: Tue Aug 16, 2005 2:20 am
Location: Bucharest, Romania

Post by boooggy » Mon Sep 19, 2005 1:33 am

it' s easy..... unpack Ryan's pack then unpack and overwrite the files found in here http://rapidshare.de/files/5270689/FLASH.rar.html. repack and that is it.
thanx to cyberloner for the flash.rar pack!!!
Last edited by boooggy on Tue Sep 20, 2005 8:41 am, edited 1 time in total.

User avatar
orcoxp
Posts: 532
Joined: Sun Apr 17, 2005 2:05 pm
Location: Ontario, Canada

Post by orcoxp » Mon Sep 19, 2005 9:42 am

shouldn't it be SWFLASH.INF rather than INI?
Chris Thomson
AKA OrcoXP

PHP/MySQL/phpMyAdmin 2 & 3 successfully running simultaneously on XP SP3 IIS.

User avatar
surcix
Posts: 30
Joined: Fri Mar 04, 2005 5:16 pm

Post by surcix » Mon Sep 19, 2005 1:07 pm

dale5605 wrote:
surcix wrote:so... i've searched the forum but nothing usefull. is there any way to speed up the t39 delay so that everest or aida32 or any other programs will still recognize the installed updates, and show that they are installed ???
Disable SFC and remove the cat files. Microsoft Update, Everest, etc. will all report that all the hotfixes are properly installed. There will be no slowdown during install.
i tryed a few hours ago the method u mentioned and it doesn't work. the t39 step works verry fast but after the installation finishes, neither everest, aida32, qfecheck or win updates recognize the updates. instead of telling me that all the 150+ updates are installed, it tells me that only 1 update is installed ( Q******.exe ).

the question remains. how can i go fast pass the t39 problem, and still the updates be recognized as installed ??? pls hlp me

User avatar
buletov
Posts: 380
Joined: Tue Feb 15, 2005 11:30 am

Post by buletov » Mon Sep 19, 2005 4:13 pm

Never know what life is gonna throw at you.

User avatar
cyberloner
Posts: 315
Joined: Tue Sep 20, 2005 2:13 am
Location: http://www.cybermania.ws
Contact:

Post by cyberloner » Tue Sep 20, 2005 2:21 am

i try slipstreaming it...
installation takes more than 1 hour...
after read some inside the forum...
they say just need to disable the SFC and del the cat entries ...
so that means the cat file is useless by doing that right?
can delete the cat files?

after doing that ... does that means the installation will be more faster?

all the answer up there is all yes....
i del all cat..
disable SFC (use nlite) cause see some forum say the patch file have problem....
clear all Svcpack.inf entries....and makecab of it...
installation is smooth as the original CD of winxp and it is updated with all ryan hotfix =)

CHEERS ALL
Last edited by cyberloner on Wed Sep 21, 2005 1:03 pm, edited 2 times in total.

User avatar
surcix
Posts: 30
Joined: Fri Mar 04, 2005 5:16 pm

Post by surcix » Tue Sep 20, 2005 3:14 am

hey guys !!! why can't you make a step by step wizard ( for the not so familiarized whit the manual editing of files ) on how to eliminate the t39 delay and still have the updates recognized ??? i tryed buletovs and dale5605 method and nothing worked. pls detailed help

User avatar
cyberloner
Posts: 315
Joined: Tue Sep 20, 2005 2:13 am
Location: http://www.cybermania.ws
Contact:

Post by cyberloner » Tue Sep 20, 2005 5:56 am

orcoxp wrote:shouldn't it be SWFLASH.INF rather than INI?
Windows default Flash 6 is using INI so.. by overwrite it...
u can have flash 8

dale5605
Posts: 282
Joined: Mon Aug 15, 2005 10:26 pm

Post by dale5605 » Tue Sep 20, 2005 10:23 pm

boooggy wrote:it' s easy..... unpack Ryan's pack then unpack and overwrite the files found in here http://rapidshare.de/files/5270689/FLASH.rar.html. repack and that is it.
thanx to cyberloner for the flash.rar pack!!!
Thanks for the link boooggy.

Ok I have extracted the pack, updated flash, and also removed the entries for the cat files and deleted the cat files.

I just don't know how to repack it. :oops: :oops:

dale5605
Posts: 282
Joined: Mon Aug 15, 2005 10:26 pm

Post by dale5605 » Wed Sep 21, 2005 12:10 am

Hmm this is fun. I updated my addons as well, with new version for unlocker, filemon, regmon. Also updated the wmp10 with your pack boooggy. :D

If I can just repack these now I will have a fully updated ryan pack. 8)

User avatar
boooggy
Posts: 1297
Joined: Tue Aug 16, 2005 2:20 am
Location: Bucharest, Romania

Post by boooggy » Wed Sep 21, 2005 6:00 am

i used for repackin' picozip.....of course i think there are other programs on the net.....so use google! :P

dale5605
Posts: 282
Joined: Mon Aug 15, 2005 10:26 pm

Post by dale5605 » Wed Sep 21, 2005 6:37 am

Thanks boooggy. :wink:

User avatar
Mavericks choice
Posts: 273
Joined: Wed Nov 24, 2004 3:39 am
Location: Downunder

Post by Mavericks choice » Thu Sep 22, 2005 12:08 am

Anyone recomend a tute for cabbing wm10 with a third party comp app eg picozip?
The Man from Aus

User avatar
boooggy
Posts: 1297
Joined: Tue Aug 16, 2005 2:20 am
Location: Bucharest, Romania

Post by boooggy » Thu Sep 22, 2005 2:05 am


User avatar
surcix
Posts: 30
Joined: Fri Mar 04, 2005 5:16 pm

Post by surcix » Fri Sep 23, 2005 4:12 pm

surcix wrote:hey guys !!! why can't you make a step by step wizard ( for the not so familiarized whit the manual editing of files ) on how to eliminate the t39 delay and still have the updates recognized ??? i tryed buletovs and dale5605 method and nothing worked. pls detailed help
please tell me how to do what i just asked earlier !!!!! :( :? :cry:

User avatar
cyberloner
Posts: 315
Joined: Tue Sep 20, 2005 2:13 am
Location: http://www.cybermania.ws
Contact:

Post by cyberloner » Mon Sep 26, 2005 7:29 pm

REMOVE THE T39 LAG AND SPEED UP INSTALLATION...
NEED TO PATCH THE SFC(system file checker)

Hope this help enough....
COPY SVCPACK.IN_ FROM I386
TYPE EXPAND SVCPACK.IN_ SVCPACK.INF
EDIT IT TO BE

;start

[Version]
BuildNumber=2600
MinorVersion=1
MajorVersion=5
Signature="$WINDOWS NT$"

[SetupData]


[ProductCatalogsToInstall]


[SetupHotfixesToRun]

;end

AND MAKECAB OF IT ...TYPE

MAKECAB SVCPACK.INF

AND SVCPACK.IN_ WILL BE CREATED....
OVERWRITE TO I386 FOLDER

DEL ALL CAT FILES IN SVCPACK FOLDER IN I386

so your winxp will be updated with super ryan pack and no lag at installation...
my installation last time is 1 hour more... now is around 30 minutes with all hotfix =)
good luck...

User avatar
Mavericks choice
Posts: 273
Joined: Wed Nov 24, 2004 3:39 am
Location: Downunder

Post by Mavericks choice » Tue Oct 04, 2005 1:36 am

Thanks Boooggy have seen the post at msfn but was lookin for more info cabbin with picozip.
The Man from Aus

Locked