[Release] Remove Unneeded Windows Components

Discuss & post Update Pack addons here.
User avatar
Kelsenellenelvian
Moderator
Posts: 4383
Joined: Tue Nov 30, 2004 8:32 pm
Location: Pocatello, ID
Contact:

Post by Kelsenellenelvian » Sun Dec 31, 2006 6:31 am

@ Bhishmar =
Have you heard of a little program called Virtual PC (It is now free BTW)?
You do know that you can try these for yourself safely without the need to reinstall windows on your actual PC?
The best way is not to trust others but to try for yourself....

User avatar
Bhishmar
Posts: 138
Joined: Mon Dec 25, 2006 2:42 pm

Post by Bhishmar » Mon Jan 01, 2007 2:44 am

Kelsenellenelvian wrote:@ Bhishmar =
Have you heard of a little program called Virtual PC (It is now free BTW)?
You do know that you can try these for yourself safely without the need to reinstall windows on your actual PC?
The best way is not to trust others but to try for yourself....
Thanks for ur suggestion.
Yes that is my motto also & of course doing it. But user feedback (with appropriate filtering) is one form of (important) input, towards supplementing ones own efforts in the path to building a reliable product/system. You will never know, each system being different to some extent, the results may vary. Some statistics is always welcome.

But then I'am sure what I said will not be news for you. I'am just in the learning phase for RVM integrator & addonpacks. :D

Btw my appreciation & thanks for all those great Kel's Addons.

regards

yufyaf
Posts: 6
Joined: Sat Jul 01, 2006 9:05 am

Post by yufyaf » Wed Jan 10, 2007 5:31 am

The links are broken, can you fix them please?

arachnoidzx2
Posts: 3
Joined: Wed Jan 17, 2007 7:29 am

Post by arachnoidzx2 » Thu Jan 18, 2007 7:31 am

This looks like an awesome Addon. But as stated, the Domain seems to be dead. Any news?

User avatar
zenmachine
Posts: 26
Joined: Tue Jul 04, 2006 8:46 am
Contact:

Post by zenmachine » Sat Jan 20, 2007 1:33 pm

Yes, all the links at the start of the thread seem to be expired...

User avatar
store88
Posts: 50
Joined: Sun Feb 04, 2007 8:54 am
Location: china

Post by store88 » Fri Mar 02, 2007 6:54 am

Yes, all the links at the start of the thread seem to be expired...

User avatar
Siginet
Site Admin
Posts: 2894
Joined: Fri May 27, 2005 1:07 pm
Location: Planet Earth
Contact:

Post by Siginet » Sun Mar 04, 2007 10:58 pm

I do not have any of these addons anymore. :(

If anyone has some of these addons can you please upload them for me? I will then host them at my host for everyone.

Sorry.
Image
--Siginet--

Techware
Your Virtual Technician
Computer Management Software

User avatar
ENU_user
Posts: 1253
Joined: Wed Jan 25, 2006 1:42 pm

Post by ENU_user » Sun Mar 04, 2007 11:12 pm

removed
Last edited by ENU_user on Sat Jun 26, 2010 12:11 pm, edited 1 time in total.

User avatar
Kiki Burgh
Posts: 206
Joined: Thu Apr 20, 2006 1:40 am
Location: Manila, Philippines

Post by Kiki Burgh » Sun Apr 15, 2007 9:00 am

hi ENU_user! has keytotime already turned over his works to you? all links from the 1st post go to: http://siginet.earlymorninghours.net/Addons/REMOVAL/ ? :(
-KIKI-

User avatar
ENU_user
Posts: 1253
Joined: Wed Jan 25, 2006 1:42 pm

Post by ENU_user » Wed Apr 18, 2007 10:10 am

..
Last edited by ENU_user on Sat Jun 26, 2010 12:33 pm, edited 2 times in total.

User avatar
rickytheanuj
Banned
Posts: 37
Joined: Tue May 22, 2007 2:39 pm
Location: Nepal

Post by rickytheanuj » Mon Jul 09, 2007 2:25 pm

i tried to download, msn explorer, windows messenger, outlook, speech, remote registry service and .....


from here, but unable to download, the link guide toward

earlymorninghours.net
when i click download it guide some other ways...

Where is the link for download?

User avatar
Siginet
Site Admin
Posts: 2894
Joined: Fri May 27, 2005 1:07 pm
Location: Planet Earth
Contact:

Post by Siginet » Sat Dec 22, 2007 11:38 pm

Does anyone have any of these addons so that I can upload them for use? I forgot to back these up before I lost the hosting for all of these addons. :(
Image
--Siginet--

Techware
Your Virtual Technician
Computer Management Software

User avatar
orcoxp
Posts: 532
Joined: Sun Apr 17, 2005 2:05 pm
Location: Ontario, Canada

Post by orcoxp » Sun Dec 23, 2007 12:59 am

I have MSN Explorer (I repacked this one to include removing MSNMsgr6 I think), Security Center, Windows Tour & Windows Messenger. Do you have somewhere I can upload them?

Also, you should make a note that using Remote Assistance through Windows Live Messenger will require something from Windows Messenger and will complain that Windows Live Messenger isn't the latest version. The only fix I found was to put Windows Messenger back in.
Chris Thomson
AKA OrcoXP

PHP/MySQL/phpMyAdmin 2 & 3 successfully running simultaneously on XP SP3 IIS.

jolt43
Posts: 3
Joined: Wed Oct 05, 2005 4:27 pm

I think I have most of them.

Post by jolt43 » Sun Dec 23, 2007 10:23 am

I knew that one day, my packrating abilities would come in handy!

This is what I have of removals:

Default_ScreenSavers_DeleteAddon.CAB
ENU--aioXp-removals-03.06.07-.7z
Integrator's-Nlite_Removals.rar
KTT_CLPSRV_DeleteAddon.CAB
KTT_COMM_DeleteAddon_1.1.CAB
KTT_DiskCleanup_DeleteAddon.CAB
KTT_FAX_DeleteAddon.CAB
KTT_FIREWALL_DELETEADDON.CAB
KTT_FRONTPAGEEXTENTIONS_DELETEADDON.CAB
KTT_IIS_DeleteAddon.CAB
KTT_IndexSrv_DeleteAddon_1.4.CAB
KTT_MessengerService_DeleteAddon.CAB
KTT_Migration_DeleteAddon.CAB
KTT_OOBE_DeleteAddon_V1.3.CAB
KTT_P2P_DeleteAddon.CAB
KTT_RemoteRegistry_DeleteAddon.CAB
KTT_SECURITYCENTER_DELETEADDON.CAB
KTT_Sound_RemovalAddon.CAB
KTT_WindowsHelp_DeleteAddon_1.2.CAB
KTT_WindowsMediaPlayer_DeleteAddon_v1.5.cab
KTT_wordpad_DeleteAddon.CAB
KTT_ZipFolder_RemovalAddon_v1.2.CAB
MrsP_Disable_WinPicFax_Addon_v1.1_WinXP2k3.cab
MrsP_Disable_WinPicFax_Addon_v1.3-070805.cab
Removal_Accessibility_DeleteAddon_v1.4.CAB
Removal_AutomaticUpdates_DeleteAddon_v1.5.cab
Removal_CharMap_DeleteAddon_v1.0.cab
Removal_ConnectionWizard_DeleteAddon.CAB
Removal_Defragmentor_DeleteAddon_v1.5.CAB
Removal_GameControllers_DeleteAddon.CAB
Removal_Games_DeleteAddon_v1.2.cab
Removal_InterntExplorer_DeleteAddon_v1.6.cab
Removal_LANG_DirDeleteAddon_v1.1.cab
Removal_MovieMaker_DeleteAddon_v1.5.CAB
Removal_MSNExplorer_DeleteAddon_v1.7.cab
Removal_MsSpeech_DeleteAddon.CAB
Removal_NetMeeting_DeleteAddon.CAB
Removal_OutlookExpress_DeleteAddon_v1.5.CAB
Removal_Srchasst_Deleteaddon_v1.2.CAB
Removal_SystemRestore_DeleteAddon_v1.6.cab
Removal_WindowsAgent_DeleteAddon_v1.1.cab
Removal_WindowsHelp_DeleteAddon_v1.0.cab
Removal_WindowsMediaPlayer_DeleteAddon_v1.0.cab
Removal_WindowsMessanger_DeleteAddon_v1.5.cab
Removal_WindowsTour_DeleteAddon_v1.8.CAB
Removal_WINNTUPG_DirDeleteAddon_v1.2.cab
RVMAddonsSyssetup_1.0.cab
SiginetAddons_RemovableCats.CAB
WINNTfix_AddOn.cab

I think most of them are the lastest version numbers given in this thread, but there might be one of two that aren't.

Where would you like them?

babyboom666
Posts: 1
Joined: Sun Oct 29, 2006 7:37 pm

Upload all please

Post by babyboom666 » Mon Dec 24, 2007 1:58 pm

Please upload all to rapidshare or megaupload

User avatar
Siginet
Site Admin
Posts: 2894
Joined: Fri May 27, 2005 1:07 pm
Location: Planet Earth
Contact:

Post by Siginet » Mon Dec 24, 2007 4:19 pm

I gave orcoxp and jolt43 posting accounts at our new online database. That is the perfect place for you guys to upload them. :D

Thanks.
Image
--Siginet--

Techware
Your Virtual Technician
Computer Management Software

vit100
Posts: 7
Joined: Thu Nov 23, 2006 3:12 pm
Location: Canada

Post by vit100 » Mon Dec 24, 2007 5:03 pm

Addon
Outlook Express
MD5Hash: 8B20341A2B98C43476E0EBE134529C4C
causes problem with MS outlook 200x..
It removes library inetcomm.dll, and outlook gives error
internet mail is not registered properly error: 0x80040154

User avatar
Siginet
Site Admin
Posts: 2894
Joined: Fri May 27, 2005 1:07 pm
Location: Planet Earth
Contact:

Post by Siginet » Sun Jan 06, 2008 10:37 pm

vit100 wrote:Addon
Outlook Express
MD5Hash: 8B20341A2B98C43476E0EBE134529C4C
causes problem with MS outlook 200x..
It removes library inetcomm.dll, and outlook gives error
internet mail is not registered properly error: 0x80040154
I commented out that file and released v1.6 of the Outlook Express removal. Try the new one and let me know if it works ok. ;)
Image
--Siginet--

Techware
Your Virtual Technician
Computer Management Software

rootfile
Posts: 66
Joined: Mon Jul 03, 2006 11:46 am

Off topic; deleting unneeded files or folders

Post by rootfile » Sat Jan 12, 2008 4:59 pm

I've searched and been unable to find an addon that deletes unneeded windows files and folders after a clean install such as Program Files\Online Services; system32\dllcache, etc. I know this stuff is a matter of personal preference so I've written an autoit script that does this because I keep finding stuff I don't need. But is it possible to do this with an addon?

User avatar
Siginet
Site Admin
Posts: 2894
Joined: Fri May 27, 2005 1:07 pm
Location: Planet Earth
Contact:

Re: Off topic; deleting unneeded files or folders

Post by Siginet » Sun Jan 13, 2008 2:40 am

rootfile wrote:I've searched and been unable to find an addon that deletes unneeded windows files and folders after a clean install such as Program Files\Online Services; system32\dllcache, etc. I know this stuff is a matter of personal preference so I've written an autoit script that does this because I keep finding stuff I don't need. But is it possible to do this with an addon?
I am pretty sure it is possible.

If you share your script I can take a look at it and see if I can create a removal for it. ;)
Image
--Siginet--

Techware
Your Virtual Technician
Computer Management Software

rootfile
Posts: 66
Joined: Mon Jul 03, 2006 11:46 am

Re: Off topic; deleting unneeded files or folders

Post by rootfile » Sun Jan 13, 2008 8:23 pm

Siginet wrote:I am pretty sure it is possible.

If you share your script I can take a look at it and see if I can create a removal for it. ;)
Here you go, but the thing is, this has to be the last thing that is run:

Code: Select all

DirCreate("C:\Backup")
FileMove(@WindowsDir & "inf\accessor.PNF", "C:\Backup", 8)
FileMove(@WindowsDir & "inf\accessor.inf", "C:\Backup", 8)
DirRemove(@WindowsDir & "Profiles\All Users\Start Menu\Programs\Microsoft Office", 1)
DirRemove(@WindowsDir & "Profiles\All Users\Start Menu\Programs\ERUNT", 1)
DirRemove(@WindowsDir & "Profiles\All Users\Start Menu\Programs\SpywareBlaster", 1)

DirRemove(@WindowsDir & "$NtUninstallWIC$", 1)
DirRemove(@WindowsDir & "$SQLUninstallMSXML2SP6-KB887606-x86-ENU$", 1)
DirRemove(@WindowsDir & "$hf_mig$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB319740$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB884020$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB884883$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB885626$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB886185$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB886716$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB887742$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB888302$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB889527$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB890859$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB891781$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB898900$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB899587$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB899589$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB900725$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB902400$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB904706$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB904942$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB908521$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB912817$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB913538$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB914389$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB915800$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB916846$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB917013$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB917021$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB917422$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB917537$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB917953$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB918997$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB923723$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB923800$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB924867$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB925398_WMP64$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB926139$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB928843$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB929399$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB930916$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB933612$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB935708$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB936782_WMP11$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB939683$", 1)
DirRemove(@WindowsDir & "$NtUninstallscripten$", 1)
DirRemove(@WindowsDir & "$NtUninstallWdf01001$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB924191$", 1)
DirRemove(@WindowsDir & "$NtUninstallKB924732$", 1)
DirRemove(@WindowsDir & "system32\1025", 1)
DirRemove(@WindowsDir & "system32\1028", 1)
DirRemove(@WindowsDir & "system32\1031", 1)
DirRemove(@WindowsDir & "system32\1037", 1)
DirRemove(@WindowsDir & "system32\1041", 1)
DirRemove(@WindowsDir & "system32\1042", 1)
DirRemove(@WindowsDir & "system32\1054", 1)
DirRemove(@WindowsDir & "system32\2052", 1)
DirRemove(@WindowsDir & "system32\3076", 1)

DirRemove(@WindowsDir & "Cursors", 1)
DirRemove(@WindowsDir & "Temp\Cookies", 1)
DirRemove(@WindowsDir & "Temp\hsperfdata_SYSTEM", 1)
DirRemove(@WindowsDir & "Temp\WPDNSE", 1)
DirRemove(@WindowsDir & "inf", 1)
DirRemove(@WindowsDir & "java", 1)

DirRemove(@ProgramFilesDir & "Microsoft CAPICOM 2.1.0.2\License", 1)
DirRemove(@ProgramFilesDir & "Online Services", 1)

FileDelete(@WindowsDir & "Temp\*.*")
FileDelete(@WindowsDir & "ie7updates\*.*")
FileDelete(@WindowsDir & "*.BMP")
FileDelete(@WindowsDir & "system32\dllcache\*.*")
FileDelete(@WindowsDir & "mui\*.*")

DirCreate(@WindowsDir & ("inf")
FilemOVE("C:\Backup\accessor.PNF", @WindowsDir & "inf", 8)
FileMOVE("C:\Backup\accessor.inf", @WindowsDir & "inf", 8)
Exit

creative4rce
Posts: 82
Joined: Mon May 21, 2007 9:55 pm

Post by creative4rce » Sat Apr 19, 2008 12:39 am

ok need help here
Two Questions
1/ the removals are to happen ... ?

*Before the update pack and addons ?
*After the update pack but before the addons?
Reason i ask

did UpdatePack=C:\RVMUpdatePack2.2.1.7z
[AddonPacks]
Kels_SafeXP_Addon_v1.5.7.14.cab
NR_IE7en_Addon_1.1.0.7z
RVMAddons_1.8.3.7z
RVMAddonsWMP10_3.1a.7z
DirectX_9.0c_End-User_Runtime_AddOn_0.3.3_-_redxii.7z
made Cd and installed .. all works well ...

on that same intergrated folder i later did

[AddonPacks]
Removal_AutomaticUpdates_DeleteAddon_v1.5.cab
Removal_LANG_DirDeleteAddon.cab
Removal_MSNExplorer_DeleteAddon_v1.7.cab=
Removal_WindowsMessanger_DeleteAddon_v1.5.cab
Removal_WINNTUPG_DirDeleteAddon_v1.1.cab
KTT_RemoteRegistry_DeleteAddon.CAB

made Cd installed but IE7 shortcut exists but empty .. folder is there but few files but no working files
and WMP10 no shortcut folder is there but few files .. no working files the desktop has no themes just that pale blue color and white background start and program tab
also tried in a one shot ..
if i use any of these removals within a list of the updated packs together not only IE7 and WMP!0 but any addons that listed with the removals wont intergrate properly either

2/ any ideas which pack or packs is causing this issue ?
Cheers

User avatar
crashfly
Posts: 789
Joined: Thu Mar 13, 2008 11:39 pm
Location: Arkansas, USA

Post by crashfly » Sun May 18, 2008 2:10 pm

I seem to be having a problem with one of the addons that I am using from this thread. It particular, I have narrowed it down to KTT_Sound_RemovalAddon.cab.

The problem comes when I go to install, during text setup mode , an error pops up saying:
The following value in the .SIF file used by Setup is corrupted or missing:

Value 0 on the line in section [WinntDirectories] with key "26."

Setup cannot continue. To quit Setup, press F3.
I have traced this problem back to the above addon because it appears to be the only addon that removes the line specified.

Code: Select all

...
rvmtemp\txtsetup.sif|26 = Media||1
...
If this is the *only* problem with the addon, I am going to try removing just that specific line from the ini file. I will report back results on that.
A mind is like a parachute, it only functions when it is open.
--Anonymous

How to Ask Questions the Smart Way

User avatar
crashfly
Posts: 789
Joined: Thu Mar 13, 2008 11:39 pm
Location: Arkansas, USA

Post by crashfly » Sun May 18, 2008 6:33 pm

Well ... my findings are in. Removing the following line:

Code: Select all

...
rvmtemp\txtsetup.sif|26 = Media||1
...
*does* help. That *at least* allows windows setup to continue. Also though, I seem to be getting missing file errors from the "Windows Sound Removal" and "Windows Screensaver Removal" addons. The files are physically being removed, however windows somehow still thinks it needs them. I can skip past the files not being there, but it is a little less 'unattended' than I really want.

With the above information, maybe a fix is in order for those two removal addons?
A mind is like a parachute, it only functions when it is open.
--Anonymous

How to Ask Questions the Smart Way

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Sun May 18, 2008 7:33 pm

I guess you are suffering this:
RVMi has a bug that only delete entries in one section (either sourcediskfiles or sourcediskfiles.x86, i can't check it right now since i'm using a mobile) of txtsetup. so if the original entries are in the other section, then an addon which has such files in [obsolete_files] will mess the matter.
I had this kind of problem when i was adding some obsolete files of wmp8 in my wmp10 addon. the solution is to delete those lines in txtsetup.sif by yourself.
Image
My work list(Hosted by dumpydooby)

User avatar
ENU_user
Posts: 1253
Joined: Wed Jan 25, 2006 1:42 pm

Post by ENU_user » Sun May 18, 2008 10:56 pm

crashfly wrote: With the above information, maybe a fix is in order for those two removal addons?
ok i updated those ...

Scrn-Savrs_which was originally an addon created by me just got replaced &updated!

for ktt's sounds I made a separate new post with his original addon of this thread
and then in-placed the threads link with the new addon i made for sound removals ..

User avatar
crashfly
Posts: 789
Joined: Thu Mar 13, 2008 11:39 pm
Location: Arkansas, USA

Post by crashfly » Sun May 18, 2008 11:26 pm

ENU_user wrote:
crashfly wrote: With the above information, maybe a fix is in order for those two removal addons?
ok i updated those ...

Scrn-Savrs_which was originally an addon created by me just got replaced &updated!

for ktt's sounds I made a separate new post with his original addon of this thread
and then in-placed the threads link with the new addon i made for sound removals ..
I thank you for that. I will try them out. See what goodness they can do me :). On a side note, I am also working on an addon myself for removal of directories outside the I386 folder. If successful (still a couple of tweaks needed), I will post the ini file and you can make it your own addon.
A mind is like a parachute, it only functions when it is open.
--Anonymous

How to Ask Questions the Smart Way

User avatar
dumpydooby
Posts: 530
Joined: Sun Jan 15, 2006 6:09 am

Post by dumpydooby » Mon May 19, 2008 12:27 am

So did keytome kick the bucket?

User avatar
crashfly
Posts: 789
Joined: Thu Mar 13, 2008 11:39 pm
Location: Arkansas, USA

Post by crashfly » Mon May 19, 2008 1:01 am

I have an additional "addon" that *successfully* removes the "Extra Directories" on the same level as I386.

PLEASE NOTE: If you need tablet support, this will *REMOVE* those needed files.

Code for Entrie_EXTRAROOT_Removal.ini is as follows:

Code: Select all

;Entrie_EXTRAROOT_Removal.ini
;By crashfly

[general]
builddate=2008/05/18
description=Extra Directories in Root Delete
language=English
title=Extra Directories in Root Removal
version=1.0
website=http://ryanvm.net/msfn

[DirDelete]
..\cmpnents
..\DOCS
..\SUPPORT
..\VALUEADD
This *has* been tested and successfully works.

I would post this on Signet's website, however I am unable to register at this time. Maybe I will be able to in the future (PM sent to Signet already), and then I will post the update there. In addition, I have a couple of other addons I am considering making. :twisted:
A mind is like a parachute, it only functions when it is open.
--Anonymous

How to Ask Questions the Smart Way

User avatar
bphlpt
Posts: 1379
Joined: Sat Apr 19, 2008 1:11 am

Post by bphlpt » Mon May 19, 2008 1:17 am

Isn't -- ..\cmpnents -- also needed if you're going to try to use the MCE addon also? And besides which, Ryan's Integrator automatically removes all those directories anyway, doesn't it? So this addon is intended to be used when? With nLite only? I haven't used nLite so I don't know if this is needed by it. I'm very confused. :?

User avatar
crashfly
Posts: 789
Joined: Thu Mar 13, 2008 11:39 pm
Location: Arkansas, USA

Post by crashfly » Mon May 19, 2008 1:45 am

bphlpt wrote:Isn't -- ..\cmpnents -- also needed if you're going to try to use the MCE addon also? And besides which, Ryan's Integrator automatically removes all those directories anyway, doesn't it? So this addon is intended to be used when? With nLite only? I haven't used nLite so I don't know if this is needed by it. I'm very confused. :?
You may be correct on the MCE addon. However, this is generally for the rest of us who do not use the MCE addon or need tablets support (otherwise the cmpnents directory could be removed from this extra addon to keep that support).

This addon is for the Integrator *only*. If I am not mistaken, only the Integrator supports certain information in the ini file (such as removals, etc). Therefore the addon will do *nothing* in nlite.

The main reason for creating this addon was similar to Signets post (way back when) to keep the process simplified and automatic. This way, I can copy over a *complete* source and just have this addon and not have to worry about removing those directories myself. In addition, I have recently had some issues with nlite and certain addons, and I was using the Integrator to specifically determine which addons were giving me problems. With further testing and "reduction", I may either stay with the Integrator, or I might even try using nlite again when I am satisfying I am not having "weird" addon problems.
A mind is like a parachute, it only functions when it is open.
--Anonymous

How to Ask Questions the Smart Way

User avatar
Siginet
Site Admin
Posts: 2894
Joined: Fri May 27, 2005 1:07 pm
Location: Planet Earth
Contact:

Post by Siginet » Mon May 19, 2008 1:47 am

bphlpt wrote:Isn't -- ..\cmpnents -- also needed if you're going to try to use the MCE addon also? And besides which, Ryan's Integrator automatically removes all those directories anyway, doesn't it? So this addon is intended to be used when? With nLite only? I haven't used nLite so I don't know if this is needed by it. I'm very confused. :?
It would be handy for those who do not use the integrator to copy the files to the destination or those who slipstream a servicepack during integration. ;)
Image
--Siginet--

Techware
Your Virtual Technician
Computer Management Software

User avatar
crashfly
Posts: 789
Joined: Thu Mar 13, 2008 11:39 pm
Location: Arkansas, USA

Post by crashfly » Mon May 19, 2008 3:06 am

Siginet wrote:It would be handy for those who do not use the integrator to copy the files to the destination or those who slipstream a servicepack during integration. ;)
Looks like I barely beat Siginet to it. Meh, it is all information.

And speaking of ... I think some of the addons need to be updated for SP3. As it specifically stands, removal of just specific files and directories are not a problem. When I use these addons:
  • KTT_MessengerService_DeleteAddon.CAB
    Removal_WindowsTour_DeleteAddon_v1.8.CAB
    Removal_MSNExplorer_DeleteAddon_v1.7.cab
    Removal_NetMeeting_DeleteAddon.CAB
    Removal_Srchasst_Deleteaddon_v1.2.CAB
I get strange behaviour around T-39 in which the install process just permanently pauses. The information screens still rotate, but the install does not proceed past that point. When those addons are removed, there are no problems at all.

This is just FYI for the people that take care of the above addons.
A mind is like a parachute, it only functions when it is open.
--Anonymous

How to Ask Questions the Smart Way

User avatar
ENU_user
Posts: 1253
Joined: Wed Jan 25, 2006 1:42 pm

Post by ENU_user » Mon May 19, 2008 6:06 am

removed :lol: when I gets more time ...
Last edited by ENU_user on Mon May 19, 2008 3:54 pm, edited 5 times in total.

User avatar
bphlpt
Posts: 1379
Joined: Sat Apr 19, 2008 1:11 am

Post by bphlpt » Mon May 19, 2008 8:07 am

Siginet wrote:It would be handy for those who do not use the integrator to copy the files to the destination or those who slipstream a servicepack during integration. ;)
Duh.. (Smacks Own head with large hammer) Of course! Integrator doesn't automatically remove those directories when integrating "in place"! Everybody knows THAT! :oops:

Sorry crashfly, shouldn't have doubted you, man.

User avatar
Pasha_ZZZ
Posts: 242
Joined: Thu Jul 13, 2006 6:27 am
Location: Russia, Slobodskoy

Post by Pasha_ZZZ » Wed May 28, 2008 7:56 am

crashfly wrote:And speaking of ... I think some of the addons need to be updated for SP3. As it specifically stands, removal of just specific files and directories are not a problem.
I need updated (for SP3) removal addons:
  • Removal_WindowsTour_DeleteAddon_v1.8.CAB
    Removal_MSNExplorer_DeleteAddon_v1.7.cab
crashfly wrote:I get strange behaviour around T-39 in which the install process just permanently pauses. The information screens still rotate, but the install does not proceed past that point. When those addons are removed, there are no problems at all.
I got same issue too with listed above addons...

dudepron
Posts: 14
Joined: Sun Jun 25, 2006 7:15 pm

Post by dudepron » Mon Jun 30, 2008 1:39 pm

The Removal_MsSpeech_DeleteAddon.CAB by keytotime doesn't seem to work correctly.
I get errors about sapicpl.hlp not found during installation.
This was tested using RVM integrator 1.5.3 and XP SP3 Update Pack 062008-r04.

dudpron

bhurtel
Posts: 36
Joined: Thu Jun 23, 2005 1:26 pm

Post by bhurtel » Wed Jul 02, 2008 11:24 pm

OOBE removal used for SP3 is causing to loose theme serivice

Freecirc
Posts: 2
Joined: Fri Nov 14, 2008 11:01 am

Outlook Express Re-Install

Post by Freecirc » Fri Nov 14, 2008 11:18 am

KeytoTime and Siginet,

Thanks for this excellent software and means to customize XP!

Last summer I created a HW indepependent image for use in my University's domain, and I used the Outlook Express removal pack as
part of the process as NO one supposedly used it. Now, months later I learn that 35 high level administrators in the U need it for a file parsing function in Web pages and Office 2007 docs.
Is there any way that you can help me create a package that I can push out to our users in the doamin that re-installs OE back ????

I have been tracking reg keys, looking into the uninstall pack, and comparing OE/system files files from other computers.....

TIA!
-Rob :oops:
RAL

Freecirc
Posts: 2
Joined: Fri Nov 14, 2008 11:01 am

Post by Freecirc » Fri Nov 14, 2008 12:42 pm

OK, never mind...

I figured it out. Sorry if I wasted anyone's time. The way to get it back on is to run the WAB50.INF and then the MSOE50.inf files from a machine that has OE from a normal install (Located in Windows/INF folder) and in each case either point the installer to the i386 folder or to another sharepoint that has the needed WAB and OE files.

DUH! :wink:

have a Blessed day!
RAL

User avatar
redxii
Posts: 395
Joined: Sun Dec 17, 2006 5:50 pm

Post by redxii » Fri Nov 28, 2008 5:30 pm

The Outlook Express remover has a typo.. [ExtrFileEdits]

Tabasco
Posts: 5
Joined: Thu Aug 10, 2006 9:09 am

Post by Tabasco » Mon Dec 29, 2008 4:17 pm

Hi KTT! I've been using your KTT_Sound_RemovalAddon.CAB with my SP2 unattended installations. However when I moved to SP3 and Ryan's Post SP3 update pack, I found that of all my addons only this one causes an error message: "kbd???.sys file is corrupt or missing" and something about "value 0 with key 26 in {Winntdirectories]". Now you have another sounds removal method with .ini file, but how to use it? Is there a way to include it into winnt.sif?

hoang0810
Posts: 1
Joined: Mon Mar 09, 2009 2:12 am

Post by hoang0810 » Mon Mar 09, 2009 2:20 am

you can remove Images and Backgrounds,
Media Center
Mouse Cursors
Movie Maker
Music samples

cezarica
Posts: 29
Joined: Mon Mar 09, 2009 9:55 pm

Post by cezarica » Mon Mar 16, 2009 4:04 pm

hi, what to do with KTT_IndexSrv_DeleteAddon_1.4.CAB cos doesn't remove all the files (noise.*, wbcache.*, wbdbase.*) from TXTSETUP.SIF? :rolleyes:

Raoul90
Posts: 675
Joined: Thu Jan 17, 2008 10:29 am
Location: The Netherlands

Post by Raoul90 » Fri Apr 03, 2009 10:52 am

Getting some error when i try to download some of them:
Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home2/aplusma1/public_html/integrator.professorcpu.net/data/downloadaddon.php on line 13

Warning: Cannot modify header information - headers already sent by (output started at /home2/aplusma1/public_html/integrator.professorcpu.net/data/downloadaddon.php:13) in /home2/aplusma1/public_html/integrator.professorcpu.net/data/downloadaddon.php on line 43

Warning: Cannot modify header information - headers already sent by (output started at /home2/aplusma1/public_html/integrator.professorcpu.net/data/downloadaddon.php:13) in /home2/aplusma1/public_html/integrator.professorcpu.net/data/downloadaddon.php on line 44

Warning: Cannot modify header information - headers already sent by (output started at /home2/aplusma1/public_html/integrator.professorcpu.net/data/downloadaddon.php:13) in /home2/aplusma1/public_html/integrator.professorcpu.net/data/downloadaddon.php on line 45

Warning: Cannot modify header information - headers already sent by (output started at /home2/aplusma1/public_html/integrator.professorcpu.net/data/downloadaddon.php:13) in /home2/aplusma1/public_html/integrator.professorcpu.net/data/downloadaddon.php on line 46

Warning: Cannot modify header information - headers already sent by (output started at /home2/aplusma1/public_html/integrator.professorcpu.net/data/downloadaddon.php:13) in /home2/aplusma1/public_html/integrator.professorcpu.net/data/downloadaddon.php on line 47

Warning: Cannot modify header information - headers already sent by (output started at /home2/aplusma1/public_html/integrator.professorcpu.net/data/downloadaddon.php:13) in /home2/aplusma1/public_html/integrator.professorcpu.net/data/downloadaddon.php on line 48

Warning: Cannot modify header information - headers already sent by (output started at /home2/aplusma1/public_html/integrator.professorcpu.net/data/downloadaddon.php:13) in /home2/aplusma1/public_html/integrator.professorcpu.net/data/downloadaddon.php on line 49

Warning: Cannot modify header information - headers already sent by (output started at /home2/aplusma1/public_html/integrator.professorcpu.net/data/downloadaddon.php:13) in /home2/aplusma1/public_html/integrator.professorcpu.net/data/downloadaddon.php on line 50

zzz
Posts: 3
Joined: Sun May 24, 2009 5:31 pm

Post by zzz » Mon May 25, 2009 4:25 pm

I'm trying "Remove Migration" addon (KTT_Migration_DeleteAddon.CAB, 58223ec2868e0a78844e72f68c90e92e) taken from this page - Official RVM Integrator website - Addons and every time when I boot WXP setup disk I'm getting this error:

Code: Select all

Windows XP Professional Setup
=============================
Setup cannot copy the file: migwiz.htm
  * To retry, press ENTER.
...
The same problem is with migwiz2.htm file as well.

How to fix it? Or is there another addon that removes Migration properly?

marzsyndrome
Posts: 239
Joined: Sun May 28, 2006 6:01 am

Post by marzsyndrome » Sun Aug 30, 2009 2:11 am

How much do the IE and WMP removal addons remove? I'm wondering if they attempt to clean everything out as much as possible without causing side effect errors. For one thing I hope the media files are left iconless afterwards...

Post Reply