[RELEASE] Boooggy's WMP 11 direct integration solution

Discuss & post Update Pack addons here.
Post Reply
User avatar
roirraW "edor"
Posts: 761
Joined: Sun Oct 15, 2006 2:25 pm

Post by roirraW "edor" » Mon Jun 02, 2008 11:01 am

I basically agree with ccl0, although in the past I always had used the WMP11 Slipstreamer first, then used nLite for all update packs and addons, and then DriverPacks.
Gigabyte case GZ-FA2CA-AJB
Gigabyte MA790X-UD4P with Realtek High Definition Audio
HIS Radeon HD 4850 512MB
AMD Athlon 64 X2 4400+ 2.3GHz
Corsair 4GB DDR2-6400 4-4-4-12
4x1TB SATA RAID 0+1/2x640GB SATA RAID 0/Misc. PATA
Windows 7 x64

User avatar
twig123
Posts: 105
Joined: Tue Jan 17, 2006 12:19 am

Post by twig123 » Mon Jun 02, 2008 11:08 am

So.. is it:
RyanVM
WMP11
addons and customize with nlite
DriverPacks

Doesn't WMP11 complain about 2 hotfixes (KB908536 and KB894871) that need to be applied after WMP11 Integration? (Sorry for all the Q:'s, but the directions are a little confising on boooggy's site)

User avatar
boooggy
Posts: 1297
Joined: Tue Aug 16, 2005 2:20 am
Location: Bucharest, Romania

Post by boooggy » Mon Jun 02, 2008 11:21 am

chiners
i didnt test it on xptablet cause i dont have it....but i suppose its working ....

twig
that 2 hotfixes are needed when u use wmp 11 on xp sp2 to fix the theme issue and oobe issue...slipstreamer prompts u to integrate only if the source doesnt contain the files in that fixes (meaning lower file version compare with the one in this fixes).
so if u integrate an update pack that contains those files or u integrate those 2 fixes directly and then u use slipstreamer, u wont get any popup.

User avatar
twig123
Posts: 105
Joined: Tue Jan 17, 2006 12:19 am

Post by twig123 » Mon Jun 02, 2008 11:59 am

Alright, I think I get it now.

I see that KB894871 isn't in the RVM pack, however KB908536 is...
I guess that I may have broken the one that IS in the RVM pack to get that error, however, I would still need to manually slip KB894871? can the WMP integrator do this, or should this be done with RVM Integrator first?
Putting the order to:
RVM Updates + KB894871
WMP11
nlite & addons
DriverPacks

Thanks a bunch!
I will test this once I get home and let you know how it goes. :D

User avatar
boooggy
Posts: 1297
Joined: Tue Aug 16, 2005 2:20 am
Location: Bucharest, Romania

Post by boooggy » Mon Jun 02, 2008 12:24 pm

nope u still need that fix and slipstreamer cant integrate it...
u can integrate with nlite as long as i know...
or
u can unpack ryans pack
then extract 894871 and take the msobmain.dll from the fix and the .cat file and add it to the ryans pack. then recompress and its done.

or even better....use sp3 :P

User avatar
twig123
Posts: 105
Joined: Tue Jan 17, 2006 12:19 am

Post by twig123 » Mon Jun 02, 2008 1:59 pm

Sweet. Thanks for the info!
...maybe we could get a summary of this added to the first post, or your site? to eliminate confusion for others in the future

User avatar
boooggy
Posts: 1297
Joined: Tue Aug 16, 2005 2:20 am
Location: Bucharest, Romania

Post by boooggy » Mon Jun 02, 2008 2:49 pm

if i will get the time....maybe i will build a small pack with this 2 hotfixes.

rootworm
Posts: 22
Joined: Thu Apr 12, 2007 2:22 am

Post by rootworm » Tue Jun 03, 2008 5:51 am

[quote="roirraW "edor""]Glad you got that figured out. One question, were you able to do the WMP11 Slipstreamer even after DriverPacks, or do you not use DriverPacks?[/quote]
Oh, I forgot about DPs. I actually do DPs last, it doesn't affect WMP11 at all...so I guess that makes WMP11 second-to-last for me.

User avatar
boooggy
Posts: 1297
Joined: Tue Aug 16, 2005 2:20 am
Location: Bucharest, Romania

Post by boooggy » Wed Jun 04, 2008 7:36 am

new version changelog
1.2.5.0:
- Regression fix from path handling improvements. This affected the case when we are copying files that overwrite in the standard architecture directory causing a crash with "Path format not supported".
- Fixed adding updated wmp drivers to driver32.cab instead of driver.cab
- Migrated code to subversion.

User avatar
twig123
Posts: 105
Joined: Tue Jan 17, 2006 12:19 am

Post by twig123 » Thu Jun 05, 2008 9:20 pm

@boooggy
I looked @ your slipstreamer page and my 2 required file versions match the requirements:
Uxtheme.dll = v6.0.2900.2845
Msobmain.dll = v5.1.2600.2659
(files are compressed as .dl_ files though)

Yet, I still get a popup saying to integrate KB908536 after...
Any ideas? I thought that if the source had the correct versions before Integrating WMP11 I would not be prompted.
(replicated in the new v1.2.5.0 as well)

User avatar
n7Epsilon
Moderator
Posts: 624
Joined: Thu Feb 17, 2005 1:37 am
Location: Cairo, Egypt

Post by n7Epsilon » Fri Jun 06, 2008 2:29 am

I have investigated the issue and it is due to me reversing the file build and the file private version components during comparison. Yes, you are correct in your thoughts, you should not be prompted if the correct versions are present before integrating WMP11.

This has been fixed and will go in next release.

User avatar
twig123
Posts: 105
Joined: Tue Jan 17, 2006 12:19 am

Post by twig123 » Fri Jun 06, 2008 6:34 pm

n7Epsilon wrote:This has been fixed and will go in next release.
Sweet! TYVM

RtOaNn
Posts: 19
Joined: Fri Jan 25, 2008 9:46 am

Post by RtOaNn » Sat Jun 07, 2008 4:01 am

n7Epsilon wrote:I have investigated the issue and it is due to me reversing the file build and the file private version components during comparison. Yes, you are correct in your thoughts, you should not be prompted if the correct versions are present before integrating WMP11.

This has been fixed and will go in next release.
Thanks a lot, was just about to post abt this issue too.

Integrated both hotfixes but WMP11 Slipstreamer still pops up the dialog box. Hope the new Slipstreamer fixes it.

User avatar
rubab
Posts: 187
Joined: Sun Dec 03, 2006 9:06 am

Post by rubab » Sun Jun 08, 2008 1:16 am

WMP11Slipstreamer v1.2.5.0
Detected source: Windows™ XP Professional SP3

Hotfixes:
windowsmedia11-kb946665-x86-intl.exe
WindowsXP-KB941569-x86-ENU.EXE
windowsmedia11-kb928788-x86-intl.exe
windowsmedia11-kb929399-v2-x86-intl.exe
windowsmedia11-kb929773-x86-intl.exe
windowsmedia11-kb932390-x86-intl.exe
windowsmedia11-kb933547-x86-intl.exe
windowsmedia11-kb935551-x86-intl.exe
windowsmedia11-kb935552-x86-intl.exe
windowsmedia11-kb939209-x86-intl.exe
WindowsMedia11-KB939683-x86-ENU.exe
windowsmedia11-kb944110-x86-intl.exe
windowsmedia11-kb944882-x86-intl.exe
windowsmedia11-kb945381-x86-intl.exe

Epsilon.Parsers.IniParser+Exceptions+MalformedLineException: Malformed line encountered.
Section: SetupHotfixesToRun
Input: AdobeRdr812.exe /sPB /rs /rps /msi"ALLUSERS=TRUE EULA_ACCEPT=YES SUPPRESS_APP_LAUNCH=YES"
Line number: 45
Identifier: Svcpack.Inf

at Epsilon.Parsers.IniParser.ThrowException(IniParserException ex)
at Epsilon.Parsers.IniParser.ParseIniCore(TextReader textReader, Boolean throwForMalformedLines, String firstSectionName, Boolean allowSections)
at Epsilon.Parsers.IniParser.Init(TextReader iniStream, Boolean throwFormatExceptionForMalformedLines)
at Epsilon.Parsers.IniParser..ctor(String filePath, Boolean throwForMalformedLines)
at WMP11Slipstreamer.Backend.PrepareForParse()
at WMP11Slipstreamer.Backend.SlipstreamWMP11()
at WMP11Slipstreamer.MainForm.WorkerMethod(Object workerParam)

Extra error information:
Section: SetupHotfixesToRun
Input: AdobeRdr812.exe /sPB /rs /rps /msi"ALLUSERS=TRUE EULA_ACCEPT=YES SUPPRESS_APP_LAUNCH=YES"
Line number: 45
Identifier: Svcpack.Inf

Deleting "G:\VRMPVOL_EN\i386\wmp11temp"... Done!

The source being modified has not been damaged.
All changes have been successfully reverted.

User avatar
bphlpt
Posts: 1370
Joined: Sat Apr 19, 2008 1:11 am

Post by bphlpt » Sun Jun 08, 2008 12:07 pm

rubab wrote:Input: AdobeRdr812.exe /sPB /rs /rps /msi"ALLUSERS=TRUE EULA_ACCEPT=YES SUPPRESS_APP_LAUNCH=YES"
???????????

Cheers and Regards.

User avatar
n7Epsilon
Moderator
Posts: 624
Joined: Thu Feb 17, 2005 1:37 am
Location: Cairo, Egypt

Post by n7Epsilon » Sun Jun 08, 2008 12:43 pm

Solution to MalformedLineException in svcpack.inf:

Open svcpack.inf, and look at the lines under [SetupHotfixesToRun].
Each line that has " in the middle, put quotes around it and double each quote inside. If you put quotes around a line that has no " in it, then nothing wrong will happen and it will work fine as well.

example line:
MyInstaller.exe /stuff:"parameters" /otherstuff abcd

should become:
"MyInstaller.exe /stuff:""parameters"" /otherstuff abcd"

You put a quote at the beginning and a quote at the end, and any quotes that were in the middle are doubled.
Last edited by n7Epsilon on Sun Jun 08, 2008 1:42 pm, edited 1 time in total.

User avatar
bphlpt
Posts: 1370
Joined: Sat Apr 19, 2008 1:11 am

Post by bphlpt » Sun Jun 08, 2008 12:54 pm

So that's 1 " at the beginning, 2 "" in the middle, and 3 """ at the end, right? In other words, you quote the entire line, then you have to double quote around the parameters within the overall quotes? I hope I'm not making this worse in trying to understand. :rolleyes:

Cheers and Regards.

User avatar
crashfly
Posts: 789
Joined: Thu Mar 13, 2008 11:39 pm
Location: Arkansas, USA

Post by crashfly » Sun Jun 08, 2008 1:16 pm

n7Epsilon wrote:I have investigated the issue and it is due to me reversing the file build and the file private version components during comparison. Yes, you are correct in your thoughts, you should not be prompted if the correct versions are present before integrating WMP11.

This has been fixed and will go in next release.
This problem, is it something to be concerned about now? If so, what is a work around *until* the next version?
A mind is like a parachute, it only functions when it is open.
--Anonymous

How to Ask Questions the Smart Way

User avatar
rubab
Posts: 187
Joined: Sun Dec 03, 2006 9:06 am

Post by rubab » Sun Jun 08, 2008 1:27 pm

Thanks n7Epsilon for the fast solution.

I actually solved it by slipstreaming the WMP11 after integrating SP3. I still don't know why the problem occurred when i integrated WMP11 last.

User avatar
n7Epsilon
Moderator
Posts: 624
Joined: Thu Feb 17, 2005 1:37 am
Location: Cairo, Egypt

Post by n7Epsilon » Sun Jun 08, 2008 1:49 pm

@bphlpt: Re-read my post, I expanded the example a little to make it more clear.

@rubab: Because you integrated a switchless installer before running the slipstreamer.

@crashfly: This issue is not a big deal, it will just cause the warning to pop-up incorrectly on SP2 sources even with the fix applied, there are no ill side effects on the integration of wmp11 or the source.

Workaround: Use SP3 sources only on XP 32-bit.

User avatar
bphlpt
Posts: 1370
Joined: Sat Apr 19, 2008 1:11 am

Post by bphlpt » Sun Jun 08, 2008 2:28 pm

Thanks for the quick response and the clarification with the new example. Very clear.

Cheers and Regards.

User avatar
crashfly
Posts: 789
Joined: Thu Mar 13, 2008 11:39 pm
Location: Arkansas, USA

Post by crashfly » Sun Jun 08, 2008 2:46 pm

Yes, thank you very much n7Epsilon. It appears the issue does not affect me in that I use a SP3 source.

Thanks again.
A mind is like a parachute, it only functions when it is open.
--Anonymous

How to Ask Questions the Smart Way

chiners_68
Posts: 55
Joined: Wed Sep 13, 2006 5:57 am

Post by chiners_68 » Tue Jun 10, 2008 7:20 am

Hi booogy.
I would like to add WMP11 slipstrwamer to a copy of MCE but get a report during the integration about 2KB's. is there a fix to get it to work with MCE..?

User avatar
boooggy
Posts: 1297
Joined: Tue Aug 16, 2005 2:20 am
Location: Bucharest, Romania

Post by boooggy » Tue Jun 10, 2008 11:20 am

please read the wmp slips site

Code: Select all

In this source the slipstreamer will pop up a warning (breaking unattended operation) unless KB908536 and KB894871 or any hotfixes that supercede them are slipstreamed, either directly with a utility like nLite or as part of an "Update Pack" before slipstreaming WMP11.

end3rkid
Posts: 39
Joined: Thu Apr 14, 2005 9:30 pm

Post by end3rkid » Tue Jun 10, 2008 11:28 pm

Getting an error with the lastest version. boooggy could you please send me the previous version?

EDIT: Fixed, was a kb corrupted, thanks mr_smartepants.
Last edited by end3rkid on Thu Jun 12, 2008 1:29 am, edited 2 times in total.

User avatar
mr_smartepants
Posts: 824
Joined: Thu May 18, 2006 5:56 am
Location: Cambridgeshire, UK

Post by mr_smartepants » Wed Jun 11, 2008 6:36 pm

end3rkid wrote: Offending hotfix: windowsmedia11-kb929399-v2-x86-intl.exe
Looks like your hotfix is corrupted. Try downloading it again from MS.
You can verify your hotfixes are not corrupted by simply doubleclicking them. if you get the installer, it's good. If you get a brief command window then nothing...it's bad.
Image
Some heroes don't wear capes, they wear Kevlar and dog-tags!

User avatar
5eraph
Site Admin
Posts: 4618
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Thu Jun 12, 2008 1:12 am

In case I haven't said so already: Thank you, boooggy and n7Epsilon. The latest Slipstreamer works flawlessly with XP x64 SP2 and my Update Pack. :)

chiners_68
Posts: 55
Joined: Wed Sep 13, 2006 5:57 am

Post by chiners_68 » Mon Jun 16, 2008 11:50 am

is there an update pack for these two updates?
please read the wmp slips site
Code:
In this source the slipstreamer will pop up a warning (breaking unattended operation) unless KB908536 and KB894871 or any hotfixes that supercede them are slipstreamed, either directly with a utility like nLite or as part of an "Update Pack" before slipstreaming WMP11.

User avatar
boooggy
Posts: 1297
Joined: Tue Aug 16, 2005 2:20 am
Location: Bucharest, Romania

Post by boooggy » Mon Jun 16, 2008 3:32 pm

u can download from xables share and then integrate with /integrate switch or via nlite

User avatar
boooggy
Posts: 1297
Joined: Tue Aug 16, 2005 2:20 am
Location: Bucharest, Romania

Post by boooggy » Tue Jun 17, 2008 10:06 am


User avatar
Stimpy
Posts: 499
Joined: Thu Dec 07, 2006 1:00 pm
Location: Denmark

Post by Stimpy » Tue Jun 17, 2008 10:43 am

Nice work Boooggy and n7Epsilon :)

StarChild
Posts: 19
Joined: Thu Oct 12, 2006 9:44 am

Post by StarChild » Tue Jun 17, 2008 11:14 am

Boooggy and n7Epsilon, just want you to know that your efforts are truly appreciated.

Thanks.

User avatar
twig123
Posts: 105
Joined: Tue Jan 17, 2006 12:19 am

Post by twig123 » Tue Jun 17, 2008 12:41 pm

StarChild wrote:Boooggy and n7Epsilon, just want you to know that your efforts are truly appreciated.

Thanks.
Ditto!
Thanks for the quick update of the new version!

User avatar
crashfly
Posts: 789
Joined: Thu Mar 13, 2008 11:39 pm
Location: Arkansas, USA

Post by crashfly » Tue Jun 17, 2008 6:38 pm

Thanks for the update guys. This has become one of the important parts of my installation disk. Thank you so much.
A mind is like a parachute, it only functions when it is open.
--Anonymous

How to Ask Questions the Smart Way

User avatar
twig123
Posts: 105
Joined: Tue Jan 17, 2006 12:19 am

Post by twig123 » Wed Jun 18, 2008 8:00 am

@boooggy & n7Epsilon - IDK what forum you'll read first, but I posted over @ the MSFN topic, an issue with 1.3.0.2

chiners_68
Posts: 55
Joined: Wed Sep 13, 2006 5:57 am

Post by chiners_68 » Wed Jun 18, 2008 8:29 am

just runnig the latest version of WMP11 slipstreamer 1.3.0.2 in autoimage & get the following

unhandled exception in UI thread.

User avatar
n7Epsilon
Moderator
Posts: 624
Joined: Thu Feb 17, 2005 1:37 am
Location: Cairo, Egypt

Post by n7Epsilon » Wed Jun 18, 2008 8:46 am

Known bug, going to be fixed in next version that will be released soon.

It only affects the unattended use, wmp11 not affected.
Last edited by n7Epsilon on Wed Jun 18, 2008 9:43 am, edited 1 time in total.

chiners_68
Posts: 55
Joined: Wed Sep 13, 2006 5:57 am

Post by chiners_68 » Wed Jun 18, 2008 9:37 am

Is it a major problem or can it be used without any issues occuring to the slipstream process?

User avatar
twig123
Posts: 105
Joined: Tue Jan 17, 2006 12:19 am

Post by twig123 » Wed Jun 18, 2008 9:45 am

@n7Epsilon - Always on top of things. I appreciate the quick response :D

@chiners_68 - manually slipping with this utility seems to work without any issues, however, calling the utility from a command line causes problems.

chiners_68
Posts: 55
Joined: Wed Sep 13, 2006 5:57 am

Post by chiners_68 » Wed Jun 18, 2008 10:25 am

i didnt back up 1.2.5.0 is there still somewhere I can download that as it worked & I need to get this image out..?

User avatar
dumpydooby
Posts: 530
Joined: Sun Jan 15, 2006 6:09 am

Post by dumpydooby » Wed Jun 18, 2008 4:15 pm

I have 1.2.4.0.

- Link removed by n7Epsilon, please try version 1.3.1.0 that has been released.

That's not the installer. That's the standalone EXE. Just overwrite the
one you have now.

Moderator edit: Please do not post links to older versions without permission first, also a new version is being released now that fixes this issue.

User avatar
n7Epsilon
Moderator
Posts: 624
Joined: Thu Feb 17, 2005 1:37 am
Location: Cairo, Egypt

Post by n7Epsilon » Wed Jun 18, 2008 6:41 pm

Version 1.3.1.0 released

User avatar
twig123
Posts: 105
Joined: Tue Jan 17, 2006 12:19 am

Post by twig123 » Thu Jun 19, 2008 11:13 am

n7Epsilon wrote:Version 1.3.1.0 released
Sweet! I tested and the command switches are working without any issues again! :D Thanks

User avatar
5eraph
Site Admin
Posts: 4618
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Sat Jun 28, 2008 2:38 pm

1.3.1.0 is working perfectly for me with XP x86 SP3 and XP x64 SP2. Thank you. :)

If only there was a tool that could do IE7 so well... ;)

User avatar
fevereb
Posts: 3
Joined: Sun Jun 29, 2008 5:43 am
Location: Hungary

Library info

Post by fevereb » Sun Jun 29, 2008 5:54 am

Hi all!

I'd like to ask that, in the media Library when there r many albums from an artist on what depends which album's cover is the first? and could it be changed? thx for the answer.
Image
Image
Image

bhurtel
Posts: 36
Joined: Thu Jun 23, 2005 1:26 pm

Post by bhurtel » Sun Jun 29, 2008 10:14 pm

i don't know why, but after integrationg of WMP11 (boogy ) and one peice IE7, i loosed my theme service..

now my unattended XPCD doesn't have theme service enabled..
also there is no show desktop icon on my quick launch bar

User avatar
twig123
Posts: 105
Joined: Tue Jan 17, 2006 12:19 am

Post by twig123 » Mon Jun 30, 2008 9:11 am

bhurtel wrote:i don't know why, but after integrationg of WMP11 (boogy ) and one peice IE7, i loosed my theme service..

now my unattended XPCD doesn't have theme service enabled..
also there is no show desktop icon on my quick launch bar
I believe the answer that you are looking for is addressed on Boooggy's slipstreamer site, link listed in the first post.

"In this source the slipstreamer will pop up a warning (breaking unattended operation) unless KB908536 and KB894871 or any hotfixes that supercede them are slipstreamed, either directly with a utility like nLite or as part of an "Update Pack" before slipstreaming WMP11. This is in order to fix issues with the "Themes" service and out-of-box experience not starting respectively on 1st boot."

bhurtel
Posts: 36
Joined: Thu Jun 23, 2005 1:26 pm

Post by bhurtel » Mon Jun 30, 2008 10:33 am

mine is windows XP SP3
so i think for SP3 it is not mentioned over the site..

what the proper step for my UAXP

i am performing in this way
XP SP3 original VLK
ryan integrator + one peice ie7
driver pack (mass storage only)
boogy wmp slipstreamer
patched files

Fragbert
Posts: 338
Joined: Tue Jan 24, 2006 10:59 am

Post by Fragbert » Mon Jun 30, 2008 10:38 am

bhurtel wrote:i don't know why, but after integrationg of WMP11 (boogy ) and one peice IE7, i loosed my theme service..

now my unattended XPCD doesn't have theme service enabled..
also there is no show desktop icon on my quick launch bar
You need to disable SFC in nlite or use onepieces all-in-one update pack.

The SP3 VLK is a black sheep among the unattended tools community. RVMi 1.5.3, slipstreamer, and many addons all have trouble specifically with VLK and the only way to be sure to defeat the integration problems is to use nlite to disable SFC - OR - use onepices AIO.

User avatar
5eraph
Site Admin
Posts: 4618
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Mon Jun 30, 2008 10:38 am

You should have better luck using this order:
  • XP SP3 original VLK
    ryan integrator + one peice ie7
    boogy wmp slipstreamer
    patched files
    driver pack (mass storage only)

Post Reply