RyanVM Update Pack 1.0.3 - Released November 4, 2004

Questions about Update Pack making? Ask here.
Locked
User avatar
RyanVM
Site Admin
Posts: 5190
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

RyanVM Update Pack 1.0.3 - Released November 4, 2004

Post by RyanVM » Tue Nov 23, 2004 6:31 pm

Replies are welcome in this thread, just try to keep them on topic.
  • BOTH: Added KB885932 Hotfix.
  • BOTH: Added KB887078 Hotfix.
  • BOTH: Fixed an issue with the wrong MSXML4 DLL being included.
  • BOTH: Made sysoc.inf a separate download since the XP Home version differs from the XP Pro version.
  • LITE: Removed some components. Do not extract 1.0.3 Lite over previous Lite installations.
Download Here
Last edited by RyanVM on Thu Dec 16, 2004 12:11 am, edited 2 times in total.

User avatar
RyanVM
Site Admin
Posts: 5190
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Thu Dec 02, 2004 12:47 pm

Rumor has it that the next big round of hotfixes will be on December 7. If that's the case, expect a new release then. Here's the changelog as it stands right now:
  • BOTH: Added KB883523 Hotfix.
  • BOTH: Added KB886677 Hotfix.
  • BOTH: Added KB887742 Hotfix.
  • BOTH: Added KB888240 Hotfix.
  • FULL: Added Copy To/Send To context menu option DLL.
  • FULL: Added Microsoft OpenType Font Properties Extension 2.1.
  • FULL: Added updated Remote Desktop Client help file.
  • FULL: Added WhoLockMe 1.04.

itsme_4ucz
Posts: 59
Joined: Thu Dec 02, 2004 11:12 pm

SFC_OS.DLL

Post by itsme_4ucz » Thu Dec 02, 2004 11:24 pm

Hi
RyanVM
can you can add it to ur upcomming Update Pack 1.4.(new one)

http://www.msfn.org/board/index.php?sho ... ntry226036

User avatar
RyanVM
Site Admin
Posts: 5190
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Fri Dec 03, 2004 12:38 am

RyanVM wrote:As I've already explained, I don't include hacked DLLs which don't give the user the ability to use the original functionality as well. Hence why I don't include a hacked tcpip.sys either.

User avatar
RyanVM
Site Admin
Posts: 5190
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Tue Dec 14, 2004 2:19 pm

Three new security updates for XP SP2 are out. I'll add them in a day or so when my finals are over and then I'll release 1.0.4.

EDIT: Make that 4
EDIT2: Make that 5

User avatar
RyanVM
Site Admin
Posts: 5190
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Wed Dec 15, 2004 12:57 am

Well, KB873339, KB885835, KB885836, and KB886185 are all integrated and working nicely. I'll add the MS Outlook update (KB887797) tomorrow and hopefully get a new release out by the evening.

User avatar
maska
Posts: 65
Joined: Tue Nov 30, 2004 5:17 am

Post by maska » Wed Dec 15, 2004 12:37 pm

About this one:
Vulnerability in HyperTerminal Could Allow Code Execution (KB873339)
What will happen if I remove HyperTerminal and then integrate your future 1.4 pack with nLite?

Acheron
Posts: 389
Joined: Thu Nov 25, 2004 4:05 pm
Location: The Netherlands
Contact:

Post by Acheron » Wed Dec 15, 2004 1:29 pm

Ryan, I made a new package with the Windows security updates. I'll wait for your package first to compare. You added some updates not available through Windows Update, did you :P

I am now up to release it. It will be called RyanVm's update pack December 04 NL.

I'm about to release update packs every month or so :)

User avatar
RyanVM
Site Admin
Posts: 5190
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Wed Dec 15, 2004 3:51 pm

maska wrote:About this one:
Vulnerability in HyperTerminal Could Allow Code Execution (KB873339)
What will happen if I remove HyperTerminal and then integrate your future 1.4 pack with nLite?
You'll have an extra couple files on your unattended CD.

I'm going to be in somewhat the same boat, as I specify winnt.sif to not install HyperTerminal. The worst that'll happen is you'll have an extra file in i386 and qfecheck will complain that the hotfix isn't installed properly (since the file it's looking for isn't there). Not the end of the world.

User avatar
RyanVM
Site Admin
Posts: 5190
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Wed Dec 15, 2004 3:51 pm

hp38guser wrote:Ryan, I made a new package with the Windows security updates. I'll wait for your package first to compare. You added some updates not available through Windows Update, did you :P

I am now up to release it. It will be called RyanVm's update pack December 04 NL.

I'm about to release update packs every month or so :)
K, I'm hoping to get mine out tonight.

Acheron
Posts: 389
Joined: Thu Nov 25, 2004 4:05 pm
Location: The Netherlands
Contact:

Post by Acheron » Wed Dec 15, 2004 4:33 pm

Ryan for the installation locations you can use the following variables:

%12% = Drivers dir
%16422% = Program Files dir
%16427% = Common Program Files dir

I used these variables for the new updates :)

I'll will try to add your updates into Dutch package. So far I have added the following after 1.0.3 full.

KB888240 - Some add-ons are not listed in the Manage Add-ons dialog box in Internet Explorer
KB886677 - Double-byte character set (DBCS) characters may appear corrupted
KB887742 - You receive the Stop error "Stop 0x05 (INVALID_PROCESS_ATTACH_ATTEMPT)"
KB873339 - Vulnerability in HyperTerminal could allow code execution
KB885835 - Vulnerabilities in Windows Kernel and LSASS could allow elevation of privilege
KB885836 - Vulnerabilities in Wordpad
KB886185 - Critical Update for Windows XP
KB887797 - Outlook Express update

So I'm just missing one XP update: KB883523 Hotfix.

Lucius Snow
Posts: 86
Joined: Wed Nov 24, 2004 6:01 am
Location: France

Post by Lucius Snow » Wed Dec 15, 2004 4:44 pm

I'm working on the pack as well on my side, so the french version should be released quickly after the original one. By the way, can you guys explain me the differences between sp2gdr and sp2qfe subfolders ? I still don't know which one i must chose to extract the files ....

User avatar
RyanVM
Site Admin
Posts: 5190
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Wed Dec 15, 2004 6:32 pm

Short answer: Use the QFE versions.

Long answer: I've posted this link on MSFN a few times, but never here. Give this KB article a read and see if it makes sense to you.
http://support.microsoft.com/default.as ... -us;824994
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
RyanVM
Site Admin
Posts: 5190
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Wed Dec 15, 2004 10:32 pm

1.0.4 is out. Continue discussion in that thread.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

Locked