Error in Integration

Questions about Update Pack making? Ask here.
Post Reply
User avatar
Zacam
Moderator
Posts: 615
Joined: Tue Sep 13, 2005 7:46 pm
Location: Portland, OR

Error in Integration

Post by Zacam » Tue Dec 27, 2005 9:15 pm

After PM'ing with Siginet it was suggested I post in the forums on my issue.

I'm currently running on a machine that was installed using RVM 2.0.1 w/ Integrator 1.0.5 with some addons. And it works beautifully.

My problem is that I'm now trying to create a new ISO for another machine using 2.0.1 w/ 1.0.5 and the same set of addons, and it's failing.

Using the same source ISO (or the cd from it) that I Integrated SP2 into (and only SP2) and either copying the contents or allowing the RVMI to copy the files generates the same results. I even recreated a clean SP2 iso using 3 seperate copies of XP Gold and 2 seperate sources for SP2 and still have the same issue.

XP Version is English XP Pro, corp key's. (SVCPACK file is NOT unicode.)

Failure is this: I select source and destination (neither directory has spaces in the path name, I've tried directories directly off the root of both C: and D: ) and I select RVMUpdate201.cab. With or without any additional addon's is irrelevant. I do not select to remove CAT files. I tell it to integrate. It processes the cab file, makes the entries necessary and goes into integration. Sit's at 1% for about 4 seconds and then snaps immediately to 100% saying it's done.

SVCPACK.INF is not altered at all. And while TXTSETUP.SIF has the line for SP2.CAB removed, the cab file still exists, and it's contents are not added to driver.cab. Anything added to the SVCPACK folder is not processed during install (for the updates or any of the addons).

It does extract the RMV cab information to rvmtemp. And it also creates the home and pro folders, though it does not process any of the files in those two. RVM_UpdateCAB.LOG indicates everything was extracted successfully and if addons are used, RVM_AddonCAB.LOG indicates everything processes as well. RVM_integrate.LOG on the other hand says it can't open input file on every single file it's supposed to process.

I've redownloaded 2.0.1 3 times (and gotten the same, correct, MD5 each time) and I've redownloaded Integrator 1.0.5. I also have Integrator 1.0.4 and 1.0.3 and it still does the same.

I utilized nLite and while it worked, it didn't work as well on adding 20% of the addons, though it appears to have managed the Update.cab. It also didn't manage to do driver integration nearly as well as my regular AutoIt method. I'd preffer to use Integrator and then adjust afterwards, make the ISO and burn. (espacially since Integrator has lower overhead and no dotNet dependancy)

I don't currently have another system at this time to test things out on, but I can grab another hard-drive to swap with. I just need to know if anyone can think of any reason this would be happening and if so, how to correct it, without going to the messure of installing XP Gold or XP SP2 on a clean HDD, only to discover that it's still going to do it there.

Attached is the RVM_integrate.LOG.

zzzz
Posts: 79
Joined: Tue May 03, 2005 3:44 am

Post by zzzz » Wed Dec 28, 2005 4:41 pm

does the expand command work properly for a single file?
(try in the I386 folder: expand setup.ex_ setuporg.exe)

also, check if the following files exist and are not corrupted: command.com, autoexec.nt and config.nt

Post Reply