RyanVM Update Pack 2.1.4 - Released November 19, 2006

Questions about Update Pack making? Ask here.
User avatar
RyanVM
Site Admin
Posts: 5168
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

RyanVM Update Pack 2.1.4 - Released November 19, 2006

Postby RyanVM » Sun Nov 19, 2006 10:59 pm

What's New
Version 2.1.4
  • Added KB920213 Hotfix. Replaces KB890046 Hotfix.
  • Added KB920342 Hotfix.
  • Added KB922599 Hotfix. Replaces KB921398 Hotfix.
  • Added KB922760 Hotfix. Replaces KB918899 and KB924496 Hotfixes
  • Added KB923980 Hotfix. Replaces KB899589 Hotfix.
  • Added KB924270 Hotfix. Replaces KB904829 and KB921883 Hotfixes.
  • Changed the way Flash is installed to better handle future updates.
  • Fixed corrupted hdaudres.dll.
  • Updated Adobe Flash Player to version 9.0.28.0.
  • Updated KB914440 Hotfix.
  • Updated Malicious Software Removal Tool to version 1.22.
  • Updated MSXML 4.0 SP2 to KB927978 release.
  • Updated MSXML 6.0 to KB927977 release.
For the love of God, read the nLite or Integrator directions for how to properly integrate this pack.

Notes
  • nLite 1.2.1 or RyanVM Integrator 1.4.2 is required to properly integrate this release.
  • If you used nLite to integrate the pack and are having problems, PLEASE read this thread before reporting problems.
Download Here
Or From My BitTorrent Tracker


Known Issues
  • High Definition Audio isn't working right for some people. As a workaround, replace the two hdaudio INFs with the ones from the September Update Pack (or directly extracted from KB888111).
If you do run into anything you think is an error, be sure to consult with the FAQ on my site before asking about it here.
Last edited by RyanVM on Sat Dec 16, 2006 1:53 pm, edited 2 times in total.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357
ViVa

Postby ViVa » Sun Nov 19, 2006 11:01 pm

Thank you!!!!!! :)
User avatar
DataX
Posts: 21
Joined: Mon Jun 12, 2006 10:03 pm
Location: [MX]
Contact:

Postby DataX » Sun Nov 19, 2006 11:05 pm

heh.. was just about to rebuild my install disc in a few minutes and 2.1.4 comes out. Great job Ryan. :)
Damage is king, Speed kills, Style is everything.
User avatar
Kelsenellenelvian
Moderator
Posts: 4380
Joined: Tue Nov 30, 2004 8:32 pm
Location: Pocatello, ID
Contact:

Postby Kelsenellenelvian » Sun Nov 19, 2006 11:08 pm

YAY!
User avatar
pawan
Posts: 67
Joined: Sat Aug 06, 2005 9:43 pm
Location: India

Postby pawan » Sun Nov 19, 2006 11:12 pm

Thanks Sir..... waiting since a long time.

Pawan
ViVa

Postby ViVa » Sun Nov 19, 2006 11:13 pm

pawan wrote:Thanks Sir..... waiting since a long time.

Pawan


Yeah, I must say, 5 days of waiting is indeed extremely long... :rolleyes:
jdrom17
Posts: 47
Joined: Sun Jan 15, 2006 1:39 am

Postby jdrom17 » Sun Nov 19, 2006 11:26 pm

Thank You Ryan! Keep up the great work!
User avatar
pawan
Posts: 67
Joined: Sat Aug 06, 2005 9:43 pm
Location: India

Postby pawan » Mon Nov 20, 2006 12:01 am

ViVa wrote:
pawan wrote:Thanks Sir..... waiting since a long time.

Pawan


Yeah, I must say, 5 days of waiting is indeed extremely long... :rolleyes:


Yes ViVa, because in last update pack there was a problem in HDA, so I have to stay with September Update Pack.

Thats why, I am saying Long Time. :lol:
treblA
Posts: 52
Joined: Sat Feb 04, 2006 10:22 am

Postby treblA » Mon Nov 20, 2006 12:14 am

thanks Ryan...your the MAN!!!!!
dkrus
Posts: 372
Joined: Wed Jun 21, 2006 1:54 pm

Postby dkrus » Mon Nov 20, 2006 12:18 am

Thanks for the update Ryan
User avatar
Mavericks choice
Posts: 273
Joined: Wed Nov 24, 2004 3:39 am
Location: Downunder

Postby Mavericks choice » Mon Nov 20, 2006 1:16 am

A Gentleman again. Time for a rebuild I guess?

Cheers
MC.
Last edited by Mavericks choice on Mon Nov 20, 2006 1:41 am, edited 1 time in total.
The Man from Aus
User avatar
ricktendo64
Posts: 3212
Joined: Mon May 22, 2006 12:27 am
Location: Honduras

Postby ricktendo64 » Mon Nov 20, 2006 1:18 am

Perfect timing Ryan... You too Kelsenellenelvian for 5.6 thank you both
User avatar
corona2k
Posts: 38
Joined: Sat Nov 18, 2006 7:07 am

Postby corona2k » Mon Nov 20, 2006 1:35 am

Thank you again for your hard work!
Image Image
User avatar
mr_smartepants
Posts: 824
Joined: Thu May 18, 2006 5:56 am
Location: Cambridgeshire, UK

Postby mr_smartepants » Mon Nov 20, 2006 2:04 am

Yes. Thank you for all your hard work Ryan. You are surely appreciated by many.
posttoast
Posts: 45
Joined: Tue Oct 31, 2006 5:54 am
Location: The Hague. The Netherlands

Postby posttoast » Mon Nov 20, 2006 2:37 am

Thanks for all the hard work mate :)
larciel
Posts: 216
Joined: Tue Dec 21, 2004 3:14 am

Postby larciel » Mon Nov 20, 2006 3:04 am

perfect, just perfect :D Thank you
datalife
Posts: 73
Joined: Wed Aug 17, 2005 6:24 pm

Postby datalife » Mon Nov 20, 2006 3:38 am

one question:

nlite 1.2.1 is full compatible with new features of this new RVMU or needed one upgrade for new hotfixex integrate it?
User avatar
buletov
Posts: 380
Joined: Tue Feb 15, 2005 11:30 am

Re: RyanVM Update Pack 2.1.4 - Released November 19, 2006

Postby buletov » Mon Nov 20, 2006 3:58 am

RyanVM wrote:nLite 1.2.1 or RyanVM Integrator 1.4.2 is required to properly integrate this release.
Never know what life is gonna throw at you.
Firefrorefiddle
Posts: 47
Joined: Thu Nov 02, 2006 5:29 am

Postby Firefrorefiddle » Mon Nov 20, 2006 4:31 am

great work ryan
datalife
Posts: 73
Joined: Wed Aug 17, 2005 6:24 pm

Postby datalife » Mon Nov 20, 2006 4:35 am

nlite is not always compatible with new hotfixes
generally it comes made one new release for the compatibility with the new hotfixes
User avatar
SoKoOLz
Posts: 180
Joined: Tue Jul 11, 2006 3:53 am

Postby SoKoOLz » Mon Nov 20, 2006 5:21 am

thx !!
Image
User avatar
pawan
Posts: 67
Joined: Sat Aug 06, 2005 9:43 pm
Location: India

Postby pawan » Mon Nov 20, 2006 5:36 am

High Definition Audio Driver still not working. :(

Pawan
User avatar
armond
Posts: 263
Joined: Tue Sep 13, 2005 11:43 am
Location: Glendale, CA USA

Postby armond » Mon Nov 20, 2006 6:19 am

Every time MS releases some security updates, and/or some public updates, I make a folder called "Required" on my hard drive and put them in that folder.
But this time, Ryan, You completely Delete this folder with Shift+Delete! Thank you for your grate job! :)
Last edited by armond on Mon Nov 20, 2006 6:29 am, edited 1 time in total.
the_guy
Posts: 242
Joined: Wed Feb 01, 2006 6:22 am
Location: PEI, Canada

Postby the_guy » Mon Nov 20, 2006 6:28 am

Good job on another great release.

the_guy
User avatar
armond
Posts: 263
Joined: Tue Sep 13, 2005 11:43 am
Location: Glendale, CA USA

Postby armond » Mon Nov 20, 2006 6:28 am

pawan wrote:High Definition Audio Driver still not working. :(
Pawan

Please let us know that on which motherboard are you testing the Update Pack?
I gave RyanVM's Update Pack to some of my friends that have Realtek HD Audio. Some other have VIA.
No one problem... :?
User avatar
RyanVM
Site Admin
Posts: 5168
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Postby RyanVM » Mon Nov 20, 2006 8:40 am

I test HDA on a Dell B130 laptop. As a workaround, try using the hdaudio INFs from the September release.
Get up to $200 off on hosting from the same people who host this website!

http://www.ryanvm.net/forum/viewtopic.php?t=2357
User avatar
m-p{3}
Posts: 47
Joined: Sat Oct 14, 2006 8:50 pm
Location: Montreal QC, Canada
Contact:

Postby m-p{3} » Mon Nov 20, 2006 8:47 am

Yay, that release made my day :)
Image
johndoe74
Posts: 11
Joined: Sat Jul 15, 2006 2:27 pm

Postby johndoe74 » Mon Nov 20, 2006 9:13 am

hi ryanvm, dont get pissed alright but what are the issues (if any) if nlite 1.0.1 is used? i've been observing the msfn nlite forums and 1.2.1 still has a ton of bugs. no offense to nuhi but it was a heck of an upgrade and still needs a lot of work before it's solid like 1.0.1. i'm gonna give the new pack a shot with 1.0.1 anyways but please let me know of anything I should be cautious of when using it. thanks

both you and nuhi rock. keep up the good work thanks
Image
User avatar
RyanVM
Site Admin
Posts: 5168
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Postby RyanVM » Mon Nov 20, 2006 9:24 am

It hasn't really been tested. You can try it, just don't come here complaining of integration bugs if it doesn't work right ;)
Get up to $200 off on hosting from the same people who host this website!

http://www.ryanvm.net/forum/viewtopic.php?t=2357
Rudi1
Posts: 232
Joined: Sun Mar 06, 2005 2:49 am

Postby Rudi1 » Mon Nov 20, 2006 9:26 am

Your release Ryan is more then welcome,Thanx a lot! :lol:
User avatar
warrior1109
Posts: 114
Joined: Sun Oct 09, 2005 12:05 pm
Location: London, UK

Postby warrior1109 » Mon Nov 20, 2006 9:29 am

Another excellent release, BIG thanx again Ryan
johndoe74
Posts: 11
Joined: Sat Jul 15, 2006 2:27 pm

Postby johndoe74 » Mon Nov 20, 2006 9:32 am

RyanVM wrote:It hasn't really been tested. You can try it, just don't come here complaining of integration bugs if it doesn't work right ;)


alright, I'll post feedback once I'm done
Image
User avatar
pawan
Posts: 67
Joined: Sat Aug 06, 2005 9:43 pm
Location: India

Postby pawan » Mon Nov 20, 2006 9:50 am

armond wrote:
Please let us know that on which motherboard are you testing the Update Pack?
I gave RyanVM's Update Pack to some of my friends that have Realtek HD Audio. Some other have VIA.
No one problem... :?


I have an Asus Motherboard, with Cmedia audio driver (ADI 1986, as showing in the device manager). I have tried all the suggestions of group members like replacing hdaudres.dll (http://www.ryanvm.net/forum/viewtopic.php?p=39466#39466), manual installation of hotfix (http://www.ryanvm.net/forum/viewtopic.php?p=37071#37071), but nothing worked, and I tried that on clean install (not on a virtual machine), now I am back to 2,1.2a. :( and now audio is working fine. :?
SHO_GuN
Posts: 137
Joined: Fri Jun 30, 2006 11:26 pm

Postby SHO_GuN » Mon Nov 20, 2006 10:00 am

Thanks Ryan.

I do have one glitch here, but no one else has mentioned it so I'm guessing its just my problem.

When I run Microsoft Update after doing an install with this pack, it lists KB920342 as an available update even though your documentation says its included in the pack.

I used nLite 1.2.1 and integrated IE7.
User avatar
RyanVM
Site Admin
Posts: 5168
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Postby RyanVM » Mon Nov 20, 2006 10:03 am

WFM. Try without nLite and see what happens.
Get up to $200 off on hosting from the same people who host this website!

http://www.ryanvm.net/forum/viewtopic.php?t=2357
User avatar
ENU_user
Posts: 1253
Joined: Wed Jan 25, 2006 1:42 pm

Postby ENU_user » Mon Nov 20, 2006 10:46 am

hope i will be able to get this one running soon ,with them couple of addons :) ,congrat's m8 and thanks again
User avatar
monkee
Posts: 23
Joined: Sun Sep 03, 2006 3:02 pm
Location: eu

Postby monkee » Mon Nov 20, 2006 10:49 am

W00T!

lessthanthree ryan :D

hope i won't have to wait for version 2.0.5 before i actually update my shit.
- shock the monkee -
johndoe74
Posts: 11
Joined: Sat Jul 15, 2006 2:27 pm

Postby johndoe74 » Mon Nov 20, 2006 11:42 am

works purrfect :D

just did a vm install - xp corp + self integrated sp2 -> ryanvm2.1.4+ryan's wmp10 -> ryan's dx9.0c (all three using integrator) -> nlite 1.0.1 to remove some crap. no wmp11, no ie7. after install and a quick run with mbsa 2.0 (with updated .CABs) it shows all updates installed fine (with the exception of ie7 obviously)
Image
User avatar
ahmerkhan
Posts: 400
Joined: Mon Aug 28, 2006 8:02 am
Location: Pakistan
Contact:

Postby ahmerkhan » Mon Nov 20, 2006 11:45 am

I am Glad to see it...:)
User avatar
armond
Posts: 263
Joined: Tue Sep 13, 2005 11:43 am
Location: Glendale, CA USA

Postby armond » Mon Nov 20, 2006 12:55 pm

Hi pawan,
That is your bad chance...
Probably Only ASUS is using CMedia HD Audio Driver...
User avatar
Mavericks choice
Posts: 273
Joined: Wed Nov 24, 2004 3:39 am
Location: Downunder

Postby Mavericks choice » Mon Nov 20, 2006 2:02 pm

Up & running so far no issues.

Cheers
MC.
The Man from Aus
techtype
Posts: 268
Joined: Mon Aug 15, 2005 5:46 pm

Postby techtype » Mon Nov 20, 2006 2:29 pm

Thanks, Ryan, I hope you never wear out!!
User avatar
fortunato
Posts: 11
Joined: Mon Nov 20, 2006 12:01 pm

Postby fortunato » Mon Nov 20, 2006 2:34 pm

Help!
Just tell me should i integrate DirestX 9.0c 1.0 andWMP 10 2.9 addons along with pack 2.1.4 ?
ViVa

Postby ViVa » Mon Nov 20, 2006 2:38 pm

If you need and / or want them, then yes of course you could integrate them along with 2.1.4.. :)

You should integrate nothing. ;)
User avatar
fortunato
Posts: 11
Joined: Mon Nov 20, 2006 12:01 pm

Postby fortunato » Mon Nov 20, 2006 2:48 pm

Thanx !
today it's first time i've got an error after integration. i don't know why ? never had any problems with Ryan before but today...
User avatar
Kelsenellenelvian
Moderator
Posts: 4380
Joined: Tue Nov 30, 2004 8:32 pm
Location: Pocatello, ID
Contact:

Postby Kelsenellenelvian » Mon Nov 20, 2006 2:51 pm

fortunato wrote:Thanx !
today it's first time i've got an error after integration. i don't know why ? never had any problems with Ryan before but today...


This does us absolutly NO GOOD without knowing what the error message was!
ViVa

Postby ViVa » Mon Nov 20, 2006 2:51 pm

Posting that specific error and telling us what addons you used might help...
User avatar
fortunato
Posts: 11
Joined: Mon Nov 20, 2006 12:01 pm

Postby fortunato » Mon Nov 20, 2006 2:54 pm

"can't copy svmg.sys"
i used all three addons above
User avatar
fortunato
Posts: 11
Joined: Mon Nov 20, 2006 12:01 pm

Postby fortunato » Mon Nov 20, 2006 3:11 pm

well, well... i see there's no one here to help me... then i'd better go and hang myself...
ViVa

Postby ViVa » Mon Nov 20, 2006 3:21 pm

Omg, after just 17 mins of no reply... you just blew your chance of getting any more support. Indeed, go and hang for yourself, goodbye.

Return to “Update Pack Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest