Questions for UpdatePack makers

Questions about Update Pack making? Ask here.
User avatar
ricktendo64
Posts: 3212
Joined: Mon May 22, 2006 12:27 am
Location: Honduras

Questions for UpdatePack makers

Postby ricktendo64 » Sun Jun 29, 2008 7:36 pm

Any other updatepack makers having trouble with KB942288-v3 Windows Installer 4.5?
I have problems with my CAT file not working...after t13 I do a qfecheck and its all good
Image

But when it first boots I do qfecheck again and i get an error, 3 of the DLLs aparently are not signed

Image

Here is my setuperr.log

Code: Select all

Error:
El programa de instalación detectó que el archivo de
sistema llamado [c:\windows\system32\msi.dll] no ha sido firmado debidamente
por Microsoft. Este archivo no se ha podido restaurar a la
versión correcta de Microsoft.
Use la utilidad SFC para comprobar la integridad del archivo.

***

Error:
El programa de instalación detectó que el archivo de
sistema llamado [c:\windows\system32\msihnd.dll] no ha sido firmado debidamente
por Microsoft. Este archivo no se ha podido restaurar a la
versión correcta de Microsoft.
Use la utilidad SFC para comprobar la integridad del archivo.

***

Error:
El programa de instalación detectó que el archivo de
sistema llamado [c:\windows\system32\msisip.dll] no ha sido firmado debidamente
por Microsoft. Este archivo no se ha podido restaurar a la
versión correcta de Microsoft.
Use la utilidad SFC para comprobar la integridad del archivo.

***

Translation is the files are not digitally signed
User avatar
5eraph
Moderator
Posts: 4441
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Postby 5eraph » Sun Jun 29, 2008 7:52 pm

You could try using the English CAT file like kal did and see if that helps.
User avatar
ricktendo64
Posts: 3212
Joined: Mon May 22, 2006 12:27 am
Location: Honduras

Postby ricktendo64 » Sun Jun 29, 2008 8:08 pm

ty 5eraph

Edit: To update you this worked, thanks again 5raph and kal...BTW somebody should report this to MS, because it does not affect us updatepack makers/users as much as it will the manual install persons
User avatar
kal
Moderator
Posts: 292
Joined: Sun Nov 06, 2005 4:23 pm
Location: Paris/FRANCE

Postby kal » Mon Jun 30, 2008 4:57 am

Yep we need to use english cat file. If I install the hotfix manually, I have the same trouble because the installer copy the french cat file.
User avatar
ricktendo64
Posts: 3212
Joined: Mon May 22, 2006 12:27 am
Location: Honduras

Postby ricktendo64 » Mon Jun 30, 2008 5:20 am

OK this is a bit offtopic but where the heck do these come from?

Code: Select all

msdrm.dll
RmActivate.exe
RmActivate_isv.exe
RmActivate_ssp.exe
RmActivate_ssp_isv.exe
SecProc.dll
SecProc_isv.dll
SecProc_ssp.dll
SecProc_ssp_isv.dll
User avatar
5eraph
Moderator
Posts: 4441
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Postby 5eraph » Mon Jun 30, 2008 5:52 am

Check KB917275. ;)

I believe It was an optional update on the Microsoft Update site at one point. All of those files belong to it.
User avatar
ricktendo64
Posts: 3212
Joined: Mon May 22, 2006 12:27 am
Location: Honduras

Postby ricktendo64 » Mon Jun 30, 2008 2:13 pm

OFMG almost got er :D, [s]just need to find out why MU keeps telling me that KB951376-v2 (bthport.sys) needs to be installed, do I have to add it to the dll cache or something?

Tried with both QFE and GDR and same result

Anybody know this one?[/s]

Edit: nm found my problem, i did not define it AGAIN! as I see OnePiece did in his entries.ini

Another question how does ryan update his asms files like that, I cannot find the hotfix responsible or one that will install on sp3, only 2 that I could install were msxml2sp6-kb887606 and msxml4-KB941833 the other one with the asms files (msxml4sp2-kb887606) failed, even if it installed it would not be as up to date as Ryans

Sorry for all the blabering and thanks for all the help
Last edited by ricktendo64 on Mon Jun 30, 2008 8:18 pm, edited 1 time in total.
User avatar
5eraph
Moderator
Posts: 4441
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Postby 5eraph » Mon Jun 30, 2008 6:50 pm

Yeah, KB951376 was a challenge for XP x64 as well due to the different ways the Integrator and nLite do things. I had to use [ExtraFileEdits]. :)

I'm still trying to work out how to include MSXML4, myself. I'll post if I manage to figure it out.
User avatar
nonno fabio
Posts: 1626
Joined: Mon Jun 06, 2005 10:36 am
Location: Northern Italy
Contact:

Postby nonno fabio » Tue Jul 01, 2008 6:51 am

Onepiece says he has found the same problem but it is caused by that specific hotfix: if you install it on a working XP system using MS patch .exe file, you'll get the same qfecheck errors after first boot
Don't ask for a different configuration of Onepiece's XP AIO Update Pack: use one of the existing vanilla XP UpdatePack with your preferred addons instead
User avatar
roirraW "edor"
Posts: 761
Joined: Sun Oct 15, 2006 2:25 pm

Postby roirraW "edor" » Tue Jul 01, 2008 9:38 am

Well at least it's consistent. :\ LOL.
Gigabyte case GZ-FA2CA-AJB
Gigabyte MA790X-UD4P with Realtek High Definition Audio
HIS Radeon HD 4850 512MB
AMD Athlon 64 X2 4400+ 2.3GHz
Corsair 4GB DDR2-6400 4-4-4-12
4x1TB SATA RAID 0+1/2x640GB SATA RAID 0/Misc. PATA
Windows 7 x64
User avatar
ricktendo64
Posts: 3212
Joined: Mon May 22, 2006 12:27 am
Location: Honduras

Postby ricktendo64 » Sun Aug 10, 2008 2:11 pm

Bump*

Hey anybody know how and where do i download the updated versions (7.2.6001.784) of mucltui.dll and mucltui.dll.mui?

Cant find it in:
http://update.microsoft.com/microsoftup ... b_site.cab
or
http://go.microsoft.com/fwlink/?LinkID=91237
User avatar
redxii
Posts: 395
Joined: Sun Dec 17, 2006 5:50 pm

Postby redxii » Sun Aug 10, 2008 3:11 pm

I unregistered and removed mucltui.dll and mucltui.dll.mui along with muweb.dll, and reinstalled MU. mucltui.dll and mucltui.dll.mui weren't downloaded, just muweb.dll. What's the purpose of mucltui.dll and mucltui.dll.mui?

I'm gonna remove mucltui.dll and mucltui.dll.mui from my update pack.
User avatar
5eraph
Moderator
Posts: 4441
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Postby 5eraph » Sun Aug 10, 2008 8:32 pm

mucltui.dll and mucltui.dll.mui don't seem to be necessary for x64 either. They have never been installed on either of my nonvirtual machines over the past 15 months.
User avatar
ricktendo64
Posts: 3212
Joined: Mon May 22, 2006 12:27 am
Location: Honduras

Postby ricktendo64 » Sun Aug 10, 2008 8:42 pm

Does anybody know where how dl them?
User avatar
ricktendo64
Posts: 3212
Joined: Mon May 22, 2006 12:27 am
Location: Honduras

Postby ricktendo64 » Mon Aug 11, 2008 6:50 pm

I guess I will have to stick with the older versions for those two files...btw this is why I would like them:

Without MUCLTUI
Image

With MUCLTUI (much nicer incon)
Image
User avatar
5eraph
Moderator
Posts: 4441
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Postby 5eraph » Sat Aug 30, 2008 6:41 am

Got your links, rick. :) (7.2.6001.784)Figured out why they've never been installed on my machines: I keep AU turned off. LOL

Return to “Update Pack Discussion”

Who is online

Users browsing this forum: No registered users and 2 guests