[RELEASE] LClock/Longhorn System Clock 1.62b

Discuss & post Update Pack addons here.
User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

[RELEASE] LClock/Longhorn System Clock 1.62b

Post by dgelwin » Sat Nov 12, 2005 2:23 pm

ok im gonna clean up this post a lot. so just to the grits :D
--updated links are in cyan
Info on LClock found here
--CHANGES:
-added two colour selections for preference based on themes.
-fixed uninstall function
-now placing LClock in Program Files where it belongs thereby freeing up two more txtsetup.sif directorys :D
-fixed control panel and lclock right click configure feature to enhance end user personal customizations.

Longhorn Clock (Default Text Colour = White)
http://rapidSUCK.de/files/8661082/Addon ... n.cab.html MD5= 71A5B2C1F7DE7219DFAA37477E9DF670

Longhorn Clock (Default Text Colour = Black)
http://rapidSUCK.de/files/8661040/Addon ... n.cab.html MD5 =95EC0600202D198DE8AA724DDCC0747D
Last edited by dgelwin on Mon Dec 05, 2005 10:39 am, edited 11 times in total.
Don't sweat petty things....or pet sweaty things

User avatar
maniaq
Posts: 147
Joined: Wed Jun 22, 2005 2:59 pm
Location: Lithuania

Post by maniaq » Sat Nov 12, 2005 2:57 pm

any mirror sites? :rolleyes: :wink:

User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

Post by dgelwin » Sat Nov 12, 2005 3:18 pm

hey if you want to mirror it go ahead please, i suck at web space, me personally i use Zdrive
which does not support direct file linking so if anyone wants to host it go ahead.
Don't sweat petty things....or pet sweaty things

User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

Post by dgelwin » Sat Nov 12, 2005 9:31 pm

has anyone tried it yet?
if answer to above question is yes then
       did you have any problems with it, or any complaint, or comment for the addon?
end if;
Don't sweat petty things....or pet sweaty things

User avatar
Zacam
Moderator
Posts: 615
Joined: Tue Sep 13, 2005 7:46 pm
Location: Portland, OR

Post by Zacam » Sat Nov 12, 2005 9:33 pm

So far so good. Tested with only it and with the RVMAddon pack, no problems. Now, if there's a way to get it to replace the default windows clock..... :-)

User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

Post by dgelwin » Sat Nov 12, 2005 9:42 pm

i thought i fixed it so that it runs at startup?
does it run at startup or not if it doesnt ill fix it.
Don't sweat petty things....or pet sweaty things

User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

Post by dgelwin » Sat Nov 12, 2005 10:09 pm

ok i fixed it, it now takes over default clock from the very first boot.

i updated my post with the new link
Don't sweat petty things....or pet sweaty things

itsme_4ucz
Posts: 59
Joined: Thu Dec 02, 2004 11:12 pm

Post by itsme_4ucz » Sun Nov 13, 2005 1:00 am


User avatar
Kelsenellenelvian
Moderator
Posts: 4383
Joined: Tue Nov 30, 2004 8:32 pm
Location: Pocatello, ID
Contact:

Post by Kelsenellenelvian » Sun Nov 13, 2005 1:05 am

Total failure nothing worked and I got the framedyn.dll error.

User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

Post by dgelwin » Sun Nov 13, 2005 1:08 am

has anyone else got this error?

--edit foundthe error it was the entries ini file i had the name mylclock.inf and its supposed to be myclock.inf

sorry i am updating the post right now with the new lynk to fixed file.

--THE LINK HAS BEEN UPDATED!! please redownload.
Don't sweat petty things....or pet sweaty things

itsme_4ucz
Posts: 59
Joined: Thu Dec 02, 2004 11:12 pm

Post by itsme_4ucz » Sun Nov 13, 2005 2:30 am

Kelsenellenelvian wrote:Total failure nothing worked and I got the framedyn.dll error.
Me too got the same error.!!

Vista
Posts: 137
Joined: Tue Aug 23, 2005 8:02 pm

Post by Vista » Sun Nov 13, 2005 4:45 am

MD5 Hash Please

User avatar
Zacam
Moderator
Posts: 615
Joined: Tue Sep 13, 2005 7:46 pm
Location: Portland, OR

Post by Zacam » Sun Nov 13, 2005 6:46 am

Should be:
C3881E61F8897CC021608D300F71E688

(checked after 5 successive downloads, didn't change)

User avatar
Kelsenellenelvian
Moderator
Posts: 4383
Joined: Tue Nov 30, 2004 8:32 pm
Location: Pocatello, ID
Contact:

Post by Kelsenellenelvian » Sun Nov 13, 2005 7:02 am

I think i found your problem

you are missing most of this :

[Optional Components]
Kelspack

[Kelspack]


You have:

[DefaultInstall]
OptionDesc ="LClock"
Tip ="LClock"
Modes =0,1,2,3
AddReg =klok.AddReg
ProfileItems=config.AddShortcut,faq.AddShortcut,lclock.AddShortcut,readme.AddShortcut,uninstall.AddShortcut

You need:

[Optional Components]
Lclock

[Lclock]
OptionDesc ="LClock"
Tip ="LClock"
Modes =0,1,2,3
AddReg =klok.AddReg
ProfileItems=config.AddShortcut,faq.AddShortcut,lclock.AddShortcut,readme.AddShortcut,uninstall.AddShortcut

User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

Post by dgelwin » Sun Nov 13, 2005 7:19 am

yes i fixed it and uploaded the new file thanx kel
Don't sweat petty things....or pet sweaty things

User avatar
Kelsenellenelvian
Moderator
Posts: 4383
Joined: Tue Nov 30, 2004 8:32 pm
Location: Pocatello, ID
Contact:

Post by Kelsenellenelvian » Sun Nov 13, 2005 7:37 am

I don't see a link m8.

User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

Post by dgelwin » Sun Nov 13, 2005 7:38 am

yeah i just removed it to prevent anyone from downloading bad one until i uploaded it with your fix
Don't sweat petty things....or pet sweaty things

User avatar
Kelsenellenelvian
Moderator
Posts: 4383
Joined: Tue Nov 30, 2004 8:32 pm
Location: Pocatello, ID
Contact:

Post by Kelsenellenelvian » Sun Nov 13, 2005 7:39 am

lol k

User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

Post by dgelwin » Sun Nov 13, 2005 7:40 am

my main problems are inf, using the integrator 1.0.3 problem i dont have these problems because i define inf install registration at startups.
Don't sweat petty things....or pet sweaty things

User avatar
Kelsenellenelvian
Moderator
Posts: 4383
Joined: Tue Nov 30, 2004 8:32 pm
Location: Pocatello, ID
Contact:

Post by Kelsenellenelvian » Sun Nov 13, 2005 7:48 am

Re-testing now for you.

User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

Post by dgelwin » Sun Nov 13, 2005 7:49 am

tnx very much for all your help kel i really appreciate it. :D
Don't sweat petty things....or pet sweaty things

User avatar
Kelsenellenelvian
Moderator
Posts: 4383
Joined: Tue Nov 30, 2004 8:32 pm
Location: Pocatello, ID
Contact:

Post by Kelsenellenelvian » Sun Nov 13, 2005 8:29 am

Works now.

User avatar
Kelsenellenelvian
Moderator
Posts: 4383
Joined: Tue Nov 30, 2004 8:32 pm
Location: Pocatello, ID
Contact:

Post by Kelsenellenelvian » Sun Nov 13, 2005 8:35 am

[general]
builddate=2005/11/07
description=Siginets petition (Im really bored and i ran out of porn)
language=Pig Latin
title=:DotNet
version=1.0 final
website=http://ryanvm.msfn.org


Please fix the info in this section.

User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

Post by dgelwin » Mon Nov 14, 2005 6:25 pm

hahaha lol sorry about that, forgot about the description.

--edit fixed it. i honestly dont remember what the hell my state of mind was when creating that description. hahaha.
Don't sweat petty things....or pet sweaty things

larciel
Posts: 216
Joined: Tue Dec 21, 2004 3:14 am

Post by larciel » Thu Nov 17, 2005 2:21 am

hey dgelwin , can you make the Lclock's default time color white? (it's black now and it intefere's with alot of themes color :O)

tia

User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

Post by dgelwin » Thu Nov 17, 2005 2:23 am

@larciel use the lclock configure in control panel, or right click lclock and click configure, :D
Don't sweat petty things....or pet sweaty things

User avatar
Siginet
Site Admin
Posts: 2894
Joined: Fri May 27, 2005 1:07 pm
Location: Planet Earth
Contact:

Post by Siginet » Sun Dec 04, 2005 3:53 pm

@dglewin I noticed that the uninstall feature does not work.

Also I would like to reccomend having it install in the default location that lclock would normally install if possible. ;)

BTW... I would also reccomend the font color be white... to keep it more like the original color. Could you release a white and a black addon? Or post info on how to change the setting in the addon itself.

Thanks dgelwin
Image
--Siginet--

Techware
Your Virtual Technician
Computer Management Software

User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

Post by dgelwin » Sun Dec 04, 2005 8:47 pm

no prob will do.
ill change the install to program files, at the time i created this addon i did not know how to use the copy files thats why i placed it in system32.
also i will create one black and one white for lclock.
--note to change the colors simply right click properties on lclock, or use the control panel cpl. :D that will help people who already have installed this addon.
Don't sweat petty things....or pet sweaty things

troscat
Posts: 78
Joined: Wed Jul 20, 2005 12:40 am
Location: Philippines

Post by troscat » Sun Dec 04, 2005 8:50 pm

To change mine to white, i edited LClock.ini with the entry below,

TextColor=16775416


Just trying to help. :)

User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

Post by dgelwin » Sun Dec 04, 2005 8:52 pm

you realized its not really necesary to edit the ini, you could always just open control panel and click on the lclock configure applet :D. muuuuuuuuccccch easier.
Don't sweat petty things....or pet sweaty things

larciel
Posts: 216
Joined: Tue Dec 21, 2004 3:14 am

Post by larciel » Mon Dec 05, 2005 4:06 am

yeah but this saves one more step ;) . and we're all here because we want to save some steps and time.. aren't we ? ;)

thank you troscat. !

User avatar
Siginet
Site Admin
Posts: 2894
Joined: Fri May 27, 2005 1:07 pm
Location: Planet Earth
Contact:

Post by Siginet » Mon Dec 05, 2005 4:12 am

Thx dglewin
Image
--Siginet--

Techware
Your Virtual Technician
Computer Management Software

ron2024
Posts: 30
Joined: Mon Dec 05, 2005 5:58 am
Location: IL

Post by ron2024 » Mon Dec 05, 2005 6:50 am

Is there a way to get the control panel to function when LClock is used as a standalone program (not installed) everything else seems to be working, but when you try to change settings in the control panel, hit apply it just shuts off the clock & no settings are changed. As a standalone, it's one less cab addon to install & no uninstall problems. Oh & thanks troscat for how to change it from black to white at least I can change that, (btw, I like it black). Now what about different colors, have any more #'s up your sleeve ? (':lol:')

troscat
Posts: 78
Joined: Wed Jul 20, 2005 12:40 am
Location: Philippines

Post by troscat » Mon Dec 05, 2005 7:24 am

@ron2024,

here's the link, http://cloford.com/resources/colours/500col.htm

btw, i've used ghostwhite. For pure white, TextColor=16777215 :)

ron2024
Posts: 30
Joined: Mon Dec 05, 2005 5:58 am
Location: IL

Post by ron2024 » Mon Dec 05, 2005 8:38 am

troscat,

Thanks for the link, definitely more then enough colors. Tried out the 2nd white seems better, I'm using Xpize & it's very light to med blue at the clock area, I'll try out some of the colors for the white needs to be colored &/or darken a little to stand out more. Thanks for the quick reply !!!

User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

Post by dgelwin » Mon Dec 05, 2005 10:36 am

--UPDATED
Don't sweat petty things....or pet sweaty things

troscat
Posts: 78
Joined: Wed Jul 20, 2005 12:40 am
Location: Philippines

Post by troscat » Mon Dec 05, 2005 9:04 pm

ron2024 wrote:troscat,

Thanks for the link, definitely more then enough colors. Tried out the 2nd white seems better, I'm using Xpize & it's very light to med blue at the clock area, I'll try out some of the colors for the white needs to be colored &/or darken a little to stand out more. Thanks for the quick reply !!!
No problem man, at your service :D

ron2024
Posts: 30
Joined: Mon Dec 05, 2005 5:58 am
Location: IL

Post by ron2024 » Tue Dec 06, 2005 8:10 pm

I used the .inf/LClock.cpl.manifest in this cab to re-install my manually installed barely working LClock, much better thank you & the uninstaller even shows up in the Add/Remove programs. Oh & white with a black shadow makes the LClock stand out better w/an Xpize theme. This is definitely going to be included in my install CD.
Your re-worked LClock is great! thanks !

User avatar
DisabledTrucker
Posts: 822
Joined: Tue Feb 22, 2005 6:14 pm
Location: Country of Mental on the Planet Trucker in the MidnightHunter Galaxy.
Contact:

Post by DisabledTrucker » Tue Dec 06, 2005 8:40 pm

Great, now I'll update my pack again to use the settings you did for the install. This way I'm not placing it in a different place, in case someone decided they wanted both of them. In my pack I also include a couple of the other themes too and my default color is a light blue for the slate theme, which makes it show up a lot easier, in case anyones wondering.
Matthew 22:36-40

I have some gmail invites left, if you'd like one IM me and let me know.

[url=mms://wmc1.liquidviewer.net/WNOR]WNOR FM-99[/url] The best station in the world!

zzzz
Posts: 79
Joined: Tue May 03, 2005 3:44 am

Post by zzzz » Wed Dec 28, 2005 12:39 am

Is there any way to change the "start w/ windows" options.
After I tick/untick it, then hit ok, then open it again and it's unticked. And it always start w/ windows (is there any other option except uninstalling it?) - sometimes I need it not to start w/ windows.

User avatar
DisabledTrucker
Posts: 822
Joined: Tue Feb 22, 2005 6:14 pm
Location: Country of Mental on the Planet Trucker in the MidnightHunter Galaxy.
Contact:

Post by DisabledTrucker » Wed Dec 28, 2005 10:44 am

open regedit and go to hkcu/software/microsoft/windows/run and look there, you can delete the key there for lclock then when you need it to start up again you can use the shortcut in the start menu. It then should start working with the tick box in the lclock itself. Outside of that I don't know what to tell you, as unticking that box should work, it does for me.
Matthew 22:36-40

I have some gmail invites left, if you'd like one IM me and let me know.

[url=mms://wmc1.liquidviewer.net/WNOR]WNOR FM-99[/url] The best station in the world!

zzzz
Posts: 79
Joined: Tue May 03, 2005 3:44 am

Post by zzzz » Wed Dec 28, 2005 4:22 pm

ok thanks.

User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

Post by dgelwin » Sat Dec 31, 2005 6:17 am

isnt it much easier to just run msconfig and deactivate it there?
Don't sweat petty things....or pet sweaty things

User avatar
DisabledTrucker
Posts: 822
Joined: Tue Feb 22, 2005 6:14 pm
Location: Country of Mental on the Planet Trucker in the MidnightHunter Galaxy.
Contact:

Post by DisabledTrucker » Sat Dec 31, 2005 9:19 am

either way, if you do it in Regedit you can fix any screw-ups that are caused by it, not sure how msconfig works when there is a real conflict like that when you want to be able to reactivate it from within LClock though. By deleting the registry entry, when LClock is restarted and you go back into it and retick that box it will place it back into Regedit again.
Matthew 22:36-40

I have some gmail invites left, if you'd like one IM me and let me know.

[url=mms://wmc1.liquidviewer.net/WNOR]WNOR FM-99[/url] The best station in the world!

User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

Post by dgelwin » Sat Dec 31, 2005 3:06 pm

the reason there is a conflict is because the registry key i used is the hkcu key for the run, and the registry key used by lclock is hklm, which is why even if it is ticked or not it makes no difference, because the hkcu key is still beeing used, the reason i used the hkcu instead of hklm was because using hklm like lclock does is real stupid because that means either every user has it activated or they dont, by using the hkcu it makes it possible to to deactivate it for whichever user you want using msconfig. :D
Don't sweat petty things....or pet sweaty things

User avatar
DisabledTrucker
Posts: 822
Joined: Tue Feb 22, 2005 6:14 pm
Location: Country of Mental on the Planet Trucker in the MidnightHunter Galaxy.
Contact:

Post by DisabledTrucker » Sat Dec 31, 2005 4:17 pm

Oh, I agree LCLock should give the option to only use it for a single user as well, but I use it on all my computers and everyone here uses it for their themes so it doesn't matter to me, unless I have to restart it due to a change in the themes then it becomes inconvenient. Maybe one day we can convince whomever created it to modify it, assuming they even go to Neowin anymore...
Matthew 22:36-40

I have some gmail invites left, if you'd like one IM me and let me know.

[url=mms://wmc1.liquidviewer.net/WNOR]WNOR FM-99[/url] The best station in the world!

User avatar
DisabledTrucker
Posts: 822
Joined: Tue Feb 22, 2005 6:14 pm
Location: Country of Mental on the Planet Trucker in the MidnightHunter Galaxy.
Contact:

Post by DisabledTrucker » Mon Jan 02, 2006 2:37 pm

If you'd like to use the rest of the Calendar themes, see my page here: http://www.ryanvm.net/forum/viewtopic.p ... highlight= for them. Keep in mind either his pack or mine will will be the default color scheme depending upon which way it's integrated, but both should install together.
Matthew 22:36-40

I have some gmail invites left, if you'd like one IM me and let me know.

[url=mms://wmc1.liquidviewer.net/WNOR]WNOR FM-99[/url] The best station in the world!

User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

Post by dgelwin » Mon Jan 02, 2006 7:15 pm

the both install perfectly together, only i recomend you integrate first mine and then DT'S or rename his so that it is alphabetically after mine, that way you can have his awesome theme, which i have become obsesed with.
@DT sorry i didnt upload the stuff for ya b4 i left home, but i left in kinda a hurry, ill upload it for ya as soon as i get back home hopefully it will still be of some use to you.

on a side note happy new years everyone
Don't sweat petty things....or pet sweaty things

zzzz
Posts: 79
Joined: Tue May 03, 2005 3:44 am

Post by zzzz » Tue Jan 03, 2006 12:35 am

oh, so the order does make difference?
I didn't think about that, I just saved all the addons as the default names and selected all. Guess that's what makes my xp build so buggy.

User avatar
DisabledTrucker
Posts: 822
Joined: Tue Feb 22, 2005 6:14 pm
Location: Country of Mental on the Planet Trucker in the MidnightHunter Galaxy.
Contact:

Post by DisabledTrucker » Tue Jan 03, 2006 2:45 am

What the difference is is that with dgelwins lclock it uses different colors and settings in it then mine does I use a light blue color as well as the Terminal fonts with mine not to mention the fact that I also include almost all of the extra calendars which are available from neowin's site where LClock is from, that he didn't include already. The biggest deal is how you want it to look when you install it.

@dgelwin, I have done a lot of upgrades to it recently you may want to have a look on my thread and see what all I've done... but yes I'll still take what you've done and see if I can still use it, let me know where I can grab it all at...

BTW, I'm already working on a larger pack for the Refresh Theme which will also put create some folders for you and add a few desktop.ini files as well as change your HDD icon for your system drive. Though I may break that all down into seperate packs for the ones who can't use them all at one time, we'll have to see how it all goes... Also, when renaming them it's in the sysoc.inf file where it needs to be made sure that it's installing in the correct order, not sure yet what that is though, but also in your txtsetup.sif file as well. In my newest edition of the LClock I've fixed where I had mine named myclock=.....dtlclock.cab... so it now reads dtclock=.......dtlclock.cab so as not to interfere with yours too, I noticed that you were using myclock= as your SYSOC instructions after I had done mine but it's not that way anymore... If you really want to make sure you have my theme, you can always pull the calendar.ini, lclock.ini, and myclock.inf out of my pack and put them elsewhere in your install disk for a backup, then after they are installed just copy those files to your lclock folder and wallah... Those are the three theme files for it that tell it what to look for. Same with his pack just grab those three file and back them up in case you'd rather have it his way and it overwrites it so that mine is defualts... Basically all mine is doing is adding the theming for it anyways...
Matthew 22:36-40

I have some gmail invites left, if you'd like one IM me and let me know.

[url=mms://wmc1.liquidviewer.net/WNOR]WNOR FM-99[/url] The best station in the world!

Post Reply