Microsoft .NET Framework 4.0 Client & Extended 20100413

Discuss & post Update Pack addons here.
User avatar
user_hidden
Posts: 1888
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Microsoft .NET Framework 4.0 Client & Extended 20100413

Postby user_hidden » Tue Apr 13, 2010 4:17 pm

Microsoft .NET Framework 4.0 Client & Extended FULL - 20100413

This is a multimode installer so you have access to the following switches:
-ai = Silent
-ai1 = Passive
/h = displays help

This package is uninstallable from Add/Remove Programs in Control Panel.

The Multimode Installer should be installed from RunOnceEX and not from SVCPACK.
If you are not familiar with setting up RunOnceEX than you should download one of the Addons instead.

This package has the Client Profile and Extended

Link: dotNet40.exe
CRC-32: 03ec93af
MD4: d76c4d6373a8422760573d182f6440a5
MD5: 8cddbac1de11b8980d934ed63f3331a6
SHA-1: 1e486b55f650d3b6a8396bcf7355ce6050b412b7
Date: 20100413
OS: Windows XP SP3 (x86 & x64)
Size: 48.7 MB

===================================

Addon for RVMi 1.6 or higher.

Integrate this addon to run the installer at RunOnceEX.
There will be progress boxes but NO user interaction is required.
Passive mode is used since setup takes a while, this way you will know
where you are in the setup process. Final installation will take
place after OOBE and before Personalized settings occur.

Link: Addon_Microsoft.Net_4.0_ROE_20100413.7z
CRC-32: a53159f7
MD4: e81db31f12c9dc8e55cc1cefeea1b944
MD5: 7079365bdea24f389e7371fb3d41831d
SHA-1: d0a7cce40bb3505a027a60812945c09788c53f16
Date: 20100413
OS: Windows XP SP3 (x86 & x64)
Size: 49.3 MB

===================================

dotNetFWVersionChecker.exe - .NET Framework Setup Verification Tool

Free DotNet VersionCheck Utility
Last edited by user_hidden on Mon May 17, 2010 7:13 am, edited 1 time in total.
ChiefZeke
Posts: 766
Joined: Fri Mar 23, 2007 5:33 pm
Location: Victorville, California

Postby ChiefZeke » Tue Apr 13, 2010 5:39 pm

Great job getting this out so fast. :D
kyuuzo
Posts: 3
Joined: Sun Dec 02, 2007 10:51 pm

Postby kyuuzo » Wed Apr 14, 2010 11:06 am

Thanks! Does this include any previous versions of the .NET Framework?
User avatar
user_hidden
Posts: 1888
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Postby user_hidden » Wed Apr 14, 2010 11:07 am

kyuuzo wrote:Thanks! Does this include any previous versions of the .NET Framework?


Framework 4.0 only
cosy
Posts: 278
Joined: Tue Apr 18, 2006 11:56 pm

Postby cosy » Wed Apr 14, 2010 2:11 pm

user_hidden wrote:Framework 4.0 only


does one need any of those old .nets, when one has this installed?
Thank you
User avatar
compstuff
Posts: 453
Joined: Fri Aug 11, 2006 3:25 pm
Location: Florida

Postby compstuff » Wed Apr 14, 2010 6:02 pm

I am wondering the same thing :oops:
adric
Posts: 561
Joined: Mon May 21, 2007 5:51 am

Postby adric » Wed Apr 14, 2010 6:39 pm

cosy wrote:
does one need any of those old .nets, when one has this installed?
Thank you


http://msdn.microsoft.com/en-us/library/ff602939.aspx

Al
User avatar
user_hidden
Posts: 1888
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Postby user_hidden » Wed Apr 14, 2010 8:59 pm

cosy wrote:does one need any of those old .nets, when one has this installed?
Thank you


it's a tossup!

it will have to be seen how older software written for pre-dotnet4 will work alone with 4.0 or requires the older versions as well.

reports from users would be helpfull to know what software worls with 4 and what software requires older versions when 4 is installed.
User avatar
ELiTE
Posts: 12884
Joined: Sun Apr 08, 2007 8:33 pm
Location: Canada

Postby ELiTE » Wed Apr 14, 2010 10:19 pm

Preliminary testing on a VM indicates NET 4 can't be installed alone. Needs runtimes from earlier NET releases. Requires further testing.
By downloading an ELiTE Switchless Installer Addon you, the End User, agree to abide by any Terms of Use prescribed by the Freeware App contained within.
User avatar
5eraph
Moderator
Posts: 4441
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Postby 5eraph » Wed Apr 14, 2010 10:21 pm

nLite complains when .NET 4 is installed alone.

    Image
And here I was hoping Microsoft had reversed its bloat-loving ways by releasing a small standalone replacement for all previous versions. :(
User avatar
ricktendo64
Posts: 3212
Joined: Mon May 22, 2006 12:27 am
Location: Honduras

Postby ricktendo64 » Wed Apr 14, 2010 10:43 pm

Where are the F@#%ing! lang packs Bill?
newsposter
Posts: 1131
Joined: Wed Sep 14, 2005 11:31 am

Postby newsposter » Wed Apr 14, 2010 10:52 pm

Office 2007 insists on having .Net 3.5 installed, won't proceed with 4.0
User avatar
ELiTE
Posts: 12884
Joined: Sun Apr 08, 2007 8:33 pm
Location: Canada

Postby ELiTE » Thu Apr 15, 2010 1:19 am

Okay. Results are in. With Net 2, 3 and 3.5 already installed, Net 4 will install just fine. I used Stimpy_JD976_DotNetFx_3in1_Addon_v2.2 and my own Net 4 switchless on XP Pro SP3 with nLite 1.4.9.1 ...... 8)
By downloading an ELiTE Switchless Installer Addon you, the End User, agree to abide by any Terms of Use prescribed by the Freeware App contained within.
User avatar
user_hidden
Posts: 1888
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Postby user_hidden » Thu Apr 15, 2010 7:22 am

just as i suspected, it seems that we need previous versions....thanks MS !
User avatar
dumpydooby
Posts: 529
Joined: Sun Jan 15, 2006 6:09 am

Postby dumpydooby » Thu Apr 15, 2010 11:07 am

It's not Microsoft's fault (except for Office, obviously). It's the fault of programmers hardcoding paths and version requirements directly into their software. Best practice is to check for the availability of functionality.
jaynbe
Posts: 277
Joined: Mon Apr 27, 2009 1:37 pm

Postby jaynbe » Thu Apr 15, 2010 2:12 pm

ricktendo64 wrote:Where are the F@#%ing! lang packs Bill?


Not available yet, only a few beta packs for now
http://www.microsoft.com/downloads/deta ... laylang=de

VC08 & VC09 runtimes required for installing dotNET 4.0
eroder
Posts: 6
Joined: Mon Jan 14, 2008 2:16 am

Postby eroder » Thu Apr 15, 2010 2:39 pm

Bejesuz, but you are one speedy gonzalez pertaining to .Net addons.
Thanx a lot and cudos to you.

PS u have a private paypal account for some ching? I'll gladly donate a couple of cents
just to keep you going and your fingers greased.....
biatche
I can't read
Posts: 326
Joined: Thu May 04, 2006 2:49 am

Postby biatche » Fri Apr 16, 2010 6:57 am

any idea if this will work in win7? i presume .net 3.51 must be preinstalled.
User avatar
bphlpt
Posts: 1241
Joined: Sat Apr 19, 2008 1:11 am

Postby bphlpt » Fri Apr 16, 2010 7:48 am

Unless you have removed them, Windows 7 comes with 1.1 SP1, 2.0 SP2, 3.0 SP2, & 3.5 SP1 installed. As far as I know, unless something's different about this installer this should work with Windows 7. If you find out anything different, please pass the information along to us.

Cheers and Regards
User avatar
ricktendo64
Posts: 3212
Joined: Mon May 22, 2006 12:27 am
Location: Honduras

Postby ricktendo64 » Fri Apr 16, 2010 11:18 am

Yes its for Windows 7 also, make sure you have 3.5 turned on not off
ChiefZeke
Posts: 766
Joined: Fri Mar 23, 2007 5:33 pm
Location: Victorville, California

Postby ChiefZeke » Fri Apr 16, 2010 2:38 pm

biatche wrote:any idea if this will work in win7? i presume .net 3.51 must be preinstalled.

Works just fine on Win7 32- and 64-bit - I installed it for both. :D
User avatar
compstuff
Posts: 453
Joined: Fri Aug 11, 2006 3:25 pm
Location: Florida

Postby compstuff » Mon May 17, 2010 1:33 am

I am testing a fresh install using this addon with Aaron Stebner's .NET Framework Setup Verification Tool and both the client and full tests fail... does anyone else have the same result?
pegasus
Posts: 150
Joined: Tue Jul 08, 2008 12:48 am

Postby pegasus » Mon May 17, 2010 2:51 am

compstuff wrote:I am testing a fresh install using this addon with Aaron Stebner's .NET Framework Setup Verification Tool and both the client and full tests fail... does anyone else have the same result?


I got the same result. Both the client & full test fail to detect .Net Framework 4.0 is properly installed using this addon.
User avatar
user_hidden
Posts: 1888
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Postby user_hidden » Mon May 17, 2010 7:08 am

pegasus wrote:
compstuff wrote:I am testing a fresh install using this addon with Aaron Stebner's .NET Framework Setup Verification Tool and both the client and full tests fail... does anyone else have the same result?


I got the same result. Both the client & full test fail to detect .Net Framework 4.0 is properly installed using this addon.



YES the dotNet is installed properly.

Aaron has released a new verifier on his blog but IMHO it does not work.

First post at bottom has 2 links to verifiers that DO work for dotNet4.
User avatar
compstuff
Posts: 453
Joined: Fri Aug 11, 2006 3:25 pm
Location: Florida

Postby compstuff » Mon May 17, 2010 7:56 am

Well for sure his tool definitely fails and the two tools you link to report OK so thanks very much

Return to “Update Pack Addons”

Who is online

Users browsing this forum: No registered users and 4 guests