RyanVM Update Pack 2.0.7a - Released June 28, 2006

Questions about Update Pack making? Ask here.
Locked
User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

RyanVM Update Pack 2.0.7a - Released June 28, 2006

Post by RyanVM » Sun Jun 25, 2006 12:58 pm

What's New
Version 2.0.7
  • Added KB889816 Hotfix. Replaces KB910623 Hotfix.
  • Added KB911280 Hotfix.
  • Added KB914389 Hotfix. Replaces KB896427 Hotfix.
  • Added KB916281 Hotfix. Replaces KB912812 Hotfix.
  • Added KB916595 Hotfix. Replaces KB887742 Hotfix.
  • Added KB917344 Hotfix.
  • Added KB917730 Hotfix. Replaces KB907717 Hotfix.
  • Added KB917953 Hotfix. Replaces KB913446 Hotfix.
  • Added KB918005 Hotfix. Replaces KB908673 and KB913365 Hotfixes.
  • Added KB918093 Hotfix.
  • Added KB918439 Hotfix.
  • Added KB919071 Hotfix. Replaces KB911904 Hotfix.
  • Removed KB898713 Hotfix. (This should fix the black screen problem)
  • Updated KB905474 Hotfix to version 1.5.532.2.
  • Updated Microsoft DirectX End-User Runtimes to June 2006 Release.
  • Updated Malicious Software Removal Tool to version 1.17.
For the love of God, read the nLite or Integrator directions for how to properly integrate this pack.

Notes
  • nLite 1.0RC7+ or RyanVM Integrator 1.2+ is required to properly integrate this release.
  • If you used nLite to integrate the pack and are having problems, PLEASE read this thread before reporting problems.
Download Here

UPDATE JUNE 28, 2006
I'm releasing a 2.0.7a update to address a few issues/updates which have come up since the initial release of 2.0.7. The main changes are the removal of the KB898439 hotfix, and the update of WGA Notifications, KB911280, and Flash9, along with a few typo fixes. It can be integrated two different ways:
  1. If you've already integrated 2.0.7, rename the file to RVMUpdatePack_2.0.7-2.0.7a.cab and integrate it as an update pack on the CD, since files need to be replaced in driver.cab.
  2. If you haven't integrated 2.0.7 yet, simply include the addon at the same time as integrating the update pack.
http://www.ryanvm.net/msfn/files/RVMAdd ... 2.0.7a.cab (2.24MB)
MD5: 1CC068C28E3D1A45E6CB29474AADFA53

Known Issues
  • None currently.
If you do run into anything you think is an error, be sure to consult with the FAQ on my site before asking about it here.
Last edited by RyanVM on Fri Jul 14, 2006 1:29 am, edited 4 times in total.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
n7Epsilon
Moderator
Posts: 624
Joined: Thu Feb 17, 2005 1:37 am
Location: Cairo, Egypt

Post by n7Epsilon » Sun Jun 25, 2006 1:01 pm

Wow! I get to post first ! Thanks for the update Ryan !

User avatar
mr_smartepants
Posts: 824
Joined: Thu May 18, 2006 5:56 am
Location: Cambridgeshire, UK

Post by mr_smartepants » Sun Jun 25, 2006 1:22 pm

Ack! And I JUST got done installing 2.0.7b3 for testing!
Ryan, any differences between b3 and 2.0.7 release? I'd hate to have to roll another ISO just for names' sake.

Great job!

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Sun Jun 25, 2006 1:24 pm

nothing under the hood
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
orcoxp
Posts: 532
Joined: Sun Apr 17, 2005 2:05 pm
Location: Ontario, Canada

Re: RyanVM Update Pack 2.0.7 - Released June 25, 2006

Post by orcoxp » Sun Jun 25, 2006 2:22 pm

RyanVM wrote: [*]Removed KB898713 Hotfix. (This should fix the black screen problem)
If this was the problem with May's updated v2.0.6 and the current date stamp on the file from MS right now is 06/01/2006 then maybe they have fixed something on there end?
Chris Thomson
AKA OrcoXP

PHP/MySQL/phpMyAdmin 2 & 3 successfully running simultaneously on XP SP3 IIS.

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Sun Jun 25, 2006 2:25 pm

They did a mass update of KB articles on 6/1/06
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
orcoxp
Posts: 532
Joined: Sun Apr 17, 2005 2:05 pm
Location: Ontario, Canada

Post by orcoxp » Sun Jun 25, 2006 2:28 pm

According to the KB article the file itself is dated June 1st
Chris Thomson
AKA OrcoXP

PHP/MySQL/phpMyAdmin 2 & 3 successfully running simultaneously on XP SP3 IIS.

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Sun Jun 25, 2006 2:30 pm

no...that's the KB article modification date. The file version info clearly shows it as being from 2005
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
surcix
Posts: 30
Joined: Fri Mar 04, 2005 5:16 pm

Post by surcix » Sun Jun 25, 2006 3:54 pm

my dell notebook battery isn't recognized anymore... with the previous pack's it work... now it says i have to contact the vendor, altough the battery works fine.... under battery in device manager there is a ! sign, and i cant use it.... what can i do ???

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Sun Jun 25, 2006 3:57 pm

Nothing that went into 2.0.7 should have any effect on that. Start over with a clean source to make sure it's not something wrong with your CD.

2.0.7 is working fine on my B130
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
surcix
Posts: 30
Joined: Fri Mar 04, 2005 5:16 pm

Post by surcix » Sun Jun 25, 2006 4:05 pm

a have a inspiron 1300 and it worked fine with earlier versions.... i used a fresh copy of win xp, integrated sp2 and pack 2.0.7 and it says it cand load the installer for the battery.... i used nlite 1.0 RC8 and i did't select the recompress driver option ... could that be the problem ??? should i use your integrator ???

User avatar
boooggy
Posts: 1297
Joined: Tue Aug 16, 2005 2:20 am
Location: Bucharest, Romania

Post by boooggy » Sun Jun 25, 2006 4:08 pm

yes use the integrator.....cause nlite seems to remove some files from driver.cab......

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Sun Jun 25, 2006 4:11 pm

surcix, you've been around here long enough to know better :).
http://www.ryanvm.net/forum/viewtopic.php?t=203
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
surcix
Posts: 30
Joined: Fri Mar 04, 2005 5:16 pm

Post by surcix » Sun Jun 25, 2006 4:11 pm

ok ... i'll try that .... i was really sacared :( :shock: ... i tought i f**ked up my battery.... i will come back with details after a clean install... thx for the sugestions

User avatar
surcix
Posts: 30
Joined: Fri Mar 04, 2005 5:16 pm

Post by surcix » Sun Jun 25, 2006 4:20 pm

RyanVM wrote:surcix, you've been around here long enough to know better :).
http://www.ryanvm.net/forum/viewtopic.php?t=203
my bad... but a "can't install battery" message on a new laptop can really scare you.... :oops: ..... I R SHAME !!! :D now i'm reintegrating with your integrator.... i'm waiting for a happy ending

PS: one more thing.... after nLite, the driver.cab file contained 4444 files, and after your integrator it contains 4778 files... that's quite a difference
Last edited by surcix on Sun Jun 25, 2006 4:24 pm, edited 1 time in total.

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Sun Jun 25, 2006 4:31 pm

Just so you know, I'm doing a new install on my laptop right now, since my last one was with a beta of 2.0.7. I strongly doubt it'll make a difference (since the main change with the different betas was attempts at getting rid of the blackscreen issue), but it'll at least help confirm or deny the problem.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
ricktendo64
Posts: 3213
Joined: Mon May 22, 2006 12:27 am
Location: Honduras

Post by ricktendo64 » Sun Jun 25, 2006 4:33 pm

OOPS!!!, :oops: Thank U :?

User avatar
surcix
Posts: 30
Joined: Fri Mar 04, 2005 5:16 pm

Post by surcix » Sun Jun 25, 2006 4:39 pm

is B130 the same thing as inspiron 1300 ??? isn't it the same model ???

PS: and did you use nLite or RVM Integrator ??? hope this solves the problem
Last edited by surcix on Sun Jun 25, 2006 4:42 pm, edited 1 time in total.

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Sun Jun 25, 2006 4:40 pm

Yes it is
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Sun Jun 25, 2006 4:59 pm

Install just finished here. No problems with the battery. Screenshot forthcoming.

BTW, I always use the Integrator.

EDIT: Here's the screenshot:
http://www.ryanvm.net/files/b130battery.png
Last edited by RyanVM on Sun Jun 25, 2006 5:43 pm, edited 2 times in total.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
TripleA
Posts: 36
Joined: Sat Oct 22, 2005 12:38 pm
Location: Planet Earth

Post by TripleA » Sun Jun 25, 2006 4:59 pm

Thank you very much for all your efforts making and maintaining this pack.

As a small token of my appreciation, I thought I'd share with you a somewhat funny random event related to v2.0.7:

Image

Now only if MD5 always worked that way! ;)

Ramon
Posts: 2
Joined: Sun Jun 25, 2006 1:50 pm

Post by Ramon » Sun Jun 25, 2006 5:21 pm

For some reason only Version 2.0.6 - Released May 14, 2006 is avaliable at the link http://www.ryanvm.net/msfn/updatepack.html and http://www.ryanvm.net/msfn/changelog.html

I found it can download if u edit the 2.06 link to http://www.ryanvm.net/msfn/files/RVMUpdatePack2.0.7.cab but i was just wondering if it was removed or if there is a problem with it or have you just not had time to update the other pages?

Thanks Ryan. Nice work!

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Sun Jun 25, 2006 5:25 pm

We go through this with people every month. You've got a cached version of the site on your computer. You need to force a reload from the server. In Firefox, it's Shift+Reload. In IE, it's Ctrl+Shift+Reload

For the record, I always update the site first before anything else when I do a release.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
surcix
Posts: 30
Joined: Fri Mar 04, 2005 5:16 pm

Post by surcix » Sun Jun 25, 2006 5:41 pm

the problem is solved.... thank's for the advice.... :D

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Sun Jun 25, 2006 5:43 pm

surcix wrote:the problem is solved.... thank's for the advice.... :D
Glad to hear it :)
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

Ramon
Posts: 2
Joined: Sun Jun 25, 2006 1:50 pm

Post by Ramon » Sun Jun 25, 2006 7:01 pm

:oops:

Sorry man. A total n00b error :D

Thanks Ryan.

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Sun Jun 25, 2006 10:43 pm

Ramon wrote::oops:

Sorry man. A total n00b error :D

Thanks Ryan.
Hey, we've all been there at some point or another :)
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
Aserone
Posts: 306
Joined: Sat Mar 11, 2006 8:46 pm
Location: Opioid dependent head.

Post by Aserone » Mon Jun 26, 2006 3:00 pm

Thanks for releasing Ryan!

Updated KB905474 removal addon. Nice to see the black screen resolved..
Last edited by Aserone on Mon Jun 26, 2006 6:08 pm, edited 3 times in total.
//Aserone-Foxy | EULA: Everything I say/post is a lie and/or forwarded from swim.

superleiw
Posts: 127
Joined: Wed Aug 03, 2005 11:22 am

Post by superleiw » Mon Jun 26, 2006 4:23 pm

will someone also do a WGA deleter for this update ryan?

User avatar
boooggy
Posts: 1297
Joined: Tue Aug 16, 2005 2:20 am
Location: Bucharest, Romania

Post by boooggy » Mon Jun 26, 2006 4:26 pm


P1R4T3
Posts: 8
Joined: Wed Dec 21, 2005 12:39 pm

Post by P1R4T3 » Mon Jun 26, 2006 6:08 pm

Thanks for your hard work. Ive seen how u guys have been struggling with the black screen error. Hats off u guys. Ure simply great.
Thanks for your hard work ryan.

User avatar
Mandarin
Posts: 213
Joined: Tue Jun 13, 2006 5:59 pm

Post by Mandarin » Mon Jun 26, 2006 7:23 pm

Finished my second ISO with the new pack and around 40 add-ons and everything is working perfectly in VMware. Good work as always.

User avatar
5eraph
Site Admin
Posts: 4621
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Mon Jun 26, 2006 9:00 pm

"Most users ever online" jumped to 61; it must be release day. :D

Thanks for the update and all the hard work. I wish I could have helped more this time around. :oops:

armond
Posts: 263
Joined: Tue Sep 13, 2005 11:43 am
Location: Glendale, CA USA

Post by armond » Mon Jun 26, 2006 9:43 pm

Hi Ryan,
Thank you very much for your hard working.
Sorry for this question, but Why you did not include this *Public* hotfixes in your update pack?
KB898543
INPUT.CPL 5.1.2600.2609
INTL.CPL 5.1.2600.2609
MSOBMAIN.DLL 5.1.2600.2626

KB914906
cryptsvc.dll 5.1.2600.2845

KB918766
DirectDB.DLL 6.00.2900.2905
MSOE.DLL 6.00.2900.2905
WAB32.DLL 6.00.2900.2905
Can I safety put them in the integrated XP?
Thank you again.

User avatar
5eraph
Site Admin
Posts: 4621
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Mon Jun 26, 2006 10:00 pm

The first two hotfixes you list are specifically for XP Starter Edition, armond.

The last one may have flown under Ryan's radar; it may solve Zardoc's problem. :)

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Mon Jun 26, 2006 10:24 pm

Yeah, I totally missed KB918766 somehow. It'll be in next month's pack.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
Mavericks choice
Posts: 273
Joined: Wed Nov 24, 2004 3:39 am
Location: Downunder

Post by Mavericks choice » Tue Jun 27, 2006 4:33 am

quote="boooggy"]http://www.firewallleaktester.com/removewga.htm[/quote]

Link would appear to be down

Cheers
MC.
The Man from Aus

User avatar
boooggy
Posts: 1297
Joined: Tue Aug 16, 2005 2:20 am
Location: Bucharest, Romania

Post by boooggy » Tue Jun 27, 2006 4:57 am


superleiw
Posts: 127
Joined: Wed Aug 03, 2005 11:22 am

Post by superleiw » Tue Jun 27, 2006 9:46 am

boooggy wrote:u right... here is another link: http://www.softpedia.com/get/Tweak/Unin ... eWGA.shtml
thanks for link and nice work on 2.0.7

User avatar
Wesmosis
Posts: 350
Joined: Tue Feb 21, 2006 7:53 pm

Post by Wesmosis » Tue Jun 27, 2006 10:05 am

wow! another aewsome release, thanx Ryan
Aserone wrote:Thanks for releasing Ryan!

Updated KB905474 removal addon. Nice to see the black screen resolved..
thanx Aserone

User avatar
pawan
Posts: 67
Joined: Sat Aug 06, 2005 9:43 pm
Location: India

Great work

Post by pawan » Tue Jun 27, 2006 10:58 am

Thanks Ryan, you have done a great job.

Now I have the latest version of Windows XP.
:D
Pawan

User avatar
mr_smartepants
Posts: 824
Joined: Thu May 18, 2006 5:56 am
Location: Cambridgeshire, UK

Post by mr_smartepants » Tue Jun 27, 2006 4:28 pm

This is wierd. :?
I just visited Microsoft Update website on my freshly 2.0.7 ISO'd laptop and dammit if KB905474 shows back up under "high-priority updates" :rolleyes:

I can verify that in the system32 folder the legitcheckcontrol.dll and all the WGA* crap is at version 1.5.532.2 already. The only other 'hack' I installed post-2.0.7 was XPize 4.4.1.
Would that trigger it?

Edit:
Doh! They updated the WGA crap to v.1.5.540.0. Everything appears to be working fine still.
Last edited by mr_smartepants on Wed Jun 28, 2006 12:57 am, edited 1 time in total.

User avatar
boooggy
Posts: 1297
Joined: Tue Aug 16, 2005 2:20 am
Location: Bucharest, Romania

Post by boooggy » Tue Jun 27, 2006 4:30 pm

nope.....i think they update it.....

edit
they updated cause it appeared for me on MU also on my real machine...... files build 1.5.0540.0
Last edited by boooggy on Tue Jun 27, 2006 4:40 pm, edited 2 times in total.

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Tue Jun 27, 2006 4:33 pm

OK, I'm going to put out a 2.0.7a update addon later tonight which will update KB911280, KB905474, and address a few other bugs which have been brought up to me privately.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

EaglePC
Posts: 30
Joined: Sat May 13, 2006 12:28 pm

Post by EaglePC » Tue Jun 27, 2006 6:12 pm

anyone notice a slight delay in restart or shutdown with 2.07
when i restart or shutdown it takes a long time then usual

User avatar
RogueSpear
Posts: 1155
Joined: Tue Nov 23, 2004 9:50 pm
Location: Buffalo, NY

Post by RogueSpear » Tue Jun 27, 2006 6:27 pm

I haven't noticed a slowdown, but I have to be honest.. I usually have so much crap on my machines that it would need to take 10 or 15 minutes to reboot for me to think it was taking longer than usual. One thing I have noticed is that with the latest updates, Visual Studio 2005 shuts down in a matter of seconds compared to the 1+ minutes it took before. So something changed somewhere for me.

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Tue Jun 27, 2006 7:11 pm

RyanVM wrote:OK, I'm going to put out a 2.0.7a update addon later tonight which will update KB911280, KB905474, and address a few other bugs which have been brought up to me privately.
It's going to take longer than expected to get this out because I came across a nasty bug in the Integrator in the process of making it that has to get fixed first.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

EaglePC
Posts: 30
Joined: Sat May 13, 2006 12:28 pm

Post by EaglePC » Tue Jun 27, 2006 7:57 pm

ryan thanks great work,hope the bug was the restart shutdown delay :)

wiz011
Posts: 23
Joined: Mon May 15, 2006 5:39 pm
Location: Serbia

Post by wiz011 » Tue Jun 27, 2006 8:19 pm

superleiw wrote:will someone also do a WGA deleter for this update ryan?
The 2.0.7 version of my "tool" is just released:

viewtopic.php?t=2224

User avatar
RyanVM
Site Admin
Posts: 5189
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Wed Jun 28, 2006 1:08 pm

The 2.0.7a update CAB has been uploaded and is available from the first post.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

Locked