Microsoft .NET Framework 2.0 Switchless Installer

Questions or comments on the switchless installers? Want to create a new one? Talk about it here.
User avatar
newb
Posts: 7
Joined: Sun Oct 09, 2005 12:23 pm

Microsoft .NET Framework 2.0 Switchless Installer

Post by newb » Thu Oct 27, 2005 5:38 pm

Microsoft .NET Framework 2.0.50727.42 Redistributable Package (x86) is now available.

http://www.microsoft.com/downloads/deta ... layLang=en

Anyone want to take a shot at a switchless installer? :?

If I make a Windows XP fresh install with .NET Framework 2.0, do I need to install .NET Framework 1.1 SP1 with KB886903 Integrated Hotfix for content compatiblity?

:shock:

User avatar
n7Epsilon
Moderator
Posts: 624
Joined: Thu Feb 17, 2005 1:37 am
Location: Cairo, Egypt

Post by n7Epsilon » Thu Oct 27, 2005 5:42 pm

No you don’t need to, as .NET 2.0 is backwards compatible with previous versions...

EDIT: I am trying to make one, but I find that this release uses a Bootstrap “Install.exe” To control the setup process and that the MSI doesn’t accept /A to make an administrative install point...

Tried importing the MSI (only) into WinInstall LE 2003 to expand it, but get an error...

Perhaps someone experienced with this (like the RyanVM himself :D ) can help with this (at least for me to learn how to make it)..

— I’m sure it won’t be long before RyanVM makes a nice silent installer for it...

-EDIT: The RTM .NET Framework broke my Visual C# 2005 Beta 2 Express Edition (I uninstalled the .NET 1.1 SP1 and .NET 2.0 Beta2 before installing the RTM), when I try to open any project or file I get the DW20.exe AppReporting program telling me that VC# has crashed...
Last edited by n7Epsilon on Thu Oct 27, 2005 5:57 pm, edited 1 time in total.

evilvoice

Post by evilvoice » Thu Oct 27, 2005 5:51 pm

maybe something like this since it seems repacking is gonna produce a bigger file

Code: Select all

dotnetfx.exe /q:a  /c:"msiexec /i netfx.msi /qn"

User avatar
dare2001
Posts: 4
Joined: Mon Apr 25, 2005 12:48 am
Location: Australia

Post by dare2001 » Fri Oct 28, 2005 4:29 am

That worked :D

User avatar
n7Epsilon
Moderator
Posts: 624
Joined: Thu Feb 17, 2005 1:37 am
Location: Cairo, Egypt

Post by n7Epsilon » Fri Oct 28, 2005 7:13 am

I have 1 question though:

If repacking is going to produce a bigger file then how did RyanVM get the (also 23 MB dotnetfx.exe for .NET 1.1) to a silent 11 MB 7-zip installer (and that is something truly amazing)...

(ie: How to obtain the administrative image of DotNet from just the MSI and without needing the bootstrap installer)...

Did he create a new MSI from scratch ?

User avatar
boooggy
Posts: 1297
Joined: Tue Aug 16, 2005 2:20 am
Location: Bucharest, Romania

Post by boooggy » Fri Oct 28, 2005 7:31 am


User avatar
MrNxDmX
Moderator
Posts: 3112
Joined: Mon Jan 03, 2005 7:33 am

Post by MrNxDmX » Fri Oct 28, 2005 7:42 am

waiting for an add-on for this,or for sb to make a silent and post in this site.
EDIT: Dont want to be rude, just dont know how to make one by myself,and also i dont have any computer of my own,just can use it for internet.
Last edited by MrNxDmX on Fri Oct 28, 2005 8:03 am, edited 1 time in total.

evilvoice

Post by evilvoice » Fri Oct 28, 2005 7:52 am

@n7Epsilon - .net 1.1sp1 compresses by that much, 2.0 does not

I dont know why people are posting for someone to make a silent package when I have told everyone how to accomplish this...without extracting the original file, without creating a transform, and keeping the smallest possible size...its amazing to me. If everyone really wants to do that much work for something that is so easy, by all means go for it...I did end up using iexpress so that I dont actually have to run any of the commands I posted...I just run dotnetfx and after extracting it runs msiexec /i netfx.msi /qn. In using iexpress, it allows people to save 10KB. Now if someone actually wants to "shrink" the msi, then we could possibly get the filesize down further.

User avatar
jessry
Posts: 14
Joined: Mon Jan 24, 2005 2:57 pm
Location: Australia

Post by jessry » Fri Oct 28, 2005 8:26 am

one question... do you need netfx 1 and 1.1 installed still after installing netfx 2 ???

User avatar
n7Epsilon
Moderator
Posts: 624
Joined: Thu Feb 17, 2005 1:37 am
Location: Cairo, Egypt

Post by n7Epsilon » Fri Oct 28, 2005 8:29 am

No actually, i have tested with Nlite (which is written in C#.NET 1.1) and it works fine with NetFx2.0 installed....

Official .NET Framework releases are backwards compatible with old .NET programs.

a06
Posts: 139
Joined: Thu Dec 23, 2004 2:11 pm

Post by a06 » Fri Oct 28, 2005 9:23 am

evilvoice wrote:maybe something like this since it seems repacking is gonna produce a bigger file

Code: Select all

dotnetfx.exe /q:a  /c:"msiexec /i netfx.msi /qn"
doesn't seem to work for me...

i see the HD working, but nothing else happens, and no .NET in add/remove

[edit]

the above command did nothing.
BUT:

Code: Select all

dotnetfx.exe /q:a /c:"install /l /q"
seems to work.

installation takes FOREVER though...


anyone know anything about some problems with 2.0? Rumors flying that:
You'll probably need both. .NET 1.1 and 2.0 are different frameworks (don't ask me why). I've heard of people running into troubles with just 2.0 installed.
this true?

player

Post by player » Fri Oct 28, 2005 10:02 am

removed
Last edited by player on Fri Dec 16, 2005 8:14 pm, edited 1 time in total.

User avatar
Kelsenellenelvian
Moderator
Posts: 4383
Joined: Tue Nov 30, 2004 8:32 pm
Location: Pocatello, ID
Contact:

Post by Kelsenellenelvian » Wed Nov 02, 2005 4:37 am

Anyone get one to work in svcpack???

sadicq
Posts: 2
Joined: Sun Aug 28, 2005 4:23 pm
Location: Piatra Neamt, Romania

Post by sadicq » Sat Nov 05, 2005 10:18 am

Hi.
@player I'm just curious: how did you compress the installer to 16 MB?
Did you remove anything else than install.exe and the language files, or did you use a powerfuller archiver than 7zip?

And, is there any functionality lost with this package?

User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

Post by dgelwin » Sat Nov 05, 2005 7:06 pm

This install will never work in svcpack, ive tried everything and so far all it does is piss me off more everytime i try something new.
Don't sweat petty things....or pet sweaty things

player

Post by player » Sat Nov 05, 2005 7:29 pm

removed
Last edited by player on Fri Dec 16, 2005 8:14 pm, edited 1 time in total.

sadicq
Posts: 2
Joined: Sun Aug 28, 2005 4:23 pm
Location: Piatra Neamt, Romania

Post by sadicq » Sun Nov 06, 2005 5:46 am

Thanks. Really useful installer. btw, it really takes some time to install...

cybpsych
Posts: 421
Joined: Wed Jan 12, 2005 2:33 am

Post by cybpsych » Mon Nov 07, 2005 6:48 pm

i've tested 3 repacked silent installers by Petya V4sechkin, RogueSpears, and player.

Petya's and RogueSpears' installers are totally silent, which I don't quite prefer to use due to the slow installation. player's installer has a visual progress bar, at least I know what's happening :)

player, i have a suggestion for your installer: How about using a more suitable .NET icon used by RyanVM's .NET FX 1.1 installer?

this would totally make your installer perfect ;)

player

Post by player » Mon Nov 07, 2005 11:57 pm

removed
Last edited by player on Fri Dec 16, 2005 8:15 pm, edited 1 time in total.

cybpsych
Posts: 421
Joined: Wed Jan 12, 2005 2:33 am

Post by cybpsych » Tue Nov 08, 2005 12:58 am

i know, what i meant was that you use this icon (msbuild.exe) on your silent installer.

*edit* ok sorry player, i got you meaning on the msbuild.exe's icon :)

good work there ;)

bledd
Posts: 47
Joined: Sat Jan 15, 2005 7:33 am

Post by bledd » Sun Nov 13, 2005 4:26 pm

ryan's got this on his site now :)

User avatar
RyanVM
Site Admin
Posts: 5190
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Sun Nov 13, 2005 4:55 pm

I've got it running directly from the MSI too. What sucks is that I thought I had it installing from svcpack.inf too, but it goes through the motions and nothing gets installed. Thankfully, I've got a contact within MS who works on .NET related stuff and he's going to look into it.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
RyanVM
Site Admin
Posts: 5190
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Mon Nov 14, 2005 10:06 am

OK, my switchless installer can be uninstalled now. If you got it yesterday, re-download :)
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
maniaq
Posts: 147
Joined: Wed Jun 22, 2005 2:59 pm
Location: Lithuania

Post by maniaq » Mon Nov 14, 2005 12:11 pm

Ryan, what switches did yu use in dotnetfx2 and java 505? tnx

User avatar
RyanVM
Site Admin
Posts: 5190
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Mon Nov 14, 2005 4:51 pm

For .NET2:

Code: Select all

netfx2.msi ADDEPLOY=1 REBOOT=Suppress /qb-!
For JRE5:

Code: Select all

jre505.msi CUSTOM=1 ADDLOCAL=ALL IEXPLORER=1 JAVAUPDATE=0 REBOOT=Suppress /qb-!

User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

Post by dgelwin » Mon Nov 14, 2005 6:23 pm

Ryan quick question what is the difference between the silent install that you made and that one that was made by roguespear.
Don't sweat petty things....or pet sweaty things

User avatar
RyanVM
Site Admin
Posts: 5190
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Mon Nov 14, 2005 6:43 pm

I dunno, I haven't looked at his.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

ual747-400
Posts: 39
Joined: Sat Nov 05, 2005 2:23 am

.net 2.0 and nLite problem....

Post by ual747-400 » Tue Nov 15, 2005 5:04 pm

I installed 2.0 on my current system and went to try some stuff in nlite rc3 and every kind of configuration i tried in nLite it kept locking up or stopping during the finalize section. anyone else seeing anything like this with 2.0 and nlite????

dale5605
Posts: 282
Joined: Mon Aug 15, 2005 10:26 pm

Post by dale5605 » Tue Nov 15, 2005 6:14 pm

It could be because you still have .NET 1.1 installed.

ual747-400
Posts: 39
Joined: Sat Nov 05, 2005 2:23 am

Post by ual747-400 » Tue Nov 15, 2005 6:16 pm

Why is that? If 2.0 has the previous in it then why would it matter if it is installed on top? I uninstalled 2.0 and nLite is working fine.

dale5605
Posts: 282
Joined: Mon Aug 15, 2005 10:26 pm

Post by dale5605 » Tue Nov 15, 2005 6:18 pm

ual747-400 wrote:Why is that? If 2.0 has the previous in it then why would it matter if it is installed on top? I uninstalled 2.0 and nLite is working fine.
nLite is a little finicky with .NET right now, that's all. That is why he is just going to end up converting everything to .NET 2.0 completely. Right now it is finicky, but it seems most users have the best results with uninstalling .NET completely and then installing 2.0 and then nLite.

ual747-400
Posts: 39
Joined: Sat Nov 05, 2005 2:23 am

Post by ual747-400 » Tue Nov 15, 2005 6:20 pm

Oh, OK. Thanks. I am working on a new version right now so I will see what works on the new install.

ual747-400
Posts: 39
Joined: Sat Nov 05, 2005 2:23 am

.net 2.0 and nLite problem....

Post by ual747-400 » Tue Nov 15, 2005 8:19 pm

Well check this one out. I uninstalled, reinstalled 1.1 and 2.0 several times as well as nLite. I was at the finishing section again with nLite and 2.0 installed and I got an error with outlook 2003 saying the send/receive was interrupted. I shut outlook down and everything proceededd as normal..........
Anyone know why Outlook could be interfering with nLite????????????

User avatar
Siginet
Site Admin
Posts: 2894
Joined: Fri May 27, 2005 1:07 pm
Location: Planet Earth
Contact:

Re: .net 2.0 and nLite problem....

Post by Siginet » Tue Nov 15, 2005 9:01 pm

ual747-400 wrote:Well check this one out. I uninstalled, reinstalled 1.1 and 2.0 several times as well as nLite. I was at the finishing section again with nLite and 2.0 installed and I got an error with outlook 2003 saying the send/receive was interrupted. I shut outlook down and everything proceededd as normal..........
Anyone know why Outlook could be interfering with nLite????????????
Please report that in the NLite forums. ;) You will get more info there.
Image
--Siginet--

Techware
Your Virtual Technician
Computer Management Software

ual747-400
Posts: 39
Joined: Sat Nov 05, 2005 2:23 am

.net 2.0 and nLite problem....

Post by ual747-400 » Tue Nov 15, 2005 9:31 pm

I will, I was just figuring since most of the people here mopre than likely use nLite I was assuming this would be good info for the members here.

User avatar
keytotime
Posts: 491
Joined: Thu Dec 16, 2004 9:44 pm

Post by keytotime » Wed Nov 16, 2005 8:35 am

Ms Released a update for office for .Net 2

http://www.microsoft.com/downloads/deta ... laylang=en

ual747-400
Posts: 39
Joined: Sat Nov 05, 2005 2:23 am

Post by ual747-400 » Wed Nov 16, 2005 12:42 pm

It is just small update for word and excel, no big deal.

player

Post by player » Mon Nov 21, 2005 6:33 pm

removed
Last edited by player on Fri Dec 16, 2005 8:15 pm, edited 3 times in total.

User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

Post by dgelwin » Mon Nov 21, 2005 6:41 pm

this is already well know that .net will not install from svcpack, now if someone was to say find a way to do it, then that would be worthy news.
Don't sweat petty things....or pet sweaty things

player

Post by player » Mon Nov 21, 2005 6:44 pm

removed
Last edited by player on Fri Dec 16, 2005 8:16 pm, edited 1 time in total.

User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

Post by dgelwin » Mon Nov 21, 2005 7:01 pm

cool, in that case im on it. ;)
Don't sweat petty things....or pet sweaty things

ual747-400
Posts: 39
Joined: Sat Nov 05, 2005 2:23 am

REG delete question

Post by ual747-400 » Mon Nov 21, 2005 9:17 pm

I am doing this before I install .net -> reg delete "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PCHealth\ErrorReporting\DW\Installed" /va

Anything wrong? The install is not continuing after this for some reason.

User avatar
n7Epsilon
Moderator
Posts: 624
Joined: Thu Feb 17, 2005 1:37 am
Location: Cairo, Egypt

Post by n7Epsilon » Tue Nov 22, 2005 2:23 am

I voted for this bug too!

Shark007
Posts: 326
Joined: Wed Nov 24, 2004 9:25 pm

Post by Shark007 » Tue Nov 22, 2005 7:23 am

removed
Last edited by Shark007 on Fri Dec 16, 2005 8:17 pm, edited 1 time in total.

ual747-400
Posts: 39
Joined: Sat Nov 05, 2005 2:23 am

Post by ual747-400 » Tue Nov 22, 2005 6:21 pm

Ok I tried this -> [-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PCHealth\ErrorReporting\DW\Installed]
and my install is going past my runonceex.cmd file I think. It is not installing .net 1.1 and .net2.0.

ykaramati
Posts: 4
Joined: Wed Jul 27, 2005 2:17 am

Post by ykaramati » Thu Nov 24, 2005 8:55 am

Attension for: newb, n7Epsilon,jessry

Player's dotnet 2.0 switchless silent installer
Dotnetfx 2.0 Installer
isn't comaptible with dotnet 1.1 sp1.
Atleast This , this programs (working with 1.1) dont work with dotnet 2.0 installed on fresh system

1. Microsoft Visual J# .NET Redistributable Package 1
2. Paint.NET v2.1b
....?

Shark007
Posts: 326
Joined: Wed Nov 24, 2004 9:25 pm

Post by Shark007 » Thu Nov 24, 2005 11:32 am

removed
Last edited by Shark007 on Fri Dec 16, 2005 8:18 pm, edited 1 time in total.

User avatar
MEULC
Posts: 407
Joined: Tue Mar 08, 2005 8:58 am

Post by MEULC » Fri Nov 25, 2005 9:19 am

Anybody found a way to install both v1.1 and v2.0 from SVCPACK?

Seems you have to reboot in between to install them successfully...

User avatar
dgelwin
Posts: 1152
Joined: Wed Aug 10, 2005 1:33 am
Location: Tegucigalpa, Honduras

Post by dgelwin » Fri Nov 25, 2005 9:27 am

install dotnet 1.1 from svcpack and use this addond dot net 2.0 to install .net 2.0 afterwards during runonceex firstboot, its what i do and it works.
Don't sweat petty things....or pet sweaty things

dazkrlauwste
Posts: 75
Joined: Thu Jan 20, 2005 12:53 am

Post by dazkrlauwste » Sun Nov 27, 2005 7:42 am

Why is Ryan's .NET Framework 2.0 installer not compatible with svcpack.inf?

Post Reply