[Help]Troubleshoot driver setup that won't install.

Forum for anything else which doesn't fit in the above forums. Site feedback, random talk, whatever, are welcome.
Post Reply
User avatar
shiner
Posts: 655
Joined: Sun Nov 08, 2009 4:18 am
Location: SE Asia

[Help]Troubleshoot driver setup that won't install.

Post by shiner » Fri Jan 16, 2015 9:50 pm

I have googled on my issue for some days now, but nothing I have found works on my PC (XP SP3 offline).
I know there are other forums, but I feel comfortable here and believe some member of RyanVM knows a bit about XP and driver installs.

I am trying to unbrick my daughter's Samsung android phone.
The method I have found is to use a program called Odin on my PC, connect the phone, and flash stock firmware onto the phone. In order to communicate with the phone, I must first install "Samsung USB Drivers for Mobile Phones". And this is my issue:

Older versions of the USB drivers appear to install correctly (according to the MSS InstallWizard) but Windows does not recognize the mobile phone using these dirivers when the phone is in "Download Mode" which is necessary to use Odin.

So, I after uninstalling the older version of the USB drivers and making sure all Samsung files and reg entries are removed from the system, I tried installing a new version 1.5.49 of the USB drivers.
Now the MSS InstallWizard says it "could not" install the drivers.
So, I dug in and unpacked the driver package to see what could be causing the problem.
After inspecting all the infs, I saw that I needed wdpmtp installed, so I downloaded and installed WMP11.
Tried installing the USB drivers again and failed with the same message.
After two days I can't find any way to install these drivers.
The MSS InstallWizard gives no error message.
I can't find any install log anywhere on my system.
Event Viewer doesn't show anything related to this installation failure.
So I don't have any clues as to what is preventing the driver package to install on my system.
Because this PC is now offline permanently, there is no anti-virus installed, Windows firewall is disabled, and there is no third-party firewall or any other security software installed.
To get Odin, the stock firmware and the drivers on my PC, I download them to my phone (the same model as my daughters btw) and transfer them to the PC using the USB cable and the stock andriod transfer method (Samsung drivers not needed for this.)

If anyone has any ideas please let me know.
For everyone's information, I have read thirty or more threads on this issue in the xda-developers website and another twenty or so posts or blogs on other sites, but nothing suggested anywhere works.
IMO, this appears to be a windows system issue which is why I am posting here.
"You can lead a horse to water, but you can't make it drink."

User avatar
ricktendo64
Posts: 3214
Joined: Mon May 22, 2006 12:27 am
Location: Honduras

Post by ricktendo64 » Sat Jan 17, 2015 3:10 am

Post the hardware id's as well as the old and new driver let me have a look

User avatar
mooms
Posts: 798
Joined: Wed Aug 27, 2008 1:29 pm
Location: France

Post by mooms » Sat Jan 17, 2015 6:14 am

I had hard times as well with those drivers, once for a GS4 mini, and also for a smart watch.
If I remember correctly you must reboot between the uninstall and the install of the different drivers.
You can also try on an other PC if you have one.

User avatar
shiner
Posts: 655
Joined: Sun Nov 08, 2009 4:18 am
Location: SE Asia

Post by shiner » Mon Jan 19, 2015 4:38 am

ricktendo64 wrote:Post the hardware id's as well as the old and new driver let me have a look
Thanks Rick.
Lately when I have free time, I am not near my PC.
I will post somethings as soon as I can.
"You can lead a horse to water, but you can't make it drink."

Post Reply