Internet Explorer 7 Beta 3 for Windows XP SP2/2003 SP1/x64

Forum for anything else which doesn't fit in the above forums. Site feedback, random talk, whatever, are welcome.
Post Reply
User avatar
MrNxDmX
Moderator
Posts: 3112
Joined: Mon Jan 03, 2005 7:33 am

Internet Explorer 7 Beta 3 for Windows XP SP2/2003 SP1/x64

Post by MrNxDmX » Thu Jun 29, 2006 6:40 pm

Internet Explorer 7 (IE7) Beta 3 has been designed to make everyday tasks easier, provide dynamic security protection and improve the development platform and manageability. End user improvements include a streamlined interface, tabbed browsing, printing advances, improved search functionality, instant feeds (RSS), dynamic security protection, and more. Visit the Internet Explorer site for more information on IE7 Beta 3.

Download: IE7 Beta 3 for Windows XP SP2
Download: IE7 Beta 3 for Windows Server 2003 SP1
Download: IE7 Beta 3 x64 Edition

Source: MSFN

See also: Paul Thurrott's Internet Explorer 7.0 Beta 3 Review

superleiw
Posts: 127
Joined: Wed Aug 03, 2005 11:22 am

Post by superleiw » Fri Jun 30, 2006 1:35 am

hopefully the last beta before it goes final

User avatar
MrNxDmX
Moderator
Posts: 3112
Joined: Mon Jan 03, 2005 7:33 am

Post by MrNxDmX » Fri Jun 30, 2006 5:59 pm

yep, i installing it with a hack.... but it has no tabs now...
urrrggghhh...
m$ sucks....

User avatar
corpseslayer
Posts: 105
Joined: Thu May 11, 2006 6:38 am
Location: Scotland

Post by corpseslayer » Fri Jun 30, 2006 8:00 pm

It was tabs that made me install firefox!!!!! But i'm waiting for the final :)
"The strong survive, we will survive, f**k all the enemies we have got" - Ian Stuart
"Use you illusions let them take you where they may till you live and learn sometimes it's best to walk away" - W. Axl Rose
"Democracy is the illusion of equality. While one man is rich and another is poor there is no equality" - Adolf Hitler

mindwarper
Posts: 255
Joined: Mon Jul 25, 2005 9:56 pm
Location: Netherlands

Post by mindwarper » Fri Jun 30, 2006 9:39 pm

better yet I am waiting for Firefox 2.0 ;)
will not take long anymore I thinfk final build will be released in August or September ;)

User avatar
Kelsenellenelvian
Moderator
Posts: 4383
Joined: Tue Nov 30, 2004 8:32 pm
Location: Pocatello, ID
Contact:

Post by Kelsenellenelvian » Fri Jun 30, 2006 10:09 pm

MrNxDmx wrote:yep, i installing it with a hack.... but it has no tabs now...
urrrggghhh...
m$ sucks....

Hahhahahahahahah LOL see what using hacks do to you?

Shark007
Posts: 326
Joined: Wed Nov 24, 2004 9:25 pm

Post by Shark007 » Fri Jun 30, 2006 10:45 pm

MrNxDmx wrote:yep, i installing it with a hack.... but it has no tabs now...
urrrggghhh...
m$ sucks....
To get the tabs working you need to install xmllitesetup.exe found it the \update folder within the installer.

shark

SHO_GuN
Posts: 144
Joined: Fri Jun 30, 2006 11:26 pm

Post by SHO_GuN » Fri Jun 30, 2006 11:36 pm

If I install this, or any other IE7 version on my computer, Windows Media Player looses its internet access.

However, if I integrate it with nLite, WMP works fine (Beta 3 will not integrate for me, so I am referring to Beta 2 when I say it works fine).

This happens with any version of WMP and any version of IE7.

Anyone else have this problem?

Anyone have any suggestions on fixing it? I would like to run the beta 3, because I watch most of my local news via WMP video clips on their web site.

tia

Edit: Got the problem solved, even though IE works fine, the problem with WMP not connecting was fixed by simply going into Internet Options --> Connections --> LAN Settings and checking "Automatically Detect Settings". Seems odd that all works fine without this box being checked when IE7 is integrated as opposed to installed after the fact.
Last edited by SHO_GuN on Sat Jul 01, 2006 8:33 pm, edited 1 time in total.

User avatar
RogueSpear
Posts: 1155
Joined: Tue Nov 23, 2004 9:50 pm
Location: Buffalo, NY

Post by RogueSpear » Fri Jun 30, 2006 11:39 pm

This newest beta release sure has made Maxthon run a hell of a lot faster :D I still haven't actually run the IE interface itself though lol

User avatar
MrNxDmX
Moderator
Posts: 3112
Joined: Mon Jan 03, 2005 7:33 am

Post by MrNxDmX » Sun Jul 02, 2006 4:20 am

Kelsenellenelvian wrote: Hahhahahahahahah LOL see what using hacks do to you?
Used hacked iecustom.dll :lol:
Shark007 wrote: To get the tabs working you need to install xmllitesetup.exe found it the \update folder within the installer.
Thanx for info. now fully working...

superleiw
Posts: 127
Joined: Wed Aug 03, 2005 11:22 am

Post by superleiw » Sun Jul 02, 2006 6:10 pm

which services need to be running for IE 7 Beta 3?

the two latest betas work fine but beta 3 seems to have problems

when opening iexplore.exe, it looks like it goes fullscreen but closes after 1/2 second, I usually have that when some service is not properly configurated

User avatar
MrNxDmX
Moderator
Posts: 3112
Joined: Mon Jan 03, 2005 7:33 am

Post by MrNxDmX » Mon Jul 03, 2006 6:53 pm

superleiw wrote:which services need to be running for IE 7 Beta 3?

the two latest betas work fine but beta 3 seems to have problems

when opening iexplore.exe, it looks like it goes fullscreen but closes after 1/2 second, I usually have that when some service is not properly configurated
i dont have an issue like yours. did u modify anything after installation?

superleiw
Posts: 127
Joined: Wed Aug 03, 2005 11:22 am

Post by superleiw » Tue Jul 04, 2006 4:31 am

no but maybe it's due to the fact that I completly disabled Windows/Microsoft Update ?

User avatar
MrNxDmX
Moderator
Posts: 3112
Joined: Mon Jan 03, 2005 7:33 am

Post by MrNxDmX » Tue Jul 04, 2006 5:13 pm

where did u get it disabled? used group policy or services.msc?

superleiw
Posts: 127
Joined: Wed Aug 03, 2005 11:22 am

Post by superleiw » Wed Jul 05, 2006 5:42 am

I enabled the registry hacks in nlite to completly remove acces to Windows Update and removed BITS

I undid the registry modification but how would I install BITS again ?

Anyway if there is no solution for this i'm gonna start anew when 2.1.0 is out

User avatar
MrNxDmX
Moderator
Posts: 3112
Joined: Mon Jan 03, 2005 7:33 am

Post by MrNxDmX » Wed Jul 05, 2006 10:28 am

superleiw wrote:I enabled the registry hacks in nlite to completly remove acces to Windows Update and removed BITS

I undid the registry modification but how would I install BITS again ?

Anyway if there is no solution for this i'm gonna start anew when 2.1.0 is out
I think nlite caused the problem with ie. you can try one of removal packs from this site, and look into second and third pages also for updated ones, cos first post hasnt been updated since april,13. you can try AutomaticUpdates Removal at link, so you cant access to wu again, as it needs automatic updates running...

superleiw
Posts: 127
Joined: Wed Aug 03, 2005 11:22 am

Post by superleiw » Thu Jul 06, 2006 2:52 am

Well now I know not to remove BITS next time (service required for WU/MU)

used 2.0.7a+ clean sp2 and it worked flawlessly


thanks for helping me MrNxDmx

User avatar
MrNxDmX
Moderator
Posts: 3112
Joined: Mon Jan 03, 2005 7:33 am

Post by MrNxDmX » Thu Jul 06, 2006 4:38 pm

no probs, you're welcome :wink:

Post Reply