[Solved] Problem With Windows Not Recognizing .vbs

Forum for anything else which doesn't fit in the above forums. Site feedback, random talk, whatever, are welcome.
Post Reply
User avatar
jamesbebby
Posts: 161
Joined: Fri Mar 13, 2009 10:32 am

[Solved] Problem With Windows Not Recognizing .vbs

Post by jamesbebby » Fri May 29, 2009 8:35 am

hi, for the first time i got this day when testin my windows (still tryin to get RunOnceEx workin)
Image
i dont think ive removed anything extra that i normally would with nLite but thats the only thing i can think of, what does windows use to run .vbs?
thanks james
Last edited by jamesbebby on Tue Jun 02, 2009 2:10 pm, edited 1 time in total.

User avatar
mf3imp
Posts: 77
Joined: Sun Nov 11, 2007 3:15 pm

Post by mf3imp » Fri May 29, 2009 9:13 am

In the screenshot I see something like "Installing Regis...", so I guess that you're adding some regtweak, and one of them can be the one that change the default behaviour for vbs file from "run/open" to "edit".
Just a guess, 'cause usually this regtweak set notepad for default opening.

User avatar
jamesbebby
Posts: 161
Joined: Fri Mar 13, 2009 10:32 am

Post by jamesbebby » Fri May 29, 2009 12:33 pm

hi, yes u r right there was a regtweak with set notepad for default opening, ive just put the regtweaks below the desktop shortcuts but still no luck, what does windows open .vbs with?
thanks james

User avatar
5eraph
Site Admin
Posts: 4619
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Fri May 29, 2009 3:48 pm

Virtual Basic Script (.vbs) files are associated with the Windows Script Host, which is installed by Windows with Internet Explorer. Windows opens them in the shell with the following command:

Code: Select all

%SystemRoot%\system32\WScript.exe "%1" %*
...where %1 is the VBS file name. I don't know what %* does.

yumeyao
Moderator
Posts: 1718
Joined: Sun Aug 27, 2006 9:24 pm
Location: Taiyuan, Shanxi, PR China

Post by yumeyao » Fri May 29, 2009 10:37 pm

are u using any IE8 Addon? I ask because when I was creating my IE8 addon I found it'd break up some files' associations, although i don't think vbs is affected.
Image
My work list(Hosted by dumpydooby)

User avatar
jamesbebby
Posts: 161
Joined: Fri Mar 13, 2009 10:32 am

Post by jamesbebby » Sat May 30, 2009 9:35 am

hi, ????????????
cheers james

User avatar
jamesbebby
Posts: 161
Joined: Fri Mar 13, 2009 10:32 am

Post by jamesbebby » Tue Jun 02, 2009 2:38 pm

hi, after alot of testin the last couple of days i found out the problem with windows not windows recognizing .vbs, there were workin fine with a standard windows disc but when i started puttin the disc though nlite things started to go wrong, first i though i was removin some windows components that windows used to open them with but after hours of testin that was not the case, then i started lookin to the addon pack that i add with nlite this is where things got quite weird say i add WMP11 & IE7, tested and vbs's ran fine, then add a SP3 update pack to it, tested vbs's were not recognized, started fresh add WMP11 & SP3 update pack, tested and vbs's ran fine, done this loads of times with a mixin of about 5 different addon pack [all windows based] and everytime the out come was different, if i put them in singly and tested vbs's ran fine, as soon as i start putin them together sometimes vb's worked and sometimes they did'nt, so i could point the finger that just 1 addon [sorry not very good at explaining things sometimes]
then i thought it mite be nlite [thank god i did why ill still be testin NOW], and it was i used RVM Integrator, add all the addons and windows recognized vbs's tested loads of times and no matter what i added or did'nt add windows would always recognized vbs's.

nlite rocks when it coms to removin components, add reg tweaks & and the rest, but when it coms to adding addons used the 1 program out there RVM Integrator, thanks 4 such great program!!!
cheers james

Post Reply