"Automatic Updates" icon in Control Panel

Forum for anything else which doesn't fit in the above forums. Site feedback, random talk, whatever, are welcome.
Post Reply
marzsyndrome
Posts: 239
Joined: Sun May 28, 2006 6:01 am

"Automatic Updates" icon in Control Panel

Post by marzsyndrome » Sun Jun 14, 2009 11:04 pm

Has anyone noticed how this always insists on displaying the 32x32 icon in Tiled/Thumbnail mode, even if a 48x48 icon exists? I edited wuaucpl.cpl to use a Vista-based iconset and that didn't seem to sort the problem.

Anyone know if there's a hidden setting that has to be changed somewhere? It seems to be the only icon in CP not displaying as nicely as every other icon.

User avatar
ENU_user
Posts: 1253
Joined: Wed Jan 25, 2006 1:42 pm

Post by ENU_user » Mon Jun 15, 2009 10:38 am

lots of explanations about Icons here: http://www.axialis.com/tutorials/vistaicons.html

marzsyndrome
Posts: 239
Joined: Sun May 28, 2006 6:01 am

Post by marzsyndrome » Mon Jun 15, 2009 2:15 pm

Hmmm ok, but which part am I supposed to concentrate on the most?


Also I doubt it's specifically a Vista issue. I'm using XP SP3 and I even tried replacing the AU icon with an equivalent from XPize. Still the same problem.

User avatar
ENU_user
Posts: 1253
Joined: Wed Jan 25, 2006 1:42 pm

Post by ENU_user » Mon Jun 15, 2009 6:19 pm

removed
Last edited by ENU_user on Sat Jun 19, 2010 4:55 pm, edited 2 times in total.

User avatar
mf3imp
Posts: 77
Joined: Sun Nov 11, 2007 3:15 pm

Re: "Automatic Updates" icon in Control Panel

Post by mf3imp » Tue Jun 16, 2009 1:52 am

marzsyndrome wrote:Has anyone noticed how this always insists on displaying the 32x32 icon in Tiled/Thumbnail mode, even if a 48x48 icon exists? I edited wuaucpl.cpl to use a Vista-based iconset and that didn't seem to sort the problem.
Anyone know if there's a hidden setting that has to be changed somewhere? It seems to be the only icon in CP not displaying as nicely as every other icon.
Some times ago I've read that this is caused by a bug of the file that contain the icon (maybe one of the windows update agent 7.x, because without it the icons are displayed correctly).
Judging from the pixelation, I always believe that it's loaded the 16x16 px icon, not the 32x32. Also the "start menu & taskbar" (or what is in english, I use the Italian version) is so pixelated. Even the avira icon (version 8) as the same glitch.

marzsyndrome
Posts: 239
Joined: Sun May 28, 2006 6:01 am

Post by marzsyndrome » Tue Jun 16, 2009 1:43 pm

Ooooh, didn't notice that "Start Menu & Taskbar" had the same problem too. Good spotting.

So would we have to 'downgrade' a specific file in Windows in order to fix the display problem?

Post Reply