XP SP4 update

Forum to discuss Update Packs created by community members for the various Windows operating systems.
Post Reply
Posts: 2
Joined: Sun Mar 03, 2019 7:30 pm

XP SP4 update

Post by gordo999 » Fri Oct 18, 2019 7:30 am

Just worked my way through an SP4 update to my XP Home x86 disk but I cannot use it as such because XP won't boot on my generation 8 Asus B360M mobo.

First of all, I want to thank those who put so much work into this project. Amazing amount of detail.

I have officially gotten W7 running on this mobo. Was not that hard except for USB 3 but a new set of drivers recently issued over at win-raid has me operating on W7 with full USB 3 functionality. Now I am trying to see what I can do with XP.

I know, I know...why??? I have W10 dual-booted with W7, each on its own drive. The dual-boot used to be with XP and before that, XP was dual booted with W98. I got W7 onto its own drive and now XP is on its own drive with a W98 partition 1 which is no longer functional.

WHY?? As Mallory put it when asked why he wanted to climb Everest, "because it's there". I like projects like this but there is one particular app I like to run live on XP rather than through a VM, where it becomes limited in its functionality. There are also games that work only on XP, and until VMs can access good sound cards, I'm stuck with the horrible VM onboard sound.

I could not even get the XP install disk to run. So, I decided to try the XP SP4 update and it has helped. Before slip-streaming SP4 with my original install disk (slip-streamed to SP3) the XP install disk stopped with an 0x000000A5 error (ACPI issues) then when I got past that with an F7 at the F6 (add storage drivers via floppy) screen, I ran into an 0x000000F7 error (can't find boot disk).

Amazingly, the SP4 update got me past that error but there was no option 'R' to enter a command prompt for repair. Has that been removed in SP4? Instead, I got three options, two to re-partition and one to leave the files as is. I was kind of stuck at that point, weighed my options, and let her roll. I knew I had an XP image to replace the install if necessary.

So, it loaded files then called for a reboot. I thought, "Uh, oh". Sure, enough, on reboot, I let the system carry on past the CD message so it could boot normally. After the 'hit a key to run CD' I got an error message that boot.ini was corrupt. Immediately following that, I got another error, 'load needed DLLs for kernel'.

OK, I know this is off-topic wrt update files, but I was hoping someone could explain how to get to a command prompt so I could try to fix my boot.ini file. Or find some kind of troubleshooter that I might be able to use via the new SP4 install disk. I can fix boot.ini from W7 if I boot from the W7 disk then hot-plug the XP disk. I would like to get access to XPs native system, however.

For some reason, the system is not reading the boot.ini file correctly. It claims to be trying to boot from C:\Windows when my XP install is on the 2nd partition on Drive D:. As I explained, C: used to be a W98 partition and I left it unused so I could run the boot.ini files from their plus ntldr. It worked fine that way for year but now, with the same boot.ini, it claims it cannot find the XP install on partition 2.

Amazingly, SP4 has allowed the system to find the installations. When I get to the screen asking if I want to re-partition or leave the file system as is, I am now presented with all the partitions so I can choose the XP partition. It's happy with that because the installation has created two new directories on partition 2 called winxp.0 and winxp.1. It has even amended the boot.ini files to refer to /winxp as /winxp.1.

So the updated SP4 install can find the right XP partition whereas the original slip-streamed XP SP3 disk cannot. Don't know what you guys did, but it worked.

However, when I try to boot the same disk, by itself (no other drives installed) it claims the boot.ini file is corrupt and it is trying to boot from C:\windows instead of C: root then D:\winxp.

I have no C:\windows directory, the directory on C: was named win98. There are no other drives attached. The 2nd error message re missing files makes sense if it cannot find the XP install. There is nothing on C: but a gutted W98 install.

But why can the new XP SP4 disk find the XP install yet it cannot be found booting straight from disk.

My boot.ini file looks like this currently, part way through a repair install.

[boot loader]
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINXP.1="Microsoft Windows XP Professional" /fastdetect

Note that the WINXP.1 was added by the repair installer. It was just WINXP before the repair install began.

Can anyone cast some light on this? Please.

Post Reply