[Addon] XPSP3 QFE POSReady Updates 20180917

Discuss & post Update Pack addons here.
Post Reply
Zephyr
Posts: 118
Joined: Sun Nov 22, 2015 4:53 pm
Location: London

Re: [Addon] XPSP3 QFE POSReady Updates 20180917

Post by Zephyr » Mon May 25, 2020 7:58 am

Hi Guys

I finally sorted out the problem with outdated ks.sys and termdd.sys and everything is tickety-boo now. The problem was caused by a bug in the integrator that caused driver.cab to be re-built with the SP3 versions of these files rather than the latest POSReady versions. This caused errors in qfecheck and SFC. I confirmed that this was the problem by extracting the contents of driver.cab, replacing ks.sys and termdd.sys with the POSReady versions and compressing the contents with Cab Maker. The solution to the problem is to remove the entries for ks.sys and termdd.sys in drvindex.inf which determines which drivers Windows Setup copies from driver cab. This can be automated by the integrator by adding these entries to entries_POSUpdates.ini:

[ExtraFileEdits]
drvindex.inf|ks.sys||2
drvindex.inf|termdd.sys||1
drvindex.inf|hsf_fs|hsf_fsks.sys|1

These instructions replace ks.sys and termdd.sys with blank lines in drvindex.inf, and ks.sys has to be deleted twice because the first time hsf_fsks.sys is truncated to hsf_fs. Finally hsf_fs has to be restored to hsf_fsks.sys.

You can make these changes yourself by editing entries_POSUpdates.ini from my release of the addon in the 7-Zip file manager. You also need to update the build dates that I forgot to do. When I get round to joining Mediafire I will make the final revision available for download.
XP FOREVER!

Zephyr
Posts: 118
Joined: Sun Nov 22, 2015 4:53 pm
Location: London

[Release] XPSP3 QFE POSReady Addon 20200528

Post by Zephyr » Tue May 26, 2020 7:07 am

I present my final revision of the XPSP3_QFE_POSReady_Addon completed on 28 May 2020.

XPSP3_QFE_POSReady_Addon_20200528_5er.7z.
MD5: 5905A4EDC6B300387793DF6C4F6C0BB6
SHA1: B29EA63EE47D78F5BF1851030115DF737F75E036
SHA256: F32A20A59163636D9AF5E08D5CDDAEC40F42418999DB6D5CEEEAB246023EA90D

Credit must be given to 5ereph for initiating this addon and the time and effort he must have put into it.

This addon slipstreams all the POSReady 2009 updates released untill EOL on 09 April 2019 directly into a 32-bit XP SP3 source when used with the XPSP3_QFE_UpdatePack. All files are from the SP3QFE branch.

An update to the Adobe Flash Player has not been included because no-one plays videos in Internet Explorer 8.

Windows Automatic Update will offer a number of obsolete version of gdiplus and the Cumulative Security Update for ActiveX Killbits for Windows XP (KB2900986) when the integrated source is installed. The gdiplus updates I recorded are as follows: KB4473077, KB4462987, KB4458000, KB4039384, KB4015383, KB3178034, KB3065979, KB3035132, KB3029944, KB3013126, KB2957503, KB2834886, KB2659262, KB4463361, KB4022884, KB2412687. This list is probably not exhaustive. They are installed as side by side assemblies in the WinSxS folder. The integrator cannot handle multiple versions of the same module in the WinSxS folder, so it is only possible to integrate the last POSReady 2009 version of gdiplus. Once integration is complete there will be two versions of gdi plus, one from the uppdate pack, and one from the addon. It seems likely that the last POSReady 2009 version of gdiplus is backwards compatible with programs written for previous versions since 2012. Therefore I recommend that you do not install these older versions of gdiplus and disable Automatic Updates.

The XPSP3 QFE POSReady Addon and XPSP3 QFE Update Pack can be integrated into the source using the RVM integrator separately or at the same time. If the are integrated seperately the [Obsolete] section of entries_posready.ini will remove security catalogues and registry entries made by the update pack for updates made obsolete by the addon. If integrated at the same time the [ExtraFilesEdits] section of entries_posready.ini will prevent the update pack from installing the registry entries for updates made obsolete by the addon, and the [Obsolete] section will remove the security catalogues.

Updates Included:

KB2926765 - MS14-027 - Shell Light-weight Utility Library
KB2962872 - MS14-037 - IE6 - BrowseWM Player
KB2993254 - MS14-062 - Message Queuing*
KB2998579 - MS14-063 - Fast FAT File System Driver
KB2991963 - MS14-078 - Japanese Input Method Editor
KB3020393 - MS15-002 - Microsoft Telnet Server Helper*
KB3021674 - MS15-003 - User Environment Group Policy module
KB3004361 - MS15-014 - Windows Security Configuration Editor Engine
KB3033889 - MS15-020 - WebBrowser Control module
KB3033890 - MS15-057 - WMP 9
KB3124275 - MS16-001 - Internet Explorer 6 - Cumulative
KB3124624 - MS16-003 - VBScript Scripting Engine v5.7
KB3109560 - MS16-007 - DirectShow Core
KB3121918 - MS16-007 - Advanced Windows 32 Base API
KB3126587 - MS16-014 - Database Support for Oracle
KB3140709 - MS16-025 - Windows Address Book
KB3139914 - MS16-032 - Secondary Logon Service DLL
KB3139398 - MS16-033 - USB Mass Storage Class driver
KB3149090 - MS16-047 - SAM Server DLL
KB3161949 - MS16-077 - Web Proxy Auto Discovery
KB3170455 - MS16-087 - Print Spooler
KB3185911 - MS16-106 - User API Client
KB3183431 - MS16-123 - Distributed File System
KB3196718 - MS16-130 - OLE Automation
KB4012584 - MS17-013 - Microsoft Color Management Module
KB4014652 - CVE-2013-6629 - DirectShow
KB4014794 - CVE-2013-6629 - DirectShow
KB4019276 - Support for TLS 1.1 and TLS 1.2
KB4025398 - CVE-2017-8557 - System Information Control
KB4025409 - CVE-2017-8563 - Lightweight Directory Access Protocol API
KB4025497 - CVE-2017-8463 - Shell Browser UI Library
KB4026061 - CVE-2017-8588 - Wordpad MFC Application
KB4034775 - CVE-2017-0250 - JET 4.0 Database Engine
KB4047211 - CVE-2017-11788 - Content Index Utility DLL
KB4052303 - CVE-2017-11885 - IP Router Manager
KB4056564 - CVE-2018-0886 - TS Single Sign On Security Package
KB4056941 - OpenType/Type 1 font driver
KB4089082 - CVE-2018-0881 - ActiveX control for streaming video
KB4089175 - CVE-2018-0883 - ZiP Compression Library
KB4089453 - CVE-2018-0878 - Windows Remote Assistance
KB4089694 - CVE-2017-13077 - Wireless Zero Configuration Service
KB4091756 - CVE-2018-0967 - WinSNMP v2.0 Manager API
KB4101477 - CVE-2018-0824 - COM Services
KB4130957 - CVE-2017-11927 - InfoTech Storage System Library
KB4291391 - CVE-2018-8304 - Windows DNS Client API
KB4457163 - CVE-2018-8468 - Windows Shell Common DLL
KB4458001 - CVE-2018-8332 - Embedded OpenType Font Engine and Font Subsetting DLL
KB4458318 - CVE-2018-8419 - Kernel CSA Library
KB4459091 - CVE-2018-8419 - Cryptographic and TLS/SSL Security Provider
KB4462935 - CVE-2018-8333 - Windows NT SMB Minirdr
KB4463103 - CVE-2018-8411 - NT Kernel
KB4467689 - CVE-2018-8550 - Remote Procedure Call Runtime
KB4467770 - Enables TLS 1.1 and TLS 1.2 in WinHTTP
KB4470118 - CVE-2018-8544 - Windows Scripting Host
KB4486463 - CVE-2019-0621 - NT Kernel & System
KB4486465 - CVE-2019-0703 - Server driver
KB4486468 - CVE-2019-0821 - Named Pipe FileSystem Driver
KB4486536 - CVE-2019-0683 - Microsoft Authentication Package v1.0
KB4486538 - CVE-2019-0683 - Kerberos Security Package
KB4487990 - Cumulative Timezone Update
KB4489493 - CVE-2019-0755 - Mailslot driver
KB4489973 - CVE-2019-0784 - Microsoft Data Access - ActiveX Data Objects
KB4489977 - CVE-2019-0617 - Microsoft (R) Red ISAM
KB4490228 - CVE-2019-0765 - User Experience Controls Library
KB4490501 - CVE-2019-0759 - Windows Spooler
KB4491443 - CVE-2019-0856 - MBT Transport driver
KB4493341 - CVE-2019-0601 - Hid Parsing Library
KB4493563 - CVE-2019-0842 - Object Linking and Embedding. NT Kernel
KB4493790 - CVE-2019-0792 - Microsoft XML Core Services 3.0 and 6.0
KB4493793 - CVE-2019-0877 - Microsoft Jet xBASE Isam
KB4493794 - CVE-2019-0851 - Microsoft Jet Paradox Isam
KB4493795 - CVE-2019-0671 - Microsoft Jet Excel Isam
KB4493796 - CVE-2019-0847 - Microsoft Jet Engine Library
KB4493797 - CVE-2019-0846 - Microsoft (R) Red ISAM
KB4493927 - CVE-2019-0848 - Multi-User Win32 Driver
KB4494059 - CVE-2019-0845 - COM Interfaces for Printer Web Pages
KB4494528 - Windows Installer
KB4495022 - CVE-2019-0802 - Microsoft GDI+
KB4500331 - CVE-2019-0708 - Terminal Server Driver

*XP Professional only.
Last edited by Zephyr on Thu Aug 06, 2020 2:46 am, edited 8 times in total.
XP FOREVER!

Zephyr
Posts: 118
Joined: Sun Nov 22, 2015 4:53 pm
Location: London

Re: [Addon] XPSP3 QFE POSReady Updates 20180917

Post by Zephyr » Thu May 28, 2020 6:00 pm

ANYONE WHO DOWNLOADED XPSP3_QFE_POSReady_Addon_20200525_5er.7z PLEASE DOWNLOAD AGAIN BECAUSE MISSING COMMA IN 5erPOSUp.inf PREVENTED TWO UPDATES FROM BEING REGISTERED.
XP FOREVER!

Zephyr
Posts: 118
Joined: Sun Nov 22, 2015 4:53 pm
Location: London

Re: [Addon] XPSP3 QFE POSReady Updates 20180917

Post by Zephyr » Thu Jun 04, 2020 9:32 am

I have produced a version of my revision of the XPSP3 QFE POSReady Addon adapted for the Home Edition of XP. It has the two Pro only updates, KB2993254 and KB3020393 removed to make a more tidy installation without redundant security catalogues and registry entries.

XPSP3_QFE_POSReady_Addon_20200604_Home.7z
MD5: 3234D93BD5EC78D1C3748F57E3961529
SHA1: 93A72DFEFCAC8443AE0D09EFAAA9399B1C03A46B
SHA256: 6123F2073A99EF9DCDD661AFBE548251CBCFEF51580CD0EEF157CA0379B1971B
XP FOREVER!

shorterxp
Posts: 38
Joined: Wed Apr 18, 2018 10:44 am

Re: [Addon] XPSP3 QFE POSReady Updates 20180917

Post by shorterxp » Mon Aug 17, 2020 5:27 pm

Incredible work! all those hyperlinks must of taken a long time!!

If user integrates these updates with nlite then removes components after the fact also with nlite, will (already-tested) nlite presets work as otherwise expected?

Correct me if I am wrong, this is order of updates to integrate to SP2 iso, correct?
  1. SP3 (note: in XP SP3 environment)
  2. XPSP3_QFE_UpdatePack (by user_hidden/5ereph)
  3. XPSP3_QFE_POSReady_Addon (by 5ereph, kindly updated by Zephyr)
Also, what of SP4 3.1b + May 2019 Update Rollup by harkaz?
Right now it seems XPSP3_QFE_UpdatePack + XPSP3_QFE_POSReady_Addon is newer.

.NET questions
Its unclear if XPSP3_QFE_UpdatePack + XPSP3_QFE_POSReady_Addon has .net updates or not. I've suggested someone should make modular up-to-date .net installer (not addon) in the harkaz thread..

I'm not a fan of .NET. Users should be free to choose post-OS-install what .net to install. SP4 involves this procedure (below), which I guess end user has to be aware of to get working.
harkaz wrote:
Fri Mar 27, 2020 5:41 am
Starting from SP3:
1) Install USP4-NODOTNET package (will not install .NET at all)
2) Install May 2019 Update Rollup
3) Install desired .NET Frameworks from Add/remove components, Control Panel

Alternative pathway:
1) Install SP4 (with .NET)
2) Install May 2019 Rollup
3) Remove all .NET Framewors from Add/remove components, Control Panel
4) Install desired .NET Frameworks from Add/remove components, Control Panel
...and judging by this post:
harkaz wrote:
Sat Jun 08, 2019 12:49 am
GH0st wrote:
Fri Jun 07, 2019 11:18 pm
Harkaz, does your recent release [May 2019 Update Rollup] include any updates for the dotNET's?
all .NET Framework updates are included in the update pack.
I guess what Im trying to say is, if XPSP3_QFE_UpdatePack + XPSP3_QFE_POSReady_Addon does indeed, exclude .net updates,a complimentary, standalone, installer, which can be run by choice, post-OS-install, is a better, more elegant solution anyway. The installer should install (user selectable) .net version, associated updates and if necessary run the executequeditems command.

I already use the AIO .NET 3.5 SP1 in a modular way as described (installer not on bootable ISO either, keeping it light). I dont believe AIO 3.5 SP1 includes updates, could be wrong and to be frank, I wonder if .net updates are even critical - most of time user only needs minimal .net, to make program run. For example its unclear if any POST SP3 updates DEPEND on .net updates, in which case, if true, would make them important.

Any feedback . thoughts appreciated.
Last edited by shorterxp on Tue Aug 18, 2020 7:50 pm, edited 1 time in total.

shorterxp
Posts: 38
Joined: Wed Apr 18, 2018 10:44 am

Re: [Addon] XPSP3 QFE POSReady Updates 20180917

Post by shorterxp » Tue Aug 18, 2020 6:21 pm

I tried a test install, integrated XPSP3_QFE_UpdatePack + XPSP3_QFE_POSReady_Addon with nlite. There seems to be a problem with KS.SYS. It is inside XPSP3_QFE_POSReady_Addon.7z, upon succesful slipstream into SP3 image, KS.SYS is missing from final image.

The only mention of "ks.sys" online is this thread on msfn, apparently directX is responsible? Im actually slipstreaming directx but its never caused problems in the past.... :?
Here is list of hotfixes I attempt to add to SP3 image

Code: Select all

[Hotfixes]
H:\NLITE\Slip - HotFixes\wic_x86_enu.exe
H:\NLITE\Slip - HotFixes\UAA_HDA_AddOn_1.0.7z
H:\NLITE\Slip - HotFixes\WindowsXP-KB955408-x86-ENU.exe
H:\NLITE\Slip - HotFixes\DirectXRuntimes-201006-Addon-32.cab
H:\NLITE\Slip - HotFixes\XPSP3_QFE_UpdatePack_20180109.7z
H:\NLITE\Slip - HotFixes\YumeYao_IE8_Addon_Nosetuperr_ENU_1.5.43.7z
H:\NLITE\Slip - HotFixes\XPSP3_QFE_POSReady_Addon_20200528_5er.7z
Update:
I manually extracts KS.sys from XPSP3_QFE_POSReady_Addon_20200528_5er.7z and compressed it to ks.sy_ then added it to i386 folder and returned the USB stick into target machine, the setup now finds KS.sys but is now asking for ms.sys!?! Unlike ks.sys, I cannot find ms.sys in XPSP3_QFE_POSReady_Addon_20200528_5er.7z to continue install.

I shall build a new bootable image without XPSP3_QFE_POSReady_Addon included and see if that fixes this problem.

Update 2:
The problem went away when XPSP3_QFE_POSReady_Addon_20200528_5er.7z was excluded from addon inclusion. What is your opinion of this Zephyr? something isn't right with it...

Zephyr
Posts: 118
Joined: Sun Nov 22, 2015 4:53 pm
Location: London

Re: [Addon] XPSP3 QFE POSReady Updates 20180917

Post by Zephyr » Thu Aug 20, 2020 5:53 am

shorterxp wrote:
Tue Aug 18, 2020 6:21 pm
I tried a test install, integrated XPSP3_QFE_UpdatePack + XPSP3_QFE_POSReady_Addon with nlite. There seems to be a problem with KS.SYS. It is inside XPSP3_QFE_POSReady_Addon.7z, upon succesful slipstream into SP3 image, KS.SYS is missing from final image.
This is weird. I have just installed my latest build XPSP3_QFE_POSReady_Addon_20200820_Pro.7z and ks.sys is present in %SystemRoot%\System32\drivers, and %SystemRoot%\Driver Cache\i386\driver.cab as expected. The entries for ks.sys are present in dosnet.inf and txtsetup.sif in my integrated Windows install. If you were installing from a USB pen drive that was faulty I would expect setup to halt during the file copy stage of the text mode setup. I prefer to use the integrator rather than nLite because it appears to be fine tuned for integrating addons and update packs, so maybe you should give the integrator a try.
XP FOREVER!

Zephyr
Posts: 118
Joined: Sun Nov 22, 2015 4:53 pm
Location: London

Jet 4.0 Database Fix

Post by Zephyr » Thu Aug 20, 2020 6:24 am

prabocor rajasa has reported that MDB Viwer Plus fails to open .mdb files with the error message "Provider cannot be found. It may not be properly installed" under an XP installation in which the XPSP3 QFE POSReady Updates addon has been integrated. After lengthy investigations I discovered that many registry entries for Jet 4.0 are missing, so I have incorporated them into 5erPOSUp.inf in my latest build which you can download here.

XPSP3_QFE_POSReady_Addon_20200820_Pro.7z
MD5: CF3083C8A3826CB93D4574D5F1655495
SHA1: 92CC5268EB0924B4F63A6D3E1C1F87EEDD792A68

XPSP3_QFE_POSReady_Addon_20200820_Home.7z
MD5: CBFC854A54364C4EFEB73C2596D05996
SHA1: 8D966AE0CA6E7B4C385695F35FA684BCAEFE2148

Using the Microsoft Process Monitor I discovered that nearly all the Jet 4.0 registry entries were missing under the key HKEY_LOCAL_MACHINE_SOFTWARE\Microsoft\Jet\4.0, along with HKEY_LOCAL_MACHINE_SOFTWARE\Classes\Microsoft.Jet.OLEDB.4.0, and HKEY_LOCAL_MACHINE_SOFTWARE\Microsoft.Jet.OLEDB.4.0Errors, and their sub keys.

Using Nirsoft's RegDllView I discovered that msjet40.dll and msjetoledb40.dll had not been registered in the ActiveX/COm section of the registry and when you attempt to register them from the command-line using regsvr32 a message appears saying that registration has been successful, but no entries have been made to the registry.
XP FOREVER!

Zephyr
Posts: 118
Joined: Sun Nov 22, 2015 4:53 pm
Location: London

Re: [Addon] XPSP3 QFE POSReady Updates 20180917

Post by Zephyr » Thu Aug 20, 2020 7:13 am

shorterxp wrote:
Mon Aug 17, 2020 5:27 pm
If user integrates these updates with nlite then removes components after the fact also with nlite, will (already-tested) nlite presets work as otherwise expected?
5erPOSUp.inf does not include an uninstall section, so I cannot see how the XPSP3 QFE POSReady Update Addon can be uninstalled.
shorterxp wrote:
Mon Aug 17, 2020 5:27 pm
Correct me if I am wrong, this is order of updates to integrate to SP2 iso, correct?
  1. SP3 (note: in XP SP3 environment)
  2. XPSP3_QFE_UpdatePack (by user_hidden/5ereph)
  3. XPSP3_QFE_POSReady_Addon (by 5ereph, kindly updated by Zephyr)
Why bother integrating SP3 into a SP2 ISO when you can easily download an SP3 ISO from unofficial sources which is OK as long as you verify it's legitimacy with an official checksum. I may not be permitted to provide a link to a SP3 ISO, but I am sure that Google will help you find what you need. As far as I can tell items 2 and 3 can be integrated at the same time with the integrator.
shorterxp wrote:
Mon Aug 17, 2020 5:27 pm
Also, what of SP4 3.1b + May 2019 Update Rollup by harkaz?
Right now it seems XPSP3_QFE_UpdatePack + XPSP3_QFE_POSReady_Addon is newer.
My XPSP3_QFE_POSReady_Addon is more up to date because includes KB4500331 which is the Remote Terminal update released on 05-11-2019.
shorterxp wrote:
Mon Aug 17, 2020 5:27 pm
Its unclear if XPSP3_QFE_UpdatePack + XPSP3_QFE_POSReady_Addon has .net updates or not. I've suggested someone should make modular up-to-date .net installer (not addon) in the harkaz thread..
.NET updates are not included with the XPSP3_QFE_UpdatePack or XPSP3_QFE_POSReady_Addon.
shorterxp wrote:
Mon Aug 17, 2020 5:27 pm
I'm not a fan of .NET. Users should be free to choose post-OS-install what .net to install. SP4 involves I guess what Im trying to say is, if XPSP3_QFE_UpdatePack + XPSP3_QFE_POSReady_Addon does indeed, exclude .net updates,a complimentary, standalone, installer, which can be run by choice, post-OS-install, is a better, more elegant solution anyway. The installer should install (user selectable) .net version, associated updates and if necessary run the executequeditems command.
nonno fabio's .NET 4.0 TRUE addon xp/2k3/Vista/7 x86 was last updated on 22-06-2017 which I assume was the last date for the release of .NET 4.0 updates for XP. I use this addon and I cannot remember Automatic Updates offering updates for XP. I did try to install the POSReady 2009 .NET 4.0 updates and ran into problems. We need an expert to advise us on the suitability of POSReady 2009 updates for .NET. Perhaps POSReady 2009 has it's own version of .NET. Anyway if the .NET 4.0 TRUE addon xp/2k3/Vista/7 x86 is fully updated then I cannot see why a repack installer would offer any advantages, except perhaps to exclude unnecessary features for a lighter install.
XP FOREVER!

shorterxp
Posts: 38
Joined: Wed Apr 18, 2018 10:44 am

Re: [Addon] XPSP3 QFE POSReady Updates 20180917

Post by shorterxp » Sat Aug 22, 2020 8:46 pm

Thanks for your repsonses.
I have always used SP2 ISo and integrated SP3 without problems previously (using nlite).
I will give integrator a try.

BTW
The reason i dont use online ISO is because my key never works with them. Perhaps Im doing something wrong. I just have standard XP PRo SP2 CD.

travma
Posts: 13
Joined: Fri Feb 06, 2015 1:59 am

Re: [Addon] XPSP3 QFE POSReady Updates 20180917

Post by travma » Wed Oct 28, 2020 8:42 pm

a) On XPSP3_QFE_POSReady_Addon_20200820_Pro.7z the rootsupd go backwards to ver 40 while the latest from user_hidden is 41. Why is this?
b) How I can find/download or generate official .sst files?
c) Which method you use to create the rootsupd.exe?

Zephyr
Posts: 118
Joined: Sun Nov 22, 2015 4:53 pm
Location: London

Re: [Addon] XPSP3 QFE POSReady Updates 20180917

Post by Zephyr » Thu Oct 29, 2020 2:29 pm

travma wrote:
Wed Oct 28, 2020 8:42 pm
a) On XPSP3_QFE_POSReady_Addon_20200820_Pro.7z the rootsupd go backwards to ver 40 while the latest from user_hidden is 41. Why is this?
When heinoganda posted instructions for making your own updated rvkroots.exe and rootsupd.exe at the MSFN board the version number could influence WU or MU to download outdated versions unless it was the version number for the latest versions of these files which was 40,0,2195,0. When user_hidden released his updated rvkroots.exe and rootsupd.exe at this forum the latest version was 41.0.2195.1810 so he used this version number in the INF file. In 2015 WU and MU stopped releasing updates for rvkroots.exe and rootsupd.exe, so the version number is irrelevant now.
travma wrote:
Wed Oct 28, 2020 8:42 pm
b) How I can find/download or generate official .sst files?
The latest .sst files are available at:
http://www.download.windowsupdate.com/m ... hroots.sst
http://www.download.windowsupdate.com/m ... lroots.sst
http://www.download.windowsupdate.com/m ... /roots.sst
http://www.download.windowsupdate.com/m ... droots.sst
http://www.download.windowsupdate.com/m ... edcert.sst

I downloaded them today from these URLs.
travma wrote:
Wed Oct 28, 2020 8:42 pm
c) Which method you use to create the rootsupd.exe?
I used the method that heinoganda provided at the MSFN board. I tried to use the 7-zip SFX maker as user_hidden had done so as to make smaller files, but I did not succeed. I suppose I could have added the updated .sst files to user_hidden's rvkroots.exe and rootsupd.exe in XPSP3_QFE_UpdatePack_20180109.7z using the 7-zip file manager.
XP FOREVER!

Post Reply