[Addon] XPSP3 QFE POSReady Updates 20180819

Discuss & post Update Pack addons here.
Post Reply
Dibya
Posts: 452
Joined: Sat Sep 12, 2015 9:34 am
Location: India

Post by Dibya » Wed Dec 09, 2015 11:10 am

Thank 5eraph for Quick update

User avatar
5eraph
Site Admin
Posts: 4608
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Tue Dec 29, 2015 8:40 am

You're welcome, Dibya. :)

Updated to 20151229:

Dibya
Posts: 452
Joined: Sat Sep 12, 2015 9:34 am
Location: India

Post by Dibya » Mon Jan 04, 2016 11:48 am

Thank a lot

User avatar
5eraph
Site Admin
Posts: 4608
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Mon Jan 04, 2016 3:46 pm

You're welcome. :)

Updated to 20160104:

Dibya
Posts: 452
Joined: Sat Sep 12, 2015 9:34 am
Location: India

Post by Dibya » Wed Jan 06, 2016 10:25 pm

:D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D :D

User avatar
5eraph
Site Admin
Posts: 4608
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Wed Jan 13, 2016 2:31 am

Updated to 20160112. Please read the Changelog for full details.

User avatar
GH0st
Posts: 521
Joined: Wed Nov 05, 2014 9:31 am
Location: Virginia, USA

Re: [Addon] XPSP3 QFE POSReady Updates 20160112

Post by GH0st » Wed Jan 13, 2016 11:23 am

Does this just remove the flash components that YOUR pack has, or both your POS and user_hidden's QFE pack?

User avatar
5eraph
Site Admin
Posts: 4608
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Wed Jan 13, 2016 5:03 pm

Both, GH0st, but requires the POSReady addon.
Last edited by 5eraph on Thu Jan 14, 2016 3:07 am, edited 1 time in total.

User avatar
GH0st
Posts: 521
Joined: Wed Nov 05, 2014 9:31 am
Location: Virginia, USA

Post by GH0st » Wed Jan 13, 2016 10:59 pm

ty

User avatar
5eraph
Site Admin
Posts: 4608
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Tue Jan 19, 2016 5:45 am

Resultant Set of Changes: v20140812 through v20160121.
Last edited by 5eraph on Thu Jan 21, 2016 6:13 pm, edited 1 time in total.

Dibya
Posts: 452
Joined: Sat Sep 12, 2015 9:34 am
Location: India

Post by Dibya » Wed Jan 20, 2016 7:09 am

5eraph wrote:Resultant Set of Changes: v20140812 through v20160112.
Awesome it is great

User avatar
Stormit
Posts: 158
Joined: Mon Jan 12, 2015 12:21 pm
Location: U.S.A.

Post by Stormit » Thu Jan 21, 2016 4:30 pm

Hi I would just like to Thank everyone for all of there hard work and time. Thanks Again :D

User avatar
5eraph
Site Admin
Posts: 4608
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Thu Jan 21, 2016 5:50 pm

You're welcome. :)

Updated to 20160121:

User avatar
5eraph
Site Admin
Posts: 4608
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Sat Jan 23, 2016 1:43 am

Updated to 20160123:

Dibya
Posts: 452
Joined: Sat Sep 12, 2015 9:34 am
Location: India

Post by Dibya » Sat Jan 23, 2016 9:56 am

thanks again for update

User avatar
5eraph
Site Admin
Posts: 4608
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Mon Jan 25, 2016 7:27 pm

You're welcome.

Updated to 20160126:

Dibya
Posts: 452
Joined: Sat Sep 12, 2015 9:34 am
Location: India

Post by Dibya » Wed Jan 27, 2016 10:35 am

awesome

User avatar
5eraph
Site Admin
Posts: 4608
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Sat Jan 30, 2016 7:08 pm

Updated to 20160131:

Dibya
Posts: 452
Joined: Sat Sep 12, 2015 9:34 am
Location: India

Post by Dibya » Mon Feb 08, 2016 6:34 am

thanks 5eraph.

User avatar
5eraph
Site Admin
Posts: 4608
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Wed Feb 10, 2016 7:04 pm

You're welcome. :)

Updated to 20160209. Please read the Changelog for full details.

IE6 is no longer receiving updates and should be considered extremely vulnerable. I'd highly recommend slipstreaming IE7 or IE8, or using an IE8 addon.

Dibya
Posts: 452
Joined: Sat Sep 12, 2015 9:34 am
Location: India

Post by Dibya » Wed Feb 24, 2016 3:35 am

thanks 5eraph
Today I have made my own unattended disc.

Dibya
Posts: 452
Joined: Sat Sep 12, 2015 9:34 am
Location: India

Post by Dibya » Mon Feb 29, 2016 9:42 am

thanks again working superfast

User avatar
5eraph
Site Admin
Posts: 4608
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Tue Mar 08, 2016 3:37 pm

Waiting for Adobe to release this month's Flash Player update...
Adobe wrote:A security update for Adobe Flash Player will also be available in the coming days.
Last edited by 5eraph on Wed Mar 09, 2016 11:40 am, edited 1 time in total.

Dibya
Posts: 452
Joined: Sat Sep 12, 2015 9:34 am
Location: India

Post by Dibya » Tue Mar 08, 2016 10:33 pm

does flash need to be updated monthly?

User avatar
5eraph
Site Admin
Posts: 4608
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Wed Mar 09, 2016 7:36 am

It seems so, Dibya. Flash Player is popular enough to be a big target for malware writers at the moment. Flaws are found often, and need patching often.

I disable it in my browser when not needed.

Dibya
Posts: 452
Joined: Sat Sep 12, 2015 9:34 am
Location: India

Post by Dibya » Wed Mar 09, 2016 8:31 am

thanks 5eraph , I have not update it for many days (using v18.something).

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Post by user_hidden » Wed Mar 09, 2016 8:55 am

i'm also awaiting the flash update to complete the update pack.
mind you it's only mrt and flash so not a big deal.

dudeuk
Posts: 181
Joined: Wed Aug 11, 2010 8:34 am

Post by dudeuk » Thu Mar 10, 2016 4:40 am

Hi All: I would just like to thank everyone here for there continued efforts to keep XP Alive!
_________________________________________________
Here Are my collection of XP files that you can download.
i will update them when i can.

https://mega.nz/#F!8nY0iBLK!JEwKcH9mYYy16iOuUrExyw

User avatar
5eraph
Site Admin
Posts: 4608
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Thu Mar 10, 2016 7:57 pm

Updated to 20160308. Please read the Changelog for full details.

dudeuk
Posts: 181
Joined: Wed Aug 11, 2010 8:34 am

Post by dudeuk » Fri Mar 11, 2016 10:23 am

Hi 5eraph ..
i tried your XPSP3_QFE_POSReady_Addon_20160308_5er
at a few attempts using this with nLite i was quite amazed i kept getting this same error and was just wondering if anyone else had same thing happen.

http://s22.postimg.org/g80givfdd/POSRea ... _ERROR.jpg

ive used your addons before and dont normally get any errors at all

i used a clean xp pro sp3 version .. addons i used

XPSP3_QFE_EnablePOSReadyMU_Addon
XPSP3_QFE_POSReady_Addon_20160308_5er
XPSP3_QFE_UpdatePack_20160308
YumeYao_IE8_Addon_Nosetuperr_ENU_1.5.18
YumeYao_WMP11_Addon_ENU_V3_4_7

User avatar
5eraph
Site Admin
Posts: 4608
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Fri Mar 11, 2016 12:14 pm

I can't reproduce your error, dudeuk.

user_hidden's update pack must be listed above the POSReady addon. This is not reflected in the order you provided above. The file won't be found if the update pack is not integrated first.

If the order is correct, there is another theory: This addon makes many edits to qfeUpPck.inf. It has been proven with other addons that some antivirus products will temporarily lock files to scan them after each edit. This can cause errors like yours. In this case, try temporarily disabling your AV to run nLite.

User avatar
5eraph
Site Admin
Posts: 4608
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Fri Mar 11, 2016 1:31 pm

I see you're using the EnablePOSReadyMU addon. It has been updated due to the change in detection MU now uses.

The new addon also removes the following line from qfeUpPck.inf:
HKLM,"SYSTEM\CurrentControlSet\Control\WindowsEmbedded\ProductVersion","FeaturePackVersion",0x00000000,"SP3"

adric
Posts: 581
Joined: Mon May 21, 2007 5:51 am

Post by adric » Fri Mar 11, 2016 3:46 pm

The Windowsembedded key does not exist on my system (u_h packs + old enable posready addon version=2014-09_1). Maybe this key is specific to what harkaz has created. Why would this key exist on a standard XP Build?

Al

User avatar
5eraph
Site Admin
Posts: 4608
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Fri Mar 11, 2016 4:43 pm

It should be on your system, adric. Can't explain why it is not.

adric
Posts: 581
Joined: Mon May 21, 2007 5:51 am

Post by adric » Fri Mar 11, 2016 5:41 pm

5eraph wrote:It should be on your system, adric. Can't explain why it is not.
Looks like this key was added for the same purpose as the posready key - to prolong getting updates. See here.

User avatar
5eraph
Site Admin
Posts: 4608
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Fri Mar 11, 2016 5:58 pm

I know it wouldn't exist in a standard XP build. What I don't understand is why it didn't get added for you by user_hidden's update pack (line 9267 of qfeUpPck.inf) when using my old Enable addon. :)

adric
Posts: 581
Joined: Mon May 21, 2007 5:51 am

Post by adric » Fri Mar 11, 2016 6:41 pm

Hmmm, I didn't realize u_h was adding that key since support for SP3 embedded ended sooner than posready. I would think only the longer lasting key would have been enough.

Anyway, now you are not alone not understanding why this key was not applied. :D I will check on the next install. My last build was in September so maybe one of the WU updates between now and then removed the key.

dudeuk
Posts: 181
Joined: Wed Aug 11, 2010 8:34 am

Post by dudeuk » Sat Mar 12, 2016 3:10 pm

compiled new xp iso today..

added first and let that process
XPSP3_QFE_UpdatePack_20160308
YumeYao_IE8_Addon_Nosetuperr_ENU_1.5.18
YumeYao_WMP11_Addon_ENU_V3_4_7

added second and let that process
XPSP3_QFE_EnablePOSReadyMU_Addon
XPSP3_QFE_POSReady_Addon_20160308_5er

worked out ok this time..

normally i just add all addons and it gets on with it ok
but from now on ill do it separately

User avatar
5eraph
Site Admin
Posts: 4608
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Sat Mar 12, 2016 4:17 pm

XPSP3_QFE_EnablePOSReadyMU_Addon has been updated, dudeuk. See my last reply to you for details.

dudeuk
Posts: 181
Joined: Wed Aug 11, 2010 8:34 am

Post by dudeuk » Sun Mar 13, 2016 7:36 am

yes i added lastest XPSP3_QFE_EnablePOSReadyMU_Addon_20160311
many thanks...
Hi All: I would just like to thank everyone here for there continued efforts to keep XP Alive!
_________________________________________________
Here Are my collection of XP files that you can download.
i will update them when i can.

https://mega.nz/#F!8nY0iBLK!JEwKcH9mYYy16iOuUrExyw

Dibya
Posts: 452
Joined: Sat Sep 12, 2015 9:34 am
Location: India

Post by Dibya » Mon Mar 14, 2016 4:51 am

@dudeuk
this the correct order my dear
XPSP3_QFE_UpdatePack_20160308
XPSP3_QFE_POSReady_Addon_20160308_5er
XPSP3_QFE_EnablePOSReadyMU_Addon
YumeYao_IE8_Addon_Nosetuperr_ENU_1.5.18
YumeYao_WMP11_Addon_ENU_V3_4_7
otherwise it will cause few nice problems as qfe updatepacks(both 5eraph and U_H) will replace wmp11 and ie8 files with ie6 and wmp9

User avatar
Stormit
Posts: 158
Joined: Mon Jan 12, 2015 12:21 pm
Location: U.S.A.

About Pack

Post by Stormit » Tue Mar 15, 2016 4:37 pm

Hi All: user_hidden and 5eraph I would just like to thank you for your continued efforts great job and hard work and time. :)

Sorry 5eraph my mistake but I still Thank You both.
Last edited by Stormit on Wed Mar 16, 2016 3:12 pm, edited 2 times in total.

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Re: About Pack

Post by user_hidden » Tue Mar 15, 2016 9:07 pm

Stormit wrote:Hi All: user_hidden I would just like to thank you for your continued efforts great job and hard work and time. :)
thank you but it's really 5eraph that has been updating POSReady updates for adding to my update pack.

dudeuk
Posts: 181
Joined: Wed Aug 11, 2010 8:34 am

Post by dudeuk » Wed Mar 16, 2016 9:49 am

Dibya wrote:@dudeuk
this the correct order my dear
XPSP3_QFE_UpdatePack_20160308
XPSP3_QFE_POSReady_Addon_20160308_5er
XPSP3_QFE_EnablePOSReadyMU_Addon
YumeYao_IE8_Addon_Nosetuperr_ENU_1.5.18
YumeYao_WMP11_Addon_ENU_V3_4_7
otherwise it will cause few nice problems as qfe updatepacks(both 5eraph and U_H) will replace wmp11 and ie8 files with ie6 and wmp9
ive tried this a few times now with nlite..

stage 1
used nlite to add
XPSP3_QFE_UpdatePack_20160308

stage 2
used nlite to add
XPSP3_QFE_POSReady_Addon_20160308_5er
XPSP3_QFE_EnablePOSReadyMU_Addon_20160311

stage 3
used nlite to add
YumeYao_IE8_Addon_Nosetuperr_ENU_1.5.18
YumeYao_WMP11_Addon_ENU_V3_4_7

when tested i get two WEPOS & POSReady updates to download in windows updates online KB3067903 & KB3033890

ill be trying RyanVM Integrator next rather than nlite to see if that has any better effect..


edit
tried same addons in same order but using RyanVM Integrator adding one addon at a time to intergrate

when tested i get three WEPOS & POSReady updates to download in windows updates online KB3067903 & KB3033890 & KB3140410
Last edited by dudeuk on Wed Mar 16, 2016 3:32 pm, edited 2 times in total.

adric
Posts: 581
Joined: Mon May 21, 2007 5:51 am

Post by adric » Wed Mar 16, 2016 10:48 am

Windows Update reoffering KB3139398 after fresh install with latest u_h and PosReady packs. Anyone else noticing this?

Dibya
Posts: 452
Joined: Sat Sep 12, 2015 9:34 am
Location: India

Post by Dibya » Wed Mar 16, 2016 11:25 am

dear adric
regentries for KB3139398 already there in the inf file of 5eraph . It should not happen
[KB3139398.AddReg]
HKLM,"%SP4REG%\KB3139398","Description",0,"%SUPD% (KB3139398)"
HKLM,"%SP4REG%\KB3139398","InstalledBy",0,"%NAME%"
HKLM,"%SP4REG%\KB3139398","InstalledDate",0,"%UPVER%"
HKLM,"%SP4REG%\KB3139398","Type",0,"Update"
HKLM,"%SP4REG%\KB3139398\Filelist\0","BuildCheckSum",0,"d332"
HKLM,"%SP4REG%\KB3139398\Filelist\0","BuildDate",0,"Fri Jan 29 14:11:23 2016"
HKLM,"%SP4REG%\KB3139398\Filelist\0","FileName",0,"usbstor.sys"
HKLM,"%SP4REG%\KB3139398\Filelist\0","Location",0,"%10%\Driver Cache\i386"
HKLM,"%SP4REG%\KB3139398\Filelist\0","Version",0,"5.1.2600.7012"
HKLM,"%HFREG%\KB3139398","Backup Dir",0,""
HKLM,"%HFREG%\KB3139398","Comments",0,"%SUPD% (KB3139398)"
HKLM,"%HFREG%\KB3139398","Fix Description",0,"%SUPD% (KB3139398)"
HKLM,"%HFREG%\KB3139398","Installed",0x10001,1
HKLM,"%HFREG%\KB3139398","Installed By",0,"%NAME%"
HKLM,"%HFREG%\KB3139398","Installed On",0,"%UPVER%"
HKLM,"%HFREG%\KB3139398","Service Pack",0x10001,4
HKLM,"%HFREG%\KB3139398","Valid",0x10001,1
HKLM,"%HFREG%\KB3139398\File 1","Flags",0,""
HKLM,"%HFREG%\KB3139398\File 1","New File",0,""
HKLM,"%HFREG%\KB3139398\File 1","New Link Date",0,""
HKLM,"%HFREG%\KB3139398\File 1","Old Link Date",0,"

User avatar
5eraph
Site Admin
Posts: 4608
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Wed Mar 16, 2016 12:57 pm

dudeuk wrote:YumeYao_WMP11_Addon_ENU_V3_4_7

when tested i get two WEPOS & POSReady updates to download in windows updates online KB3067903 & KB3033890
Those two updates are specific to WMP11, and beyond the scope of the POSReady addon. Tried my hand at updating YumeYao's WMP addons. Turns out that YumeYao's WMP addons don't work so well when integrated with the POSReady addon.
adric wrote:Windows Update reoffering KB3139398 after fresh install with latest u_h and PosReady packs. Anyone else noticing this?
Dibya wrote:It should not happen
If the problem is what I think it is then I'll need to test on bare metal (not in virtual machine). Give me some time to work on it.

User avatar
5eraph
Site Admin
Posts: 4608
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Wed Mar 16, 2016 1:59 pm

Need more information, adric. Are you using RVMi, or nLite? Are you integrating the update pack and the POSReady addon at the same time?

I ask because usbstor.sys needs to be updated in driver.cab. The CAB file is only updated in RVMi when an update pack is integrated in the current session. The addon must be integrated at the same time as the update pack when using RVMi.

adric
Posts: 581
Joined: Mon May 21, 2007 5:51 am

Post by adric » Wed Mar 16, 2016 2:32 pm

I don't use nlite, only RVMI. I always run a windows update (web) check after completing and customizing the install. At the time, MU did not show any outstanding fixes. the KB seems to have reappeared since yesterday. This is what I installed. Update Pack first, then another run with Addons

Code: Select all

[AddonPacks]
Addon_DirectX32_9.0c_Runtimes_201006.7z=Z:\$XPi\@Addons
Kels_Runtimes_addon_v8.8.rar=Z:\$XPi\@Addons
Ricks-YumeYao_MicrosoftVC7891012RuntimeLibraries_MixedAddon_2_2_3.7z=Z:\$XPi\@Ad
MassStorageAddons_IaStor_8.9.2.1002.7z=Z:\$XPi\@Addons
RogueSpearAddonsM2-XPSP3-NoKtD_8.09.7z=Z:\$XPi\@Addons
XPSP3_QFE_EnablePOSReadyMU_Addon.7z=Z:\$XPi\@Addons
XPSP3_QFE_POSReady_Addon_20160308_5er.7z=Z:\$XPi\@Addons
YumeYao_WMP11_Addon_ENU_v3.5.1.7z=Z:\$XPi\@Addons
YumeYao_IE8_Addon_Nosetuperr_ENU_1.5.18.7z=Z:\$XPi\@Addons

adric
Posts: 581
Joined: Mon May 21, 2007 5:51 am

Post by adric » Wed Mar 16, 2016 2:45 pm

5eraph wrote:Need more information, adric. Are you using RVMi, or nLite? Are you integrating the update pack and the POSReady addon at the same time?

I ask because usbstor.sys needs to be updated in driver.cab. The CAB file is only updated in RVMi when an update pack is integrated in the current session. The addon must be integrated at the same time as the update pack when using RVMi.
That may be it. I've always run the update pack and Addons as separate runs. Looks like I still have an old version of the usbstor.sys Not sure why this did not show up when I first checked with MU

Code: Select all

filever C:\WINDOWS\system32\drivers\USBSTOR.SYS
--a-- W32i   DLL ENU   5.1.2600.5512 shp     26,368 04-14-2008 usbstor.sys

Post Reply