Recent site security upgrade

Forum for anything else which doesn't fit in the above forums. Site feedback, random talk, whatever, are welcome.
Post Reply
User avatar
RyanVM
Site Admin
Posts: 5186
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Recent site security upgrade

Post by RyanVM » Wed Nov 02, 2016 2:45 pm

I recently enabled HTTPS support for this site, thanks to LetsEncrypt. From all the testing I've done, everything should Just Work at this point, but feel free to comment here if you run into anything odd.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
5eraph
Site Admin
Posts: 4618
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Wed Nov 02, 2016 3:07 pm

Thanks, Ryan. Works for me in Firefox 49.0.2 32-bit on XPx64.

User avatar
bphlpt
Posts: 1346
Joined: Sat Apr 19, 2008 1:11 am

Post by bphlpt » Wed Nov 02, 2016 5:51 pm

And it works for me as well using SRWare Iron (a Chrome variant) on Win7x64.

Cheers and Regards

User avatar
compstuff
Posts: 464
Joined: Fri Aug 11, 2006 3:25 pm
Location: Florida

Post by compstuff » Wed Nov 02, 2016 7:13 pm

Thanks for that & everything... Works for me with Chrome 54.0.2840.71

Love LetsEncrypt I use it also :-)

User avatar
GH0st
Posts: 529
Joined: Wed Nov 05, 2014 9:31 am
Location: Virginia, USA

Post by GH0st » Wed Nov 02, 2016 11:26 pm

Works fine for me,

WinXP Pro x86, uSP4, Iron with extensions of "HTTPS Everywhere" and "uBlock"

User avatar
RyanVM
Site Admin
Posts: 5186
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Thu Nov 03, 2016 12:08 am

Looks like my CSP policies broke the editor controls (yay inline scripts). I'll work on tweaking them soonish.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
mooms
Posts: 768
Joined: Wed Aug 27, 2008 1:29 pm
Location: France

Post by mooms » Thu Nov 03, 2016 6:08 am

Indeed.
Alteration of the world
Want to thank me ? If you buy something on Banggood with this link, I will earn a little %.

User avatar
5eraph
Site Admin
Posts: 4618
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Fri Nov 04, 2016 11:35 am

Noticing a couple things since this update. First, the pages never stop loading--need to stop loading the page in order to refresh it (unless you use F5). And secondly, the number of "guest" visitors is consistently about half of what we usually get. We used to have between 15 and 35 guests at any given time; now we rarely get out of the single digits.

User avatar
mooms
Posts: 768
Joined: Wed Aug 27, 2008 1:29 pm
Location: France

Post by mooms » Fri Nov 04, 2016 1:23 pm

I don't have the issue about the never ending loading pages.
Alteration of the world
Want to thank me ? If you buy something on Banggood with this link, I will earn a little %.

User avatar
RyanVM
Site Admin
Posts: 5186
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Fri Nov 04, 2016 4:05 pm

5eraph wrote:Noticing a couple things since this update. First, the pages never stop loading--need to stop loading the page in order to refresh it (unless you use F5). And secondly, the number of "guest" visitors is consistently about half of what we usually get. We used to have between 15 and 35 guests at any given time; now we rarely get out of the single digits.
I wonder if there's fewer bots hitting the site or something.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
RyanVM
Site Admin
Posts: 5186
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Re: Recent site security upgrade

Post by RyanVM » Fri Nov 04, 2016 8:56 pm

I decided to go even more fancy pants and do the long-awaited phpBB3 upgrade too :D. Obviously there's some work to do still, but everything should at least be ported over now!
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
mooms
Posts: 768
Joined: Wed Aug 27, 2008 1:29 pm
Location: France

Re: Recent site security upgrade

Post by mooms » Sat Nov 05, 2016 11:05 am

I was shocked when I encountered a white and blue webpage ! :smile:
The editor controls and smileys are still broken.
Alteration of the world
Want to thank me ? If you buy something on Banggood with this link, I will earn a little %.

User avatar
bphlpt
Posts: 1346
Joined: Sat Apr 19, 2008 1:11 am

Re: Recent site security upgrade

Post by bphlpt » Sat Nov 05, 2016 11:14 am

I was, too, mooms. I couldn't find an exact theme like the old one, but there are other options available if you edit your profile.

Cheers and Regards

User avatar
mooms
Posts: 768
Joined: Wed Aug 27, 2008 1:29 pm
Location: France

Re: Recent site security upgrade

Post by mooms » Sat Nov 05, 2016 11:31 am

Thanks for the info, Digi (Dark Blue) & Digi (Dark Blue 2) are cool, but I think the old theme is more readable (maybe I was used to).
edit: but the title of the forum is missing with these themes, we have phpBB instead.
Alteration of the world
Want to thank me ? If you buy something on Banggood with this link, I will earn a little %.

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Re: Recent site security upgrade

Post by user_hidden » Sat Nov 05, 2016 11:46 am

hmmmm logged in today and noticed the change.
the forums has become a PhpBB generic theme.

and where did my Moderator powers go ???

User avatar
mooms
Posts: 768
Joined: Wed Aug 27, 2008 1:29 pm
Location: France

Re: Recent site security upgrade

Post by mooms » Sat Nov 05, 2016 11:53 am

user_hidden wrote:and where did my Moderator powers go ???
Image

Sorry couldn't resist :smile:
Alteration of the world
Want to thank me ? If you buy something on Banggood with this link, I will earn a little %.

User avatar
bphlpt
Posts: 1346
Joined: Sat Apr 19, 2008 1:11 am

Re: Recent site security upgrade

Post by bphlpt » Sat Nov 05, 2016 7:56 pm

mooms wrote:Thanks for the info, Digi (Dark Blue) & Digi (Dark Blue 2) are cool, but I think the old theme is more readable (maybe I was used to).
edit: but the title of the forum is missing with these themes, we have phpBB instead.
That's what I thought, too. Hopefully, Ryan will find a theme similar to the old one. That would also be my preference.

Cheers and Regards

User avatar
5eraph
Site Admin
Posts: 4618
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Sun Nov 06, 2016 10:13 am

RyanVM wrote:I wonder if there's fewer bots hitting the site or something.
Visitor numbers are back up to where they were previously. And now I can see the actual bots.

Sent you a PM, user_hidden. :)

User avatar
RyanVM
Site Admin
Posts: 5186
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Re: Recent site security upgrade

Post by RyanVM » Sun Nov 06, 2016 3:21 pm

Yeah, I picked the Digi theme specifically because it was the closest out-of-the-box theme I could find that resembled the old one. I thought I had it properly set as the default one, though. Guess not :(

TBH, I don't have the time to try to build a theme that matches the old one more closely. If someone's feeling that motivated, feel free to shoot me a PM. Otherwise, this'll have to do :)
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
keloo05
Posts: 276
Joined: Mon Jun 26, 2006 10:04 pm
Location: Romania

Re: Recent site security upgrade

Post by keloo05 » Sun Nov 06, 2016 5:47 pm

This update lost a great feature from the old forum: the ability to view posts since last visit (or I can't find it...)
Is there any way you can bringt it back? Or is there any way to see what was being posted since last visit?
Thnak you very much.

User avatar
5eraph
Site Admin
Posts: 4618
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Re: Recent site security upgrade

Post by 5eraph » Sun Nov 06, 2016 7:03 pm

"New posts" is still there, keloo05. There's a dedicated link for "New posts" in the Digi themes in the upper-left corner. In prosilver (or any other theme) click the hamburger icon (three horizontal lines) in the upper-left corner to find "new posts."

User avatar
=[FEAR]=JIGSAW
Posts: 380
Joined: Mon Feb 18, 2008 11:54 am
Location: Cape Town, South Africa

Re: Recent site security upgrade

Post by =[FEAR]=JIGSAW » Mon Nov 07, 2016 2:37 am

Works, but don't like the theme ... would like something darker :p

User avatar
5eraph
Site Admin
Posts: 4618
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Re: Recent site security upgrade

Post by 5eraph » Mon Nov 07, 2016 6:27 am

You can access several dark themes from your User Control Panel. In the upper-right corner of any forum page:
  • Click your name --> User Control Panel --> Board preferences --> Edit global settings --> My board style
Select anything but prosilver.

User avatar
keloo05
Posts: 276
Joined: Mon Jun 26, 2006 10:04 pm
Location: Romania

Re: Recent site security upgrade

Post by keloo05 » Mon Nov 07, 2016 9:14 am

5eraph wrote:"New posts" is still there, keloo05. There's a dedicated link for "New posts" in the Digi themes in the upper-left corner. In prosilver (or any other theme) click the hamburger icon (three horizontal lines) in the upper-left corner to find "new posts."
I found it, with the Digi themes. Thank you very much.
Still, the counter which showed the number of new posts is lost.

User avatar
mooms
Posts: 768
Joined: Wed Aug 27, 2008 1:29 pm
Location: France

Re: Recent site security upgrade

Post by mooms » Mon Nov 07, 2016 11:36 am

I have an issue: The site don't remember me, I have to re-login each time I close my browser.

I use an extension, CookieKeeper, to keep cookies from the site I visit often (like RyanVM) and delete the other when the browser closes, but, even after protecting the cookies from deletion, I have to login again if i have closed Firefox.
It worked fine before the upgrade.

edit: never mind, it was a mis-configuration on my end, it works now.
Last edited by mooms on Mon Nov 07, 2016 11:52 am, edited 2 times in total.
Alteration of the world
Want to thank me ? If you buy something on Banggood with this link, I will earn a little %.

User avatar
RyanVM
Site Admin
Posts: 5186
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Re: Recent site security upgrade

Post by RyanVM » Mon Nov 07, 2016 11:37 am

=[FEAR]=JIGSAW wrote:Works, but don't like the theme ... would like something darker :p
Happy to add more theme options if you've got suggestions.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
=[FEAR]=JIGSAW
Posts: 380
Joined: Mon Feb 18, 2008 11:54 am
Location: Cape Town, South Africa

Re: Recent site security upgrade

Post by =[FEAR]=JIGSAW » Wed Nov 09, 2016 12:18 pm

RyanVM wrote:
=[FEAR]=JIGSAW wrote:Works, but don't like the theme ... would like something darker :p
Happy to add more theme options if you've got suggestions.
It's all good, 5eraph pointed me in the right direction.

I was using this theme from a member on this forum

Code: Select all

https://userstyles.org/styles/91535/ryanvm-net-forum-alternative-skin

User avatar
mooms
Posts: 768
Joined: Wed Aug 27, 2008 1:29 pm
Location: France

Re: Recent site security upgrade

Post by mooms » Wed Nov 09, 2016 12:53 pm

I still have the login problem after all.
Don't know what to do.
Alteration of the world
Want to thank me ? If you buy something on Banggood with this link, I will earn a little %.

User avatar
user_hidden
Posts: 1924
Joined: Thu Dec 06, 2007 7:52 am
Location: Canada eh!

Re: Recent site security upgrade

Post by user_hidden » Wed Nov 09, 2016 4:05 pm

mooms

do you have an add blocker running?

User avatar
mooms
Posts: 768
Joined: Wed Aug 27, 2008 1:29 pm
Location: France

Re: Recent site security upgrade

Post by mooms » Wed Nov 09, 2016 6:37 pm

Yes, of course, I have multiple content blocker:
Ublock Origin, Noscript, Ghostery, DecentralEyes, but nothing seems to be blocked here, and I don't see why it should prevent the cookies to works.

Edit: I think I've found the problem (and the solution):

I use a bookmark (well, it not a bookmark actually, it's one the most visited Firefox bookmarks, it's important to be precised, because it cannot be edited, at least not easily) to access to the newposts directly:

Code: Select all

http://ryanvm.net/forum/search.php?search_id=newposts
As you can see there is no "s" in the http, that's because the "bookmark" is used since a long time, before RyanVM switched to https.

That's what caused the issue here, because the cookies are set to not be used on hoot, only https, after editing them to allow http, the issue is gone, I am correctly remembered and automatically redirected to

Code: Select all

https://ryanvm.net/forum/search.php?search_id=newposts
When using the url

Code: Select all

https://ryanvm.net/forum/search.php?search_id=newposts
to access the forum with a fresh session of Firefox, even with untouched cookies, I'm still remembered.
Alteration of the world
Want to thank me ? If you buy something on Banggood with this link, I will earn a little %.

ChiefZeke
Posts: 767
Joined: Fri Mar 23, 2007 5:33 pm
Location: Victorville, California

Re: Recent site security upgrade

Post by ChiefZeke » Sat Nov 12, 2016 5:00 pm

Login problem exists for me - must login every time - no ad/content blockers in use.

User avatar
bphlpt
Posts: 1346
Joined: Sat Apr 19, 2008 1:11 am

Re: Recent site security upgrade

Post by bphlpt » Sat Nov 12, 2016 6:46 pm

Well it's most likely on your end, Chief. So how, EXACTLY, do you attempt to login? What link, using what browser, with which extensions installed?

Cheers and Regards

User avatar
mooms
Posts: 768
Joined: Wed Aug 27, 2008 1:29 pm
Location: France

Re: Recent site security upgrade

Post by mooms » Sun Nov 13, 2016 4:38 pm

If you use a bookmark or similar, be sure it use HTTPS (see my previous post).
Alteration of the world
Want to thank me ? If you buy something on Banggood with this link, I will earn a little %.

User avatar
GH0st
Posts: 529
Joined: Wed Nov 05, 2014 9:31 am
Location: Virginia, USA

Re: Recent site security upgrade

Post by GH0st » Mon Nov 14, 2016 12:56 am

My browser is remembering me, so it logs in automaticly, so guess its the cookie that keeps the password in it. Which my CCleaner deletes all cookie except the ones I choose to keep, so I dont have to remember to login each time.

I really dont like this new changes at all ... of coarse I am a man who does not like change, which is why I stay with WinXP! :)

I know all updates are for security, so, will learn to like it at some point

User avatar
mooms
Posts: 768
Joined: Wed Aug 27, 2008 1:29 pm
Location: France

Re: Recent site security upgrade

Post by mooms » Mon Nov 14, 2016 7:11 am

Then delete all cookies from ryanvm.net, reboot the browser and try to log again, then see if it remembers you.
If you use Firefox, I recommend this extension for the management of your cookies, even better than CCleaner: https://addons.mozilla.org/firefox/addon/cookiekeeper/
Alteration of the world
Want to thank me ? If you buy something on Banggood with this link, I will earn a little %.

User avatar
GH0st
Posts: 529
Joined: Wed Nov 05, 2014 9:31 am
Location: Virginia, USA

Re: Recent site security upgrade

Post by GH0st » Wed Nov 16, 2016 1:18 am

It works for me, just fine. No problems here at this time! CCleaner saves/deletes cookies fine for me

Dibya
Posts: 455
Joined: Sat Sep 12, 2015 9:34 am
Location: India

Re: Recent site security upgrade

Post by Dibya » Sat Dec 24, 2016 10:11 am

Thanks Admin for Upgrade

User avatar
RyanVM
Site Admin
Posts: 5186
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Re: Recent site security upgrade

Post by RyanVM » Mon Jan 09, 2017 10:32 pm

I just updated to phpBB 3.2.0 and naturally it broke the theme we were using (well, it was somewhat-usable but broken enough to be annoying). I've reverted back to the default style for now, but I can assure you that I'll try to get something less fugly installed as soon as possible.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
RyanVM
Site Admin
Posts: 5186
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Re: Recent site security upgrade

Post by RyanVM » Mon Jan 09, 2017 10:50 pm

I've installed two new themes that are compatible with 3.2.0 (not a lot to choose from, so they'll have to do for now) - Cynthia and Lucid Lime. I've set Lucid Lime as the new board default for now.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
GH0st
Posts: 529
Joined: Wed Nov 05, 2014 9:31 am
Location: Virginia, USA

Re: Recent site security upgrade

Post by GH0st » Mon Jan 09, 2017 11:42 pm

I am happiest with "ProSilver" theme. Easy on the eyes. I found some of the other ones were hiding stuff on me. Couldn't find the buttons for "Quick Links", which I use daily

Thanks for the updates!!!

User avatar
=[FEAR]=JIGSAW
Posts: 380
Joined: Mon Feb 18, 2008 11:54 am
Location: Cape Town, South Africa

Re: Recent site security upgrade

Post by =[FEAR]=JIGSAW » Mon Jan 16, 2017 2:53 am

Lucid Lime is perfect as a default ;)

User avatar
=[FEAR]=JIGSAW
Posts: 380
Joined: Mon Feb 18, 2008 11:54 am
Location: Cape Town, South Africa

Re: Recent site security upgrade

Post by =[FEAR]=JIGSAW » Mon Jan 23, 2017 2:58 am

Is there a way to get 'external' links to open in a tab/window ??

User avatar
mooms
Posts: 768
Joined: Wed Aug 27, 2008 1:29 pm
Location: France

Re: Recent site security upgrade

Post by mooms » Mon Jan 23, 2017 5:09 am

TabMixPlus for Firefox have an option for that.
Alteration of the world
Want to thank me ? If you buy something on Banggood with this link, I will earn a little %.

User avatar
=[FEAR]=JIGSAW
Posts: 380
Joined: Mon Feb 18, 2008 11:54 am
Location: Cape Town, South Africa

Re: Recent site security upgrade

Post by =[FEAR]=JIGSAW » Tue Jan 24, 2017 1:59 am

Will give it a go, but I was refering to this site's settings ?

Post Reply