RyanVM Update Pack 2.1.4 - Released November 19, 2006

Questions about Update Pack making? Ask here.
User avatar
5eraph
Site Admin
Posts: 4619
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Mon Nov 20, 2006 3:23 pm

Seventeen minutes is not an eternity of waiting. More detail is needed. Did you integrate with nLite or the RVM Integrator? At what point do you get the error?

These are things that must be known if you want help. We're not clairvoyant, nor are we suicide counselors. Whining only establishes that you are impatient.

User avatar
RyanVM
Site Admin
Posts: 5187
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Mon Nov 20, 2006 3:51 pm

Um, I don't see any files called "svmg.sys" on my standard XP install CD. Are you sure you're working with a clean source?
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

newsposter
Posts: 1131
Joined: Wed Sep 14, 2005 11:31 am

Post by newsposter » Mon Nov 20, 2006 4:43 pm

A quick google search brings up no references to that file anywhere on the net.

A search of microsoft.com also brings up reference.

Firefrorefiddle
Posts: 47
Joined: Thu Nov 02, 2006 5:29 am

Post by Firefrorefiddle » Mon Nov 20, 2006 7:34 pm

a search with variations of the name brought up nothing significant either.
seems like it might be an addon problem to me, not a pack problem. are you using any extra integrators?

gonna give the pack a whirl myself later on tonight and see if i come up with errors

stevec4
Posts: 29
Joined: Sat Jul 29, 2006 4:49 pm

Post by stevec4 » Mon Nov 20, 2006 7:46 pm

Thanks Ryan
Works perfectly as usual.

Now take Thursday Off... :)

Steve

ViVa

Post by ViVa » Mon Nov 20, 2006 7:49 pm

Guys... this guy is just messing with us, I suggest you don't waste any more time on him.

User avatar
joll69
Posts: 28
Joined: Sun Oct 09, 2005 6:59 pm

Post by joll69 » Mon Nov 20, 2006 8:51 pm

this is a tad off-topic, but has anyone else observed this behavior? Link

techtype
Posts: 268
Joined: Mon Aug 15, 2005 5:46 pm

Post by techtype » Mon Nov 20, 2006 9:17 pm

joll69 wrote:this is a tad off-topic, but has anyone else observed this behavior? Link
Yeah, I've seen it exactly as described. I don't know if it really is working, but I'd guess not.

Firefrorefiddle
Posts: 47
Joined: Thu Nov 02, 2006 5:29 am

Post by Firefrorefiddle » Mon Nov 20, 2006 10:10 pm

hm, interesting. what ie7 source did you use?
the protected mode for IE7 actually only applies to vista, which makes me think you got yourself
an addon with the wrong version of ie7 (don't bash me if i'm wrong about this, i'm just guessing that there would be a difference in packages for IE7vista vs ie7xp)
either that or something on your system is making ie7 think it's running on vista, is my guess
as i said, protected mode only applies to vista

hope this helps somewhat,
cheers

HelloKitty

Post by HelloKitty » Tue Nov 21, 2006 12:01 am

I'm getting this message after using the 2.1.4:
Image

with nlite 1.2.1

and the update packs:
Image

This is the first time I've encountered this message. I've been using nlite for 7+ months now and never got this message once. I even used the recent latest version with (v2.1.3) with the same nlite 1.2.1 without any alterations in the components and it worked flawlessly.

But ever since i tried to integrate 2.1.4, Pristine, HmmXP and Bliss with my current configuration I get the error message (shown above). And after I close it; it continues the process as if nothing happens. Can this error be tolerated? I'm afraid that it might cause future problems when installing windows even dou I'd be able to create the ISO.

btw; I did not integrate IE7 at all. I'm not sure if its an nlite problem (yes I've read the FAQS, but its just that the error only popped up when I moved to version 2.1.4 so I presume that it might be a bug in the new update pack.

thanks for reading! :)

User avatar
RyanVM
Site Admin
Posts: 5187
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Tue Nov 21, 2006 12:03 am

Read the note in the first post about issues with nLite integration. Hint: this isn't the place to be asking.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
buletov
Posts: 380
Joined: Tue Feb 15, 2005 11:30 am

Post by buletov » Tue Nov 21, 2006 3:57 am

Very nice Ryan...
Never know what life is gonna throw at you.

Eiffel
Posts: 73
Joined: Fri Nov 03, 2006 3:36 am

Post by Eiffel » Tue Nov 21, 2006 4:22 am

Hi Ryan. There is an new font update for EU : http://download.microsoft.com/download/ ... update.EXE
It replaces old Arial and Times fonts. Will you included in the next pack ?

fluid
Posts: 148
Joined: Wed Nov 24, 2004 4:46 am

Post by fluid » Tue Nov 21, 2006 7:25 am

Is IE 7 integrated here? I can't seem to remeber if IE 7 had a hotfix number. Pardon the ignorance.

ViVa

Post by ViVa » Tue Nov 21, 2006 8:32 am

No it's not.

Martin H
Posts: 26
Joined: Fri Nov 17, 2006 8:03 am
Location: Denmark

Post by Martin H » Tue Nov 21, 2006 11:02 am

@Ryan

I remember that in the thread for your previous release i.e v2.1.3, then someone asked you about why KB917537 wasen't included in the pack, and then you said that you had missed that one, and that it would be included in the next update pack i.e. v2.1.4. After having read through the changelog for v2.1.4, then i can't see that it's included in this month either. Could you please tell me if there is a specific reason to this ? Anyway, it's not a big issue, but i was just curious about it :)

Thank's in advance.

Martin.

ViVa

Post by ViVa » Tue Nov 21, 2006 11:29 am

Ryan decided not to include it after all, since not that many ppl use IIS on Windows XP.

[/Ryan's-answering-machine]

hbinded
Posts: 11
Joined: Thu Nov 09, 2006 1:22 am

Post by hbinded » Tue Nov 21, 2006 12:04 pm

just out of curiosity, do you guys install a fresh copy of windows every time an update pack is released?

Thanks and thumbs up ryan!

ViVa

Post by ViVa » Tue Nov 21, 2006 12:06 pm

I do every after every 2-3 new update packs, since my pc is usually a mess by then. ;)

User avatar
RyanVM
Site Admin
Posts: 5187
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Tue Nov 21, 2006 12:31 pm

Martin H wrote:@Ryan

I remember that in the thread for your previous release i.e v2.1.3, then someone asked you about why KB917537 wasen't included in the pack, and then you said that you had missed that one, and that it would be included in the next update pack i.e. v2.1.4. After having read through the changelog for v2.1.4, then i can't see that it's included in this month either. Could you please tell me if there is a specific reason to this ? Anyway, it's not a big issue, but i was just curious about it :)

Thank's in advance.

Martin.
ViVa pretty much said it all (for the record, I told him over IM already about the decision :P). IIS is a component which isn't installed by default with Windows XP, for good reason. It's a massively stripped down version compared to Server2k3. For that reason, I decided to leave it out in order to keep the hotfix count down. Those who decide to install IIS with their copy of XP will have to either install it after the fact (not the end of the world) or find someone willing to make an addon for it (if you're going to request that, please do so in the proper place).

If you want to discuss the issue further, my PM box is always open :)
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
joll69
Posts: 28
Joined: Sun Oct 09, 2005 6:59 pm

Post by joll69 » Tue Nov 21, 2006 2:22 pm

it's not really an issue, i was just wondering if anyone has seen the same thing i've seen, as it seems more than i little odd...what i'm getting at is that this probly doesnt have much to do with nlite, just the integration of ie7 on top of ie6 before setup starts...

i didnt use an addon of ie7, i downloaded the xp sp2 installer from m$ directly..

also, in my testing involving 2.1.4, ie7 must be installed after setup is finished, otherwise IE fails to load..no error message, nothing in the system logs, it just loads for half a second, then disappears...i'm not sure what happens with browsing from an explorer window, as i never tried it and have already overwritten that VM...but when i did the same install, and moved ie7 from nlite hotfix integration to runonceex, the issue disappears...

again, not bitching, just noting differences...i dont have any problem installing ie7 post-setup...just wondering if this 'glitch' (protected mode in xp) is just a cosmetic one...i still have 2.1.3, and i'll be doing some testing later on it, although it's probly nothing :rolleyes:

Martin H
Posts: 26
Joined: Fri Nov 17, 2006 8:03 am
Location: Denmark

Post by Martin H » Tue Nov 21, 2006 5:00 pm

@ViVa + Ryan

Thank's mates :) No problem whatsoever, just curious :)

CU, Martin.

decmk_
Posts: 5
Joined: Fri Sep 09, 2005 3:59 am

Setup non-fatal error

Post by decmk_ » Thu Nov 23, 2006 4:13 am

Hi everyone, and thanks’ to Ryan for great work, but in this new version I got this error in event viewer and in setuperr.txt in windows folder.

Setuperr.txt
Error:
Setup could not register the OLE Control C:\WINDOWS\system32\plugin.ocx because of the following error:
LoadLibrary returned error 126 (the specified module could not be found).


***

RVM_Integrator_1.4.2.log file

21-11-2006 14¦12¦43
Log Startup @ 14:12:43 On 21-11-2006

14:12:43 - RVMIntegrator v1.4.2
14:12:43 - C:\1WIN\RVM_Integrator_1.4.2.exe
14:12:51 - Windows XP Professional - Corporate SP2 Found
14:13:35 -
14:13:35 - Source Drive = C:\1WIN\XPSP2UNA-OK
14:13:35 - Destination Drive = C:\1WIN\XPSP2UNA-OK
14:13:35 - Destination Size = 20900.74609375
14:13:35 - Working Directory = C:\1WIN\XPSP2UNA-OK\I386
14:13:35 - Temp Directory = C:\1WIN\XPSP2UNA-OK\I386\rvmtemp
14:13:35 -
14:13:35 - Starting Integration
14:13:35 -
14:13:35 - Checking Destination For OS Type.
14:13:35 - Windows XP Professional - Corporate SP2 Found
14:13:35 - Clearing any Read Only Attributes.
14:13:37 -
14:13:38 - Extracting RVMUpdatePack2.1.4.7z
14:13:38 - MD5 Hash = 03E89707EEE2718D4FF052FDC7516F6F
14:13:53 - Extracting Themes_Kels_Royale_Noir_Addon_MYWALL.CAB
14:13:53 - MD5 Hash = 3A1C82179B72685C6B11FB189D0EDEB3
14:13:54 - Extracting Boooggy_WMP11Addon_1.3.7.7z
14:13:54 - MD5 Hash = C4C80DC2EF37B85AACB2A978D0D754AC
14:14:00 - Extracting Kel_Royale_Addons_4.1.cab
14:14:00 - MD5 Hash = 7FFA3C4AD14828B3ADAD62550FE28600
14:14:00 - Extracting Kels_AutoPlay_addon_v5.2.3790.67.CAB
14:14:00 - MD5 Hash = A61729D1CD89145C6F5442D424DF2E9D
14:14:01 - Extracting Kels_ClearType_addon_v1.1.CAB
14:14:01 - MD5 Hash = 35201988CB564CF34957B9DE3138A37F
14:14:01 - Extracting Kels_FindTarget_addon_v1.1.CAB
14:14:01 - MD5 Hash = 6DC95821D57DB13B9749712D555A0D16
14:14:02 - Extracting microsoft_java_addons.cab
14:14:02 - MD5 Hash = 15C385B2CF0830B61040C37C819E03D5
14:14:02 - Extracting PatchAddon_SFC_OS.cab
14:14:02 - MD5 Hash = 53D56D5B62743817E520AC71F4D96586
14:14:02 - Extracting PatchAddon_TCPIP.cab
14:14:02 - MD5 Hash = 4A645CD6C6E37076A6519D3B01307114
14:14:02 - Extracting PatchAddon_UXTHEME.cab
14:14:02 - MD5 Hash = F6D48B87F9D914BA9D518EF85B194C8A
14:14:02 - Extracting Remote_Desktop_addon_v5.2.3790.1830.cab
14:14:02 - MD5 Hash = 411992FCBA96FDB394C7BD6C78957379
14:14:03 - Extracting Removal_WINNTUPG_DirDeleteAddon_v1.2.cab
14:14:03 - MD5 Hash = CECBFB14D24AC3760BBEADAB4A8C815D
14:14:03 - Extracting Ricktendo64_Zune_Theme_AddOn_v1.1.rar
14:14:03 - MD5 Hash = BD66C606A958E517B8C3BE12B282DD59
14:14:04 - Extracting RogueSpearAddonsDotNET11SP120-VJ1120.zip
14:14:04 - MD5 Hash = DBAFEBA807B6EFFE65442F45E0F18C6E
14:14:06 - Extracting RVMAddonsDX9_1.0.7z
14:14:06 - MD5 Hash = 7A794BAD2FBC7C44EE3A85683B7825C4
14:14:07 - Extracting RVMAddonsWGA_1.5.716.0.7z
14:14:07 - MD5 Hash = 770F522BD3A3F2480ADFCAA2292151F6
14:14:08 -
14:14:08 - Gathering temp files
14:14:08 - Expanding driver.cab
14:15:01 - Expanding SP2.cab
14:15:10 - Copying files for driver.cab repackaging.
14:15:11 - Moving files for driver.cab repackaging.
14:15:11 - Compressing Files
14:20:12 - Shifting Stuff Around
14:20:12 -
14:20:44 - Analyzing 17 Entry Files
14:20:44 - Processing RyanVM Update Pack v2.1.4 Build Date: 11/19/2006
14:20:45 - Processing Royale Integration Pack v4 Build Date: 10/09/2005
14:20:45 - WARNING: Filename Exceeds 8.3 Format - royale_ss.dll
14:20:45 - WARNING: Filename Exceeds 8.3 Format - EnergyBliss.jpg
14:20:46 - Processing AutoPlay CPL v5.2.3790.67 Build Date: 2006/02/18
14:20:46 - Processing ClearType v1.1 Build Date: 2006/02/19
14:20:46 - Processing RyanVM DirectX 9.0c Addon v1.0 Build Date: 10/14/2006
14:20:46 - Processing Find Target v1.1 Build Date: 2006/02/20
14:20:46 - Processing Microsoft Java Pack v1.0 Build Date: 2005/09/22
14:20:46 - Processing Microsoft Remote Desktop Client v5.2.3790.1830 v5.2.3790.1830 Build Date: 2006/11/01
14:20:46 - Processing Royale Noir Theme v1 Build Date: 2006/10/29
14:20:46 - Processing RogueSpear's Microsoft .NET All-in-One Addon v2.0.50727.42 Build Date: 10/11/2006
14:20:46 - Processing Multi-Patch: SFC_OS.DLL - Disables WFP v1.0 Build Date: 06/17/2006
14:20:46 - Processing Multi-Patch: TCPIP.SYS - 100 Connections v1.0 Build Date: 06/17/2006
14:20:46 - Processing Multi-Patch: UXTHEME.DLL v1.0 Build Date: 06/17/2006
14:20:46 - Processing RyanVM Update Pack WGA Addon v1.5.716.0 Build Date: 11/04/2006
14:20:46 - Processing Boooggy WMP11 Addon v1.3.7 Build Date: 11/15/2006
14:20:46 - Processing Zune v1.0 Build Date: 2006/11/02
14:20:47 - Processing WINNTUPG Directories Removal v1.2 Build Date: 2006/02/23
14:20:47 - obsolete_files Found in entries.ini
14:20:47 - ExtraFileEdits Found in entries_java.ini
14:20:47 - ExtraFileEdits Found in entries_tcpip.ini
14:20:49 - ExtraFileEdits Found in entries_uxtheme.ini
14:20:49 - obsolete_files Found in Entrie_WINNTUPG_Removal.ini
14:20:51 - Processing Sysoc.inf
14:20:51 - Adding Components
14:20:51 - Processing svcpack.inf
14:20:51 - removing obsolete hotfixes
14:20:51 - adding ProductCatalogsToInstall
14:20:51 - Processing dosnet.inf
14:20:51 - Modifying any SP2.cab areas in dosnet.inf
14:20:51 - Editing [Files]
14:20:51 - Processing txtsetup.sif
14:20:51 - Editing [Fileflags]
14:20:52 - Editing [WinntDirectories]
14:20:52 - Editing [SourceDisksFiles]
14:20:52 - Modifying any SP2.cab areas in txtsetup.sif
14:20:55 - Processing [EditFile]
14:20:57 - Entire .ini Processing Completed in 12 Seconds
14:20:57 - Compressing and Moving Edited Files
14:20:58 -
14:20:58 - Processing mmssetup.cab
14:20:58 - Expanding mmssetup.cab
14:20:58 - Processing entries.ini
14:20:58 - Rebuilding mmssetup.cab
14:21:00 - Rebuilding mmssetup.cab Complete.
14:21:00 -
14:21:01 - Hex Editing Files
14:21:01 - sfc_os.dll 5.1.2600.2180 Patched at offset 60644.
14:21:04 - tcpip.sys 5.1.2600.2892 No match at offset 325026. Patch skipped.
14:21:05 - tcpip.sys 5.1.2600.2892 Patched at offset 325574.
14:21:07 - uxtheme.dll 6.0.2900.2845 Patched at offset 104746.
14:21:08 -
14:21:08 - Calculating the amount of files to pack into driver.cab
14:21:26 - Rebuilding driver.cab
14:27:58 - Rebuilding drvindex.inf
14:27:59 - Rebuilding drvindex.inf Complete.
14:27:59 - Moving Files
14:27:59 - Cleaning Up.
14:27:59 - Replacing driver.cab
14:28:03 - Integration is at 100%, Cleaning Up
14:28:05 - Integration Completed.
14:28:05 - Total Integration Time = 870 Seconds

Log Shutdown @ 14:30:28 On 21-11-2006

And I found this in z_datastore.ini

;This section is useful if you release a new version of your pack and you want to delete your old version from their I386 directory.
;It will delete any file you list here and it will also delete the according entries from dosnet.inf and txtsetup.sif
[Obsolete_Files]
flash.ocx=RyanVM Update Pack
msxml5.dll=RyanVM Update Pack
msxml5r.dll=RyanVM Update Pack
plugin.ocx=RyanVM Update Pack ----- HERE


How to fix this.

User avatar
RyanVM
Site Admin
Posts: 5187
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Thu Nov 23, 2006 9:39 am

You can ignore the error. I removed plugin.ocx in this pack because the recent IE cumulative updates do as well. If MS thinks it isn't necessary anymore, so do I :P. Unfortunately, I can't remove it the "right" way so that you don't see that kind of error because doing so would require me to edit syssetup.inf, which is digitally signed to not allow any changes.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
ENU_user
Posts: 1253
Joined: Wed Jan 25, 2006 1:42 pm

Post by ENU_user » Thu Nov 23, 2006 10:57 am

any 1 has problems running SFC with the cd or is their a WorkGround or a fix
as mentioned in kb897128 ,kb885522

decmk_
Posts: 5
Joined: Fri Sep 09, 2005 3:59 am

Post by decmk_ » Thu Nov 23, 2006 11:07 am

Thanks for info.
btw a also try to manually remove line from layout.inf and also get same error
Maybe you made an update pack without removing this file or tell me how to edit you pack to leave this file to be installed by default.

BZJoe
Posts: 35
Joined: Sun Apr 16, 2006 1:19 pm

Post by BZJoe » Thu Nov 23, 2006 4:07 pm

Darn it. I just installed on an HP DV2120 and the driver for the HD Audio (888111) is not working. This is an "nlited" CD so I'll have to go back and redo a CD with only the Update Pack to retest ...

User avatar
RyanVM
Site Admin
Posts: 5187
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Thu Nov 23, 2006 5:34 pm

decmk_ wrote:Thanks for info.
btw a also try to manually remove line from layout.inf and also get same error
Maybe you made an update pack without removing this file or tell me how to edit you pack to leave this file to be installed by default.
Just edit the line out of entries.ini if you want plugin.ocx to be left untouched. Or you can just ignore the message since it isn't hurting anything and you know why it's appearing now.
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
Timks
Posts: 19
Joined: Sat Feb 25, 2006 8:44 pm

Post by Timks » Thu Nov 23, 2006 10:20 pm

Thank you Ryan for such a great program and addon/s and website. I have no troubles with your update pack and addons. If I ever have any troubles it is all ways my own stupidity (usuly caused by lack of sleep)ImageImageImageImageImage
Thanks - RyanVM, Nuhi, Kelsenellenelvian, Bâshrat the Sneaky, Foxy, Siginet, Rappinhood, Mrs Peel, Ricktendo64, Xable, Zacam and the people on this board for all your hard work.

User avatar
orcoxp
Posts: 532
Joined: Sun Apr 17, 2005 2:05 pm
Location: Ontario, Canada

Post by orcoxp » Thu Nov 23, 2006 10:41 pm

Maybe someone is willing to make an addon to remove this line if they are using a patched syssetup.dll?
Chris Thomson
AKA OrcoXP

PHP/MySQL/phpMyAdmin 2 & 3 successfully running simultaneously on XP SP3 IIS.

chuckenheimer
Posts: 53
Joined: Wed Sep 20, 2006 4:31 pm

Post by chuckenheimer » Fri Nov 24, 2006 12:57 am

After bumping around a bit here, I want to say what an effort Ryan! The resulting install CD at the moment contains just the latest 2.1.4 release but I am amazed.

I feel very encouraged at moving forward with the switchless installers I've d/l'd and working toward a solution for my specific Gigabyte motherboard chipset drivers next. The DriverPacks.net Forum looks like I may be able to receive some assistance with this there.

Anyway, just wanted to express my thanks again for this effort!

ViVa

Post by ViVa » Fri Nov 24, 2006 1:36 am

I know it's offtopic, but I can't resist the urge.

First integrate Ryan's pack plus your desired addons with RyanVM integrator, THEN integrate the desired driverpacks with the BASE integrator.

User avatar
buletov
Posts: 380
Joined: Tue Feb 15, 2005 11:30 am

Post by buletov » Fri Nov 24, 2006 5:27 am

..and then delete all the .org files DriverPacks leaves behind in the I386 folder. :mrgreen:
Never know what life is gonna throw at you.

InFeKtioN
Posts: 5
Joined: Mon Nov 13, 2006 3:39 pm
Location: Indiana

Post by InFeKtioN » Fri Nov 24, 2006 12:06 pm

Nice work !

Thanks Ryan.......

This is my very first post here. I have only found his site a month or so ago. It is the best !

I would like to take this opportunity to thank everyone here that participates in using their own personal time and providing all of these great add-ons/installers ....

Thanks Again !

Alex
Posts: 28
Joined: Mon Sep 05, 2005 5:18 pm

Post by Alex » Fri Nov 24, 2006 5:14 pm

Not topic related and deleted by author...
Last edited by Alex on Tue Nov 28, 2006 7:37 pm, edited 1 time in total.

User avatar
RyanVM
Site Admin
Posts: 5187
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Fri Nov 24, 2006 9:25 pm

I completely changed Flash integration with 2.1.4. flash.ocx doesn't even exist on a 2.1.4 CD anymore ;)
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

User avatar
MrNxDmX
Moderator
Posts: 3112
Joined: Mon Jan 03, 2005 7:33 am

Post by MrNxDmX » Fri Nov 24, 2006 10:05 pm

Hey folks, what are your problems with mac. flash player? Is it a real installation problem, or a program conflict, or you just dont want it in your install cd? I have one request for flash removal, what do you think about that?

User avatar
5eraph
Site Admin
Posts: 4619
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Fri Nov 24, 2006 10:22 pm

My Flash addon is obsolete, Alex. I've requested to have it removed from the Addons Download List to avoid confusion in the future.

clttv
Posts: 2
Joined: Sat Nov 25, 2006 1:07 am

help

Post by clttv » Sat Nov 25, 2006 1:11 am

hello guys
ima new for all of this
so can someone just gimmi the right steps to install all those updates ..
thanx alot

amirali_esh
Posts: 101
Joined: Wed Feb 16, 2005 4:05 pm

Post by amirali_esh » Sat Nov 25, 2006 2:03 am

hello guys
ima new for all of this
so can someone just gimmi the right steps to install all those updates ..
thanx alot
http://www.ryanvm.net/msfn/manual.html

clttv
Posts: 2
Joined: Sat Nov 25, 2006 1:07 am

Post by clttv » Sat Nov 25, 2006 4:55 am

thanx amirali_esh

Alex
Posts: 28
Joined: Mon Sep 05, 2005 5:18 pm

Post by Alex » Sat Nov 25, 2006 6:39 am

Not topic related and deleted by author...
Last edited by Alex on Tue Nov 28, 2006 7:35 pm, edited 1 time in total.

User avatar
RyanVM
Site Admin
Posts: 5187
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Sat Nov 25, 2006 10:08 am

It should also allow for conflict-free upgrading with future Flash versions (or at least, the same as what one would get if they'd installed 9.0.28 themselves).
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

TechnoHunter
Posts: 506
Joined: Sun Feb 26, 2006 4:13 am

Post by TechnoHunter » Sat Nov 25, 2006 6:09 pm

you mean that this allows you to delete the uber annoying flash.ocx file? or better yet you dont have to delete it as its not there?

nice!

User avatar
RyanVM
Site Admin
Posts: 5187
Joined: Tue Nov 23, 2004 6:03 pm
Location: Pennsylvania
Contact:

Post by RyanVM » Sun Nov 26, 2006 11:21 am

Correct, it's not even there anymore (go ahead, check i386 after pack integration ;))
Get up to $200 off on hosting from the same people who host this website!
http://www.ryanvm.net/forum/viewtopic.php?t=2357

Alex
Posts: 28
Joined: Mon Sep 05, 2005 5:18 pm

Post by Alex » Mon Nov 27, 2006 3:36 pm

Not topic related and deleted by author...
Last edited by Alex on Tue Nov 28, 2006 7:34 pm, edited 1 time in total.

User avatar
5eraph
Site Admin
Posts: 4619
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Mon Nov 27, 2006 5:16 pm

If you integrate RVMUP 2.1.4 in the same session as your modified addon then your new FLASH.OCX will be deleted from the source because it's listed under [obsolete_files] in Ryan's ENTRIES.INI.

If you integrate your modified addon in a later integration session then FLASH.OCX will remain, but...

In either case you're replacing Ryan's blank SWFLASH.INF with yours, creating a conflict between the code in your file and this code in RVMUpPck.inf:

Code: Select all

[Flash.AddReg]
HKCU,"SOFTWARE\Macromedia\FlashPlayer","FlashPlayerVersion",0,"%FLASHVERSION%"
HKLM,"SOFTWARE\Microsoft\Active Setup\Installed Components\%FLASHGUID%",,,"Adobe Flash Player 9 ActiveX"
HKLM,"SOFTWARE\Microsoft\Active Setup\Installed Components\%FLASHGUID%","ComponentID",0,"Flash"
HKLM,"SOFTWARE\Microsoft\Active Setup\Installed Components\%FLASHGUID%","IsInstalled",1,01,00,00,00
HKLM,"SOFTWARE\Microsoft\Active Setup\Installed Components\%FLASHGUID%","Version",0,"%FLASHVERSION%"
HKLM,"SOFTWARE\Microsoft\Active Setup\Installed Components\%FLASHGUID%","Locale",0,"EN"
HKLM,"%ACTIVEXCOMP%\%FLASHGUID%","Compatibility Flags",0x10001,0
HKLM,"SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Accepted Documents","flash",0,"application/x-shockwave-flash"
HKLM,"SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\OptionalComponents\SwFlash","Installed",0,1

..

[Flash.Register]
11,Macromed\Flash,Flash9b.ocx,1
Update Pack 2.1.4 also removes entries in TXTSETUP.SIF and DOSNET.INF related to FLASH.OCX. Your FLASH.OCX probably won't get copied to the hard drive because Windows Setup won't know where to find it, but Ryan's FLASH9B.OCX will copy.

If you absolutely must install Flash your own way then you'll have to modify Ryan's Update Pack by altering the sections I mention above, but I have to admit that Ryan's method of updating Flash is superior to Body's because it allows you to update an in-place Flash 9 installation later. It's also easier for Ryan to manage updates later because all related code is in one place.

Alex
Posts: 28
Joined: Mon Sep 05, 2005 5:18 pm

Post by Alex » Mon Nov 27, 2006 6:00 pm

Not topic related and deleted by author...
Last edited by Alex on Tue Nov 28, 2006 7:33 pm, edited 1 time in total.

User avatar
5eraph
Site Admin
Posts: 4619
Joined: Tue Jul 05, 2005 9:38 pm
Location: Riverview, MI USA

Post by 5eraph » Mon Nov 27, 2006 6:16 pm

If you're not using Ryan's Update Pack then we really should be discussing Flash in my addon thread.

I'll see what I can do to create a working addon for you, but since I don't have a Dell disc to test with I can't guarantee anything. ;)

Alex
Posts: 28
Joined: Mon Sep 05, 2005 5:18 pm

Post by Alex » Tue Nov 28, 2006 2:25 pm

Not topic related and deleted by author...
Last edited by Alex on Tue Nov 28, 2006 7:36 pm, edited 1 time in total.

Locked